Kopano4S (Zarafa 2.0)

Tosoboso

Benutzer
Mitglied seit
27. August 2012
Beiträge
1.131
Punkte für Reaktionen
10
Punkte
64
Ah, ok das erklärt es: bei der Community Edition Beta Nightly Build kann so was mal vorkommen. Ich Baue eine neue und Lade die dann hoch. Mit Kopano4s-refresh bekommst du die dann. Frage: warum nutzt du nicht die Default Edition, das erspaart einige Überraschungen. =>kopano4s-downgrade und dann die Default installieren..
-TosoBoso
 

millilenium

Benutzer
Mitglied seit
03. Februar 2014
Beiträge
132
Punkte für Reaktionen
0
Punkte
16
Super danke.
Werde in ca 1 Woche auf die ds1621xs+ wechseln, dann werde ich das downgrade machen
 

Andy+

Benutzer
Mitglied seit
25. Januar 2016
Beiträge
3.472
Punkte für Reaktionen
26
Punkte
114
Bezüglich dem Container auf der Startseite des Webadmin ganz oben und bezüglich der K4S-Installation im Paketzentrum.
 

chats

Benutzer
Mitglied seit
29. September 2012
Beiträge
359
Punkte für Reaktionen
0
Punkte
16
Welche Version ist denn nun für den Produktiven Einsatz zu empfehlen?
Das müsste doch dann die Default sein, oder?
 

Andy+

Benutzer
Mitglied seit
25. Januar 2016
Beiträge
3.472
Punkte für Reaktionen
26
Punkte
114
Die Default ist die stabile Version, die Beta ist eben Beta, da kann sich schon mal ein Bug bemerkbar machen.
 

millilenium

Benutzer
Mitglied seit
03. Februar 2014
Beiträge
132
Punkte für Reaktionen
0
Punkte
16
=>kopano4s-downgrade und dann die Default installieren..
-TosoBoso

Hallo TosoBoso, sorry für die dumme Frage - aber wie genau ist das Downgrade zu vollziehen?
Es gibt mehrere Posts dazu aber keinen für mich klaren weg.
  • kopano4s-backup
  • kopano4s-downgrade
  • Paket löschen - stable installieren
  • Datenbank restore?
Vielleicht kann mir hier jemand helfen. Danke!
 

Tosoboso

Benutzer
Mitglied seit
27. August 2012
Beiträge
1.131
Punkte für Reaktionen
10
Punkte
64
Hallo TosoBoso, sorry für die dumme Frage - aber wie genau ist das Downgrade zu vollziehen? Es gibt mehrere Posts dazu aber keinen für mich klaren weg.
  • kopano4s-backup
  • kopano4s-downgrade
  • Paket löschen - stable installieren
  • Datenbank restore?
Code:
 > $ kopano4s-downgrade help
Usage: kopano4s-upgrade plus start | atm-on-fs | help. (switch to attachments on file system by 'atm-on-fs')
Migrating Kopano Editions Community or Supported with higher release number by means of downgrade in 4 steps
Step 1: database backup as a fallback running kopano4a-backup restore timestamp to recover if this job fails.
Step 2: mapi brick-level method kopano-backup for importing users into older database version later.
Step 3: truncate kopano database, restart with default edition which will recreate database ready for import
Step 4: import of users via kopnao4s-restore-user all setting old password.
This is an all-in one scripted solution taking away the pain of loading different k4s version and running backup utilities.
It reccomended to run this sript via Synology task scheduler to avoid time-out before completion when running via terminal
It is required to have an initial brick level kopano-backup run to allow shorter total runtime of this script.
Die Help Funktion sollte das Ausführen. Wenn man eine Community Edition hat, kann man nicht so einfach ein Downgrade machen.
Dazu muss die Datenbank neu Aufgebaut werden und genau dafür braucht man Backup-Restore, was dieses Skript automatisiert.
Wenn man also auf Community Edition ist, fährt man einen kopano-backup initial, dann das Skript und dann kann man die Default Edition via SPK drüberladen
-TosoBoso
 

hovas

Benutzer
Mitglied seit
21. Juli 2011
Beiträge
10
Punkte für Reaktionen
0
Punkte
1
Hallo TosoBoso, zwischezeitlich hatte ich dann doch noch die Neuinstallation gemacht, Fehler bleibt leider wie beschrieben. Hier noch mehr Details zur K4S v.1.13 Installation.
Versionen: Kopano4S C-Core-10.0.6_Webapp-4.3_Z-Push-2.5.2 installed
Edition: Paket vom Community Package Hub (ohne Lizenz)
Plattform: VirtualDSM 6.2.3-25426 Update 2
 

chats

Benutzer
Mitglied seit
29. September 2012
Beiträge
359
Punkte für Reaktionen
0
Punkte
16
Mit den Versionen tue ich mich schwer.
Ich habe Kopano immer über das Paketzentrum Kopano heruntergeladen. Da ich nun auf die default wechseln möchte wegen stabilität zeigt mir Kopano im WebAdmin und auch im Docker an das ich die Community Version habe obwohl ich eine Seriennummer habe.
Nun möchte ich an einem TestNas die default installieren mit meiner Seriennummer. Das gelingt mir jedoch nicht. Egal was ich installiere es steht immer da das ich die Community Version habe. Das ist doch seltsam.
Also meine Frage konkret: Wie installiere ich eine Default Version mit vorhandener Lizenz? Welches SPK ist hier das richtige?
 

Andy+

Benutzer
Mitglied seit
25. Januar 2016
Beiträge
3.472
Punkte für Reaktionen
26
Punkte
114
Du kannst die Default herunterladen, nimm den linken Tab, also nicht Beta. Deinstalliere alles, DS neu booten, installiere manuell die Default. Gleich zu Beginn kannst Du die Lizenznummer eingeben und dann sollte das funktionieren.

Dass bei Dir die Beta installiert wird, hängt wohl damit zusammen, dass Du im Paketzentrum Beta aktiviert hast. Da ich mir da aber sicher sein wollte, habe ich schon immer manuell installiert.
 

Andy+

Benutzer
Mitglied seit
25. Januar 2016
Beiträge
3.472
Punkte für Reaktionen
26
Punkte
114
Und immer daran denken, jeder Boot tut gut. Auch nach der Neuinstallation macht es Sinn, da der WebAdmin bei mir dann nicht funktionierte, jedoch spätestens, wenn die Mailkonten zur Abholung von Emails eingerichtet sind, steht ein Reboot an. Das mache ich schon lange so und sorgte bislang für einen störungsfreien Betrieb.
 

diluciano

Benutzer
Mitglied seit
23. November 2010
Beiträge
3
Punkte für Reaktionen
0
Punkte
1
Hallo Leute, ich hab mal wieder. Probleme mit Kopano4s 1.13, update lief gut. Seit einigen Tagen habe ich folgendes Problem.
WIr haben eine sehr große Datenbank, ca 80 GB ( ist ein EMAIL ARCHIV ), Attachments extern im Filesystem ( /volume1/kopano/attachements,
rechte auf kopano.kopano 660 ) , geprüft.

Im Kopano-Web-Client ist beim abrufen der Mails alles gut, Attachments werden angezeigt als briefklammer, und beim öffnen der Mails sind die Anhänge definitiv da und werden geladen ( PDF, JPG , was auch immer..) soweit sogut.

ABER: sobald ich mit einem anderen Klienten darauf zu greife ( z.b Thunderbird), wird ebenfalls in der Übersicht alles korrekt angezeigt ( mail mit Büroklammer, wenn Attachment da....) . Sobald man aber auf die Mail klickt, um sie zu öffnen, verschwindet die Büroklammer , und die mail hat kein Attachment. Strange.
Das übel. das ist nicht bei allen emails so - manche Anhänge sind zugreifbar.

In den "schlechten Fällen" hab ich den Thunderbird gedebugt - die mail wird tatsächlich ohne anhang vom Diskstatoin-Kopano geschickt, im debug log wird sogar die korrigierte Größe ohne anhang berechnet.

[(null) 15744: IMAP]: D/IMAP ReadNextLine [stream=1F5ADF40 nb=17 needmore=0]
[(null) 15744: IMAP]: I/IMAP 1CB2A800:diskstation:S-INBOX/_DIVERSES/FritzBox:CreateNewLineFromSocket: --=_ZG_static--

[(null) 15744: IMAP]: D/IMAP ReadNextLine [stream=1F5ADF40 nb=17 needmore=0]
[(null) 15744: IMAP]: I/IMAP 1CB2A800:diskstation:S-INBOX/_DIVERSES/FritzBox:CreateNewLineFromSocket: FLAGS (\Seen))

[(null) 15744: IMAP]: I/IMAP 1CB2A800:diskstation:S-INBOX/_DIVERSES/FritzBox:STREAM:CLOSE: Normal Message End Download Stream
[(null) 15744: Main Thread]: D/IMAP Updating stored message size from 56739, new size 7251
[(null) 15744: IMAP]: D/IMAP ReadNextLine [stream=1F5ADF40 nb=27 needmore=0]

[(null) 15744: IMAP]: I/IMAP 1CB2A800:diskstation:S-INBOX/_DIVERSES/FritzBox:CreateNewLineFromSocket: 18 OK UID FETCH completed

Error log ist momentan sauber, hatte aber auch schon Einträge bzgl Zugriffsrechte auf /var/lib/kopano/attachments.....
Diese sind nach neustart des gesamten Systems weg...

Ich bin gerade ratlos.....wenn die DB oder der Anhang-FIlestore defekt wäre, würde doch auch der Kopano Client nicht funzen????
Da die IMAP übertragung von Kopano per ungesicherter Übertragung stattfindet ( port 143), kann das ein Sicherheits-"Feature" sein vom Virenschutz oder sonstiges?? ( Test von Windows 10 PC aus....)


Danke für eure Hilfe - wäre mega dringend, da Produktivsystem.
Sitze am System, kann jedes indiz liefern....
DANKE
 

Tosoboso

Benutzer
Mitglied seit
27. August 2012
Beiträge
1.131
Punkte für Reaktionen
10
Punkte
64
Hi,
die Zugriffsprobleme /var/lib/kopano/attachments, die nach dem Neustart weg sind, das is eine Initialisierungsfunktion von Kopano4S.
Falls du ein Zertifikat passend zu Kopano (z.B. mail.meineDomain.com) hast und es Teil deiner Default Domain ist (mit LetsEncrypt Zertifikat), dann kannst du SSL für Zarafa-Client 237 und IMAP(s) 993 nutzen, das mache ich seit Jahren so. Vielleicht löst das dein Problem via IMAPs statt IMAP.
Mit Kommando >kopano4s-init ssl wird das LE-Zertifikat Default Domaine der Synology wird inden COntainer Kopiert und für ZCPs, IMAPs, ICALs eingerichtet. Ein anderer Grund für dein Problem kann ein Virenscanner auf IMAP Level sein, den ggf. lokalieiseren und abschalten..
Hoffe das hilft weiter.. teu teu
-TosoBoso
 

chats

Benutzer
Mitglied seit
29. September 2012
Beiträge
359
Punkte für Reaktionen
0
Punkte
16
Das heisst also aus dem Paketzentrum wird die Community Version installiert. (wenn Beta NICHT angehackt ist)
Auf dem cphub.net "rechter Reiter" die Beta Verion und "linker Reiter" die default Version.

Aber was geschieht denn wenn ich alles ohne Lizenz installiere und füge die Lizenz dann später hinzu? Wird dann aus der Community automatisch eine default Version?
 

Jens72

Benutzer
Mitglied seit
24. März 2008
Beiträge
103
Punkte für Reaktionen
0
Punkte
15
Hallo,
ich hatte ein Update Kopano4S von Version 1.00 auf Version 1.13 durchgeführt. Dieses hat aber nach der Installation den Docker Container nicht mehr gestartet. Somit habe ich nun eine komplette Neuinstallation gemacht welche auch wenn ich den Benutzer anlege super funktioniert...
Nun zu meinem Problem, sobald ich mit Kopano4s-backup restore "ts" mein Backup einspiele wird die Maria DB richtig mit meinem Backup von ca. 1,9GB gefüllt aber danach startet der Docker Container nur kurz und bricht dann ab.
Im Log File vom Docker Container steht folgendes:



[TABLE]
[TR]
[TD]2020-09-23 18:08:08[/TD]
[TD]stdout[/TD]
[TD]Wed Sep 23 20:08:06 2020: [=======] Server shutdown complete.[/TD]
[/TR]
[TR]
[TD]2020-09-23 18:08:08[/TD]
[TD]stdout[/TD]
[TD]Wed Sep 23 20:08:06 2020: [warning] Warning, you can lose data! If you don't know what you're doing, you shouldn't be using this option![/TD]
[/TR]
[TR]
[TD]2020-09-23 18:08:08[/TD]
[TD]stdout[/TD]
[TD]Wed Sep 23 20:08:06 2020: [warning] You can force the server to start with --ignore-database-version-conflict[/TD]
[/TR]
[TR]
[TD]2020-09-23 18:08:08[/TD]
[TD]stdout[/TD]
[TD]Wed Sep 23 20:08:06 2020: [warning] WARNING: Database version (8,7,80,0,118) is newer than the server version (8,7,14,0,118)[/TD]
[/TR]
[TR]
[TD]2020-09-23 18:08:08[/TD]
[TD]stdout[/TD]
[TD]exiting as server stopped; if non-grace shutdown see last entry from /var/log/kopano/server.log and consider kopano4s-init reset or re-install[/TD]
[/TR]
[TR]
[TD]2020-09-23 18:08:08[/TD]
[TD]stdout[/TD]
[TD]staying alive while kopano service is running..[/TD]
[/TR]
[TR]
[TD]2020-09-23 18:08:08[/TD]
[TD]stdout[/TD]
[TD]Starting periodic command scheduler: cron.[/TD]
[/TR]
[TR]
[TD]2020-09-23 18:08:08[/TD]
[TD]stdout[/TD]
[TD]rsyslogd: run failed with error -3000 (see rsyslog.h or try https://www.rsyslog.com/e/3000 to learn what that number means)[/TD]
[/TR]
[TR]
[TD]2020-09-23 18:08:08[/TD]
[TD]stdout[/TD]
[TD]different pid files for them (-i option).[/TD]
[/TR]
[TR]
[TD]2020-09-23 18:08:08[/TD]
[TD]stdout[/TD]
[TD]If you want to run multiple instances of rsyslog, you need to specify[/TD]
[/TR]
[TR]
[TD]2020-09-23 18:08:08[/TD]
[TD]stdout[/TD]
[TD]rsyslogd: pidfile '/run/rsyslogd.pid' and pid 296 already exist.[/TD]
[/TR]
[TR]
[TD]2020-09-23 18:08:08[/TD]
[TD]stdout[/TD]
[TD]Starting enhanced syslogd: rsyslogd already started.[/TD]
[/TR]
[TR]
[TD]2020-09-23 18:08:08[/TD]
[TD]stdout[/TD]
[TD]Starting Kopano sys ...[/TD]
[/TR]
[TR]
[TD]2020-09-23 18:08:08[/TD]
[TD]stdout[/TD]
[TD]Starting mail retriever agent: fetchmail.[/TD]
[/TR]
[TR]
[TD]2020-09-23 18:08:08[/TD]
[TD]stdout[/TD]
[TD]Removing stale PID file /var/run/fetchmail/fetchmail.pid. ... (warning).[/TD]
[/TR]
[TR]
[TD]2020-09-23 18:08:08[/TD]
[TD]stdout[/TD]
[TD]Starting Postfix Mail Transport Agent: postfix.[/TD]
[/TR]
[TR]
[TD]2020-09-23 18:08:07[/TD]
[TD]stdout[/TD]
[TD]Starting Kopano mail ...[/TD]
[/TR]
[TR]
[TD]2020-09-23 18:08:07[/TD]
[TD]stdout[/TD]
[TD]Starting nginx: nginx.[/TD]
[/TR]
[TR]
[TD]2020-09-23 18:08:07[/TD]
[TD]stdout[/TD]
[TD]Starting Kopano web ...[/TD]
[/TR]
[TR]
[TD]2020-09-23 18:08:07[/TD]
[TD]stdout[/TD]
[TD]Starting gateway: kopano-gateway.[/TD]
[/TR]
[TR]
[TD]2020-09-23 18:08:07[/TD]
[TD]stdout[/TD]
[TD]Starting search: kopano-search.[/TD]
[/TR]
[TR]
[TD]2020-09-23 18:08:06[/TD]
[TD]stdout[/TD]
[TD]Starting LMTP dagent: kopano-dagent.[/TD]
[/TR]
[TR]
[TD]2020-09-23 18:08:06[/TD]
[TD]stdout[/TD]
[TD]Starting spooler: kopano-spooler.[/TD]
[/TR]
[TR]
[TD]2020-09-23 18:08:06[/TD]
[TD]stdout[/TD]
[TD]Starting server: kopano-server.[/TD]
[/TR]
[TR]
[TD]2020-09-23 18:08:06[/TD]
[TD]stdout[/TD]
[TD]Starting Kopano core ...[/TD]
[/TR]
[TR]
[TD]2020-09-23 17:51:46[/TD]
[TD]stdout[/TD]
[TD]Wed Sep 23 19:51:44 2020: [=======] Server shutdown complete.[/TD]
[/TR]
[TR]
[TD]2020-09-23 17:51:46[/TD]
[TD]stdout[/TD]
[TD]Wed Sep 23 19:51:44 2020: [warning] Warning, you can lose data! If you don't know what you're doing, you shouldn't be using this option![/TD]
[/TR]
[TR]
[TD]2020-09-23 17:51:46[/TD]
[TD]stdout[/TD]
[TD]Wed Sep 23 19:51:44 2020: [warning] You can force the server to start with --ignore-database-version-conflict[/TD]
[/TR]
[TR]
[TD]2020-09-23 17:51:46[/TD]
[TD]stdout[/TD]
[TD]Wed Sep 23 19:51:44 2020: [warning] WARNING: Database version (8,7,80,0,118) is newer than the server version (8,7,14,0,118)[/TD]
[/TR]
[TR]
[TD]2020-09-23 17:51:46[/TD]
[TD]stdout[/TD]
[TD]exiting as server stopped; if non-grace shutdown see last entry from /var/log/kopano/server.log and consider kopano4s-init reset or re-install[/TD]
[/TR]
[TR]
[TD]2020-09-23 17:51:46[/TD]
[TD]stdout[/TD]
[TD]staying alive while kopano service is running..[/TD]
[/TR]
[TR]
[TD]2020-09-23 17:51:46[/TD]
[TD]stdout[/TD]
[TD]Starting periodic command scheduler: cron.[/TD]
[/TR]
[TR]
[TD]2020-09-23 17:51:46[/TD]
[TD]stdout[/TD]
[TD]Starting enhanced syslogd: rsyslogd.[/TD]
[/TR]
[TR]
[TD]2020-09-23 17:51:46[/TD]
[TD]stdout[/TD]
[TD]Starting Kopano sys ...[/TD]
[/TR]
[TR]
[TD]2020-09-23 17:51:46[/TD]
[TD]stdout[/TD]
[TD]Starting mail retriever agent: fetchmail.[/TD]
[/TR]
[TR]
[TD]2020-09-23 17:51:46[/TD]
[TD]stdout[/TD]
[TD]Removing stale PID file /var/run/fetchmail/fetchmail.pid. ... (warning).[/TD]
[/TR]
[TR]
[TD]2020-09-23 17:51:46[/TD]
[TD]stdout[/TD]
[TD]Starting Postfix Mail Transport Agent: postfix.[/TD]
[/TR]
[TR]
[TD]2020-09-23 17:51:45[/TD]
[TD]stdout[/TD]
[TD]Starting Kopano mail ...[/TD]
[/TR]
[TR]
[TD]2020-09-23 17:51:45[/TD]
[TD]stdout[/TD]
[TD]Starting nginx: nginx.[/TD]
[/TR]
[TR]
[TD]2020-09-23 17:51:45[/TD]
[TD]stdout[/TD]
[TD]Starting Kopano web ...[/TD]
[/TR]
[TR]
[TD]2020-09-23 17:51:45[/TD]
[TD]stdout[/TD]
[TD]Starting gateway: kopano-gateway.[/TD]
[/TR]
[TR]
[TD]2020-09-23 17:51:45[/TD]
[TD]stdout[/TD]
[TD]Starting search: kopano-search.[/TD]
[/TR]
[TR]
[TD]2020-09-23 17:51:44[/TD]
[TD]stdout[/TD]
[TD]Starting LMTP dagent: kopano-dagent.[/TD]
[/TR]
[TR]
[TD]2020-09-23 17:51:44[/TD]
[TD]stdout[/TD]
[TD]Starting spooler: kopano-spooler.[/TD]
[/TR]
[TR]
[TD]2020-09-23 17:51:44[/TD]
[TD]stdout[/TD]
[TD]Starting server: kopano-server.[/TD]
[/TR]
[TR]
[TD]2020-09-23 17:51:44[/TD]
[TD]stdout[/TD]
[TD]Starting Kopano core ...[/TD]
[/TR]
[TR]
[TD]2020-09-23 17:50:39[/TD]
[TD]stdout[/TD]
[TD]Wed Sep 23 19:50:35 2020: [=======] Server shutdown complete.[/TD]
[/TR]
[TR]
[TD]2020-09-23 17:50:39[/TD]
[TD]stdout[/TD]
[TD]Wed Sep 23 19:50:35 2020: [warning] Warning, you can lose data! If you don't know what you're doing, you shouldn't be using this option![/TD]
[/TR]
[TR]
[TD]2020-09-23 17:50:39[/TD]
[TD]stdout[/TD]
[TD]Wed Sep 23 19:50:35 2020: [warning] You can force the server to start with --ignore-database-version-conflict[/TD]
[/TR]
[TR]
[TD]2020-09-23 17:50:39[/TD]
[TD]stdout[/TD]
[TD]Wed Sep 23 19:50:35 2020: [warning] WARNING: Database version (8,7,80,0,118) is newer than the server version (8,7,14,0,118)[/TD]
[/TR]
[TR]
[TD]2020-09-23 17:50:39[/TD]
[TD]stdout[/TD]
[TD]exiting as server stopped; if non-grace shutdown see last entry from /var/log/kopano/server.log and consider kopano4s-init reset or re-install[/TD]
[/TR]
[TR]
[TD]2020-09-23 17:50:39[/TD]
[TD]stdout[/TD]
[TD]staying alive while kopano service is running..[/TD]
[/TR]
[TR]
[TD]2020-09-23 17:50:39[/TD]
[TD]stdout[/TD]
[TD]Restarting nginx: nginx.[/TD]
[/TR]
[TR]
[TD]2020-09-23 17:50:38[/TD]
[TD]stdout[/TD]
[TD]Starting periodic command scheduler: cron.[/TD]
[/TR]
[TR]
[TD]2020-09-23 17:50:38[/TD]
[TD]stdout[/TD]
[TD]Starting enhanced syslogd: rsyslogd.[/TD]
[/TR]
[TR]
[TD]2020-09-23 17:50:37[/TD]
[TD]stdout[/TD]
[TD]Starting Kopano sys ...[/TD]
[/TR]
[TR]
[TD]2020-09-23 17:50:37[/TD]
[TD]stdout[/TD]
[TD]Starting mail retriever agent: fetchmail.[/TD]
[/TR]
[TR]
[TD]2020-09-23 17:50:37[/TD]
[TD]stdout[/TD]
[TD]Starting Postfix Mail Transport Agent: postfix.[/TD]
[/TR]
[TR]
[TD]2020-09-23 17:50:37[/TD]
[TD]stdout[/TD]
[TD]Starting Kopano mail ...[/TD]
[/TR]
[TR]
[TD]2020-09-23 17:50:36[/TD]
[TD]stdout[/TD]
[TD]Starting nginx: nginx.[/TD]
[/TR]
[TR]
[TD]2020-09-23 17:50:36[/TD]
[TD]stdout[/TD]
[TD]Starting Kopano web ...[/TD]
[/TR]
[TR]
[TD]2020-09-23 17:50:36[/TD]
[TD]stdout[/TD]
[TD]Starting gateway: kopano-gateway.[/TD]
[/TR]
[TR]
[TD]2020-09-23 17:50:36[/TD]
[TD]stdout[/TD]
[TD]Starting search: kopano-search.[/TD]
[/TR]
[TR]
[TD]2020-09-23 17:50:36[/TD]
[TD]stdout[/TD]
[TD]Starting LMTP dagent: kopano-dagent.[/TD]
[/TR]
[TR]
[TD]2020-09-23 17:50:35[/TD]
[TD]stdout[/TD]
[TD]Starting spooler: kopano-spooler.[/TD]
[/TR]
[TR]
[TD]2020-09-23 17:50:35[/TD]
[TD]stdout[/TD]
[TD]Starting server: kopano-server.[/TD]
[/TR]
[TR]
[TD]2020-09-23 17:50:35[/TD]
[TD]stdout[/TD]
[TD]Starting Kopano core ...[/TD]
[/TR]
[TR]
[TD]2020-09-23 17:50:35[/TD]
[TD]stdout[/TD]
[TD]Active services: kopano-server kopano-spooler kopano-dagent kopano-search kopano-gateway postfix fetchmail nginx php7.3-fpm[/TD]
[/TR]
[TR]
[TD]2020-09-23 17:50:11[/TD]
[TD]stderr[/TD]
[TD]chmod: cannot access '/var/log/kopano/amavis.log': No such file or directory[/TD]
[/TR]
[TR]
[TD]2020-09-23 17:50:05[/TD]
[TD]stderr[/TD]
[TD]chown: cannot access '/var/log/kopano/amavis.log': No such file or directory[/TD]
[/TR]
[TR]
[TD]2020-09-23 17:50:05[/TD]
[TD]stderr[/TD]
[TD]chmod: cannot access '/etc/kopano/ssl/clients/*': No such file or directory[/TD]
[/TR]
[TR]
[TD]2020-09-23 17:50:05[/TD]
[TD]stdout[/TD]
[TD]Starting mail retriever agent: fetchmail.[/TD]
[/TR]
[TR]
[TD]2020-09-23 17:50:04[/TD]
[TD]stdout[/TD]
[TD]Done.[/TD]
[/TR]
[TR]
[TD]2020-09-23 17:50:04[/TD]
[TD]stdout[/TD]
[TD]Adding user fetchmail to group kopano[/TD]
[/TR]
[TR]
[TD]2020-09-23 17:50:04[/TD]
[TD]stdout[/TD]
[TD]Adding user `fetchmail' to group `kopano' ...[/TD]
[/TR]
[TR]
[TD]2020-09-23 17:50:04[/TD]
[TD]stdout[/TD]
[TD]init: enable fetchmail in kopano-default, add it to dagent local_admin_users and start it..[/TD]
[/TR]
[TR]
[TD]2020-09-23 17:50:04[/TD]
[TD]stdout[/TD]
[TD]setting acl, ssl, fetchmail and plugins..[/TD]
[/TR]
[TR]
[TD]2020-09-23 17:50:04[/TD]
[TD]stderr[/TD]
[TD]Generation complete.[/TD]
[/TR]
[TR]
[TD]2020-09-23 17:50:04[/TD]
[TD]stderr[/TD]
[TD] en_US.UTF-8... done[/TD]
[/TR]
[TR]
[TD]2020-09-23 17:49:56[/TD]
[TD]stderr[/TD]
[TD] en_GB.UTF-8... done[/TD]
[/TR]
[TR]
[TD]2020-09-23 17:49:48[/TD]
[TD]stderr[/TD]
[TD] de_DE.UTF-8... done[/TD]
[/TR]
[TR]
[TD]2020-09-23 17:49:40[/TD]
[TD]stderr[/TD]
[TD]Generating locales (this might take a while)...[/TD]
[/TR]
[TR]
[TD]2020-09-23 17:49:36[/TD]
[TD]stdout[/TD]
[TD]increasing php upload_max_filesize to 15M..[/TD]
[/TR]
[TR]
[TD]2020-09-23 17:49:36[/TD]
[TD]stdout[/TD]
[TD]increasing file-limits for user kopano adn www-data running sockets..[/TD]
[/TR]
[TR]
[TD]2020-09-23 17:49:36[/TD]
[TD]stderr[/TD]
[TD]usermod: no changes[/TD]
[/TR]
[TR]
[TD]2020-09-23 17:49:36[/TD]
[TD]stdout[/TD]
[TD]modifying kopano user and group ids (1080 / 65550) plus file limits ..[/TD]
[/TR]
[TR]
[TD]2020-09-23 17:49:35[/TD]
[TD]stdout[/TD]
[TD]initializing virtual aliases and pwd e.g. for proxy..[/TD]
[/TR]
[TR]
[TD]2020-09-23 17:49:35[/TD]
[TD]stdout[/TD]
[TD]image intializing UID, GID, etc-cfg, log, ssl, post-build[/TD]
[/TR]
[/TABLE]



vermutlich habe ich beim Zurücksichern vom Backup was falsch gemacht?

Ich habe es mit einer leeren Datenbank und dann Kopano4s-backup restore "ts" versucht und dann auch nochmal neu installiert und einen Benutzer mit Postfach angelegt und dann mit Kopano4s-backup restore "ts" das Backupp zurückgesichert doch bei beiden Verfahren startete dann der Docker Container nur noch kurz und schaltete sich dann wieder ab.
Ich hoffe Ihr könnt mir helfen.
Vielen Dank
Jens
 

Andy+

Benutzer
Mitglied seit
25. Januar 2016
Beiträge
3.472
Punkte für Reaktionen
26
Punkte
114
Die erste Frage ist, welche Kopanoversion 1.13 Du installiert hast.

Da es erst ab der v1.01 die Hauptunterscheidung zwischen Default und Beta gab, hattest Du bislang in jedem Fall die Beta und ich nehme durch das Update einfach einmal an, dass Du auch nun die v1.13 Beta hast. Wenn Du aber die Default für das Update genommen hast, wäre das Problem klar.

Wie hast Du das Backup gemacht?
 

Jens72

Benutzer
Mitglied seit
24. März 2008
Beiträge
103
Punkte für Reaktionen
0
Punkte
15
Ich hatte mir zuvor von dem Container der Version 1 ein Foto gemacht da steht "kopano4s:Community_base_B-8.7.80"
Das Update hatte ich mit der 1.13 Beta durchgeführt
Danach habe ich dann Beta ausgeschaltet und habe dann die normale V1.13 default installiert.
Das Backup hatte ich mit dem Task und Backup Script erstellt.
Extra hatte ich die Datenbank aber vor dem Update auch mit der MySQL Workbench nochmal gesichert.
 
  AdBlocker gefunden!

Du bist nicht hier, um Support für Adblocker zu erhalten, denn dein Adblocker funktioniert bereits ;-)

Klar machen Adblocker einen guten Job, aber sie blockieren auch nützliche Funktionen.

Das Forum wird mit einem hohen technischen, zeitlichen und finanziellen Aufwand kostenfrei zur Verfügung gestellt. Wir zeigen keine offensive oder Themen fremde Werbung. Bitte unterstütze dieses Forum, in dem du deinen Adblocker für diese Seite deaktivierst.