Kopano4S (Zarafa 2.0)

Andy+

Benutzer
Mitglied seit
25. Januar 2016
Beiträge
3.559
Punkte für Reaktionen
38
Punkte
114
@Tosoboso, ich habe gesehen, dass es wieder neue Images gibt, jedoch sind die Modulversionen noch gleich. Dadurch erfolgt im WebAdmin keine Anzeige für einen Refresh, wie sonst. Könnten solche Imageupdates nicht mit einem Kürzel versehen werden, also ....-1, ....-2, ....-3 usw.?

Das neue Default-Image läuft übrigens bestens ..... :cool:
 

Tosoboso

Benutzer
Mitglied seit
27. August 2012
Beiträge
1.175
Punkte für Reaktionen
14
Punkte
64
Hi, die Anpassungen im Image sind nur marginal, daher kann man updaten, mit einem Refresh, muss aber nicht.
Ebenso sind die Anpassungen in der K4S v.1.13 minimal, die nun zum Download steht.
-TosoBoso
 

diluciano

Benutzer
Mitglied seit
23. November 2010
Beiträge
3
Punkte für Reaktionen
0
Punkte
1
Hallo Kopaner, ich bin relativ neu hier ( zumindest aktiv) hier im Forum und brauche Hilfe. Ich installiere auf einer DS415+
( DSM 6.2.3-25426 Update 2 ,8 GB RAM, Docker und Kopano in der Version 1.13,). Installation läuft gut durch, k4s Admin läuft, aber: der Docker Container startet nicht. Das Image wurde heruntergeladen.
Ich finde die Docker log-files nicht.
Bekomme ich von euch HIlfe? Was braucht man noch für Indizien? Ich liefere promt :) Wäre dringend. Vielen Dank
Oder bin ich in dem Thread falsch?
Gruss Tom
 

Tosoboso

Benutzer
Mitglied seit
27. August 2012
Beiträge
1.175
Punkte für Reaktionen
14
Punkte
64
Hi,
Kannst du in der Docker GUI checken, ob es den Kopan4s container gibt und was unter Detail->Protokoll steht.
Welche Ausgabe bekommst du bei > kopano-status, welche bei > kopano4s-init reset (erneutes Anlegen des Containers)?
Was steht im package.log (in /var/packages/Kopano4s/target/log)?
-TosoBoso
 

diluciano

Benutzer
Mitglied seit
23. November 2010
Beiträge
3
Punkte für Reaktionen
0
Punkte
1
Hallo TosoBoso, danke für die schnelle Antwort. Die Lösung war: Alles nochmal deinstallieren, und dann Diskstation neu starten.
Danach alles neu installiert - BINGO. DB importiert vom temporären Server, der in der Zwischenzeit das Mailstystem beherbergt hatte ( backup per kopano4s-backup, restore mit kopano4s-backup restore <ts> ) . Hat jetzt alles geklappt.
Was mich noch stört im gesamten System: die suche per WebApp ist unausgereift, z.b. findet die Suche nur im Posteingang einen bestimmten Betreff nicht, aber per Such-range über alle Ordner findet er die gleiche Suche...........

Schönen Sonntag noch

Gruss Tom
 
Zuletzt bearbeitet von einem Moderator:

Andy+

Benutzer
Mitglied seit
25. Januar 2016
Beiträge
3.559
Punkte für Reaktionen
38
Punkte
114
Wer den Thread liest, liest von mir immer: Reboot - Installation - Einrichtung - Reboot. Sollten die Abholaccounts danach eingerichtet werden, ist erfahrungsgemäss ein nochmaliger Reboot empfohlen, das war trotz allen Befehlen usw. noch immer am besten.
 

Tosoboso

Benutzer
Mitglied seit
27. August 2012
Beiträge
1.175
Punkte für Reaktionen
14
Punkte
64
Ich habe die Reboots nie verstanden und für etwas esoterisch gehalten, aber es gibt Fälle, wo es nötig ist (und daran ist nicht der Entwickler schuld) :)
-TosoBoso
 

hovas

Benutzer
Mitglied seit
21. Juli 2011
Beiträge
10
Punkte für Reaktionen
0
Punkte
1
Nach dem Update auf K4S v.1.13 läuft bei mir alles wieder prima, nur im Kopano4S-Admin hält sich bei der User-Verwaltung hartnäckig folgende Fehlermeldung (auch nach Reboot & Refresh):
OCI runtime exec failed: exec failed: container_linux.go:345: starting container process caused "exec: \"kopano-cli\": executable file not found in $PATH": unknown

Lässt sich das vielleicht ohne die große Schlaufe über eine Neuinstallation fixen?
 

Andy+

Benutzer
Mitglied seit
25. Januar 2016
Beiträge
3.559
Punkte für Reaktionen
38
Punkte
114
Wenn ich versuche, auf DSM 7-Preview K4S zu installieren, erhalte ich folgendes:

K4S_DSM7-1.JPG

K4S_DSM7-2.JPG

Dann ist wohl was dran, an unserem Thema im DSM 7-Thread.
 

chats

Benutzer
Mitglied seit
29. September 2012
Beiträge
384
Punkte für Reaktionen
0
Punkte
16
Bei mir kommt diese Meldung:


Gibt es da noch einen anderen Weg das Update aufzuspielen?
Vorherige Updates wurden immer ohne Fehler installiert.

kopano_fehlermeldung.JPG
 

Andy+

Benutzer
Mitglied seit
25. Januar 2016
Beiträge
3.559
Punkte für Reaktionen
38
Punkte
114
Da hatte das System versucht, die falsche Version zu verwenden. Lade die richtige, ist wohl Beta, von cphub.net.
 

chats

Benutzer
Mitglied seit
29. September 2012
Beiträge
384
Punkte für Reaktionen
0
Punkte
16
Ach Herrjeh. Das wollte ich eigentlich vermeiden.
Ich versuche heute Abend mal die spk von cphub.net zu installieren.
 

millilenium

Benutzer
Mitglied seit
03. Februar 2014
Beiträge
139
Punkte für Reaktionen
1
Punkte
18
Habe bei den Usern selbiges Problem wie hovas:

OCI runtime exec failed: exec failed: container_linux.go:345: starting container process caused "exec: \"kopano-cli\": executable file not found in $PATH": unknown

Kennt hier jemand eine Lösung?
Vielen Dank.
 

Andy+

Benutzer
Mitglied seit
25. Januar 2016
Beiträge
3.559
Punkte für Reaktionen
38
Punkte
114
Nach dem Update auf K4S v.1.13 läuft bei mir alles wieder prima, nur im Kopano4S-Admin hält sich bei der User-Verwaltung hartnäckig folgende Fehlermeldung (auch nach Reboot & Refresh):
OCI runtime exec failed: exec failed: container_linux.go:345: starting container process caused "exec: \"kopano-cli\": executable file not found in $PATH": unknown

Das könnte vlt. abhängig von der Plattform sein, denn bei mir ist das nicht.
 

Andy+

Benutzer
Mitglied seit
25. Januar 2016
Beiträge
3.559
Punkte für Reaktionen
38
Punkte
114
Vielleicht hilft da ein Refresh des Containers oder ein Reset.
 

Tosoboso

Benutzer
Mitglied seit
27. August 2012
Beiträge
1.175
Punkte für Reaktionen
14
Punkte
64
Wenn ich versuche, auf DSM 7-Preview K4S zu installieren, erhalte ich folgendes:

Anhang anzeigen 55152

Dann ist wohl was dran, an unserem Thema im DSM 7-Thread.
Ja und K4s ist ein dickes Brett im Portieren, da einiges mit Root passiert incl. Datenbank, User, Share anlegen, ALCs, etc. Wie ich bereits im DSM7-Thread sagte werde ich versuchen Jitsi-Meet auf DSM7 zu portieren mit Anwendung von Lower Privilege. Das wird dann die Vorlage für K4s 2.0 mit neuer Ajax-GUI, Docker Compose und mehreren Containern, aber das kleine Brett zuerst bohren.. Die GUI ohne Root laufen zu lassen hate ich bei K4S ja mal versucht, das geht, sobald der GUI user (z.b. admin) Teil der Gruppe Docker ist.
-TosoBoso
 

Tosoboso

Benutzer
Mitglied seit
27. August 2012
Beiträge
1.175
Punkte für Reaktionen
14
Punkte
64
Nach dem Update auf K4S v.1.13 läuft bei mir alles wieder prima, nur im Kopano4S-Admin hält sich bei der User-Verwaltung hartnäckig folgende Fehlermeldung (auch nach Reboot & Refresh): OCI runtime exec failed: exec failed: container_linux.go:345: starting container process caused "exec: \"kopano-cli\": executable file not found in $PATH": unknown
Lässt sich das vielleicht ohne die große Schlaufe über eine Neuinstallation fixen?
Hi, welche Version / Edition benutzt du? Default, Standard, oder Community. Der Fehler tritt bei mir und Anderen nicht aud, der Fehler ist im Container und ich muss erstmal wissen, welcher Container es ist. Wenn ich es finde, kann ich den Container neu bauen und du kannst via kopano4s-init refresh den Container ziehen, ohne eine Neuinstallation machen zu müssen.
-TosoBoso
 
  AdBlocker gefunden!

Du bist nicht hier, um Support für Adblocker zu erhalten, denn dein Adblocker funktioniert bereits ;-)

Klar machen Adblocker einen guten Job, aber sie blockieren auch nützliche Funktionen.

Das Forum wird mit einem hohen technischen, zeitlichen und finanziellen Aufwand kostenfrei zur Verfügung gestellt. Wir zeigen keine offensive oder Themen fremde Werbung. Bitte unterstütze dieses Forum, in dem du deinen Adblocker für diese Seite deaktivierst.