Befehl autossh beim Synology-Start

skyflyer8

Benutzer
Mitglied seit
29. Aug 2019
Beiträge
5
Punkte für Reaktionen
0
Punkte
1
Folgende Problematik:
Aufgrund von DSlite-Problematik möchte ich von der Diskstation eine Tunnelverbindung zu meinem Remote-Server über ssh aufbauen, damit ich von unterwegs auf meine Diskstation zugreifen kann. Für die, die es interessiert, die Vorgehensweise ist hier beschrieben: Link.

Klappt auch hervorragend über die Commandozeile mit dem Befehl:
"autossh -M 0 -f -o ConnectTimeout=10 -o ServerAliveInterval=60 -o ServerAliveCountMax=2 -N -R 5001:192.168.0.206:5001 root@meineServerAdresse".

Die Frage ist, wie kann man den obigen autossh-Befehl beim Start von Diskstation ausführen?
Was ist versucht habe, ist die Datei namens "autossh.sh" anzulegen, wo ich den obigen Befehl gespeichert habe.
Als nächstes ein benutzdefiniertes Script erstellt mit dem folgenden Inhalt:
"bash /volume1/homes/benutzer/autossh.sh".
Beim Ausführen des Scripts passiert aber nichts.

Auch das Hinzufügen des obigen Befehls (mit dem vorangestellten @reboot) in die crontab-Datei hat nichts gebracht.

Weiß jemand, woran es liegt? Danke
 

ctrlaltdelete

Benutzer
Mitglied seit
30. Dez 2012
Beiträge
1.316
Punkte für Reaktionen
128
Punkte
89
Führst du den Befehl in der Konsole ohne root rechte aus?
 

Stationary

Benutzer
Mitglied seit
13. Feb 2017
Beiträge
749
Punkte für Reaktionen
154
Punkte
69
Kann man das nicht wie bei jedem Linux-basierten System durch einen systemd Service lösen? So habe ich das zumindest auf meinen RasPis gemacht, wenn ich bestimmte Dienste (z.B. MC-Server) automatisch beim Anschalten starten wollte, da die Pis ja headless betrieben werden.
Etwa so würde ich mir das vorstellen:

$ sudo nano /etc/systemd/system/autossh.service

[Unit]
Description=autossh
After=network.target
[Service]
autossh -M 0 -f -o ConnectTimeout=10 -o ServerAliveInterval=60 -o ServerAliveCountMax=2 -N -R 5001:192.168.0.206:5001 root@meineServerAdresse"
[Install]
WantedBy=multi-user.target


$ sudo systemctl enable autossh.service
 
Zuletzt bearbeitet:

skyflyer8

Benutzer
Mitglied seit
29. Aug 2019
Beiträge
5
Punkte für Reaktionen
0
Punkte
1
Danke, hat aber leider auch nicht geklappt. Der Tunnel wird nicht aufgebaut.

Ich muss dazu sagen, ich bin absolut kein Linux-Experte und tappe jetzt total im Dunkeln, warum der Befehl in der Commandozeile funktioniert und sonst nicht :unsure:.
 
Zuletzt bearbeitet von einem Moderator:

Fusion

Benutzer
Mitglied seit
06. Apr 2013
Beiträge
12.269
Punkte für Reaktionen
386
Punkte
359
Hast du mal probiert im Aufgabenplaner folgende Zeile(n)?

/volume1/homes/benutzer/autossh.sh
oder falls die Datei nicht ausführbar ist mit
sh /volume1/homes/benutzer/autossh.sh
 

ctrlaltdelete

Benutzer
Mitglied seit
30. Dez 2012
Beiträge
1.316
Punkte für Reaktionen
128
Punkte
89
Welche DSM Version hast du?
 

Fusion

Benutzer
Mitglied seit
06. Apr 2013
Beiträge
12.269
Punkte für Reaktionen
386
Punkte
359
Oder mal den gesamten Befehl direkt und kein script referenzieren.

Oder sich mal /bin/env mit ausgeben lassen bzw. das script selbst loggen.
Vielleicht fehlt dann nur der Pfad ala /bin/autossh oder ähnlich.
Sprich was in /root/.Profile oder /root/.bashrc so alles läuft wenn du dich auf der Konsole anmeldest, aber nicht unbedingt, wenn das ganze per Aufgabenplaner aufgerufen wird.
 
  AdBlocker gefunden!

Du bist nicht hier, um Support für Adblocker zu erhalten, denn dein Adblocker funktioniert bereits ;-)

Klar machen Adblocker einen guten Job, aber sie blockieren auch nützliche Funktionen.

Das Forum wird mit einem hohen technischen, zeitlichen und finanziellen Aufwand kostenfrei zur Verfügung gestellt. Wir zeigen keine offensive oder Themen fremde Werbung. Bitte unterstütze dieses Forum, in dem du deinen Adblocker für diese Seite deaktivierst.