VM Windows XP Pro

Pinocchio

Benutzer
Mitglied seit
06. Mrz 2021
Beiträge
29
Punkte für Reaktionen
6
Punkte
3
Liebe Foristen,
ich möchte mit VMM eine VM Windows XP Pro 32-Bit aufsetzen.
Nachdem mir das nach Anlaufschwierigkeiten mit Win 10 und Win 7 gelungen ist, stehe ich bei Win XP vor einem Problem. Bei Win 10 und Win 7 habe ich von MS eine ISO Datei.
Ich habe die Win XP Pro CD in ein ISO kopiert. Der VMM bootet mit dieser ISO aber nicht.
Was muss ist tun um das zum Laufen zu bringen?
 

synfor

Benutzer
Mitglied seit
22. Dez 2017
Beiträge
3.919
Punkte für Reaktionen
352
Punkte
143
BIOS-Type passend für XP eingestellt (Nur XP 64bit kann von UEFI booten)?
 

Pinocchio

Benutzer
Mitglied seit
06. Mrz 2021
Beiträge
29
Punkte für Reaktionen
6
Punkte
3
... Legacy BIOS

1618234394044.png

How-to Install WinXP in the Virtual Machine Manager (VMM)​


  1. Install and configure the Synology Virtual Machine Manager package (you’ll need to enable seeing Beta packages in the Package Manager settings).
  2. Get a WinXP-SP3 ISO from somewhere. MSFT doesn’t offer one to the public. I had one from an old job. You’re on your own here.
  3. You need special drivers for WinXP. Synology will give you the Win7+ drivers, but those are no good for WinXP. After a God-awful amount of digging I found the WinXP drivers (or most of them) in oVirt-toolsSetup-4.1-3.fc24.iso, which is at http://resources.ovirt.org/pub/ovirt-4.1/iso/oVirt-toolsSetup/. Download that, and save it next to the WinXP.iso.
  4. Back to the Synology, under the VMM’s Virtual Machine tab, select Create -> Create. Go through the prompts until it asks you to download Synology_VMM_Guest_Tool_1.4.1.iso. That is for Win7+ OSes. You can skip that.
  5. As the 2 ISOs, enter your WinXP ISO and the oVirt-toolsSetup-4.1-3.fc24.iso
  6. Using the Gear button next to the hard drive size field, make sure the hard drive is IDE.
  7. On the next page, “Default VM Network” is good, but click the Gear icon. Change the model to “virtio”. (This is very important)
  8. Select your way through the rest of the VM Wizard. I left everything at the default from here on.
  9. Install WinXP, per normal. During part of the install your mouse won’t work. So, use the old Alt+<letter> (e.g., Alt+N) to go through the WinXP setup wizard. As an aside, even after full install sometimes the mouse won’t work using Synology’s web display and you’ll have to shut that web browser tab and re-connect. A minor annoyance but easily recoverable.
  10. When that is done (and if you’re a cautious person, now would be a good time to clone the VM as a temporary backup), go to Device Manager, and you’ll see that 4 devices aren’t working (Ethernet, PCI Device, PCI Simple Communications Controller, and Video Controller). The lack of Ethernet is a big problem as you have no network connectivity without it.
  11. Run E:\ovirt-guest-tools-setup.exe from the oVirt-toolsSetup-4.1-3.fc24.iso. When that is done, drivers for 3 of the 4 devices (Ethernet, PCI Device, PCI Simple Communications Controller) will be installed.
  12. You can go to Device Manager again. You’ll notice afterwards the VirtIO Serial Driver now exists but, has the wrong driver. Also, Video Controller (VGA) isn’t installed. I have found no fix for these. Yes, I have tried all 3 of the video options the Synology VMM allows you (vga, vmvga, and cirrus). None of them worked. Manually installing the VirtIO Serial driver didn’t work either. Nothing horrid seems to happen based on these not being installed properly.
  13. You’re almost done.
  14. If you have an old WinXP-SP3 build (like I did) you’ll still not be able to get to 80% of the Internet. This is because your version of IE is less than IE8. Enable Windows Updates (My Computer->Properties->Automatic Updates-> Automatic). Unfortunately, that 80% of the Internet you cannot access includes MSFT’s Windows Updates web site, the one you can normally get to via IE (well done MSFT). So, using the Automatic Updates (which still works) is your only hope. I had to pull down 100+ updates and it took the better part of a day and multiple reboots. But eventually, you’ll get to the IE8 update and can access the Windows Update web site and that other 80% of the Internet. (Also, if you want Chrome you'll have to hunt down v49 or lower as WinXP support from Chrome has ended).
  15. Once fully updated, you’re good to go.

Babe mir das in Deutsch übersetzt, verstehe aber nur Bahnhof.
 

blurrrr

Benutzer
Mitglied seit
23. Jan 2012
Beiträge
6.203
Punkte für Reaktionen
1.077
Punkte
248
Vielleicht schilderst Du mal genauer, wo Dein Problem ist? Halt kein UEFI für XP nutzen und ansonsten "wie gehabt" - mitunter funktioniert Deine ISO auch einfach nicht - mal "woanders" getestet? :)
 

Pinocchio

Benutzer
Mitglied seit
06. Mrz 2021
Beiträge
29
Punkte für Reaktionen
6
Punkte
3
Mit der ISO (= Inhalt der Installation-CD) habe ich bereits unter VirtualBox auf einem anderen Rechner eine einwandfrei laufende Win XP-VM erstellt. Habe bei einem zweiten Versuch mit UltraISO die ISO-Datei neu erzeugt = selbes Ergebnis..
Das Problem: Der Installationsvorgang der Win XP-VM im VMM startet und bricht sofort mit der Meldung "no bootable CD/DVD" ab.
 

blurrrr

Benutzer
Mitglied seit
23. Jan 2012
Beiträge
6.203
Punkte für Reaktionen
1.077
Punkte
248
Der Installationsvorgang der Win XP-VM im VMM startet und bricht sofort mit der Meldung "no bootable CD/DVD" ab.

Versteh ich nicht - entweder "startet" der Installationsvorgang (dann wird ja von CD gebootet), oder eben nicht?
 

Pinocchio

Benutzer
Mitglied seit
06. Mrz 2021
Beiträge
29
Punkte für Reaktionen
6
Punkte
3
Es kommt diese Meldung an dann geht's nicht mehr weiter.
1618247862348.png
 

blurrrr

Benutzer
Mitglied seit
23. Jan 2012
Beiträge
6.203
Punkte für Reaktionen
1.077
Punkte
248
Gut, der Installationsvorgang startet "nicht", die VM bootet, sucht das Startmedium und kann das Boot-Medium nicht lesen. Da die ISO auf dem NAS liegt - hast Du die vorherigen Installationen auch mit der ISO (als diese schon auf dem NAS lag) durchgeführt, oder lag die ISO-Datei da noch lokal auf dem Rechner?

Nur für den Fall der Fälle: https://archive.org/details/WinXPProSP3x86

Mitunter stimmen auch die Berechtigungen an der Datei nicht (kann ich mir zwar nicht vorstellen, aber vllt doch mal zur Sicherheit drüber schauen?). Alternativ - gehe ich zwar nicht von aus, aber wer weiss - es ist definitiv eine "ISO" (also nicht nur die Dateiendung *g*)?

Könntest auch erstmal die VirtIO-Treiber-CD rauslassen und nur die XP-ISO einbinden (VirtIO-Disk dann halt im laufenden Betrieb hinzufügen). Theoretisch sind es mit VirtIO-Treibern ja 2 CD-Laufwerke... oder stellste das "Booten von" um auf das CD-Laufwerk mit der XP-ISO.
 

Pinocchio

Benutzer
Mitglied seit
06. Mrz 2021
Beiträge
29
Punkte für Reaktionen
6
Punkte
3
Erst mal vielen Dank für den Fall der Fälle!
Hatte bei allen Installationen die ISO auf der NAS. Die Prozedur ist genauso wie bei den anderen VMs.
Der einzige Unterschied: Win 10 + Win 7 ISO-Download / Win XP ISO aus CD.
Verstehe ich das richtig: Gasterweiterungen (VirtIO-Treiber) erst mal weglassen und probieren.
Ist eine .iso .
Der .iso fehlten Berechtigungen - ist jetzt Vollzugriff.
Mit oder ohne Gasterweiterungen + trotz Berechtigungen - es hat sich leider nichts geändert.
Kann ich vom Steuer-PC mit CD oder ISO auch die VM anlegen - ich frage wegen "oder lag die ISO-Datei da noch lokal auf dem Rechner?
 

blurrrr

Benutzer
Mitglied seit
23. Jan 2012
Beiträge
6.203
Punkte für Reaktionen
1.077
Punkte
248
Das mit dem Gast-Gedöns brauchst Du erst, wenn es um die zu nutzende Festplatte geht (dafür braucht es dann Treiber). Ich "glaube" (weiss es leider nicht, nutze VMM nicht) man konnte wählen zwischen "vom lokalen PC" und "vom NAS". Ich würde es aber auch einfach mal mit der ISO aus dem o.g. Link versuchen. Wenn Du möchtest, kannst Du mir die ISO auch mal zum Download bereitstellen, dann kann ich auch mal schauen, ob ich davon booten kann.
 

mamema

Benutzer
Mitglied seit
23. Okt 2009
Beiträge
553
Punkte für Reaktionen
114
Punkte
63
hab ich gelesen, dass Du es in Virtualbox schon laufen hast? Dort VM in ova Version 1 exportieren. In VMM importieren fertig!
 
  • Like
Reaktionen: blurrrr

Pinocchio

Benutzer
Mitglied seit
06. Mrz 2021
Beiträge
29
Punkte für Reaktionen
6
Punkte
3
hab ich gelesen, dass Du es in Virtualbox schon laufen hast? Dort VM in ova Version 1 exportieren. In VMM importieren fertig!

Die Idee ist gut und habe es davor genauso probiert. Ergebnis nach dem Start im VMM blauer Bildschirm und Absturz.
 

Pinocchio

Benutzer
Mitglied seit
06. Mrz 2021
Beiträge
29
Punkte für Reaktionen
6
Punkte
3
Nachtrag:
Ich werde mit VirtualBox eine neue reine Win XP SP3 aufsetzen ohne restliche Updates, Software Gasterweiterungen ... und diese dann konvertieren - vielleicht funktioniert's. Der Versuch war es allemal wert. Vielleicht stört sich der VMM daran. Kann ich später alles aufspielen.
Einstweilen danke euch allen für die Tipps, wenn es läuft oder auch nicht melde ich mich wieder.
 

Pinocchio

Benutzer
Mitglied seit
06. Mrz 2021
Beiträge
29
Punkte für Reaktionen
6
Punkte
3
... keine Chance. Auch die neue XP-VM (VirtualBox => konvertiert ova) steigt aus. Im VMM startet der XP-Bildschirm, danach wird dieser gleich blau. Ende.
 

ctrlaltdelete

Benutzer
Mitglied seit
30. Dez 2012
Beiträge
1.456
Punkte für Reaktionen
157
Punkte
89
Das muss mit deiner ISO zusammenhängen, bei mir lief eine XP-VM ohne Probleme.
 

DIY

Benutzer
Mitglied seit
05. Dez 2020
Beiträge
52
Punkte für Reaktionen
18
Punkte
58
Ort
BY
Moin zusammen,

ohne jetzt den ganzen Thread im Detail gelesen zu haben - also ausprobiert ...
... und XP32 läuft im VMM.

Erst die Bilder ....
VMM-XP32-install.jpg

VMM-XP32-drivers.jpg


Dann der Text ...
- ISO XP32 Pro OEM SP1a
- ISO virtio - Link: https://fedorapeople.org/groups/vir...ownloads/archive-virtio/virtio-win-0.1.149-1/
(einfach mal rausgegriffen und gschaut ob es XP32 Treiber gibt...)
- VMM Maschine erstellen mittels 'Andere'
- Legacy BIOS
(VGA / e1000 / 1x CPU / 2GB RAM / 10GB HDD IDE - also das Minimum ;-))
- Boot von der ISO

...warten...lange warten...Nümmerlie suchen...warten...Benutzereintrag...usw...

- VMM
(XP32 nach dem ersten erfolgreichen Boot umstellen auf Netzwerkkarte RTL8139 und Umstellen auf Grafikkarte Cirrus )
- Virtio CD-Mount
- XP32
(Treiber Update manuell für die '3 gelben Fragezeichen')


Have Fun.




PS
Nicht vergesssen - https im Internet gibst dann nur mit einem aktuellen Browser (oder halt nur suchen mittels 'Bing' im Ur-Alt-IExplorer...)

PPS
Ergänzung ... es läuft auch nach der Änderung auf 4GB und 2x CPU
 
Zuletzt bearbeitet:

ikorbln

Benutzer
Mitglied seit
26. Nov 2017
Beiträge
254
Punkte für Reaktionen
15
Punkte
18
Hm, komisch....habe es eben auch getestet (wie oben beschrieben) und es läuft ohne Probleme.......
Einstellungen genauso gemacht wie oben?? (Das Thema Gäste-Tools brauchste erstmal nicht zum booten)
Achso, meine DS ist eine 218+ ..... was ist deine??
 

blurrrr

Benutzer
Mitglied seit
23. Jan 2012
Beiträge
6.203
Punkte für Reaktionen
1.077
Punkte
248
SP1 ist aber auch schon wat in die Jahre gekommen... 😁 Ohne Gast-Tools funktioniert nur, wenn man die entsprechend beschränkte Hardware auswählt (kein VirtIO). Kann man aber sicherlich auch mal versuchen, wenn sonst nix geht (k.A. ob man das beim VMM kann, in jeder normalen Virtualisierungsumgebung kann man auf die Alternativen (Storage: IDE/SATA + NIC: Realtek/Intel) zurückgreifen). :)
 

Pinocchio

Benutzer
Mitglied seit
06. Mrz 2021
Beiträge
29
Punkte für Reaktionen
6
Punkte
3
Ich wollte nicht gleich das ganze Forum in Bewegung setzen, aber ganz vielen Dank für eure Mühe.
Für den zweiten Versuch habe ich direkt von der Installations-CD über VirtualBox eine neue XP-VM erstellt und diese dann in ova 1 exportiert. Win XP Pro 32 läuft im VMM kurz an und stürzt mit blauem Screen ab.

Ich hab' ne neue 720+, 10 GB RAM, 2 x 16 TB Seagate IronWolf Pro, 2 x Seagate Ironwolf 510 NAS SSD NVMe 480 GB

Win XP brauche ich für ältere Software, die sich unter Win 7 und Win 10 auch im Kompatibilitätsmodus nicht installieren lässt - es fehlt eine DLL im OS. VM-XP hat keine Verbindung nach draußen - also kein Sicherheitsrisiko.

Bei Winfuture gibt's eine XP 64-Bit ISO, evtl. sollte ich diese mal probieren.
Dann der Text ...
- ISO XP32 Pro OEM SP1a
- ISO virtio - Link: https://fedorapeople.org/groups/vir...ownloads/archive-virtio/virtio-win-0.1.149-1/
(einfach mal rausgegriffen und gschaut ob es XP32 Treiber gibt...)
- VMM Maschine erstellen mittels 'Andere'
- Legacy BIOS
(VGA / e1000 / 1x CPU / 2GB RAM / 10GB HDD IDE - also das Minimum ;-))
Könntest du mir das als Anfänger nochmal erklären. Verstehe das mit dem ISO virtio Link und VM Maschine mittels andere noch nicht.
Gibt es noch einen weitern Weg aus einer Installation-CD ein bootfähiges ISO zu erzeugen oder sogar von der Installations-CD zu starten?
Merkwürdig ist es schon, dass es bei euch läuft - wo ist bei mir der Gehler - keine Ahnung aber davon jede Menge.