Kopano4S (Zarafa 2.0)

Matis

Benutzer
Mitglied seit
28. Mai 2015
Beiträge
697
Punkte für Reaktionen
5
Punkte
44
Seit dem letzten backup haben ich folgenden Fehler. Das backup wird abgebrochen.
Kann mir jemand helfen was ich tun muss?

SqlDump error: mysqldump: Error 2020: Got packet bigger than 'max_allowed_packet' when dumping table `properties` at row: 1274140 mysqldump: Error 2020: Got packet bigger than 'max_allowed_packet' when dumping table `properties` at row: 1272258..
MyMaxPackets habe ich auf 512 und dann auf 1024 erhöht. Scheint aber keinen Einfluß zu haben.
Hat mit keiner einen Tipp? Ich kann keine Backups mehr machen.
 

FricklerAtHome

Benutzer
Mitglied seit
01. Okt 2017
Beiträge
333
Punkte für Reaktionen
3
Punkte
24
Glück Auf Matis

schau mal in den "Variablen" des MySql bzw. MariaDB Servers.

Dort gibt es eine Variable "max_allowed_packet. Bei mir steht dort als Wert "16.777.216". Am einfachsten geht das mit phpMyAdmin!
Ansonsten gibt es unter Kopano Core SQL Tuning noch weitere Hinweise.

immer ein Licht bei Nacht
F@H
 

Matis

Benutzer
Mitglied seit
28. Mai 2015
Beiträge
697
Punkte für Reaktionen
5
Punkte
44
Vielen Dank. ich kann die Tabelle "variablen" nicht mit phpMyAdmin finden. Ich bin damit aber auch absolut nicht vertraut. Das ist mehr ein stochern und ich will nichts kaputt machen.
 

FricklerAtHome

Benutzer
Mitglied seit
01. Okt 2017
Beiträge
333
Punkte für Reaktionen
3
Punkte
24
@Matis

öffne phpMyAdmin und wähle nicht eine Datenbank sonder den Server aus. In der kleinen grauen obersten Leiste steht dann wie in diesem Bilschirmfoto nur "Server: MariaDB 10". In der Menüleiste direkt darunter findest du den Reiter "Variablen". Anklicken und dann in der Auflistung nach "max allow packet" suchen. Über den Bleistift kannst dann den Wert anpassen. Das anpassen ist etwas tricky da nur gültige Werte angenommen werden. Im Default steht da ein Wert in etwa in der Mitte zwischen 1024 und dem auf deinen System möglichen Höchstwert. Ich würde den stehenden Wert um das 1,25 fache erhöhen und dann neu testen. Damit der Wert greift musst die die Datenbank ggf. neu starten.

immer ein Licht bei der Nacht
F@H Bildschirmfoto 2021-01-20 um 14.49.16.png Bildschirmfoto 2021-01-20 um 14.50.04.png
 

Anhänge

  • Bildschirmfoto 2021-01-20 um 14.49.16.png
    Bildschirmfoto 2021-01-20 um 14.49.16.png
    226,8 KB · Aufrufe: 3
  • Like
Reaktionen: Matis

Matis

Benutzer
Mitglied seit
28. Mai 2015
Beiträge
697
Punkte für Reaktionen
5
Punkte
44
Lieber Frickler,

vielen Dank. Hab "variablen" gefunden. War nicht auf home.

Bei mir stand dort: 1.073.741.824, lt. der Beschreibung der Max-Wert.
Hab es mit der Hälfte versucht, ging ebenfalls nicht, gleicher Fehler.
Dann nochmals die Hälfte: 268.435.456.
Und Hurra, das Backup lief wieder durch (ohne Maria neu zu starten).

Das entspricht jetzt den 256MB die in der Konfig von K4S unter MyMaxPacket steht.
Muß das evtl. gleich sind? Und warum waren sie plötzliche nicht mehr gleich?

Ich hab keine Ahnung, warum bei mir dort so rießige Werte stehen.

Vielen, vielen Dank. Das hat mir sehr geholfen!
 

FricklerAtHome

Benutzer
Mitglied seit
01. Okt 2017
Beiträge
333
Punkte für Reaktionen
3
Punkte
24
@Matis

wenn ich mich recht erinnere testet beim Install von K4S das Install-Script von Tosoboso die Fähigkeiten der MariaDB und trägt dann einen Empfehlungswert in MyMaxPacket fürs Tuning der Datenbank ein. Deine MariaDB hat den Wert entweder nicht übernommen oder irgendetwas anderes hat ihn überschreiben. Der Wert in meiner MariaDB entspricht dem Default.
Man kann den Wert so wie ich es dir gezeigt habe über phpMyAdmin einstellen, es geht aber auch übers mySql-Terminal oder in der Config Datei
"my.cfg" der Datenbank. Die im NAS hinterlegte my.cfg ist aus meinen Erfahrungen nicht restistent gegen Updates!
Beobachte das einfach. Schön das ich helfen konnte!

immer ein Licht bei der Nacht
F@H
 

Huhie

Benutzer
Mitglied seit
29. Nov 2007
Beiträge
348
Punkte für Reaktionen
3
Punkte
18
Moin Zusammen,
nach langer Zeit versuche ich mich mal wieder an Kopano4s. Leider habe ich etwas den Anschluss verpasst...

vergesst was hier stand, das war völliger Bullshit... Sorry dafür

Ich habe in der Ablage noch eine alte Installationsanleitung gefunden und bin danach vorgegangen.
Allerdings bekomme ich beim Start des Pakets die Fehlermeldung "Error Kopano share still empty post mount timeout 60 sec"

Kann mir da jemand von euch sagen, woher dieser Fehler stammt?

viele Grüße
Huhie
 
Zuletzt bearbeitet:

Jens H

Benutzer
Mitglied seit
06. Jun 2010
Beiträge
213
Punkte für Reaktionen
0
Punkte
16
Hallo,
ich habe vor einiger Zeit (siehe Postings rund um #1450, Januar 2020) versucht, meine Synology mit Kopano auch als Mailserver einzurichten, um nicht nur über Fetchmail diverse Gmx- und Provider-Mails abzufragen und zu verteilen, sondern parallel dazu auch diverse eigene Mailadressen wie zB MeinVorname@meinedomain.at, MeinNachname@meinedomain.at usw. Daran bin ich vorerst gescheitert, habe dann aber auch nicht weiter herumexperimentiert, damit der Port 25 zu bleibt und ich auf der sicheren Seite bin.
Nun ist es aber so, dass einer meiner Garmin-Accounts noch auf eine dieser alten Mailadressen meiner hauseigenen meinedomain.at läuft, und ich habe das Passwort dieses Accounts vergessen. Also muss ich, um das Passwort zu ändern, vorübergehend einen Mailserver anwerfen. Soviel zur Vorgeschichte.

Nun möchte ich nicht (wieder mal :) ) voreilig herumexperimentieren, sondern nach Möglichkeit gleich von Anfang an die korrekten Einträge machen, so dass ich die oben genannten Mails erhalten kann.

In der Domainverwaltung für des "Providers" bei dem ich meine Domain gekauft habe, ist der MX-Records Eintrag noch von alten Zarafa-Zeiten drinnen, es sollten also alle @meinedomain.at E-Mails an die (fixe) IP Adresse meiner Synology weitergeleitet werden.


Nach meinem Verständnis muss ich nun noch:
- den Router Port 25 auf die Synology leiten
- in der Kopano Admin-Oberfläche unter SMPTD die entsprechenden Einträge machen. Hier fängt es schon an. Was muss hier bei SMTPD-Name und bei meine Domain eingetragen werden? mail.meinedomain.at oder nur meinedomain.at?
- wo (zum Geier!) werden die unterschiedlichen @meinedomain.at meinem User zugeordnet? Bei Fetchmail werden ja nur die externen Mails, die von diversen Providern abgeholt werden, eingetragen. Bei Zarafa konnte ich jedem User in Sekundenschnelle x-beliebige @meinedomain.at Mailadressen zuordnen, indem ich das bei den alias-Adressen eingetragen habe. Man konnte so mal eben ganz schnell eine neue Mailadresse für einen bestimmten User aktivieren und wieder deaktivieren.
- was ist eventuell sonst noch zu tun?


Edit: Ich weiß, dass Garmin vor nicht allzu langer Zeit gehackt wurde. Bitte trotzdem keine Tipps wie "Frag im Darknet nach Deinem Passwort!"
Danke für (bessere) Hinweise!
Jens
 

Andy+

Benutzer
Mitglied seit
25. Jan 2016
Beiträge
3.730
Punkte für Reaktionen
81
Punkte
114
Was muss hier bei SMTPD-Name und bei meine Domain eingetragen werden? mail.meinedomain.at oder nur meinedomain.at?

SMTPD-Name = mail.meinedomain.at
Domain = meinedomain.at

Betreffend der Zuordnungen sollte es über Fetchmail gehen, wenn jeder User einen eigenen externen Account hat. Die Eingaben im Bereich Fetchmail lassen sich per Script erledigen:

#!/bin/bash
#kopano-fetchmail add K-User RMBox-User PW RMBox-Server Protocol Port SSL Folders
#bzw.
#kopano-fetchmail add USERNAME EMAILADRESSE PASSWORT IMAPSERVER imap 993 ssl INBOX
#
kopano-fetchmail add KOPANOUSER_1 EMAILBENUTZERNAME_1 EMAILPASSWORT_1 IMAPADRESSEPROVIDER imap 993 ssl INBOX
kopano-fetchmail add KOPANOUSER_2 EMAILBENUTZERNAME_2 EMAILPASSWORT_2 IMAPADRESSEPROVIDER imap 993 ssl INBOX
kopano-fetchmail add KOPANOUSER_3 EMAILBENUTZERNAME_3 EMAILPASSWORT_3 IMAPADRESSEPROVIDER imap 993 ssl INBOX
kopano-fetchmail add KOPANOUSER_4 EMAILBENUTZERNAME_4 EMAILPASSWORT_4 IMAPADRESSEPROVIDER imap 993 ssl INBOX
kopano-fetchmail add KOPANOUSER_5 EMAILBENUTZERNAME_5 EMAILPASSWORT_5 IMAPADRESSEPROVIDER imap 993 ssl INBOX
kopano-fetchmail add KOPANOUSER_6 EMAILBENUTZERNAME_6 EMAILPASSWORT_6 IMAPADRESSEPROVIDER imap 993 ssl INBOX
kopano-fetchmail add KOPANOUSER_7 EMAILBENUTZERNAME_7 EMAILPASSWORT_7 IMAPADRESSEPROVIDER imap 993 ssl INBOX
kopano-fetchmail add KOPANOUSER_8 EMAILBENUTZERNAME_8 EMAILPASSWORT_8 IMAPADRESSEPROVIDER imap 993 ssl INBOX
kopano-fetchmail init
kopano-fetchmail restart
kopano-fetchmail list

Die in der gezeigten Beispielsequenz gezeigten KOPANOUSER_1-8 sind unter User angelegt und werden als K-User im Bereich Fetchmail angezeigt. Ich nehme an, um das gehts, oder?
 

Jens H

Benutzer
Mitglied seit
06. Jun 2010
Beiträge
213
Punkte für Reaktionen
0
Punkte
16
Danke Andy,
ich glaube, hier liegt wie seinerzeit schon ein Missverständnis vor, weshalb wir auch damals schon nicht weiter gekommen sind. Es gibt keine Zugangsdaten zu den E-Mails @meinedomain.at, weil ich bei meinem Anbieter meiner Domain nur die Domaingebühren bezahle, aber für keine Email Adressen. Auch die Homepage zur Domain liegt auf der Synology. Es gibt nichts Externes! Die Mailadressen muss ich daher lokal „einrichten“ und den entsprechenden Useraccounts zuordnen. Deshalb glaube ich nicht, dass es mit Fetchmail klappt, denn es gibt ja nichts abzuholen - von wo denn auch! Wenn irgendjemand ein Mail an ...@meinedomain.at sendet, so kommt die direkt ohne Umwege an meine Synology!
Und genau da stehe ich an: wo sage ich Kopano, welche @meinedomain.at Emails ich überhaupt annehme bzw. welchen Usern diese dann ins Postfach geschoben werden?
Ich hoffe, ich konnte das Problem verständlich schildern.
Jens
 

Andy+

Benutzer
Mitglied seit
25. Jan 2016
Beiträge
3.730
Punkte für Reaktionen
81
Punkte
114

FricklerAtHome

Benutzer
Mitglied seit
01. Okt 2017
Beiträge
333
Punkte für Reaktionen
3
Punkte
24
@Jens in Austria

wenn ich das richtig verstehe hat du eine registierte Domäne über einen Provider im Internet. Diese hat jedoch keinen MX-Eintrag (das bedeutet diese Domäne hat beim Provider keinen eigenen E-Mail Server bzw. MTA). Du hast aber einen MX-Eintrag für diese Domäne auf dein lokales Kopano4S mittels entsprechender Einträge beim Provider erstellt. Somit kommen die E-Mails für deine "meineDomäne.at" direkt auf deinem Syno-Nas und damit Kopano4S an.
Für diesen Fall brauchst du kein Fetchmail, da holst ja keine Mail bei irgendwem ab. Du brauchst aber eine wasser, spam, viren und relay geschützte Postfix-Konfiguration. ---- Jetzt kommt die Anmerkung am Ende der Antwort! ----

Um deine Konfiguration so zu betreiben muss du dich beim MTA (sprich Postfix) um einiges selber kümmern! In der Basis K4S Konfiguration werden die Benutzer und damit die zum Empfang berechtigten E-Mail Adressen in der Kopano-Datenbank verwaltet. Du musst also Postfix mittels main.cf beibringen nur diese zu aktzeptieren und alle anderen zu verwerfen. Dein MTA Postfix bzw. in diesem Fall dein NAS steht bei einer solchen Nutzung der ganzen Welt für jedweden Missbrauch offen. Auch das musst du manuel verhindern. Da können wie hier nicht helfen!

Aber was geht.! -- und nun zur Anmerkung

Die Erweitung deiner Domäne beim Provider mit einem MTA (Mail-Adressen) sollte kein Vermögen kosten. Ich zahle in DE für eine "meineDomäne.de" inklusive 5 Mail Adressen keine 12 € pro Jahr. Alle Mails an potenzielle Adressen dieser Domäne landen also erstmal da. Gibt es die Adresse nicht vernichtet sie der Provider. -- Per fetchmail hole ich die "berechtigten Adressen" beim Provider ab und mein kopano4S steht sicherheitsauffällig gar nicht im Internet. --- wenn ich dein Konstrukt richtig verstanden habe, sparst du eventuell bei Kosten gegen Sicherheit.
Mit der bei mir und wahrscheinlich häufigsten Kombi --> Provider mit Mail-Domän ---> fetchmail für Kopano4S gehst du vielen trivialen Sicherheitsproblemen aus dem Weg. Die erste Security-Wall übernimmt der Provider. Meist ist der in allen Belangen aktueller als Du / Ich.
Dann sollte mit einer explizierten Fetchmail.rc auch die manuelle MTA (Postfix) Konfiguration nicht mehr notwendig sein.

immer ein Licht bei der Nacht (gestern -14 Grad Celsius und 39 cm Schnee)
F@H
 

Jens H

Benutzer
Mitglied seit
06. Jun 2010
Beiträge
213
Punkte für Reaktionen
0
Punkte
16
@F@H:
Ja, es ist genauso wie Du es beschreibst. Nun bin ich aber endgültig verwirrt. Wozu gibt es dann denn die ganzen SMTP-Einträge, die bei "normaler" Verwendung von Kopano (Abholung der Emails über Fetchmail von externen Providern) gar nicht vonnöten sind und der direkte Mailempfang/Versand ohnehin nicht funktioniert? In welchem Fall muss man denn zB überhaupt den Port 25 öffnen, das braucht man dann ja auch nicht!?
Jedenfalls ist dann ist Kopano nach meinem Verständnis kein voller Ersatz für das Zarafa Paket, denn mit Zarafa ging das extrem einfach. Man konnte sich sogar aussuchen, ob beim Versand von Emails nur über den Server des externen Providers versandt wird oder direkt über die Diskstation. Problem mit Zugriffen von extern hatte ich meines Wissens nach damals mit Zarafa nicht wirklich, weil ich ab dem 3. Anmeldeversuch die IP geblockt habe. Aber wie schon gesagt, ich würde diese Funktion nur kurz benötigen, damit ich Zugriff aufs Garmin-Konto habe und die Mail-Adresse ändern kann. Ist aber nicht extrem wichtig, weil es nur der Zweitaccount für meinen Hund ist (nicht lachen!), den ich regelmäßig zum Laufen mitnehme.
Die vorgeschlagene Lösung, über meinen Provider Adressen zu buchen, ist wohl die sicherste und ich spare mir das herumfrickeln :)
Danke!
 

Andy+

Benutzer
Mitglied seit
25. Jan 2016
Beiträge
3.730
Punkte für Reaktionen
81
Punkte
114
Der wohl wichtigste Unterschied zwischen Z4H und K4S ist, daß Z4H keinen eigenen Mailserver hatte. Die Frage wäre daher, wie Du das eingerichtet hattest.
 

Jens H

Benutzer
Mitglied seit
06. Jun 2010
Beiträge
213
Punkte für Reaktionen
0
Punkte
16
Ich habe mit dem offiziellen Zarafa-Synology Paket gearbeitet, nie mit Zarafa for Home. Das hat nur bis zur DSM Version 5 funktioniert.
Und das war sogar für mich als Laie relativ einfach. Einen MX-Records Eintrag für "mail" bei meinem Provider hat dafür gesorgt, dass alle @meinedomain.at E-mails an die IP-Adresse meiner Synoloygy (=IP der Homepage, die ebenfalls auf der Synology läuft) geht. Am Router habe ich die entsprechenden Ports geöffnet (25 und 110 glaub ich). Dann gab es irgendwo in der Zarafa administration die Möglichkeit, beliebig viele Alias Namen einzutragen. Da habe ich zB für meinen Useraccount "vorname.nachname", "nachname" und "vorname" hinzugefügt, und schon hatte ich alle möglichen Permutationen meines Namens als E-mailadresse mit @meinedomain.at. Den Mail-Versand habe ich wenn ich mich richtig erinnere nur über meinen Provider bei A1 zugelassen, das gab es irgendwo samt Passwort und Port einzutragen.
 

Andy+

Benutzer
Mitglied seit
25. Jan 2016
Beiträge
3.730
Punkte für Reaktionen
81
Punkte
114
offiziellen Zarafa-Synology Paket

Bei diesem war das wie bei Z4H, es setzte auf dem Mailserver der DS auf. Erst K4S brachte einen eigenen Mailserver mit, daher muss der Mailserver der DS deaktiviert oder deinstalliert sein. Was Du damals mit dem DS-Mailserver gemacht hast, musst Du jetzt also im K4S-package anpassen.

BTW: "offiziell" war Zarafa damals auch nicht, was heute Tosoboso für danach Z4H und heute K4S ist, war damals Julian Dohle, welcher die SPKs bis v0.6.0 erstellt hatte.
 

Jens H

Benutzer
Mitglied seit
06. Jun 2010
Beiträge
213
Punkte für Reaktionen
0
Punkte
16
Ja stimmt, es war eine Kombination aus Synology Mailserver und Zarafa. Die analoge Anpassung in K4S ist mir zu heiß. Ich gehe dann wohl den Weg, die E-Mail Adressen beim Provider meiner Domain zu erstehen. Das Schont die Nerven :)
 

Andy+

Benutzer
Mitglied seit
25. Jan 2016
Beiträge
3.730
Punkte für Reaktionen
81
Punkte
114
Ich weiss nicht, ist der Unterschied da so gross?
 

Jens H

Benutzer
Mitglied seit
06. Jun 2010
Beiträge
213
Punkte für Reaktionen
0
Punkte
16
Wenn ich über die Kommandozeile irgendwelche kryptischen Parameter in config-Dateien schreiben muss, dann ja. In der Kopano-DSM Oberfläche konnte ich keine Möglichkeit finden, die gewünschten E-Mail Adressen einzutragen und einem User zuzuordnen.
 

Andy+

Benutzer
Mitglied seit
25. Jan 2016
Beiträge
3.730
Punkte für Reaktionen
81
Punkte
114
Und über WinSCP und dann Dateien bearbeiten, ggf. mit Copy-Paste, wenn möglich? Ich meine reinfliegen tut es ohnehin nicht von alleine .... ;)
 
  AdBlocker gefunden!

Du bist nicht hier, um Support für Adblocker zu erhalten, denn dein Adblocker funktioniert bereits ;-)

Klar machen Adblocker einen guten Job, aber sie blockieren auch nützliche Funktionen.

Das Forum wird mit einem hohen technischen, zeitlichen und finanziellen Aufwand kostenfrei zur Verfügung gestellt. Wir zeigen keine offensive oder Themen fremde Werbung. Bitte unterstütze dieses Forum, in dem du deinen Adblocker für diese Seite deaktivierst.