Init_3rdparty Skript und Sammlung von 3rd-Party Erweiterungen

Trolli

Benutzer
Mitglied seit
12. Jul 2007
Beiträge
9.848
Punkte für Reaktionen
1
Punkte
0
Dafür ist ja eigentlich das Wiki gedacht. Wenn man zu einem Thema mal alles zusammengetragen hat, könnte man eine entsprechende Anleitung ins Wiki stellen. Ist ja für einige Projekte hier auch bereits umgesetzt. Problem dabei ist zur Zeit aber noch, dass wir bisher noch keine vernünftige Möglichkeit haben, den Programmcode im Wiki abzulegen. Das macht es bei einigen Themen recht schwierig...

Trolli
 

jahlives

Moderator
Mitglied seit
19. Aug 2008
Beiträge
18.275
Punkte für Reaktionen
2
Punkte
0
Problem dabei ist zur Zeit aber noch, dass wir bisher noch keine vernünftige Möglichkeit haben, den Programmcode im Wiki abzulegen.
Für MediaWiki gibt es Geshi, welches wirklich schnell installiert ist und gute Unterstützung für 28 Sprachen bietet. Lässt sich auch relativ einfach beliebig erweitern (z.B. Farben beim Code oder Links bei Funktionen ins entsprechende Manual). Wenn Marc uns lässt dann könnten wir das selber machen und wenn wir den Server übernehmen wollen dann installieren wir gleich noch runPHP dazu;)

Gruss

tobi
 

Trolli

Benutzer
Mitglied seit
12. Jul 2007
Beiträge
9.848
Punkte für Reaktionen
1
Punkte
0
Find ich super. Vielleicht sollten wir das an geeigneter Stelle nochmal vortragen...
 

Selfcontrol

Benutzer
Mitglied seit
06. Aug 2008
Beiträge
53
Punkte für Reaktionen
0
Punkte
0
IPKG per .spk installieren ?

Ist es möglich IPKG per .spk Paket zu installieren ?
evtl. gleich incl. open-ssh und open-ssl ...... dann könnte man gleich sauber per WinSCP auf das NAS zugreifen

incl. der bereits erstellten .spk Pakete bräuchte der unbedarfte User dann gar nicht mehr auf Telenet losgelassen werden

das IPKG scheint man ja wohl nacht jedem Firmwareupdate eh wieder neu installieren zu müssen , wäre dann der einfachste weg

wie ieht es mit einem zentralen Speicherplatz für alle bisher erstellten .spk aus
ist dafür Platz innerhalb des Wikis ? ... achja und dann auch gleich mit Versionsnummern

mfg S
 

Trolli

Benutzer
Mitglied seit
12. Jul 2007
Beiträge
9.848
Punkte für Reaktionen
1
Punkte
0
IPKG bleibt beim Firmwareupdate vollständig erhalten. Garantien gibt es dafür natürlich nicht.

Das mit den .spk Dateien im Wiki ist so ein Problem. Geht zur Zeit leider (noch?) nicht.

Trolli
 

EPIX

Benutzer
Mitglied seit
21. Sep 2008
Beiträge
219
Punkte für Reaktionen
0
Punkte
16
wegen: Ablage der spk's

und wie wäre es im Download bereich?
Da könnte man die Dinger ja aufbewahren und immer nur das aktuelle anbieten...
 

Trolli

Benutzer
Mitglied seit
12. Jul 2007
Beiträge
9.848
Punkte für Reaktionen
1
Punkte
0
Haben wir einen Downloadbereich? Wo?
 

EPIX

Benutzer
Mitglied seit
21. Sep 2008
Beiträge
219
Punkte für Reaktionen
0
Punkte
16
NÖ, aber wäre ja möglich (theoretisch):cool:
 

Spawn2001

Benutzer
Mitglied seit
09. Mrz 2009
Beiträge
5
Punkte für Reaktionen
0
Punkte
0
Das Benchmark.spk hat ein fehler in der cfg datei. Sie verweist auf sich selber was ein "Die Seite wird nicht gefunden" zur folge hat.


Ich habe mir das entsprechend geändert. Nun läuft es tip top

Hi, bin neu hier...

...wo und wie hast du den Eintrag geändert ?
Bei mir kommt die Meldung auch
"Es tut uns Leid, die von Ihnen gesuchte Seite konnte nicht gefunden werden."

schon mal Danke !
 

ag_bg

Benutzer
Mitglied seit
19. Jan 2008
Beiträge
1.736
Punkte für Reaktionen
0
Punkte
0
Hier:

Rich (BBCode):
/usr/syno/synoman/webman/3rdparty/Ordner der Anwendung/application.cfg

best regards
 

Spawn2001

Benutzer
Mitglied seit
09. Mrz 2009
Beiträge
5
Punkte für Reaktionen
0
Punkte
0
danke !

aber wie editiere ich jetzt die datei und was kommt da jetzt genau rein ?

bin da mit SSH drauf (Putty)
 

ketchup

Benutzer
Mitglied seit
18. Dez 2008
Beiträge
9
Punkte für Reaktionen
0
Punkte
0
Probleme beim Installieren

Seit ein paar Wochen bin ich stolzer Besitzer einer DS209+ und sehr zufrieden. Ich wollte jetzt das beschriebene Paket Init_3rdparty.spk installieren. Ich habe es auf auf der DS abgelegt und mit dem Befehl:
IPKG install [Pfad aufs Paket]
installieren wollen. Leider bekomme ich eine Fehlermeldung, sinngemäß "Paket unbekannt" Wer kann mir etwas Nachhilfe geben?
:D
 
Zuletzt bearbeitet:

miroethi

Benutzer
Mitglied seit
04. Feb 2009
Beiträge
50
Punkte für Reaktionen
0
Punkte
6
Das .spk paket muss über die Weboberfläche installiert werden. Gehe per Browser in dein Management (IP_DER_DS:5000) und wechsle in das Menü Paketmanagement. Dort wählst du das Paket das du installieren willst aus und folgst den weiteren Schritten die dir das Management der DS vorgibt.
 

Totti

Benutzer
Mitglied seit
27. Jan 2007
Beiträge
75
Punkte für Reaktionen
0
Punkte
0
Installation funktioniert nicht

Hallo ich habe die neue Firmware installiert und wollte nun Init_3rdparty.spk 1.4 Paket installieren hochladen klappt und dann kommt dann kommt Paket konnte nicht installiert werden.....
Was für ein Fehler konnte es sein...


vielen Dank im voraus
Totti
 

Matthieu

Super-Moderator
Teammitglied
Mitglied seit
03. Nov 2008
Beiträge
13.115
Punkte für Reaktionen
35
Punkte
344
Für alle Firmwares ab 0914 gibt es ein neues Paket das es in der entsprechenden Diskussion zu 0914 gibt.

Das alte produzierte besagte Fehlermeldung.

MfG Matthieu
 

itari

Benutzer
Mitglied seit
15. Mai 2008
Beiträge
21.900
Punkte für Reaktionen
7
Punkte
0
Probier mal hier mit dem Paket ...

Itari
 

Totti

Benutzer
Mitglied seit
27. Jan 2007
Beiträge
75
Punkte für Reaktionen
0
Punkte
0
Habe ich probiert es kommt die Meldung Paket konnte nicht installiert werden

Hatte die alte Firmware drauf und mußte das System komplett neu aufsetzen
 

itari

Benutzer
Mitglied seit
15. Mai 2008
Beiträge
21.900
Punkte für Reaktionen
7
Punkte
0
Da das Init_3rdparty.spk-Paket für aller Versionen das Gleiche ist und ich es seit fast einem Jahr immer bei jedem Firmware-Update einspiele, kann ich das fast nicht glauben, dass es beim Installieren Fehlermeldungen bringt.

Nach dem Starten können die alten Versionen des Paketes bei der neuen Firmware (09xx) dazu führen, dass der sys-Apache stehen bleibt, weil der Port doppelt belegt wird, aber das wäre auch schon alles. Dieses Problem hatte ich in obigem Beitrag erläutert und durch hinzufügen einer Leerstelle entschärft ...

Aber sollte bei dir das Init_3rdparty.spk nicht zu installieren sein, dann ist es halt so. Solange ich keine Ahnung habe, welche Fehler darin sein könnten, kann ich auch nichts Verändertes schreiben. Und bis dahin musste halt ohne die Pakete für die es geschrieben wurde, auskommen.

Falls jemand allerdings den/die Fehler entdeckt und korrigiert hat, der muss (!) gemäß der GPL 3 dieses dann auch hier veröffentlichen, ansonsten wird er/sie von mir mit einem Fluch belegt :D.

Itari
 

Matthieu

Super-Moderator
Teammitglied
Mitglied seit
03. Nov 2008
Beiträge
13.115
Punkte für Reaktionen
35
Punkte
344
Fehler werden übrigens in der Datei /var/log/messages abgelegt. Abzurufen mittels SSH-Befehl:
Rich (BBCode):
more /var/log/messages

MfG Matthieu
 

Totti

Benutzer
Mitglied seit
27. Jan 2007
Beiträge
75
Punkte für Reaktionen
0
Punkte
0
Muss ich noch vorher irgend etwas installieren oder aktivieren !!!


ich Danke Dir jm voraus


Totti

habe versucht über Aktualisierung zu installieren und ich soll erst die alte deinstallieren gibts aber nicht !!!!!!
Was kann das sein ....

danke
 
Zuletzt bearbeitet:
  AdBlocker gefunden!

Du bist nicht hier, um Support für Adblocker zu erhalten, denn dein Adblocker funktioniert bereits ;-)

Klar machen Adblocker einen guten Job, aber sie blockieren auch nützliche Funktionen.

Das Forum wird mit einem hohen technischen, zeitlichen und finanziellen Aufwand kostenfrei zur Verfügung gestellt. Wir zeigen keine offensive oder Themen fremde Werbung. Bitte unterstütze dieses Forum, in dem du deinen Adblocker für diese Seite deaktivierst.