Windows 10 WebDAV Netzlaufwerk Autologin

c0smo

Benutzer
Mitglied seit
08. Mai 2015
Beiträge
2.548
Punkte für Reaktionen
8
Punkte
84
Genau das selbe Problem hat mich auch ewig genervt, bis ich schließlich einen Workaround gefunden habe, der die Problematik zumindest teilweise löst.

1. Erstelle eine Bat Datei mit folgendem Inhalt
net use \\DDNS.de@SSL@Port für WebDAV\DavWWWRoot Passwort /user:User /P:NO

2. Lege die Datei in irgendeinem Verzeichnis ab

3. Erstelle eine neue Aufgabe über die Aufgabenplanung in Win10 (taskschd.msc)
a) Rechtsklick - Aufgabe erstellen
b) Name vergeben
c) Neuer Trigger / Aufgabe starten bei: Anmeldung
d) Neue Aktion / Aktion: Programm starten / Skript: Pfad zu der erstellten Bat Datei

4. Regedit öffnen
a) HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\WebClient\Parameters
b) Den Wert von dem Schlüssel BasicAuthLevel auf 2 ändern

5. In den Diensten von Windows, muss der WebClient automatisch ausgeführt werden.

6. WebClient beenden und neu starten oder Rechner neu starten.

Mit diesen Schritten ist zumindest das Problem behoben, dass nach jedem Rechner Neustart erneut die Anmeldeinformationen für das WebDAV Laufwerk eingegeben werden müssen.
Was allerdings nicht zu beheben ist, ist die selbe Prozedur für das Öffnen eines Office Dokuments. Hier greifen MS Richtlinien, die diese erfordern.

Aber auch hierfür gibt es anscheinend einen Workaround, den ich allerdings nicht probiert habe, da es m.E. zu aufwendig wäre.
Es müsste ein Proxy dazwischen geschaltet werden. Dieser muss in den Sicherheitseinstellungen von den Internet Optionen definiert werden. Anschließend muss eine neue Mehrteilige Zeichenfolge unter folgendem Pfad erstellt werden.
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\WebClient\Parameters, die den Namen AuthForwardServerList bekommt. In diesen Wert können dann beliebig viele Server definiert werden, die ohne Anmeldeoptionen auskommen.
 
Zuletzt bearbeitet:

geryg

Benutzer
Mitglied seit
04. April 2018
Beiträge
3
Punkte für Reaktionen
0
Punkte
0
Ich habe genau das gleiche Problem wie der Threadersteller. Gibt es dafür wirklich keine einfach Lösung.
 

geryg

Benutzer
Mitglied seit
04. April 2018
Beiträge
3
Punkte für Reaktionen
0
Punkte
0
Ausgangspost
Habe das gleiche Problem wie Du. Hast Du schon ne Lösung dafür. Es nervt tierisch. Netdrive ist keine Option.
 
Zuletzt bearbeitet von einem Moderator:

c0smo

Benutzer
Mitglied seit
08. Mai 2015
Beiträge
2.548
Punkte für Reaktionen
8
Punkte
84
Was gefällt dir an meiner Lösung nicht? Du wirst keinen einfacheren Workaround finden. Das Problem liegt an MS und deren Restriktionen, die bei Anmeldungen über WebDAV und eine FQDN greifen. Nenne es Bug, Einschränkung oder Sicherheitsfeature, dass Ergebnis bleibt das selbe. Entweder du installierst einen Proxy und befolgst die unten aufgeführten Tipps oder du lebst mit "einem" Klick mehr.

https://support.microsoft.com/en-gb...ation-requests-when-you-open-office-documents
https://support.microsoft.com/en-gb...en-you-access-webdav-based-fqdn-sites-in-wind
https://support.microsoft.com/en-us...cally-reconnect-a-dav-share-when-basic-authen
 

Sir Toby

Benutzer
Mitglied seit
10. März 2018
Beiträge
12
Punkte für Reaktionen
0
Punkte
0
Hey

Da bin ich endlich wieder :) Sorry für meine lange Abwesenheit.
Ich bin ja sehr froh, dass ich nicht alleine mit dem Problem bin. :p

Also eine BAT Datei mit Benutzername und Passwort im Klartext kommt für mich nicht in Frage. Wer die Datei hat, hat damit den Zugang. Von der Änderung des Registry Eintrags "BasicAuthLevel" auf "2" kann ich auch nur abraten. Hier könnten die Anmeldeinformationen im Klartext unverschlüsselt an den Server gesendet werden. Und wer die Übertragung abfängt hat hier dann ebenfalls den Zugang. Hier ist "1" die richtige einstellung (nur bei SSL Verbindungen). Da ich ein SSL Zertifikat von Lets Encrypt verwende sollte dies auch gehen.

Ich habe eine Anfrage in der Microsoft Community gestellt. Leider habe ich nur eine Antwort bekommen.
Hier wurde auf folgende Seite verwiesen:
https://support.microsoft.com/de-de...en-you-access-webdav-based-fqdn-sites-in-wind

Ich denke hier wird das Problem sehr gut beschrieben. Windows nimmt an, dass es sich bei einer Adresse mit Punkten (https://wasweissich.domain.de) um einen Server im Internet handelt und sendet daher die Anmeldeinformationen nicht automatisch (Aus Sicherheitsgründen). Prinzipiell ist ja die Annahme von Windows auch korrekt.

Ich habe daraufhin meine DS im internen Netzwerk über "https://gerätename/ordner" angehängt und somit keine Punkte verwendet. Das hat mich zu dem Ergebnis gebracht, dass ich zwar zum öffnen der Adresse die Anmeldedaten bestätigen musste aber beim öffnen einer Datei nicht mehr. Dies ist immerhin ein kleiner Fortschritt.

Lt. dem Windows Artikel sollte sich der gleiche Effekt einstellen wenn man die Adresse mit den Punkten in einen Registry Eintrag schreibt (Quasi als vertrauenswürdige Adresse). Dies habe ich getan, jedoch hat sich an der Situation danach nichts geändert. Ich musste bei der Internetadresse weiterhin beim öffnen der Adresse sowie beim öffnen von Dateien die Anmeldedaten bestätigen. Der Registry Eintrag ist somit ohne Funktion.

Hat jemand diesen Registry Eintrag schon einmal erfolgreich getestet?

Gruß

Toby
 

c0smo

Benutzer
Mitglied seit
08. Mai 2015
Beiträge
2.548
Punkte für Reaktionen
8
Punkte
84
  AdBlocker gefunden!

Du bist nicht hier, um Support für Adblocker zu erhalten, denn dein Adblocker funktioniert bereits ;-)

Klar machen Adblocker einen guten Job, aber sie blockieren auch nützliche Funktionen.

Das Forum wird mit einem hohen technischen, zeitlichen und finanziellen Aufwand kostenfrei zur Verfügung gestellt. Wir zeigen keine offensive oder Themen fremde Werbung. Bitte unterstütze dieses Forum, in dem du deinen Adblocker für diese Seite deaktivierst.