WinBTRFS Driver

Wollfuchs

Benutzer
Mitglied seit
06. September 2020
Beiträge
537
Punkte für Reaktionen
112
Punkte
119
;) der Mist mit dem WinBTRFS ist dann wohl auf meinem Mist gewachsen .. in einem Thread ging es um "wahhhh mein NAS will nciht mehr .." und um zu sehen ob und was auf der Platte ist, meinte ich "es scheint doch ein WinBTRFS zu geben".

Jedoch .. zu meiner Schande, habe ich lediglich davon gelesen, es nie probiert. Daher verfolge ich nun umso aufmerksamer Deine Fortschritte.
 

ottosykora

Benutzer
Mitglied seit
17. April 2013
Beiträge
4.300
Punkte für Reaktionen
70
Punkte
128
gut ich bleibe dran am Basteln, vielleicht finde ich zumindest eine Anleitung , Tutorial oder sonst was. Im Github, dort wo es publiziert ist finde ich nichts, muss mal sehen ob da irgednwie ein man gibt oder so was. Jedenfalls soll eine der dll auch GUI produzieren, aber bis jetzt weiss ich nicht wie.

Also wenn jemand was hört, bin auf Empfang
 

ottosykora

Benutzer
Mitglied seit
17. April 2013
Beiträge
4.300
Punkte für Reaktionen
70
Punkte
128
eine Ahnung wie ich eine normale usb Platte btrfs formatieren kann?
 

ottosykora

Benutzer
Mitglied seit
17. April 2013
Beiträge
4.300
Punkte für Reaktionen
70
Punkte
128
News: habe also bequemlichkeitshalber einen Linux gestertet (desinfec't)
eine normale ext Platte eingesteckt, mit gparted geschaut wie die heisst

dann eben sudo mkfs.btrfs -f /dev/sdc1

Habe nicht einmal gemarkt dass was passierte, ging milisek.

mit gparted angeschaut, das sagt ja, es ist eine btrfs Partition drauf

Partition drauf, also nur eine, ist Btrfs.
Dann drauf mit sudo einige Ordner angelegt.

Zurück zu windows:
die Platte wird wie sonst ein Laufwerk mit Buchstaben etc angezeigt mit dem Inhalt, also den Ordnern die ich angefertigt habe.

Merkwürdig: es wird zweimal angezeigt mit unterschiedlichen Laufwerkbachstaben.

Soweit also der winbtrfs scheint in der einfachsten Aufgabe zu funktionieren
 

Anhänge

  • btrfstoshi1.png
    btrfstoshi1.png
    29,3 KB · Aufrufe: 9

Wollfuchs

Benutzer
Mitglied seit
06. September 2020
Beiträge
537
Punkte für Reaktionen
112
Punkte
119
danke fuer Deine Muehe ..
was sagt denn der Windows Geraetemanager zu den mehrfachen LW Buchstaben?
 

ottosykora

Benutzer
Mitglied seit
17. April 2013
Beiträge
4.300
Punkte für Reaktionen
70
Punkte
128
Die nun so vorbereitet Platte an DS angesteckt, ja kann man dort genau so brauchen für Backup oder USB Copy etc.
 

ottosykora

Benutzer
Mitglied seit
17. April 2013
Beiträge
4.300
Punkte für Reaktionen
70
Punkte
128
devmgmt ist etwas verwirrt
 

Anhänge

  • devman1.png
    devman1.png
    28,4 KB · Aufrufe: 9

ottosykora

Benutzer
Mitglied seit
17. April 2013
Beiträge
4.300
Punkte für Reaktionen
70
Punkte
128
volume name ist toshi

es ist so ein Toshiba USB 2.5'' Teil
 

ottosykora

Benutzer
Mitglied seit
17. April 2013
Beiträge
4.300
Punkte für Reaktionen
70
Punkte
128
und verrückt, ich kann unter Windows drauf schreiben!
Ganz normal copy paste Bildchen etc.
 

ottosykora

Benutzer
Mitglied seit
17. April 2013
Beiträge
4.300
Punkte für Reaktionen
70
Punkte
128
jetzt habe ich es mit den 2 drives.

winbtrfs macht den einen

der andere kommt von dem Paragon Linux Driver, der macht dann das gleiche, aber nimmt den nächsten Buchstaben

nur der Paragon kann nur lesen, r/w lässz sich nicht einschlten, für Datenrettung vielleicht die bessere Option ;-)
 
  • Like
Reaktionen: Wollfuchs

ottosykora

Benutzer
Mitglied seit
17. April 2013
Beiträge
4.300
Punkte für Reaktionen
70
Punkte
128
Heute: weiteren USB Adapter gefunden.
Beide HD der 218+ damit an PC gehängt.

Nein das winmd kann damit so nichts anfangen. Erkennt nichts, keinen Raid, respektive kann die btrfs Teile nicht lesen.

Der Paragon Linux hat wohl einen Linux Driver installiert, auch wenn Automount aus ist, werden bei PC Start die beiden System Partitionen eingehängt, also einzeln, jede mit eigenem Laufwerk Buchstaben.

Weitere Partitionen können nach wie vor nicht gelesen werden. Auch der Linuxreader von Diskinternals sieht zwar alles, kann damit aber nichts anfangen.

Also noch keine einfache Lösung in Sicht.
 

synfor

Benutzer
Mitglied seit
22. Dezember 2017
Beiträge
2.351
Punkte für Reaktionen
73
Punkte
88
Schon mal daran gedacht, dass sich hier mehrere Treiber ins Gehege kommen?
 

ottosykora

Benutzer
Mitglied seit
17. April 2013
Beiträge
4.300
Punkte für Reaktionen
70
Punkte
128
ja sicher, aber muss zuerst etwas die Logik dahinter finden.

winbtrfs funktioniert, das ist sicher seit gestern

winmd noch ncht so recht, werde den Paragon versuchen zu deinstallieren, der kann mit Raid offenbar auch nicht mehr angangen.


Momentan versuche ich mich wieder mit Linux, komme aber noch nicht dorthin wo ich sein will, also Daten sehen und rauskopieren.

siehe mein andere TH hier bei Datenrettung
(bin gerade dran in -buntu)
 

ottosykora

Benutzer
Mitglied seit
17. April 2013
Beiträge
4.300
Punkte für Reaktionen
70
Punkte
128
Schon mal daran gedacht, dass sich hier mehrere Treiber ins Gehege kommen?

also nun den Paragon zuerst mal entfernt.
Ja, jetzt werden die Systempartitionen (ext4) nicht mehr automatisch gemounted.

Allerdings der winmd macht seine Arbeit immer noch nicht, es werden Raid nicht angeschaut.
 
  AdBlocker gefunden!

Du bist nicht hier, um Support für Adblocker zu erhalten, denn dein Adblocker funktioniert bereits ;-)

Klar machen Adblocker einen guten Job, aber sie blockieren auch nützliche Funktionen.

Das Forum wird mit einem hohen technischen, zeitlichen und finanziellen Aufwand kostenfrei zur Verfügung gestellt. Wir zeigen keine offensive oder Themen fremde Werbung. Bitte unterstütze dieses Forum, in dem du deinen Adblocker für diese Seite deaktivierst.