Time Backup - Sicherung bricht automatisch ab!

propella97

Benutzer
Mitglied seit
26. Dezember 2015
Beiträge
34
Punkte für Reaktionen
0
Punkte
0
Hallo!
Ich bin ein Neuling hier und habe folgendes Problem mit mir gebracht:

Ich habe eine Haupt-Synology (DS215j) von der ich eine Sicherung auf eine 2. Synology (DS213j) starte. (Beise Syno's sind im selben Netzwerk)
Jeden Tag um 0:00 Uhr wird eine Sicherung via Time Backup automatisch gestartet, doch diese bricht aus einem (für mich) unerfindlichen Grund ab! :confused:
Im Protokoll von Time Packup des Paket-Zentrums steht:

Type: Date/Time: Event:
ERR 2015-12-26 00:00:45 Task [Backup] has failed to backup version [20151226-0000].
-----------------------------------------------------------------------------------------------------------------------
INFO 2015-12-26 00:00:35 Task [Backup] is creating backup version [20151226-0000].


Beide Synology's haben die neuste Firmware (5.2-5644 Update 1), doch das Problem will und will sich nicht lösen. :mad:

Ich bedanke mich im Vorraus für möglische Antworten! :D

LG propella97
 

lukas_09

Benutzer
Mitglied seit
03. Oktober 2015
Beiträge
51
Punkte für Reaktionen
0
Punkte
0
Hallo propella97,

was Time Backup genau ist, weiss ich nicht so genau :)

Ich vermute dass bei dir keine Verbindung aufgebaut wird da bereits nach 10 Sek. Schluss ist - so zumindest entnehme ich das deinem Beitrag.

Ich nutze selber seit ein paar Wochen eine rsync Sicherung vom DS215+ auf DS115.

Die erste ging über LAN die nächsten dann entfernt.

Alles klappt auf Anhieb.

Vielleicht kann ich dir diese Methode ans Herz legen, hierbei könnte ich bei der Einrichtung helfen.

Gruß

Lukas

PS. Vielleicht beschreibst du ein wenig mehr welche Einstellungen du bei beiden DS für diesen Vorgang vorgenommen hast.
 
Zuletzt bearbeitet:

dil88

Benutzer
Mitglied seit
03. September 2012
Beiträge
28.575
Punkte für Reaktionen
2
Punkte
644
Du hast auf der 213j in "Datensicherung & Replikation" unter Sicherungsdienste den "Time-Backup-Dienst aktiviert"? Wenn ja, hat es denn schon einmal funktioniert?
 

propella97

Benutzer
Mitglied seit
26. Dezember 2015
Beiträge
34
Punkte für Reaktionen
0
Punkte
0
unter Sicherungsdienste den "Time-Backup-Dienst aktiviert"?
- Ja, habe ich.

hat es denn schon einmal funktioniert?
- Ja, hat es. Aber nur die 1. Sicherung war vollständig.

@lukas_09 Time Backup ist ein Sicherungsprogramm, welches in Versionen sichert und nicht nur die neuste Version.
Das heißt, ich kann mir z.B. eine Sicherung von vor einem Monat anschauen, da ich dort villeicht ein Dokument noch hatte, welches ich einen Tag später gelöscht habe.

LG propella97
 

dil88

Benutzer
Mitglied seit
03. September 2012
Beiträge
28.575
Punkte für Reaktionen
2
Punkte
644
Hast Du Dir die Logfiles /var/log/timebkp.debug und /var/log/timebkp.log schon angesehen?
 

propella97

Benutzer
Mitglied seit
26. Dezember 2015
Beiträge
34
Punkte für Reaktionen
0
Punkte
0
Hast Du Dir die Logfiles /var/log/timebkp.debug und /var/log/timebkp.log schon angesehen?
- Nein, da ich keine Ahnung habe, wie ich dort hin gelangen soll! Ich bin ein totaler Syno-Neuling :D

LG propella97
 

dil88

Benutzer
Mitglied seit
03. September 2012
Beiträge
28.575
Punkte für Reaktionen
2
Punkte
644
Entweder mit einem Tool wie WinSCP einloggen, durch den Verzeichnisbaum klicken und die Dateien anzeigen lassen. Oder per Shell (Einführung gibts im Wiki).
 

propella97

Benutzer
Mitglied seit
26. Dezember 2015
Beiträge
34
Punkte für Reaktionen
0
Punkte
0
Danke, ich schau's mir mal an :D
 

propella97

Benutzer
Mitglied seit
26. Dezember 2015
Beiträge
34
Punkte für Reaktionen
0
Punkte
0
Wenn ich zu /var/log/timebkp.debug bzw. /var/log/timebkp.log navigieren will kommt "permission denied".
Doch ich bin mit dem Admin Konto angemeldet!

LG propella97
 

dil88

Benutzer
Mitglied seit
03. September 2012
Beiträge
28.575
Punkte für Reaktionen
2
Punkte
644
Du musst den User root verwenden mit dem Admin-Passwort.
 

propella97

Benutzer
Mitglied seit
26. Dezember 2015
Beiträge
34
Punkte für Reaktionen
0
Punkte
0
Habe mich bei Putty mit dem Namen root angemeldet und wollte zu /var/log/timebkp.log navigieren, doch:

SynologyNAS> /var/log/timebkp.log
-ash: /var/log/timebkp.log: Permission denied


LG propella97
 

propella97

Benutzer
Mitglied seit
26. Dezember 2015
Beiträge
34
Punkte für Reaktionen
0
Punkte
0
@meagain Danke, hat funktioniert :D

Also, hier der code von /var/log/timebkp.log:

Rich (BBCode):
{INFO}{1451080835}{Backup}{Task [Backup] is creating backup version [20151226-0000].}
{ERR}{1451080845}{Backup}{Task [Backup] has failed to backup version [20151226-0000] due to [failure to create snapshot].}
{INFO}{1451167236}{Backup}{Task [Backup] is creating backup version [20151227-0000].}
{ERR}{1451167249}{Backup}{Task [Backup] has failed to backup version [20151227-0000] due to [failure to create snapshot].}

Da kann sogar ich daraus lesen "[failure to create snapshot]"! Aber was bedeutet dies?

Und der Code von /var/log/timebkp.debug:

Rich (BBCode):
Dec 26 00:00:35 [24046]BK_INFO:task_3[Backup] starts running.
Dec 26 00:00:35 [24046]BK_INFO:Creating snapshots.
Dec 26 00:00:35 [24049]BK_ERR:try to create SSH tunnel
Dec 26 00:00:36 [24050]BK_ERR:ssh returns non-zero [255].
Dec 26 00:00:39 [24046]BK_ERR:ssh returns non-zero [255].
Dec 26 00:00:39 [24046]BK_ERR:failed to create iscsi target [timebkp-target-SynologyNAS_0011323F7D5F-vol1-snap1] on the server [admin@192.168.178.27]
Dec 26 00:00:42 [24071]BK_ERR:ssh returns non-zero [255].
Dec 26 00:00:45 [24046]BK_ERR:ssh returns non-zero [255].
Dec 26 00:00:45 [24046]BK_WARN:creating snapshot of volume1 failed
Dec 26 00:00:45 [24046]BK_WARN:no snapshot has been created
Dec 26 00:00:45 [24046]BK_INFO:task_3[Backup] finished. Smart recycle working...
Dec 26 00:00:45 [24046]BK_INFO:task_3[Backup] smart recycle done.
Dec 26 13:17:25 CGI_ERR:SYNONetBkpRsyncExecute() error, code = [255]

Aha: Dec 26 00:00:45 [24046]BK_WARN:creating snapshot of volume1 failed. Aber Warum?
 
Zuletzt bearbeitet:

propella97

Benutzer
Mitglied seit
26. Dezember 2015
Beiträge
34
Punkte für Reaktionen
0
Punkte
0
Noch was Wichtiges:
Ich habe in /var/log/timebkp.debug noch ein bischen herumgestöbert und dabei ist mir folgendes aufgefallen:
Die Sicherungen vom (keine Ahnung wann) bis zum 11.Dez.2015 verliefen reibungslos, doch bei der Sicherung von 12.Dez.2015 trat folgende Fehlermeldung auf:

Rich (BBCode):
Dec 12 00:19:25 [15331]BK_ERR:unmount /dev/mapper/vol1-snap0 from snapshot device /tmp/timebkp_15331/volume1 failed

Doch was heißt nun das?

Ab diesem Tag an kam diese Fehlermeldung:

Rich (BBCode):
Dec 13 00:00:47 [26283]BK_ERR:failed to create iscsi target [timebkp-target-SynologyNAS_0011323F7D5F-vol1-snap1] on the server [admin@fd00::211:32ff:fe23:151d]

LG propella97
 

meagain

Benutzer
Mitglied seit
29. Dezember 2012
Beiträge
250
Punkte für Reaktionen
0
Punkte
16
Hallo propella97

Ich habe hier einen Thread gelesen, der vielleicht auch bei dir zutreffen könnte.

Hast du Jumboframes eingeschaltet? Falls ja wäre es wohl einen Versuch wert diese (auf beiden Geräten) auszuschalten.

Ansonsten würde ich bei Synology eine Support-Meldung aufmachen, die sind eigentlich recht hilfsbereit...

Viele Grüsse
meagain
 

propella97

Benutzer
Mitglied seit
26. Dezember 2015
Beiträge
34
Punkte für Reaktionen
0
Punkte
0

propella97

Benutzer
Mitglied seit
26. Dezember 2015
Beiträge
34
Punkte für Reaktionen
0
Punkte
0
Ich habe mich mal erkundigt,was Jumboframes sind, und wie man diese an/ausschalten kann.
Also, sowohl auf meiner Haupt Synology (DS215j) als auch bei meiner Zweit Synology (DS213j) sind die Jumboframes ausgeschaltet.

Nun bin ich noch ratloser, als ich vorher schon war... :confused:
Wie kann ich am besten den Synology Support erreichen?
support@synology.com?

Bei einer Sache, habe ich noch weniger Ahnung: Warum will Time Backup ein "iscsi target" erstellen, wenn ich doch nirgens eins habe?


LG propella97
 
Zuletzt bearbeitet:

meagain

Benutzer
Mitglied seit
29. Dezember 2012
Beiträge
250
Punkte für Reaktionen
0
Punkte
16
Hallo propella97

Du kannst den technischen Support hier kontaktieren.

Ich hätte im Synology Forum auch noch andere Beiträge gefunden, aber da wurden zum Teil an der Installation manuell Änderungen vorgenommen und das würde ich nur tun, wenn man wirklich weiss, auf was man sich da einlässt :)

Ich denke da ist der Weg, den Synology Support zu kontaktieren, wohl der sinnvollere. Wenn du deine Meldung auf Englisch verfasst, hast du vermutlich schneller eine Antwort.

Viele Grüsse
meagain
 

propella97

Benutzer
Mitglied seit
26. Dezember 2015
Beiträge
34
Punkte für Reaktionen
0
Punkte
0
Ich werde mich mit dem Syno-Support in Verbindung setzen!
Wenn ich eine Lösung für das Problem habe, werde ich sie natürlich hier posten! ;)

LG propella97
 
Zuletzt bearbeitet:

propella97

Benutzer
Mitglied seit
26. Dezember 2015
Beiträge
34
Punkte für Reaktionen
0
Punkte
0
Ich habe, bevor ich mich mit dem Synology-Support in Verbindung gesetzt habe, einfach mal eine Sicherung per Hand gestartet.
Und siehe da - es funktioniert! :D :eek:
Das heißt, es liegt daran, dass die Sicherung automatisch gestartet wird...
Aber was wir da anders gemacht?
Der Timer macht ja auch nichts anderes, als sozusagen auf den Knopf "Jetzt Datensicherung durchführen" zu drücken, oder? :confused:

LG propella97
 
  AdBlocker gefunden!

Du bist nicht hier, um Support für Adblocker zu erhalten, denn dein Adblocker funktioniert bereits ;-)

Klar machen Adblocker einen guten Job, aber sie blockieren auch nützliche Funktionen.

Das Forum wird mit einem hohen technischen, zeitlichen und finanziellen Aufwand kostenfrei zur Verfügung gestellt. Wir zeigen keine offensive oder Themen fremde Werbung. Bitte unterstütze dieses Forum, in dem du deinen Adblocker für diese Seite deaktivierst.