SMB Netzwerkverbindung trennt sich regelmäßig (MAC)

Clamsy

Benutzer
Mitglied seit
31. Mrz 2022
Beiträge
65
Punkte für Reaktionen
6
Punkte
8
Hi zusammen,

mein neuer Mac verliert regelmäßig (mindestens 1x am Tag) die Verbindung zur Synology DS 423+ und damit sind alle eingebundenen Volumen erst einmal wieder nicht verfügbar auf dem Mac.

Ich kann aber sofort nach der Trennung auf die DS zugreifen, muss halt dann wieder alle Laufwerke der Reihe nach aktivieren.

Mit meinem alten iMac (2015) ist mir das zwar ach ab und an passiert, aber nicht mit so einer Regelmäßigkeit von mindestens 1x am Tag.

Womit kann das zusammenhängen? Ist es eine Einstellung auf der DS, auf der Fritz!Box oder auf dem Mac?
Ich wüsste nicht was ich anders gemacht haben soll.
 

*kw*

Benutzer
Contributor
Sehr erfahren
Maintainer
Mitglied seit
10. Aug 2013
Beiträge
1.736
Punkte für Reaktionen
721
Punkte
134
Bin ganz bei dir, das Problem habe ich auch, obwohl bei mir alles 24/7 (DS) läuft. Konkrete Ursachen konnte ich bisher keine ermitteln. Bewusst fällt mir das nach einem Standby des Mac auf, aber auch nicht jedesmal. Wie du schon schreibst, "regelmäßig unregelmäßig". Mit meinem Late2013 war das ebenfalls nicht so.

Grundsätzlich habe ich einen DS-Ordner (video) in die Anmeldeobjekte gezogen, was zumindest bei einem Neustart gleich die Verbindung zum NAS aktiviert/herstellt.

PS: Ich bin jetzt seit über einem Jahr mit dem Apple-Support am rumzackern, weil das Teilen von Daten (SMB, "Dateifreigabe") nicht einwandfrei funktioniert. (Neu)Start mit aktivierter Funktion --> keine Zugriff. Deaktivert --> (Neu)Start --> Aktivieren --> Geht. 🙄
PPS: egal, ob Kabel oder WLAN, das MBA meiner Frau ebenso
 

Clamsy

Benutzer
Mitglied seit
31. Mrz 2022
Beiträge
65
Punkte für Reaktionen
6
Punkte
8
OK. Ich habe auch schon viel recherchiert - auch in englischen Foren. Sehr sehr viele Berichte über Abbrüche - nicht nur bei Mac, sondern auch bei Windows. Und jeder schiebt es auf den anderen.
Der eine sagt das ist die Fritzbox
der andere sagt, nein die Fritz!Box ist es nicht, das kommt von der DS
Die von Synology sagen, nein das kann nur der Mac und oder die Fritz!Box sein.

Ping/Pong spiel über viele Parteien und keiner sucht nach der Ursache. Ich finde das einfach schade.
 

*kw*

Benutzer
Contributor
Sehr erfahren
Maintainer
Mitglied seit
10. Aug 2013
Beiträge
1.736
Punkte für Reaktionen
721
Punkte
134
Meine Frau hatte bis vor kurzem ein Notebook mit Win10 und ich greife mit meinem iPad/iPhone per FileExplorer drauf zu (SMB). Dort gibt es keine Probleme.

Die Fritte schließe ich an der Stelle aus, weil der Fehler bereits in der "FritzBox-only-Version" als auch jetzt, mit Adguard/Unbound (als DNS) passiert(e). Mit dem alten iMac 27 (macOS Catalina hatte ich keine/kaum Probleme). Das ging erst mit meinem M1 und Big Sur/Monterey los.
 

Clamsy

Benutzer
Mitglied seit
31. Mrz 2022
Beiträge
65
Punkte für Reaktionen
6
Punkte
8
Ich hab dem M2 Ultra im Mac Studio. Ich probiere gerade ein externes Tool aus. Ping mich gerne in 1-2 Wochen an, sollte ich es vergessen einen Erfahrungsbericht darüber zu schreiben.
 
  • Like
Reaktionen: *kw*

maxblank

Benutzer
Contributor
Sehr erfahren
Mitglied seit
25. Nov 2022
Beiträge
2.802
Punkte für Reaktionen
1.425
Punkte
224
Bitte mal prüfen, ob „Privat-Relay“ deaktiviert ist. Falls nein, mal deaktivieren.
 
  • Like
Reaktionen: *kw*

*kw*

Benutzer
Contributor
Sehr erfahren
Maintainer
Mitglied seit
10. Aug 2013
Beiträge
1.736
Punkte für Reaktionen
721
Punkte
134
PS: Ich habe kein iCloud+, aber deaktiviere im LAN mal die "Tracking der IP-Adresse beschränken".
 

Clamsy

Benutzer
Mitglied seit
31. Mrz 2022
Beiträge
65
Punkte für Reaktionen
6
Punkte
8
Ich habe zwar iCloud+, aber Privat-Relay ist deaktiviert.
Das "Tracking der IP-Adresse beschränken" ist aktiv. Werde ich aber aktuell mal nicht ausprobieren. Ich prüfe gerade ein Tool und möchte jetzt zugleich nicht zuviel gleichzeitig am System ändern. Aktuell schaut das Tool gut aus. Zumindest bin ich seit gestern mit der DS verbunden und hatte keine Trennung. Ich habe dazu extra ein Finder-Fenster offen welches einen Ordner auf der NAS anzeigt. Sobald eine Trennung wäre, würde dieses Verzeichnis zurückspringen auf "Mac Studio von ..." So war es zumindest immer in der Vergangenheit.

Aber aktuell schaut es gut aus, ich werde das definitiv erst mal die nächsten Tage beobachten, und wenn es die Lösung ist, dann gebe ich euch bescheid.
 

*kw*

Benutzer
Contributor
Sehr erfahren
Maintainer
Mitglied seit
10. Aug 2013
Beiträge
1.736
Punkte für Reaktionen
721
Punkte
134
Was ich gerade bestätigen kann, dass sich über Nacht die Verbindung - ohne jegliche Aktivität - wieder getrennt hat. Die DS war im Finder unter "Orte" zwar noch vorhanden, aber die angelegten Favoriten (DS Ordner video/music) waren ausgehängt (ohne "Eject-Symbol").

Wenn ich die Ordner anklicke, passiert eine Weile gar nichts, dann kommt eine Fehlermeldung "Original konnte nicht gefunden werden". Wenn ich in der macOS-Systemsteuerung auf "Netzwerk" klicke, werden mir keine Einträge angezeigt; dieser Menüpunkt ist nicht aktiv.

IT-Regel #1: Reboot tut gut...

Zumindest sind die Netzwerkeinträge wieder sichtbar und ich kann die Favoriten erneut einhängen. Auch die "Autoanmeldung" hat "normal" funktioniert. Mal sehen, wie lange...

Ich behaupte mal, im Problem liegt Apple "in Führung".

[edit]: das nächtliche TM-Backup um 03:00 Uhr funktioniert fehlerfrei, also muss zumindest eine Verbindung bestehen. Da die Abbrüche auch untertags passieren, sehe ich das keinen ursächlichen Zusammenhang
 

Benares

Benutzer
Sehr erfahren
Mitglied seit
27. Sep 2008
Beiträge
12.611
Punkte für Reaktionen
3.041
Punkte
448
Und an diesem "iCloud, Privat-Relay"-Gedöns liegt's nicht? Wir hatten doch kürzlich den Fall, dass nslookup bei einem MAC die IP des NAS zwar richtig auflöste, aber andere Dinge wie ping, traceroute plötzlich nach außen gingen (fritz.box-Problem)
Der MAC hat doch bestimmt auch eine hosts-Datei. Trag dort mal testweise "<NameDesNAS>" und "<NameDesNAS>.fritz.box" ein.
 
  • Like
Reaktionen: *kw*

*kw*

Benutzer
Contributor
Sehr erfahren
Maintainer
Mitglied seit
10. Aug 2013
Beiträge
1.736
Punkte für Reaktionen
721
Punkte
134
Hab ich gemacht, werde berichten.

PS: dieses "Gedöns" gibt es unter macOS nur mit iCloud+ und da ich eher geneigt bin, mich zu "ent-clouden" hab ich das gar nicht erst gebucht. ;)
 

Clamsy

Benutzer
Mitglied seit
31. Mrz 2022
Beiträge
65
Punkte für Reaktionen
6
Punkte
8
So,
also ich habe jetzt mal ein paar Tage den Mac durchlaufen lassen. Nicht 1x wurde nun die Verbindung getrennt. Was macht das Tool anders? Ich weiß es nicht, aber es hält die Verbindung stabil.

Das Tool ist im App-Store zu finden. Kostet aber ein paar wenige Euros. Für mich hat sich die Anschaffung gelohnt.

Das Tool heißt AutoMounter

Dort habe ich die Synology als Server konfiguriert und die Laufwerke angebunden. Alles ohne irgendwelchen speziellen Mount-Optionen. Siehe Screenshots

Bildschirmfoto 2024-05-18 um 15.27.12.png
Bildschirmfoto 2024-05-18 um 15.28.19.png
Bildschirmfoto 2024-05-18 um 15.28.49.png

Mit dem Tool könnten noch spezielle Regeln eingeführt werden, wann welches Volumen verbunden werden soll, wenn eine App x gestartet wird, oder man sich in einem WLAN y einloggt etc. Aber das habe ich alles nicht gemacht. Einfach nur das was ihr auf den Screenshots seht. Mehr nicht.

Nach der Einrichtung und nach dem 1. Neustart vom Mac, werdet ihr dann zum Verbinden noch den User und das Passwort eingeben müssen, denn das habe ich nämlich bei der Einrichtung der Mounts nicht vorgegeben.

Seit dem läuft nun mein Mac schon 4 Tage ununterbrochen ohne das er einmal die Verbindung zur DS verloren hat.

Für mich ist somit das Problem gelöst. Das Problem was @*kw* berichtet, war auch genau das gleiche bei mir. Aus irgendwelchen gründen wurden alle Mounts getrennt und die DS war aber in Netzwerk noch zu sehen - ohne Eject. Die Volumen mussten durch anklicken der Ordner danach wieder gemountet werden. Jetzt nicht mehr.... ;-)

Probiert es aus, ich glaube die paar wenigen Euros lohnen sich. Berichtet Euer Ergebnis ob es genauso geholfen hat. Ich bin überzeugt das es auch bei Euch helfen wird. Und vielleicht nutzt sogar der ein oder andere dann noch die zusätzlichen Optionen, die man aber eigentlich nicht braucht. Ich wollte mit der Pro-Version nur noch dem Hersteller ein kleines Dankeschön mit auf den Weg geben (das waren glaube ich dann nochmal 2,99 In-App-Kauf). Die Basis-Version kostete glaube ich 7,99 oder 8,99 - ich weiß es nicht mehr. Ich habe einfach gekauft, weil ich auch gelesen hatte, dass es einem US-Bürger damit die Problematik gelöst hatte. Versuch ist geglückt 👍
 
  • Like
Reaktionen: *kw*

*kw*

Benutzer
Contributor
Sehr erfahren
Maintainer
Mitglied seit
10. Aug 2013
Beiträge
1.736
Punkte für Reaktionen
721
Punkte
134
@Clamsy: Danke für die Rückmeldung!


Ich habe derweil @Benares' Tipp beherzigt und die DS in die hosts-Datei eingetragen. Keine Ahnung, aber seit dem Neustart blieben die Laufwerke als Favorit aktiv.

Und wenn sich die DS symbolisch "ejected" hatte, habe ich nur auf einen - der noch gemounteten - Verzeichnisse geklickt habe, wurde die DS als solche wachgerüttelt.

Ich bleibe am Ball und berichte.
 

Clamsy

Benutzer
Mitglied seit
31. Mrz 2022
Beiträge
65
Punkte für Reaktionen
6
Punkte
8
Und wenn sich die DS symbolisch "ejected" hatte, habe ich nur auf einen - der noch gemounteten - Verzeichnisse geklickt habe, wurde die DS als solche wachgerüttelt.
Ja genau, so war es bei mir auch ;-)

Ich habe jetzt wirklich mehrere Tage den Mac laufen lassen, zugleich habe ich immer das Finder-Fenster offen gelassen wo ich einen Ordner der DS offen hatte. So konnte ich sehen, ob die Verbindung "über nacht oder irgendwann" mal getrennt wurde.

In der Vergangenheit wurde ich - so wie du beschrieben hast - getrennt, und wenn ich ein Finder-Fenster offen hatte mit einem DS-Ordner, dann befand ich mich nach der Trennung immer auf dem "Root" (ich weiß das ist nicht das Root-Verzeichnis), aber ich war dann immer auf dem Ort "Mac Studio von ..." oder wenn es ein Macbook oder iMac wäre dann entsprechend Macbook von oder iMac von.

Probiere erst mal das von Benares aus, vielleicht klappt das auch. Alternativ halt das Tool ;-)
 
  • Like
Reaktionen: *kw*

*kw*

Benutzer
Contributor
Sehr erfahren
Maintainer
Mitglied seit
10. Aug 2013
Beiträge
1.736
Punkte für Reaktionen
721
Punkte
134
Ich denke, dass Apple mit macOS und SMB ein Problem hat. Die SMB-Verbindungen von iPhone/iPad zur DS mit der App "FileExplorer" sind stabil.
 

Clamsy

Benutzer
Mitglied seit
31. Mrz 2022
Beiträge
65
Punkte für Reaktionen
6
Punkte
8
Das glaube ich nicht. Ich habe auch mit afp versucht. da hatte ich die gleichen Probleme.
 

*kw*

Benutzer
Contributor
Sehr erfahren
Maintainer
Mitglied seit
10. Aug 2013
Beiträge
1.736
Punkte für Reaktionen
721
Punkte
134
Ich bin seinerzeit schnell von AFP weg, als sich SMB auch bei Apple als "Quasi-Standard" abzeichnete. Von daher kann ich nichts beitragen. Aber...

24 Stunden später immer noch keine ausgehängten Ordner. Okay, beim Anklicken rödelte er im music-Verzeichnis rum, bis er alles eingelesen hatten, aber keine Abbrüche. Das war das Ziel.

So, und jetzt lobe ich nicht zu viel, das Frühstück ist gerade vom Tisch und der Tag noch lang. ;)
 


 

Kaffeautomat

Wenn du das Forum hilfreich findest oder uns unterstützen möchtest, dann gib uns doch einfach einen Kaffee aus.

Als Dankeschön schalten wir deinen Account werbefrei.

:coffee:

Hier gehts zum Kaffeeautomat 

 
 
  AdBlocker gefunden!

Du bist nicht hier, um Support für Adblocker zu erhalten. Dein Adblocker funktioniert bereits ;-)

Klar machen Adblocker einen guten Job, aber sie blockieren auch nützliche Funktionen.

Das Forum wird mit hohem technischen, zeitlichen und finanziellen Aufwand kostenfrei zur Verfügung gestellt. Wir zeigen keine offensive Werbung und bemühen uns um eine dezente Integration.

Bitte unterstütze dieses Forum, in dem du deinen Adblocker für diese Seite deaktivierst.

Du kannst uns auch über unseren Kaffeautomat einen Kaffe ausgeben oder ein PUR Abo abschließen und das Forum so werbefrei nutzen.

Vielen Dank für Deine Unterstützung!