Kopano4S (Zarafa 2.0)

chats

Benutzer
Mitglied seit
29. September 2012
Beiträge
384
Punkte für Reaktionen
0
Punkte
16
Bis zu dem Backup klappt alles soweit ganz gut.
Aber sobald ich den downgarde starte mit dem befehl kopano4s-downgrade kommen einige von den folgenden Fehlermeldungen.


2020-10-31 13:21:48,283 - backup - ERROR - Traceback (most recent call last):
File "/usr/lib/python3/dist-packages/kopano/log.py", line 103, in log_exc
try: yield
File "/usr/lib/python3/dist-packages/kopano_backup/__init__.py", line 891, in load_acl
member_type, value = row[1].Value
AttributeError: 'int' object has no attribute 'Value'

2020-10-31 13:21:48,283 - backup - ERROR - Traceback (most recent call last):
File "/usr/lib/python3/dist-packages/kopano/log.py", line 103, in log_exc
try: yield
File "/usr/lib/python3/dist-packages/kopano_backup/__init__.py", line 947, in load_rules
etxml = ElementTree.fromstring(data)
File "/usr/lib/python3.7/xml/etree/ElementTree.py", line 1315, in XML
parser.feed(text)
TypeError: a bytes-like object is required, not 'dict'
 

chats

Benutzer
Mitglied seit
29. September 2012
Beiträge
384
Punkte für Reaktionen
0
Punkte
16
Bin nun ein klein wenig weiter gekommen. Also es wird von alles Usern immer wieder nur der eine korrekt angelegt. Alle anderen dagegen enden mir einer Fehlermeldung. Wenn ich nun die anderen im Kopano Admin-Fenster vorher anlege und dann den restore mache scheint es zu klappen.
Vielleicht hilft das ja irgendwie weiter.
 

Andy+

Benutzer
Mitglied seit
25. Januar 2016
Beiträge
3.559
Punkte für Reaktionen
38
Punkte
114
Als Worst-Case-Szenario ein paar Fragen:

- Hast Du Outlook im Einsatz und damit eine extrahierte PST, oder welches Emailprogramm?
- Hast Du Offline alle Daten aus Kopano, also Mails, Kalender, Kontakte, Aufgaben, Notizen zur Verfügung?
- Bist Du alleiniger User?

Hintergrund ist, im Fall eines Falles, alles runterschmeissen von der DS, einschliesslich Datenbank, komplett neu installieren und über Outlook alle Daten wieder einlesen

Wie sieht es damit aus bei Dir?
 

chats

Benutzer
Mitglied seit
29. September 2012
Beiträge
384
Punkte für Reaktionen
0
Punkte
16
Hi Andy, das wäre für mich zwar eine Lösung aber leider nicht die Lösung. Der Grund ist das ich das schon einmal gemacht habe. Zwar ohne Datenverlust jedoch fehlten einige Dinge die wohl beim exportieren nicht mitgenommen werden. eMail und Kontakte usw alles das solch eigens vorgenommene Einstellungen wurden nicht übernommen. Zum Beispiel Kategorien oder ähnliches. Daher stand jetzt noch der Königsweg mit dem downgrade.
Sollte es nicht zu schaffen sein tritt der "Worst Case" wohl leider ein.
 

Jens H

Benutzer
Mitglied seit
06. Juni 2010
Beiträge
202
Punkte für Reaktionen
0
Punkte
16
Heute kam wieder das obligatorische EMail rein, siehe unten. Habe allerdings seit dem Downgrade und dem anschließenden
"sudo sed -i -e 's~#pid_file~pid_file~' /etc/kopano/server.cfg"
kein "restart" oder "init" oder so gemacht. Liegts nur daran oder ist da nach wie vor a bisserl der Wurm drin?

/etc/cron.daily/logrotate:
invoke-rc.d: WARNING: No init system and policy-rc.d missing! Defaulting to block.
invoke-rc.d: WARNING: No init system and policy-rc.d missing! Defaulting to block.
invoke-rc.d: WARNING: No init system and policy-rc.d missing! Defaulting to block.
Stopping Postfix Mail Transport Agent: postfix.
Starting Postfix Mail Transport Agent: postfix.
invoke-rc.d: WARNING: No init system and policy-rc.d missing! Defaulting to block.
Stopping Postfix Mail Transport Agent: postfix.
Starting Postfix Mail Transport Agent: postfix.
 

Andy+

Benutzer
Mitglied seit
25. Januar 2016
Beiträge
3.559
Punkte für Reaktionen
38
Punkte
114
Bei Kopano gehe ich immer nach der Devise: Jeder Boot tut Gut. Bei Fehlern usw. ist das immer das erste, was ich mache, das hat bislang oft etwas beheben können.
 

Tosoboso

Benutzer
Mitglied seit
27. August 2012
Beiträge
1.175
Punkte für Reaktionen
14
Punkte
64
Heute kam wieder das obligatorische EMail rein, siehe unten. Habe allerdings seit dem Downgrade und dem anschließenden. /etc/cron.daily/logrotate:
invoke-rc.d: WARNING: No init system and policy-rc.d missing! Defaulting to block.
invoke-rc.d: WARNING: No init system and policy-rc.d missing! Defaulting to block.
invoke-rc.d: WARNING: No init system and policy-rc.d missing! Defaulting to block.
Stopping Postfix Mail Transport Agent: postfix.
Starting Postfix Mail Transport Agent: postfix.
invoke-rc.d: WARNING: No init system and policy-rc.d missing! Defaulting to block.
Stopping Postfix Mail Transport Agent: postfix.
Starting Postfix Mail Transport Agent: postfix.
Hi, das kannst du ignorieren, logrotate ist einfach mit Aktionen und Warnungen geschwätzig.
Ich habe mehrfach versucht das zu unterdrücken, geht aber nicht immer..
-TosoBoso
 

Andy+

Benutzer
Mitglied seit
25. Januar 2016
Beiträge
3.559
Punkte für Reaktionen
38
Punkte
114
Mit dem Zarafa-Client bekomme ich im Offline-Modus nach dem Start von Outlook die Fehlermeldung

Anhang anzeigen 56059

Im Online-Modus ist das nicht. "Wiederholen" hilft nicht, nur mit "Ignorieren" komme ich darüber hinweg.

Es gibt Hinweise, dass es mit der Datenbank zu tun hat, jedoch gibt es auch noch andere Ansätze, allerdings nichts greifbares für Lösungen. Hat da jemand Ideen dazu, mit was es zusammenhängen kann?

Im Zusammenhang mit Outlook habe ich Ungereimtheiten, vlt. gibt es Hinweise darauf:

Ich verwende schon immer den Zarafa-Client im Online-Modus. Das funktioniert einwandfrei und auch reibungslos. Ebenso IMAP funktioniert einwandfrei, jedoch habe ich dann nur auf Emails Zugriff.

Nehme ich ActiveSync, bleibt das Protokoll bei der Übertragung regelmässig bei den Kalendereinträgen hängen, dann geht es auch nicht weiter. Es gibt keine Fehlermeldungen, keine Hinweise usw. Im Zusammengang mit Android-Smartphones oder TbSync für Thunderbird gibt es jedoch keine Probleme.

Nehme ich den Zarafa-Client im Offline-Modus, kommt regelmässig die obige Fehlermeldung und auch bei "Ignorieren" werden schlussendlich nicht alle Emails übertragen.

Hat jemand Hinweise darauf?
 

Andy+

Benutzer
Mitglied seit
25. Januar 2016
Beiträge
3.559
Punkte für Reaktionen
38
Punkte
114

Andy+

Benutzer
Mitglied seit
25. Januar 2016
Beiträge
3.559
Punkte für Reaktionen
38
Punkte
114
Zarafa-Client im Offline-Modus

Das hat sich erledigt. Durch Löschung von Doppel-Mails und säubern in allen Bereichen läuft das wieder, Offline und Online ... (y)

Was aber nicht läuft, ist ActiveSync

1604603886377.png

Immer an der gleichen Stelle und bleibt hängen. Kalender ist der "Normalkalender", dann habe ich 6 weitere für besondere Angelegenheiten. Hätte ich den ZC nicht, wäre das nicht so dolle .... o_O
 

dociceage

Benutzer
Mitglied seit
25. März 2014
Beiträge
18
Punkte für Reaktionen
0
Punkte
7
Hallo Zusammen

habe gestern per init refresh das Update auf die Kopano4S C-Core-10.0.6_Webapp-5.0_Z-Push-2.6.0 gestartet.
Soweit lief auch alles gut - aber das Google2FA Plugin läuft seitdem nicht mehr.

Sind irgendwelche Probleme mit den Plugins im allgemeinen bekannt ?
 

Andy+

Benutzer
Mitglied seit
25. Januar 2016
Beiträge
3.559
Punkte für Reaktionen
38
Punkte
114
Glück Auf Groupies

Das 2FA Plugin ist wohl abgekündigt! Der Entwickler (FAMILIETHIMM) hat leider keine Zeit mehr für die Weiterentwicklung und ab Kopano WebApp 8.5.3 funktioniert es auch nicht mehr. Die Kopanoentwickler haben die Sicherheitsmechanismen der WebApp verbessert. Das verhindert die bisherigen Zugriffsmöglichkeiten des Plugin.

immer ein Licht bei der Nacht
f@h

Das wurde bereits gesagt.
 

Tosoboso

Benutzer
Mitglied seit
27. August 2012
Beiträge
1.175
Punkte für Reaktionen
14
Punkte
64
Das 2FA Plugin ist wohl abgekündigt! Der Entwickler (FAMILIETHIMM) hat leider keine Zeit mehr für die Weiterentwicklung und ab Kopano WebApp 8.5.3 funktioniert es auch nicht mehr. Die Kopanoentwickler haben die Sicherheitsmechanismen der WebApp verbessert. Das verhindert die bisherigen Zugriffsmöglichkeiten des Plugin. Das wurde bereits gesagt.
Genau und deswegen habe ich das 2FA Plugin aus den Container Builds entfernt.
-TosoBoso
 

Andy+

Benutzer
Mitglied seit
25. Januar 2016
Beiträge
3.559
Punkte für Reaktionen
38
Punkte
114

Tosoboso

Benutzer
Mitglied seit
27. August 2012
Beiträge
1.175
Punkte für Reaktionen
14
Punkte
64

dociceage

Benutzer
Mitglied seit
25. März 2014
Beiträge
18
Punkte für Reaktionen
0
Punkte
7

FricklerAtHome

Benutzer
Mitglied seit
01. Oktober 2017
Beiträge
279
Punkte für Reaktionen
1
Punkte
18
DeskApp unter MacOS BIG SUR instabil!

Glück Auf Kopanoies

ich habe, wie immer als early adopter, einige meiner MAC'S auf Big Sur per UpGrade gebracht.
Auf diesen Rechnern stürzt die bisher auf den alten Rechnern stabile DeskApp ab.
Eingesetzte Version auf allen Rechnern die Version 2.7.1. Die Abstürze folgen keinem mir kenntlichen Muster.
Also Vorsicht! ---- Die WEB-APP läuft im Browser stabil.
Scheinbar läuft der Kopano-DeskApp Helper Amok, zumindest "reagiert" er nicht mehr!


Glück Auf, Licht bei der Nacht und Maske im Gesicht

f@h
 
Zuletzt bearbeitet:

IBRU

Benutzer
Mitglied seit
01. Januar 2012
Beiträge
99
Punkte für Reaktionen
0
Punkte
6
Servus zusammen,

nach eingigen Updates funktioniert der Emailerhalt und Versand jetzt, dafür werden die Nutzer (User) nicht mehr geladen und angezeigt. Zwei alte Nutzer die angelegt waren können mit Outlook ohne Probleme angesprochen werden aber wie gesagt, ich sehe sie nicht mehr und kann auch keine neuen mehr über die Admin-Oberlfäche anlagen.

Was kann das sein? Server Neustart ist gemacht und mit Logs auslesen oder sowas bin ich bei der Oberfläche irgendwie zu doof.
 

chats

Benutzer
Mitglied seit
29. September 2012
Beiträge
384
Punkte für Reaktionen
0
Punkte
16
Kennt jemand die Konfig-Einstellungen um sich via harmonizely.com mit kopano zu verbinden?
Es ist gefragt die
issuer server url
und die
api server url
Hat wer Erfahrungen damit?
 
  AdBlocker gefunden!

Du bist nicht hier, um Support für Adblocker zu erhalten, denn dein Adblocker funktioniert bereits ;-)

Klar machen Adblocker einen guten Job, aber sie blockieren auch nützliche Funktionen.

Das Forum wird mit einem hohen technischen, zeitlichen und finanziellen Aufwand kostenfrei zur Verfügung gestellt. Wir zeigen keine offensive oder Themen fremde Werbung. Bitte unterstütze dieses Forum, in dem du deinen Adblocker für diese Seite deaktivierst.