Jumbo Frames im GB-LAN mit LevelOne GSW-0807 8-Port Gigabit Switch und Marvell Yukon

Matthieu

Super-Moderator
Teammitglied
Mitglied seit
03. November 2008
Beiträge
13.086
Punkte für Reaktionen
16
Punkte
334
Mach doch mal bitte einen Screenshot. Fände das wirklich großartig wenn jemand sooo viel aus seiner DS herausholen konnte.

MfG Matthieu
 

coolhot

Benutzer
Mitglied seit
01. März 2009
Beiträge
926
Punkte für Reaktionen
0
Punkte
0
Ab Win Vista wurde der Tcp Stack verbessert. Ich hatte ja auch ein Problem mit der Netzwerkperformance unter Win xp. Seit ich unter Win 7 pro unterwegs bin erreiche ich sogar höhere Werte als von Synology angegeben.

Mein Nas: Synology DS 109+
Schreibperformance unter XP vom PC zum NAS ca 30 MB/s. Lesend 40 MS/s.
Schreibperformance unter Win 7 vom PC zum Nas ca 60 MB/s. Lesend > 80 MB/s.


Danke, das macht Hoffnung. Das ist ein wirklich deutlicher Unterschied zwischen WinXP und Win7.

Bitte beschreibe deine Konfiguration genauer:

Jumbo Frames aktiv? Falls ja lies bitte mal deinen Windows-MTU-Wert aus mit dem Tool DRTCP aus dem Beitrag von itari. Das kann einfach als .exe gestartet werden - ohne Installation.

Bis zu welcher Packetgröße klappt bei dir der unfragmentierte Ping:

ping -f -l <packetgröße in bytes) <ds>

Welche GB-LAN-NIC?
Welcher Switch?

Kabelart und -länge?

Mit welcher Dateigröße wurde getestet?

Und ein Screenshot wäre natürlich toll.
 

juwi

Benutzer
Mitglied seit
01. Dezember 2008
Beiträge
145
Punkte für Reaktionen
1
Punkte
18
Hier meine Konfiguration:
NAS: Synology DS 109+ (Firmware 844)

So mittlerweile bin ich dem Fehler mit der geringen Netzwerkperformance auf die Schliche gekommen.
Es lag schlicht alleine am Betriebssystem (vorher WinXP SP3 + alle Updates). Nach Recherchen meinerseits, hat Microsoft seit Windows Vista ordentlich an der Netzwerkperformance gedreht.
Jetzt testweise unter Win 7 x64 habe ich eine Leserate von ~76 Mb/s und schreiben tu ich mit ~61 Mb/s.

Vielen Dank an alle für die Hilfe.

Benutzte Hardware:
Core E6600 @ 3200 Mhz.
Systemplatte: Mtron SSD 32 GB (SLC Chips, 100 Mb/s lesen und schreiben)
Datenplatte: Seagate ST3500320AS 500 GB (7200 U/min, 32MB Cache)

Switch: DLINK DGS 1005 D (Gigabit Ethernet, Green Eco)
Netzwerkkabel: Cat5E
Jumboframes: 4096
Sende/Empfangspuffer bei der Netzwerkkarte: 512 KB statt 256 KB.
Festplatte im NAS: Western Digital EADS 1TB
http://www.synology-forum.de/showthread.html?p=53299#post53299


Screenshot folgt gleich.
Wenn jemand die Transferate live über Teamviewer sehen möchte, lässt sich einrichten :).

Edit - Bild:
 
Zuletzt bearbeitet:

itari

Benutzer
Mitglied seit
15. Mai 2008
Beiträge
21.900
Punkte für Reaktionen
3
Punkte
0
Das sind schöne Werte :D

Itari
 

coolhot

Benutzer
Mitglied seit
01. März 2009
Beiträge
926
Punkte für Reaktionen
0
Punkte
0
@juwi: Respekt, das sind Topwerte.

Verätst du uns noch deine Netzwerkkarte und Motherboard?

Du hast JF auf 4096 eingestellt, hast du dazu in Windows etwas in den Einstellungen geändert oder nur im Treiber der Netzwerkkarte?

Funktioniert bei dir der Ping-Befehl unfragmentiert?

Hast du JF mit 9000 auch getestet?
 

juwi

Benutzer
Mitglied seit
01. Dezember 2008
Beiträge
145
Punkte für Reaktionen
1
Punkte
18
Ergänzung:
Kabellänge: ca. 7m
Motherboard: Asus P5W DH Deluxe
Netzwerkkarte: Onboard Marvel Yukon 88e8053 Gigabit Ethernet

@Coolhot
Unter Windows habe ich im Treiber lediglich Jumboframes aktiviert und den Sende- und Empfangspuffer verdoppelt. Sonst nichts. Mit 9K Jumboframes habe ich es noch nicht probiert.
Heute Abend mache ich den Pingtest.
 

juwi

Benutzer
Mitglied seit
01. Dezember 2008
Beiträge
145
Punkte für Reaktionen
1
Punkte
18
Hallo Coolhot:

ping -f -l <packetgröße in bytes) <ds> ist bei mir bis 3980 bytes möglich, danach kommt entweder "Zeitüberschreitung" oder "Paket müsste fragmentiert werden, DF-Flag ist jedoch gesetzt".

Komischerweise bootet sich meine DS neu wenn der Wert zu groß ist?!?
 

coolhot

Benutzer
Mitglied seit
01. März 2009
Beiträge
926
Punkte für Reaktionen
0
Punkte
0
Danke für die Ergänzung der Rahmendaten - ist meiner Konfiguration sehr ähnlich.

Hallo Coolhot:

ping -f -l <packetgröße in bytes) <ds> ist bei mir bis 3980 bytes möglich, danach kommt entweder "Zeitüberschreitung" oder "Paket müsste fragmentiert werden, DF-Flag ist jedoch gesetzt".

Komischerweise bootet sich meine DS neu wenn der Wert zu groß ist?!?


Wie meinst du das mit dem neu booten?

Wenn du im LAN-Treiber und der DS die JF-Größe auf 9000 stellst - funktioniert das nicht?
 

coolhot

Benutzer
Mitglied seit
01. März 2009
Beiträge
926
Punkte für Reaktionen
0
Punkte
0
@itari: Klingt witzig, gibt´s aber wirklich -Schau dir mal das nette Tool "Power Off" an (allerdings nur für Win).

... und das passt auch noch dazu.
 
Zuletzt bearbeitet:

juwi

Benutzer
Mitglied seit
01. Dezember 2008
Beiträge
145
Punkte für Reaktionen
1
Punkte
18
Ich meinte mit Booten, das sich meine DS einfach neugestartet hat wenn der Wert zu hoch war. Anschließend bekam ich per Email eine Nachricht, dass sie aufgrund eines Stromausfalls neugestartet wurde?
Sprich der Ping hat die DS abgeschossen. Ihr könnt es ja mal versuchen nachzustellen ;).
 

okieh

Benutzer
Mitglied seit
13. Januar 2009
Beiträge
60
Punkte für Reaktionen
0
Punkte
0

Das ist am Anfang immer so, auch bei mir. Mit der Zeit ändert sich diese Rate aber auf einen wesentlich realistischeren Wert, d. h. die Transferrate geht deutlich runter. Hast du diesen Kopiervorgang mal bis zum Ende durchlaufen lassen oder immer nach ein paar Sekunden abgebrochen? Windows ist in der Hinsicht einfach doof und kann nicht rechnen - der Wert am Schluss, dass ist die wirkliche Transferrate!
 

itari

Benutzer
Mitglied seit
15. Mai 2008
Beiträge
21.900
Punkte für Reaktionen
3
Punkte
0
Das ist am Anfang immer so, auch bei mir. Mit der Zeit ändert sich diese Rate aber auf einen wesentlich realistischeren Wert, d. h. die Transferrate geht deutlich runter. Hast du diesen Kopiervorgang mal bis zum Ende durchlaufen lassen oder immer nach ein paar Sekunden abgebrochen? Windows ist in der Hinsicht einfach doof und kann nicht rechnen - der Wert am Schluss, dass ist die wirkliche Transferrate!

Der Wert am Schluss ist die Busy-Time, aber nicht die Transferrate. Oder willst du wirklich das Anlegen von Verzeichnissen, Ändern von Rechten usw. als "Transferzeit" mitrechnen ... für mich ist die Transferzeit nicht die Dauer, wie lange es dauert, sondern wie schnell die Datenübertragung über Netz geht. Wie lange dann die Rechner noch daran herum knabbern, hat ja nicht wirklich was damit zu tun ... Insofern kann eine kleine Datei (1 MB) mit 100 MByte/s über Netz hüpfen aber 5 Minuten brauchen, bis sie fertig angelegt auf der entfernten Platte liegt. :D

Itari
 

juwi

Benutzer
Mitglied seit
01. Dezember 2008
Beiträge
145
Punkte für Reaktionen
1
Punkte
18
Am Ende steht bei mir 59 MB/s (schreiben). Die Leserate ist auch fast gleich. Es findet also keine wesentliche Änderung statt.

Auf der anderen Seite hängt die Transferrate ja auch immer vom Füllstand der Platte ab (sprich davon an welcher Stelle die Daten auf der Platte geschrieben wurden), da die Sektoren am Ende langsamer gelesen und geschrieben werden. Ich habe zum Beispiel noch 250 Gb frei.
 
Zuletzt bearbeitet:

okieh

Benutzer
Mitglied seit
13. Januar 2009
Beiträge
60
Punkte für Reaktionen
0
Punkte
0
Der Wert am Schluss ist die Busy-Time, aber nicht die Transferrate. Oder willst du wirklich das Anlegen von Verzeichnissen, Ändern von Rechten usw. als "Transferzeit" mitrechnen ...

Naja, ich sehe das anders. Wenn es bei mir mit dem Wert 60 startet und am Schluss nur noch 20 da steht, nehme ich doch mal an, dass die 20 der eher realistischere Wert ist, oder? Außerdem sollte man bei diesem Thema vielleicht mal zum NAS Performance Toolkit von Intel greifen und sich nicht auf WinDoof verlassen.

Heiko
 

Matthieu

Super-Moderator
Teammitglied
Mitglied seit
03. November 2008
Beiträge
13.086
Punkte für Reaktionen
16
Punkte
334
Wir hatten uns hier mal auf iperf/jperf als Vergleichsmittel geeinigt ... (siehe meine Anleitung im Wiki).

MfG Matthieu
 

juwi

Benutzer
Mitglied seit
01. Dezember 2008
Beiträge
145
Punkte für Reaktionen
1
Punkte
18
Hier mal ein Screenshot von den Übertragungsraten am Ende der gleichen Datei.
Die Leserate ist um ca. 10MB/s eingebrochen. Bei anderen grösseren Dateien hatte ich am Ende auch schon > 70 MB/s beim Lesen. Entspricht aber auch dem Verhalten der Desktopfestplatte(n) im Rechner. Ich bin also zufrieden :).

 

okieh

Benutzer
Mitglied seit
13. Januar 2009
Beiträge
60
Punkte für Reaktionen
0
Punkte
0
Kannst auch zufrieden sein, keine Frage ein sehr guter Wert!

@Matthieu: äh ja, mag sein, aber schließt das die Nutzung der NAS PT aus?? Ich wollte nur drauf hinweisen, sich nicht auf Windows zu verlassen. :)

Heiko
 

Matthieu

Super-Moderator
Teammitglied
Mitglied seit
03. November 2008
Beiträge
13.086
Punkte für Reaktionen
16
Punkte
334
Kannst auch zufrieden sein, keine Frage ein sehr guter Wert!

@Matthieu: äh ja, mag sein, aber schließt das die Nutzung der NAS PT aus?? Ich wollte nur drauf hinweisen, sich nicht auf Windows zu verlassen. :)

Heiko

Sicherlich nicht. Aber vergleichbare Werte gibt es nur von ein und demselben Program. Du kannst auch iperf und das Intel PT nicht vergleichen. Die haben alle eigene Verfahren. Und wir hatten uns halt mal auf iperf geeinigt weil es relativ einfach zu verwenden ist.

MfG Matthieu
 

underdog

Benutzer
Mitglied seit
28. Oktober 2009
Beiträge
11
Punkte für Reaktionen
0
Punkte
0
Jumbo Frames bedeutet in erster linie weniger Prozessorauslastung. Wenn der Prozessor der Jeweiligen Geräte genügend Leistung hat wird keine Beschleunigung sichtbar.

Frage: Wie hoch ist dein Netzwerkdurchsatz in der Praxis im 1GB Lan?
 
  AdBlocker gefunden!

Du bist nicht hier, um Support für Adblocker zu erhalten, denn dein Adblocker funktioniert bereits ;-)

Klar machen Adblocker einen guten Job, aber sie blockieren auch nützliche Funktionen.

Das Forum wird mit einem hohen technischen, zeitlichen und finanziellen Aufwand kostenfrei zur Verfügung gestellt. Wir zeigen keine offensive oder Themen fremde Werbung. Bitte unterstütze dieses Forum, in dem du deinen Adblocker für diese Seite deaktivierst.