Nextcloud 12

rednag

Benutzer
Mitglied seit
08. Nov 2013
Beiträge
3.952
Punkte für Reaktionen
11
Punkte
104
Ich mußte bei dem Update auf 12.0.1 bzgl. PHP/Apache ändern. Nextcloud läuft bei mir unter PHP7 und Apache24. Der integrierte Updater hat beim anlegen vom Backup einen Timeout geworfen, wurde aber im Hintergrund weiterhin ausgeführt. Unverständlich, da meine Daten in der Wolke nur etwa 50MB belegen.
Den "Maintenance"-Mod mußte ich nach erfolgreicher Aktualisierung aber in der confog.php manuell deaktivieren. Soweit passt nun wieder alles.
 
#
Hallo maalik,

Bücher und Hardware zum Thema gibt es bei Amazon: Nextcloud 12 

 

Andy+

Benutzer
Mitglied seit
25. Jan 2016
Beiträge
3.925
Punkte für Reaktionen
120
Punkte
129
Mit veränderten PHP-Einstellungen scheint es zu gehen :

PHP Warning: PHP Startup: Unable to load dynamic library '/usr/local/lib/php56/modules/mapi.so' - /usr/local/lib/php56/modules/mapi.so: cannot open shared object file: No such file or directory in Unknown on line 0
Starting scan for user 1 out of 1 (rescan)

+---------+-------+--------------+
| Folders | Files | Elapsed time |
+---------+-------+--------------+
| 4978 | 29215 | 00:02:00 |
+---------+-------+--------------+

Kann jemand sagen, was es mit der mapi.so auf sich hat?
 

Tom80

Benutzer
Mitglied seit
06. Okt 2015
Beiträge
125
Punkte für Reaktionen
0
Punkte
16
Hallo,

Ich habe heute ein Update auf NC12 versucht, aber jetzt bekomme ich immer einen "Internal Server Error" wenn ich die Seite aufrufe.
Wenn ich über SSH dann z.B. ein "sudo -u http php occ maintenance:repair" mache erhalte ich den folgenden Fehler:

An unhandled exception has been thrown:
exception 'Doctrine\DBAL\DBALException' with message 'Failed to connect to the database: An exception occured in driver: could not find driver' in /volume1/web/nextcloud/lib/private/DB/Connection.php:61


Hier wird irgendein Treiber nicht gefunden.


Ein "php56 -i | grep -i pdo" mit SSH ergibt folgendes:

API Extensions => mysql,mysqli,pdo_mysql
PDO
PDO support => enabled
PDO drivers => mysql, dblib, pgsql, sqlite
pdo_dblib
PDO Driver for FreeTDS/Sybase DB-lib => enabled
pdo_mysql
PDO Driver for MySQL => enabled
pdo_mysql.default_socket => /run/mysqld/mysqld.sock => /run/mysqld/mysqld.sock
pdo_pgsql
PDO Driver for PostgreSQL => enabled
pdo_sqlite
PDO Driver for SQLite 3.x => enabled


Ein "php70 -i | grep -i pdo"

PDO
PDO support => enabled
PDO drivers =>


Wie trage ich da bei php70 den Treiber ein?
Jemand eine Idee?

Tom80
 

TheGardner

Benutzer
Mitglied seit
30. Nov 2012
Beiträge
1.694
Punkte für Reaktionen
14
Punkte
64
Apache 2.4 und/oder php7.0 in Betrieb?

Das wäre der Fehler! Auf Apache 2.2 und php 56 wechseln und dann Nextcloud nochmal aufrufen bzw. das Update nochmal durchführen.
 

Tom80

Benutzer
Mitglied seit
06. Okt 2015
Beiträge
125
Punkte für Reaktionen
0
Punkte
16
Habe alles probiert, an den Apache und php-Einstellungen lag es nicht direkt.

Das Problem an dem Internal Server Error lag daran:

{"reqId":"p76OncE1KTPM6D693p2U","level":3,"time":"2017-08-09T16:21:37+00:00","remoteAddr":"****","user":"--","app":"PHP","method":"GET","url":"\/nextcloud\/index.php\/login","message":"touch(): Unable to create file \/volume1\/web\/nextcloud\/data\/appdata_***\/js\/core\/merged-share-backend.js because No such file or directory at \/volume1\/web\/nextcloud\/lib\/private\/Files\/Storage\/Local.php#199","userAgent":"Mozilla\/5.0 (Windows NT 10.0; WOW64; rv:54.0) Gecko\/20100101 Firefox\/54.0","version":"12.0.1.5"}

Das Verzeichnis js gab es unter nextcloud/data/appdata_**/ schlicht nicht, habe das dann aus einer Testinstallation von Nextcloud12 dahin kopiert und schon war der Fehler weg. ( Rechte musste ich noch neu setzen)

Tom80
 

Andy+

Benutzer
Mitglied seit
25. Jan 2016
Beiträge
3.925
Punkte für Reaktionen
120
Punkte
129
...........ansprechen der cron.php mit der Crontab, jedoch hat das eher was mit DSM 6.1.1 zu tun, denn mit DSM 5.2 gings noch.............

Jetzt geht alles wieder, ich hatte etwas Zeit und auch den Fehler gefunden. Es sind die Kleinigkeiten in der crontab mit den Zeichen. Vorher ging noch sowas wie "%d.%m.%Y um %H:%M:%S", jetzt muss ich daraus "\%Y-\%m-\%d um \%H-\%M-\%S" machen, dodass meine Kommandoketten nun lauten wie zB.

0,10,20,30,40,50 * * * * root /bin/su -s /bin/sh -c "/usr/local/bin/php56 -f /volume1/web/owncloud/cron.php" http && /bin/echo $(/bin/date +"ok am \%Y-\%m-\%d um \%H-\%M-\%S Uhr") >> /volume1/Sicherungen/Protokolle/ownCloud_cron_php__$(/bin/date +\%Y-\%m-\%d).log 2>&1

oder

0,10,20,30,40,50 * * * * root /bin/su -s /bin/sh -c "/usr/local/bin/php56 -f /volume1/web/owncloud/occ files:cleanup" http >> /volume1/Sicherungen/Protokolle/ownCloud_cleanup__$(/bin/date +\%Y-\%m-\%d).log 2>&1
1,11,21,31,41,51 * * * * root /bin/su -s /bin/sh -c "/usr/local/bin/php56 -f /volume1/web/owncloud/occ files:scan rescan" http >> /volume1/Sicherungen/Protokolle/ownCloud_scan_rescan__$(/bin/date +\%Y-\%m-\%d).log 2>&1

und siehe da, alles flutscht wie früher. Und auch solche Logeinträge, wie

/bin/echo $(/bin/date +"ok am \%Y-\%m-\%d um \%H-\%M-\%S Uhr") >>

gehen auch nur auf diesem Wege, auch wenn es nur Einträge sind. Sehen diese anders aus geht nichts mehr. Darauf soll einer erst mal kommen ..... :cool:
 
Zuletzt bearbeitet:

Andy+

Benutzer
Mitglied seit
25. Jan 2016
Beiträge
3.925
Punkte für Reaktionen
120
Punkte
129
Kann berichten, dass bei mir Version 12 mit PHP 7.0 und Apache 2.4 ebenfalls läuft.

Für die Updates muss ich zwar immer auf 2.2 und 5.6 runterstellen, danach läuft es aber ohne Probleme.

lg

Das stimmt schon, auch für ownCloud 10. Jedoch die Einträge in der crontab gehen nur mit php56-Einträgen.
 

Andy+

Benutzer
Mitglied seit
25. Jan 2016
Beiträge
3.925
Punkte für Reaktionen
120
Punkte
129
Ich warte bis ich die stable über den Updater ausgeliefert bekomme.
@maalik ja ich hab schon im Vorfeld gehört dass der Updater mit Apache 2.4 und php 7 nicht arbeitet.

Zum Thema cron, welche option versucht ihr zum laufen zu bekommen, den Webcron?
Ich benutze die option cron (Systemeigener Cron) bringt cron über php 7 irgend welche Vorteile?

Auch hier, am besten ist die crontab, aber auch das geht nur mir php56. Mit php70 kommen nur Fehler oder Driverprobleme.
 

Andy+

Benutzer
Mitglied seit
25. Jan 2016
Beiträge
3.925
Punkte für Reaktionen
120
Punkte
129
...........exception 'Doctrine\DBAL\DBALException' with message 'Failed to connect to the database: An exception occured in driver: could not find driver' in /volume1/web/nextcloud/lib/private/DB/Connection.php:61..........

zB. sowas
 

maalik

Benutzer
Mitglied seit
05. Feb 2016
Beiträge
633
Punkte für Reaktionen
6
Punkte
38
Habt ihr eigentlich auch das Problem, dass die ganzen Icons mit PHP 7.0 seit dem Update auf 12.0.1 nicht mehr angezeigt werden?
 

rednag

Benutzer
Mitglied seit
08. Nov 2013
Beiträge
3.952
Punkte für Reaktionen
11
Punkte
104
Welche Icons? Bei mir sieht alles soweit in Ordnung aus.
 

maalik

Benutzer
Mitglied seit
05. Feb 2016
Beiträge
633
Punkte für Reaktionen
6
Punkte
38
Nahezu alle Icons.

Der Link im CSS wird total schräg gesetzt: background-image: url(../../../core/css/../img/actions/share.svg?v=1);

Bei PHP 5.6 ohne Probleme
 

Anhänge

  • Unbenannt.jpg
    Unbenannt.jpg
    16,2 KB · Aufrufe: 150

rednag

Benutzer
Mitglied seit
08. Nov 2013
Beiträge
3.952
Punkte für Reaktionen
11
Punkte
104
Sieht bei Dir wirklich ein wenig schräg aus. Ich habs auch unter Apache24 und PHP7 am laufen, sieht aber wie gehabt aus.

Unbenannt.jpg
 

maalik

Benutzer
Mitglied seit
05. Feb 2016
Beiträge
633
Punkte für Reaktionen
6
Punkte
38

rednag

Benutzer
Mitglied seit
08. Nov 2013
Beiträge
3.952
Punkte für Reaktionen
11
Punkte
104
Mach mal das Update auf 12.0.2. Evtl. sieht es dann besser aus.
 

maalik

Benutzer
Mitglied seit
05. Feb 2016
Beiträge
633
Punkte für Reaktionen
6
Punkte
38
Bereits hinter mir, ohne Erfolg.
 

rednag

Benutzer
Mitglied seit
08. Nov 2013
Beiträge
3.952
Punkte für Reaktionen
11
Punkte
104
Dann kann ich leider nicht mehr dazu beitragen.

Andere Frage: Ist das Update ohne Timeouts bei Dir durchgelaufen?
 

maalik

Benutzer
Mitglied seit
05. Feb 2016
Beiträge
633
Punkte für Reaktionen
6
Punkte
38
Update auf 12.0.1 habe ich manuell gemacht, auf 12.0.2 habe ich es das erste mal (!) über den Webupdater geschafft. Wie gesagt, ich denke es ist ein Problem von NC. Wird ja bereits diskutiert, auch diese seltsame CSS-Codierung
 

rednag

Benutzer
Mitglied seit
08. Nov 2013
Beiträge
3.952
Punkte für Reaktionen
11
Punkte
104
Na ja, von einer 12er Version erwarte ich doch ein wenig mehr. Meine Daten in der Wolke belegen gerade mal 45MB. Der erste Timeout war beim anlegen eines Backups....
 

OdinsAuge

Benutzer
Mitglied seit
12. Nov 2015
Beiträge
346
Punkte für Reaktionen
16
Punkte
24
Ich versuche gerade mal wieder external Storage zum Laufen zu bringen, leider ohne Erfolg.

Auf der DS ist SMB aktiviert. In der NC ist external Storage aktiviert.

In den Persönlichen Einstellungen in NC habe ich als host folgendes probiert: DSName, lokale IP, \\DSName
Als share volume1 und auch direkt den ordner den ich einbinden möchte, mal mit \ und mal ohne \
User hat Zugriff auf besagt Ordner.

Als Fehler bekomm ich immer file_exists(): open_basedir restriction in effect. File(/dev/fd) is not within the allowed path(s):

/volume1/Share ist aber im open_basedir eingetragen.

Hab ich etwas übersehen oder liegts einfach nur daran dass ich den Pfad falsch eintrage?
 
NAS-Central - Ihr Partner für NAS Lösungen
NAS-Central - The Home of NAS

Kaffeautomat

Wenn du das Forum hilfreich findest oder uns unterstützen möchtest, dann gib uns doch einfach einen Kaffee aus.

Als Dankeschön schalten wir deinen Account werbefrei.

:coffee:

Hier gehts zum Kaffeeautomat 

Hosted by netcup