neue DS218+ mit 4 TB WD Red erweiterte S.M.A.R.T Test hängt bei 90%

Mikka69

Benutzer
Mitglied seit
14. Mai 2020
Beiträge
18
Punkte für Reaktionen
0
Punkte
1
Hallo,
ich habe eine neue DS218+ mit 2 WD Red WD40EFAX und bisher zum testen nur einige wenige Daten aufgespielt.
Der schnelle SMART Test läuft fehlerfrei durch.
Beim erweiterten SMART Test bleibt er bei beiden WD Red‘s auch nach über 12 Std. bei 90% hängen.
Habe jetzt gefühlt alle Beiträge dazu gelesen, aber keine Lösung gefunden.

Soweit ich das beurteilen kann, sehen die SMART Werte ok aus
Hier mal die Werte der HD1
51EE0F17-A883-449A-9778-70C13662F1A7.jpg
11169D86-7619-4DB2-AE86-3A990C4D0497.jpg

Hat jemand eine Idee, warum der Test immer bei 90% stehen bleibt bzw. wie sich das Problem lösen läßt?
Das die DS und die Festplatten neu sind, frage ich mich natürlich ob hier ein Software oder Bedienungsfehler meinerseits vorliegt,
oder Im schlimmsten Fall wirklich ein Hardwarefehler bei beiden neuen Platten vorhanden ist :confused:

Gruß Mikka
 

Mikka69

Benutzer
Mitglied seit
14. Mai 2020
Beiträge
18
Punkte für Reaktionen
0
Punkte
1
Hier auch noch die Werte der HD2

9BC5FF7F-3A9D-4A8F-8F5D-B3DA682392F7.jpg
2DC61A4C-8BF1-444B-A59F-6B9814AEC6C6.jpg
 

TeXniXo

Benutzer
Mitglied seit
07. Mai 2012
Beiträge
4.752
Punkte für Reaktionen
49
Punkte
134
Die SMART-Werte beider HDDs scheinen in Ordnung zu sein. Wie lang dauert es bis du zu 90% gekommen bist? Evtl. noch bisschen gedulden?
 

Mikka69

Benutzer
Mitglied seit
14. Mai 2020
Beiträge
18
Punkte für Reaktionen
0
Punkte
1
Bis zu den 90 % ca. 15 min. und dann geht es nicht weiter.
Nach 12-14 Std. hab ich dann abgebrochen. Auch weiterer Test verlief genauso.
Wenn man den Test startet steht da er soll ca. 14 min. dauern
 

synfor

Benutzer
Mitglied seit
22. Dezember 2017
Beiträge
1.979
Punkte für Reaktionen
12
Punkte
58
Vergiss das mit den 14 min. Der erweiterte S.M.A.R.T.-Selbsttest dauert mit Sicherheit länger als 14 min und auch länger bis er bei 90% ist. Darüber hinaus steht bei WD der Test gern mal längere Zeit auf 90% (länger als bei den 10er Schritten zuvor) und manchmal hängt er dort auch. Hängende Tests hatte ich allerdings noch nicht.
 

tricho

Benutzer
Mitglied seit
22. Oktober 2014
Beiträge
32
Punkte für Reaktionen
0
Punkte
12
Hallo Mikka,
also die beiden Platten gehören zu den Modellen, die WD ohne Ankündigung auf SMR-Recording umgestellt hat (WD Red 20 - 40 - 60 EFAX) . Ich wüßte jetzt nicht wieso sich das auf das SMART-Test Verhalten auswirken sollte, aber diese Modelle regieren möglicherweise etwas anders als Platten mit CMR-Recording.

Außerdem solltest Du bedenken, das diese Platten für den Raid-Einsatz vielleicht nicht geeignet sind (Wegen SMR). Schließlich sei noch erwähnt, dass die WD20EFAX und WD60EFAX von Synology erst kürzlich als inkompatibel vermerkt wurden. Wie so sollte die WD40EFAX jetzt ausgerechnet kompatibel sein? Vermutlich landen die bald auch auf dieser Liste.

Wenn Du es noch kannst tausch die Platten gegen andere aus.

Gruß Ortwin
 

Kurt-oe1kyw

Benutzer
Mitglied seit
10. Mai 2015
Beiträge
5.647
Punkte für Reaktionen
14
Punkte
144
Website
www.silvia-kurt.at
Bis zu den 90 % ca. 15 min. und dann geht es nicht weiter.
Nach 12-14 Std. hab ich dann abgebrochen.
Willkommen im Forum.
Vergiss die Anzeige mit den 90% einfach.
Ich habe es im Forum schon öfter erwähnt, bei einer DS gilt immer GEDULD haben!
Die SMART Werte deiner HDDs sehen beide sehr gut aus.
Starte noch mal den großen SMART (Erweiterter Test) und dann lass den laufen so lange bis er beendet ist!
Wenn er aber nach 3 Tagen immer noch nicht fertig ist, dann stimmt etwas nicht.

Die Problematik mit der SMR Technik bleibt allerdings, es betrifft die WD red Modelle 2,3,4 und 6 TB HDDs der neuen Serie:

wd_red_smr_typenliste_stand15mai2020.jpg

Früher waren die alle mit CMR Technik.
Google mal nach WD red SMR Problematik da wirst du auf mehreren Seiten schnell fündig.
DAS ist aber normalerweise unabhängig von deiner Wartezeit mit dem SMART Test.
 
Zuletzt bearbeitet:

Mikka69

Benutzer
Mitglied seit
14. Mai 2020
Beiträge
18
Punkte für Reaktionen
0
Punkte
1
Ok, werde den Test mal länger laufen lassen, wenn es bis zu 3 Tage dauern kann.
Sollte man den Test immer mit nur Mit einer HD machen oder kann er auch bei beiden HD parallel durchgeführt werden.
Macht es evtl. Sinn erst am PC mit dem WD Tool zu testen?

Das mit der SMR Problem hab ich zwar gelesen, aber nichts wie sich das im laufendem Betrieb darstellt bzw. auffällt?
 

Mikka69

Benutzer
Mitglied seit
14. Mai 2020
Beiträge
18
Punkte für Reaktionen
0
Punkte
1
Habe den erweiterten SMART Test gestern gestartet und nach ca. 20 min. ist er bei 90% angekommen und da steht er jetzt nach fast 24 Std. immer noch.
Mal sehen ob er noch zum Ende kommt.
Mich würde nur mal interessieren, was die Ursache bzw. der Grund dafür ist, das er so lange braucht? :confused:
 

Mikka69

Benutzer
Mitglied seit
14. Mai 2020
Beiträge
18
Punkte für Reaktionen
0
Punkte
1
Hallo,

also auch nach 3 Tage steht er noch bei 90% und was nun? :confused:
 

peterhoffmann

Benutzer
Mitglied seit
17. Dezember 2014
Beiträge
2.912
Punkte für Reaktionen
17
Punkte
84
Vielleicht hängt auch nur die DSM-Oberfläche und gibt das Ergebnis nicht richtig weiter.

Gehe mal auf die Konsole (ssh), logge dich zu root um und setze für die erste HDD folgenden Befehl ab:
Rich (BBCode):
smartctl -a -d ata /dev/sda
für die zweite HDD:
Rich (BBCode):
smartctl -a -d ata /dev/sdb
Bei der Ausgabe erkennst du wann welcher Smarttest mit welchem Ergebnis durchgeführt wurde.
 

Mikka69

Benutzer
Mitglied seit
14. Mai 2020
Beiträge
18
Punkte für Reaktionen
0
Punkte
1
Da ich den Test erstmal nur bei HDD2 durchführe, habe ich das mal per ssh nachgeschaut
Ich werd da aber nicht wirklich schlau draus :confused:
Hier das Ergebnis:

=== START OF READ SMART DATA SECTION ===
SMART overall-health self-assessment test result: PASSED

General SMART Values:
Offline data collection status: (0x00) Offline data collection activity
was never started.
Auto Offline Data Collection: Disabled.
Self-test execution status: ( 241) Self-test routine in progress...
10% of test remaining.
Total time to complete Offline
data collection: ( 1320) seconds.
Offline data collection
capabilities: (0x7b) SMART execute Offline immediate.
Auto Offline data collection on/off support.
Suspend Offline collection upon new
command.
Offline surface scan supported.
Self-test supported.
Conveyance Self-test supported.
Selective Self-test supported.
SMART capabilities: (0x0003) Saves SMART data before entering
power-saving mode.
Supports SMART auto save timer.
Error logging capability: (0x01) Error logging supported.
General Purpose Logging supported.
Short self-test routine
recommended polling time: ( 2) minutes.
Extended self-test routine
recommended polling time: ( 12) minutes.
Conveyance self-test routine
recommended polling time: ( 2) minutes.
SCT capabilities: (0x3039) SCT Status supported.
SCT Error Recovery Control supported.
SCT Feature Control supported.
SCT Data Table supported.

SMART Attributes Data Structure revision number: 16
Vendor Specific SMART Attributes with Thresholds:
ID# ATTRIBUTE_NAME FLAG VALUE WORST THRESH TYPE UPDATED WHEN_FAILED RAW_VALUE
1 Raw_Read_Error_Rate 0x002f 100 253 051 Pre-fail Always - 0
3 Spin_Up_Time 0x0027 206 205 021 Pre-fail Always - 2675
4 Start_Stop_Count 0x0032 100 100 000 Old_age Always - 109
5 Reallocated_Sector_Ct 0x0033 200 200 140 Pre-fail Always - 0
7 Seek_Error_Rate 0x002e 200 200 000 Old_age Always - 0
9 Power_On_Hours 0x0032 100 100 000 Old_age Always - 182
10 Spin_Retry_Count 0x0032 100 100 000 Old_age Always - 0
11 Calibration_Retry_Count 0x0032 100 100 000 Old_age Always - 0
12 Power_Cycle_Count 0x0032 100 100 000 Old_age Always - 104
192 Power-Off_Retract_Count 0x0032 200 200 000 Old_age Always - 0
193 Load_Cycle_Count 0x0032 200 200 000 Old_age Always - 208
194 Temperature_Celsius 0x0022 122 119 000 Old_age Always - 25
196 Reallocated_Event_Count 0x0032 200 200 000 Old_age Always - 0
197 Current_Pending_Sector 0x0032 200 200 000 Old_age Always - 0
198 Offline_Uncorrectable 0x0030 100 253 000 Old_age Offline - 0
199 UDMA_CRC_Error_Count 0x0032 200 200 000 Old_age Always - 0
200 Multi_Zone_Error_Rate 0x0008 100 253 000 Old_age Offline - 0

SMART Error Log Version: 1
No Errors Logged

SMART Self-test log structure revision number 1
Num Test_Description Status Remaining LifeTime(hours) LBA_of_first_error
# 1 Extended offline Aborted by host 10% 104 -
# 2 Short offline Completed without error 00% 103 -
# 3 Short offline Completed without error 00% 102 -
# 4 Extended offline Aborted by host 10% 102 -
# 5 Short offline Completed without error 00% 85 -
# 6 Short offline Completed without error 00% 12 -
# 7 Extended offline Aborted by host 10% 12 -

SMART Selective self-test log data structure revision number 1
SPAN MIN_LBA MAX_LBA CURRENT_TEST_STATUS
1 0 0 Not_testing
2 0 0 Not_testing
3 0 0 Not_testing
4 0 0 Not_testing
5 0 0 Not_testing
Selective self-test flags (0x0):
After scanning selected spans, do NOT read-scan remainder of disk.
If Selective self-test is pending on power-up, resume after 0 minute delay.
 
Zuletzt bearbeitet:

peterhoffmann

Benutzer
Mitglied seit
17. Dezember 2014
Beiträge
2.912
Punkte für Reaktionen
17
Punkte
84
Die Smartdaten sehen grundsätzlich einwandfrei aus.

Für das Ergebnis der Smarttests ist folgender Absatz wichtig:
Rich (BBCode):
# 1 Extended offline Aborted by host 10% 104 -
# 2 Short offline Completed without error 00% 103 -
# 3 Short offline Completed without error 00% 102 -
# 4 Extended offline Aborted by host 10% 102 -
# 5 Short offline Completed without error 00% 85 -
# 6 Short offline Completed without error 00% 12 -
# 7 Extended offline Aborted by host 10% 12 -
Wie man sieht, sind die kurzen Smarttests bei Stunde 12, 85, 102 und 103 alle durchgelaufen.
Die langen Smarttests bei Stunde 12, 103 und 104 leider nicht.

Ist es möglich, dass die Smarttests durch einen Neustart unterbrochen wurden?
Oder hast du eventuell einen Long- und direkt danach einen Short-Test gestartet? Von den Zeiten könnte das passen.

Du kannst auch einen Long-Test über die Konsole starten (siehe smartctl -h). So umgehst du ein eventuelles Problem mit der DSM-Oberfläche.

Wenn das auch nicht geht, kannst du in allerletzter Konsequenz die HDD ausbauen und an einem PC den Smarttest durchlaufen lassen.
 

Mikka69

Benutzer
Mitglied seit
14. Mai 2020
Beiträge
18
Punkte für Reaktionen
0
Punkte
1
....
Du kannst auch einen Long-Test über die Konsole starten (siehe smartctl -h). So umgehst du ein eventuelles Problem mit der DSM-Oberfläche.

Wenn das auch nicht geht, kannst du in allerletzter Konsequenz die HDD ausbauen und an einem PC den Smarttest durchlaufen lassen.
Also über Konsole bleibt er genauso bei 90 % hängen. :(

Werde jetzt mal die HD am PC mit dem WD Tool testen.
 

Mikka69

Benutzer
Mitglied seit
14. Mai 2020
Beiträge
18
Punkte für Reaktionen
0
Punkte
1
Da ich eine Festplatte am Rechner noch nie getestet habe, kann ich die eigentlich so aus
der DiskStation rausnehmen und im Rechner anschließen und den Test durchführen?
Oder gibt es da eventuell Probleme mit der Formatierung?
Gibt es da eventuell noch was zu beachten?
 

peterhoffmann

Benutzer
Mitglied seit
17. Dezember 2014
Beiträge
2.912
Punkte für Reaktionen
17
Punkte
84
In einem Linuxsystem sollte das kein Problem darstellen.

Bei allen Operationen sollte immer ein frisches Backup vorhanden sein.
 

synfor

Benutzer
Mitglied seit
22. Dezember 2017
Beiträge
1.979
Punkte für Reaktionen
12
Punkte
58
Läuft das Testtool von WD überhaupt unter Linux? Abgesehen davon, ist es für den Test egal, was für ein Dateisystem auf der Platte ist und ob das System, auf dem der Test läuft, dieses unterstützt.
 

peterhoffmann

Benutzer
Mitglied seit
17. Dezember 2014
Beiträge
2.912
Punkte für Reaktionen
17
Punkte
84
Es ging mir eher um einen erweiterten Smarttest mit smartctl und nicht um das WD-Tool.
Das WD-Tool wird aufgrund der tollen Smartwerte wohl Freudensprünge machen und alles für "ok" befinden (reine Vermutung). Aber versuchen kann man es ja auch mal und schauen, was es so ausspuckt.
 

synfor

Benutzer
Mitglied seit
22. Dezember 2017
Beiträge
1.979
Punkte für Reaktionen
12
Punkte
58
Auch für smartctl unter Linux ist es egal, was sich auf der Platte befindet, und war hier nicht gerade vor kurzem einer mit einer WD-Platte, die in S.M.A.R.T. total unauffällig war, bei der aber das WD-Testtool den Test wegen zu vielen fehlerhaften Sektoren abgebrochen hat?

Komisch finde ich jedoch, dass die Test immer bei 90% hängen bleiben, das S.M.A.R.T.-Log aber einen Abbruch bei 10% meldet und dass die Tests schon nach etwa einer viertel Stunde schon bei 90% sind. Das ist viel zu schnell für den vollständigen Test. Interessant wäre auch, was das Log zu dem letzten hängengebliebenen Test sagt.
 

Mikka69

Benutzer
Mitglied seit
14. Mai 2020
Beiträge
18
Punkte für Reaktionen
0
Punkte
1
Jetzt habe ich bei Festplatten mit dem WD Data LifeGuard Diagnostics Program getestet mit folgendem Ergebnis:
Test Option: QUICK TEST
Model Number: WDC WD40EFAX-68JH4N0
Firmware Number: 82.00A82
Capacity: 4000.79 GB
SMART Status: PASS
Test Result: PASS

Test Time: 17:05:34, May 20, 2020
Test Option: EXTENDED TEST
Model Number: WDC WD40EFAX-68JH4N0Firmware Number: 82.00A82
Capacity: 4000.79 GB
SMART Status: PASS
Test Result: FAIL
Test Error Code: 08-Too many bad sectors detected.
Test Time: 17:06:02, May 20, 2020
Das Testergebnis ist bei beiden HDs identisch
Der schnelle Test ist wie im DSM ohne Fehler.
Der erweiterte Test bricht sofort nach 2 Sek. mit dem Ergebnis oben ab.

Also sind wirklich beide neunen Festplatten defekt? :confused:
Oder kann es noch was anderes als Ursache geben? :confused: