iPKGui - Eine Weboberfläche für iPKG

QTip

Super-Moderator
Teammitglied
Mitglied seit
04. September 2008
Beiträge
2.323
Punkte für Reaktionen
1
Punkte
84
Website
www.smallco.de
Vorwort
iPKGui ist eine Weboberfläche für iPKG® und oPKG. Inspiriert durch Synaptic, einer grafischen Oberfläche für apt, bietet diese Applikation eine ähnliche Handhabung. So können Pakete einfach per Klick für die Installation, Entfernung oder Aktualisierung zu einer Warteschlange hinzugefügt werden, um im Anschluss die Aktionen ohne weitere Eingaben ausführen zu lassen. Die endgültige Ermittlung der Abhängigkeiten und die Installation der Pakete wird weiterhin vom CLI durchgeführt. iPKGui stellt kein Ersatz für iPKG oder oPKG, sondern vielmehr eine grafisches Werkzeug dar, dass einem den Überblick über die Pakete und das Handling vereinfachen soll.

Nach 6 Monaten Entwicklung, Programmierung und Testen ist nun die erste öffentliche Version fertig. Die meisten Funktionen sind bereits vorhanden, einige etwas weniger Wichtige fehlen noch, werden aber in der nächsten Zeit integriert.

Paketname: ipkgui_1.0-241.spk
Lizenz: GPL3
Firmware: 3.0.1337 und höher
Abhängigkeiten: Perl, iPKG oder oPKG
Sprachen: Deutsch, Englisch, Französisch
Browser getestet: Firefox 47.0.1, Internet Explorer 11.420.10586.0, Chrome 51.0.2704.106 m, Safari 5.17 (7534.57.2), Opera 38.0.2220.31
letzte Änderungen: hinzugefügt: Modul 'CGI' für Perl 5.22 und höher, siehe Changelog.

Download direkt oder über das Paketzentrum mit folgender Url: https://www.cphub.net

Was noch nicht geht:
  • Entfernen von Paketen, welche eine Abhängigkeit für andere Pakete darstellen. Hier gibt es eine Warn-/Hinweismeldung durch das CLI, wenn dies zutrifft. Dann muss, solange es diese Funktion nicht gibt, die entsprechenden Pakete in der richtigen Reihenfolge manuell entfernt werden. (sollte funktionieren)
  • integrierte Hilfe (kommt vermutlich mit 1.0)
ipkgui_1.jpg

Alles auf eigenes Risiko!

Aufbau
Wie oben schon erwähnt, ist iPKGui in Anlehnung an Synaptic entstanden und hat viele Ansätze von dort übernommen. Auf der linken Seite befindet sich eine Liste von Filtern, welche die Paketliste nach dem Status der Pakete filtert. Die Liste von Filtern lässt sich auf Kategorien umschalten, indem die Auswahlbox oberhalb angewählt wird. Diese Kategorien kommen von der iPKG/oPKG Paketliste und nicht von mir. Da die Kategorien teilweise mehrfach in unterschiedlicher Schreibweise vorkommen und man diese dann in der Liste hätte, wurden die Kategorien von mir gruppiert und in die jeweilige Sprache übersetzt.

Erster Start

Der erste Start dauert ein wenig länger, da zum ersten Mal die Liste der Pakete und einige Zusatzlisten für iPKGui aufbereitet wird. Auf einer DS211j kann das schon mal ~17 Sekunden dauern. Wurde per iPKG/oPKG CLI noch kein Update durchgeführt, ist die Liste der Pakete leer. In diesem Fall einfach einmalig den Button "Update" drücken, die Liste wird dann nach kurzer Zeit gefüllt.

iPKG oder oPKG
iPKG wird seit vielen Jahren nicht mehr weiterentwickelt. oPKG ist ein direkter Fork (Abzweig) von iPKG und wird zur Zeit immer noch gewartet und weiterentwickelt. oPKG hat z.B. dieses Problem mit wget und wget-ssl nicht , da es libcurl benutzt. Auf lange Sicht ist es somit sinnvoller auf oPKG zu setzen.
 
Zuletzt bearbeitet:

QTip

Super-Moderator
Teammitglied
Mitglied seit
04. September 2008
Beiträge
2.323
Punkte für Reaktionen
1
Punkte
84
Website
www.smallco.de
Kurzanleitung

Bedienung
Bei Markierung von mehreren Paketen gleichzeitig, wird immer der Status des obersten Paketes für die verfügbaren Aktionen herangezogen.
Beispiel:
Das oberste Paket ist installiert, darauf folgt ein nicht installiertes Paket und ein Paket wofür eine Aktualisierung vorliegt. Werden nun diese Pakete "zur Neuinstallation" markiert, bekommt das oberste Paket den Status "Markiere zur Neuinstallation", das darauf Folgende den Status "Markiere zur Installation" und das 3. Paket "Markiere zur Aktualisierung". Die Applikation schließt unmögliche Zustände aus und nimmt den für dieses Paket und der gewählten Aktion bestmöglichen Status, es denkt also mit.

Wird bei der Markierung von Paketen zur Installation (nun auch bei Neuinstallation und Aktualisierung) abhängige, aber fehlende Pakete entdeckt, dann erscheint eine Seite mit den zusätzlich zu installierenden Paketen. Um die angebotenen Änderungen zu übernehmen, muss der Button "Markieren" betätigt werden. Der Button "Abbruch" beendet diesen Schritt und führt keine Markierungen durch.

  • Werden mehr als 30 Pakete gleichzeitig markiert, erscheint eine Warnmeldung, nach Klick auf "Ja" kann dies aber trotzdem durchgeführt werden.
    Dies kann in den Einstellungen angepasst werden.
Nach dem einige Pakete markiert wurden (jedoch mindestens 1) wird der Button "Anwenden" anwählbar. Nach Drücken von selbigem erscheint auf der linken Seite eine Übersicht der durchzuführenden Aktionen. Die rechte Seite zeigt eine Zusammenfassung und die evtl. herunterzuladene Dateigröße. Durch Klick auf den Button "Ausführen" werden die markierten Aktionen durchgeführt, der Button "Abbruch" führt zurück zur Liste, ohne die Markierungen zu entfernen.

Das Ausführen der Aktionen findet auf einer weiteren Seite statt. Auf dieser ist oben ein Fortschrittsbalken zu sehen, der die Anzahl der Schritte nach Aktionen getrennt darstellt (Installation, Entfernen, Aktualisieren etc). Im unteren Teil der Seite kann man in fast Echtzeit die Ausgabe der Meldungen des CLI verfolgen. Abfragen vom CLI können hiermit aber nicht beantwortet werden. Sollte dies einmal vorkommen, dann bitte das entsprechende Paket merken und mir mitteilen.

iPKGui ist für mehrere Benutzer ausgelegt (vornehmlich Administratoren) und hat ein einfaches Locking eingebaut, damit gleichzeitige Ausführungen abgefangen werden. Der Benutzer bekommt dies dann in einem Dialog mitgeteilt. Nach der Erstinstallation sind nur die Administratoren berechtigt die Anwendung zu öffnen, andere Benutzer sehen das Icon im Menü nicht. Um anderen Benutzern den Zugriff zu gestatten, kann unter "Systemsteuerung - Anwendungsberechtigungen" oder über "Benutzer - Bearbeiten - Applikationen" dies eingestellt werden.

Defekte Pakete (Definition: Pakete die durch das Fehlen von einem oder mehreren abhängigen Paket(en) nicht lauffähig sind) werden nach dem Start von iPKGui ermittelt und gekennzeichnet. Zusätzlich gibt es einen neuen Status "Defekt" und 2 Icons. Wird ein defektes Paket erkannt erhalten die fehlenden Pakete ebenfalls ein neues Icon und erscheinen in der Liste unter dem Status "Defekt". Es gibt nun 4 Möglichkeiten dies zu beheben:
  1. das fehlende Paket wird per Installation nachinstalliert
  2. das defekte Paket wird erneut installiert (dadurch werden automatisch die fehlenden Pakete mit installiert)
  3. das defekte Paket entfernen
  4. falls ein Paket selbst compiliert wurde und von iPKG/oPKG bzw. iPKGui als "fehlend" erkannt wird, das Paket als "Externe Installation" markieren
Erzwinge Optionen (-force...)
Um die Benutzung einer force-Option an den Paketen sichtbar zu machen, existieren die folgenden Kürzel (shortcuts) unterhalb der Icons:
  • FO = -force-overwrite
  • FN = -nodeps
  • FON = -force-overwrite + -nodeps
  • FD = -force-depends
  • FR = -force-removal-of-dependent-packages
Des weiteren wird auf den Seiten "vor dem Hinzufügen" und "vor dem Ausführen" die force-Option hinter dem jeweiligem Paket angezeigt.

Die eingegeben Filter werden in einer neuen Liste "Filterergebnisse" nur für die aktuelle Sitzung gesichert und können abgerufen werden.

Die Logdatei kann nun über den Button "Logdatei einsehen" auf der Statusleiste links unten aufgerufen werden.

Toolbar
Die Toolbar stellt die folgenden Befehle zur Verfügung:

  • Aktualisieren
    Hiermit wird die Liste der Pakete per iPKG/oPKG aktualisiert (identisch mit ipkg/opkg-cl update) und anschließend die Liste der Pakete für iPKGui neu aufbereitet. Hierbei werden Aktualisierungen und neue Pakete entdeckt und in der Liste markiert. Neue Pakete sind aber nur einmal sichtbar und deren Markierung verschwindet beim nächsten Start von iPKGui.
  • Markiere Upgrades
    iPKGui kennzeichnet erkannte Aktualisierungen in der Liste automatisch...mit diesem Button werden alle verfügbaren Aktualisierungen markiert und direkt zum Abschnitt "Installiert (aktualisierbar)" gesprungen.
  • Anwenden
    Markierte Änderungen werden hierdurch angewandt, d.h. alle zuvor markierten Aktionen für diese Pakete (Installation, Aktualisierungen oder Entfernung) werden nun durchgeführt. Nach Klick wird eine Auflistung der durchzuführenden Änderungen angezeigt. Der Button ist nur anwählbar, wenn zuvor mindestens eine Aktion markiert wurde.
  • Einstellungen
    die folgenden Formulare können auch direkt über den kleinen Pfeil neben dem Button aufgerufen werden.
    • Allgemein
      Einstellungen ab wieviel 'Markierungen gleichzeitig' eine Warnung erfolgt oder ob und wie oft eine Paketlistenaktualisierung stattfinden soll, mit anschließender DSM-Benachrichtigung, kann hier konfiguriert werden. Im Feld "Paketquellen Datei/Pfad" wird der Pfad zu der Datei oder des Verzeichnisses mit mehreren Paketquellendateien angegeben (erkennt iPKGui automatisch). Für gewöhnlich ist dieser Pfad schon korrekt, kann aber bei Bedarf angepasst werden. Da sich iPKG und oPKG nur in dem 1. Buchstaben unterscheiden, sollte dies auch für oPKG zutreffen (Vorraussetzung: es wurde mit den Angaben "./configure --prefix=/opt --with-opkglibdir=/opt/lib --with-opkgetcdir=/opt/etc" vor dem Compilieren auf /opt eingestellt).
    • Farben
      wie der Name schon verrät, können hiermit die Farben der Listen individuell eingestellt werden. Mit dem Button "OK" oder "Sichern" werden die eingestellten Farben gesichert - bei ersterem wird das Formular allerdings verlassen. Mit 'Default' kehrt man zur Werkseinstellung zurück.
    • Paketquellen
      Paketquellen können hier angelegt, editiert, aktiviert/deaktiviert und gelöscht werden. Möchte man in einer vorhandenen Paketquellendatei eine weitere Paketquelle hinzufügen, dann wählt man in der Spalte "Datei" den schon vorhandenen Dateinamen (inkl. Endung) aus und wählt den Button "Sichern". Der verwendete Paketmanager wird, neben der Anzahl von Paketquellen, in der Toolbarleiste der Paketquellentabelle angezeigt.
  • Über iPKGui
    Informationen über iPKGui, Lizenz, Copyright etc.
Kontextmenü
Das Kontextmenü ist für die Auswahl der gewünschten Aktion zuständig.

  • Abwählen
    wählt das markierte Paket ab und stellt den ursprünglichen Status wieder her
  • Alle abwählen
    wählt alle markierten Pakete ab und stellt den ursprünglichen Status wieder her
  • Markiere für Installation
    wählt das markierte Paket für die Installation
    • Erzwinge Optionen
      • Erzwinge Überschreiben (-force-overwrite)
        Überschreibe gleiche Dateien von anderen Paketen
      • Ignoriere Abhängigkeiten (-nodeps)
        fehlende Abhängigkeiten nicht markieren/installieren
      • Erzwinge Überschreiben, Ignoriere Abhängigkeiten (-force-overwrite -nodeps)
        Beide Optionen gleichzeitig
  • Markiere für Neuinstallation
    wählt das markierte Paket für die Neuinstallation
    • Erzwinge Optionen
      • Erzwinge Überschreiben (-force-overwrite)
        Überschreibe gleiche Dateien von anderen Paketen
      • Ignoriere Abhängigkeiten (-nodeps)
        fehlende Abhängigkeiten nicht markieren/installieren
      • Erzwinge Überschreiben, Ignoriere Abhängigkeiten (-force-overwrite -nodeps)
        Beide Optionen gleichzeitig
  • Markiere für Aktualisierung
    wählt das markierte Paket für die Aktualisierung
    • Erzwinge Optionen
      • Erzwinge Überschreiben (-force-overwrite)
        Überschreibe gleiche Dateien von anderen Paketen
      • Ignoriere Abhängigkeiten (-nodeps)
        fehlende Abhängigkeiten nicht markieren/installieren
      • Erzwinge Überschreiben, Ignoriere Abhängigkeiten (-force-overwrite -nodeps)
        Beide Optionen gleichzeitig
  • Markiere für Entfernung
    wählt das markierte Paket für die Entfernung
    • Erzwinge Optionen
      • Ignoriere Abhängigkeitsfehler (-force-depends)
        Mit dieser Option lassen sich Pakete entfernen, welche eine Abhängigkeit für andere Pakete darstellen und bei denen eine normale Entfernung Fehler verursachen würde
      • Erzwinge Rekursiv (-force-removal-of-dependent-packages)
        Diese Option entfernt dieses Paket und alle Pakete, welche eine Abhängigkeit zu diesem Paket besitzen !Vorsicht!
  • Externe Installation
    Diese Funktion dient dazu, um selbst compilierte Pakete in die Struktur und somit als Abhängigkeit in iPKG/oPKG zu integrieren. So markierte Pakete können weder aktualisiert noch entfernt werden. Durch nochmaliges Anwählen der Funktion wird dies rückgängig gemacht.
  • Halte Version
    markiert das Paket damit die aktuelle Version gehalten wird, zu erkennen an einem Haken. Durch nochmaliges Anwählen wird "Halte Version" wieder aufgehoben. Gehaltene Pakete werden bei einer Aktualisierung ignoriert, jedoch kann das Paket neuinstalliert oder entfernt werden. Da unsere iPKG/oPKG-Feeds nur immer eine Version zur gleichen Zeit bereitstellen, wird eine Neuinstallation höchstwahrscheinlich eine neue Version installieren. (nicht getestet)
  • Eigenschaften
    zeigt erweiterte Eigenschaften des Paketes, wie z.B. Link zum Paket, abhängige Pakete und installierte Dateien
 
Zuletzt bearbeitet:

tAntChen

Benutzer
Mitglied seit
12. September 2011
Beiträge
67
Punkte für Reaktionen
0
Punkte
6
Hi OTip,


ich hab mir die App gerade installiert und bisschen damit rum gespielt, gefällt mir wirklich sehr gut. Die usability finde ich besonder klasse da hast du dich an den Synaptic wirklich gut angenähert. Das inspiriert mich auch gleich an meiner App weiter zu arbeiten. Vor allem würde ich gern auch mal mit ExtJs arbeiten, damit habe bis jetzt leider noch nie was gemacht.

naja jedenfalls TOP gemacht!!
 

QTip

Super-Moderator
Teammitglied
Mitglied seit
04. September 2008
Beiträge
2.323
Punkte für Reaktionen
1
Punkte
84
Website
www.smallco.de
Hi,

danke für die Blumen, war auch eine lange Zeit bis zur aktuellen Version. Es wird noch kräftig daran weitergearbeitet, das nächste Update kommt die Tage.

ExtJS ist ja nichts anderes als eine erweitertes Javascript. Ich habe mir das selber durch Suchmaschineneinträge und Tutorials angeeignet; hatte mit Javascript in der Vergangenheit eher wenig zu tun. Vorkenntnisse in anderen Sprachen wie HTML und PHP machen es um einiges leichter.

Falls du mal Hilfe bei einer Aufgabe brauchst, kannst ruhig mal anklopfen.
 

QTip

Super-Moderator
Teammitglied
Mitglied seit
04. September 2008
Beiträge
2.323
Punkte für Reaktionen
1
Punkte
84
Website
www.smallco.de
iPKGui 0.6-102 beta

20.05.2013 - iPKGui 0.6-102 beta
  • Unterstützung für oPKG
    am besten /opt als Präfix benutzen, dann ./configure -prefix=/opt -with-opkglibdir=/opt/lib -with-opkgetcdir=/opt/etc und compilieren
  • Einstellungen wie Listenfarben, automatische Paketlistenaktualisierung, Paketquellenverwaltung
  • Lesen der Paketlisten weiter optimiert
  • Unterstützung für mehrere Paketquellen und mehreren Paketquellen in einer Datei
  • 'gehalten' wurde in 'gesperrt' umbenannt
  • diverse kleine Bugfixes
 
Zuletzt bearbeitet:

haweK

Benutzer
Mitglied seit
01. Dezember 2012
Beiträge
35
Punkte für Reaktionen
1
Punkte
8
Danke für das Tool. Eine Frage noch. Warum ist es auf der 213+ in deutsch und auf der 213 in english?

Gruß
hawe
 

QTip

Super-Moderator
Teammitglied
Mitglied seit
04. September 2008
Beiträge
2.323
Punkte für Reaktionen
1
Punkte
84
Website
www.smallco.de
Poste mir mal was du auf beiden Diskstations unter "Systemsteuerung - Regionale Optionen - Sprache - Anzeigesprache" und Taskleitenmenü rechts oben unter "Optionen - Anzeigesprache" eingestellt hast.
 

haweK

Benutzer
Mitglied seit
01. Dezember 2012
Beiträge
35
Punkte für Reaktionen
1
Punkte
8
Ok, da ist was anders.
213+ -> Konto/Anzeigesprache/Deutsch, 213 -> Konto/Anzeigesprache/Systemvoreinstellung.

Bei beiden habe ich in Systemsteuerung/Regionale Optionen folgendes eingestellt:

Sprache/Anzeigesparche -> Browser Standardeinstellung
Sprache/Benachrichtigungssprache -> Deutsch
Sprache/Codepage -> Deutsch

Gruß
hawe
 

QTip

Super-Moderator
Teammitglied
Mitglied seit
04. September 2008
Beiträge
2.323
Punkte für Reaktionen
1
Punkte
84
Website
www.smallco.de
"Systemvoreinstellung" wird nicht ausgewertet, das wäre die Browser/Betriebssystemeinstellung. Wenn "Systemvoreinstellung" eingestellt ist, dann habe ich es international belassen, also englisch. Die Spracheinstellung in den persönlichen Benutzereinstellungen (Taskleiste oben rechts) haben eine höhere Priorität als die globalen des DSM.
 

DKeppi

Benutzer
Mitglied seit
01. April 2011
Beiträge
3.034
Punkte für Reaktionen
10
Punkte
104
Top Package...funktioniert einwandfrei!
Danke QTip :)
 

DSL-Hexe

Super-Moderator
Teammitglied
Mitglied seit
01. April 2008
Beiträge
652
Punkte für Reaktionen
1
Punkte
44
Was muss ich noch vorher installieren? Ich habe perl installiert und er sagt immer ich soll perl installieren
 

QTip

Super-Moderator
Teammitglied
Mitglied seit
04. September 2008
Beiträge
2.323
Punkte für Reaktionen
1
Punkte
84
Website
www.smallco.de
Das Perl Paket von Synology aus dem Paketzentrum, nicht das IPKG Perl.
 

QTip

Super-Moderator
Teammitglied
Mitglied seit
04. September 2008
Beiträge
2.323
Punkte für Reaktionen
1
Punkte
84
Website
www.smallco.de
iPKGui 0.7-129 beta

08.06.2013 - iPKGui 0.7-129 beta


  • Abhängigkeitenüberprüfung auch bei Neuinstallation, Aktualisierung und Entfernung
  • Abhängigkeitenüberprüfung nach Start auf "Defekte Pakete"
  • neuer Status 'Defekt' und 'fehlende Abhängigkeit'
  • neuer Status 'Externe Installation'
  • force-Optionen verfügbar
  • temporäre Filter History
  • Logdateiansicht
  • Farben der Meldungen in der Statusleiste werden nun von der Farbeinstellung übernommen
  • kleinere Design-Fehler behoben
  • falschen Pfad zum Cron-Skript korrigiert
  • fehlende Kommatas in den Paketquellenlisten werden nun automatisch korrigiert
 

Tommi2day

Benutzer
Mitglied seit
24. August 2011
Beiträge
975
Punkte für Reaktionen
7
Punkte
38
Prima Tool.

Ich habe aber gerade das Problem, das ich eine weitere Packetquelle in /opt/etc/ipkg habe, diese mir aber unter package-sources nicht angezeigt wird. Einige Packages aus dieser Quelle werden auch als "broken" markiert. Welche Regel gilt für "Broken?

Wenn ich versuche die Quelle nachzutragen, wird sie nicht gespeichert. Fehlt mir noch was wichtiges?

ipkgui_broken.jpg
 
Zuletzt bearbeitet:

Tommi2day

Benutzer
Mitglied seit
24. August 2011
Beiträge
975
Punkte für Reaktionen
7
Punkte
38
Noch eine Kleinigkeit:

Die Auswertung der Versionsnummer scheint noch nicht ganz korrekt zu sein. Ich würde eine niedrigere Version nicht als "upgradeable" kennzeichnen
ipkgui_upgradable.jpg

Thomas
 

QTip

Super-Moderator
Teammitglied
Mitglied seit
04. September 2008
Beiträge
2.323
Punkte für Reaktionen
1
Punkte
84
Website
www.smallco.de
Prima Tool.

Ich habe aber gerade das Problem, das ich eine weitere Packetquelle in /opt/etc/ipkg habe, diese mir aber unter package-sources nicht angezeigt wird. Einige Packages aus dieser Quelle werden auch als "broken" markiert. Welche Regel gilt für "Broken?

Wenn ich versuche die Quelle nachzutragen, wird sie nicht gespeichert. Fehlt mir noch was wichtiges?
Hast du eine Datei /opt/etc/ipkg oder ist das ein Verzeichnis in diesem die Datei mit den Paketquellen liegt? Kannst du mir den Inhalt deiner Paketquellendatei mal zeigen?

Welche Regel gilt für "Broken?
Die Pakete mit dem "Blitz" im Statusicon können nicht richtig funktionieren, sind also "broken", da mysql5 nicht vorhanden ist "Missing dependency". Liegt evtl. an der fehlenden Paketquelle, mach mal noch nichts Weiteres, bis ich das analysiert habe.

Noch eine Kleinigkeit:

Die Auswertung der Versionsnummer scheint noch nicht ganz korrekt zu sein. Ich würde eine niedrigere Version nicht als "upgradeable" kennzeichnen
Ja, sehe ich genauso, die Prüfung erfolgt nur auf "ungleich" nicht auf höher...wird gefixed.
Wie hast du denn aus der Paketquelle eine neue Datei installieren können, als in der Paketquelle vorhanden ist? Kann ja nur aus einer 2. Quelle sein, die die gleiche Datei in neuerer Version bereitstellt.
 

Tommi2day

Benutzer
Mitglied seit
24. August 2011
Beiträge
975
Punkte für Reaktionen
7
Punkte
38
Hast du eine Datei /opt/etc/ipkg oder ist das ein Verzeichnis in diesem die Datei mit den Paketquellen liegt? Kannst du mir den Inhalt deiner Paketquellendatei mal zeigen?
DS1812> ls -l /opt/etc/ipkg
total 8
-rw-r--r-- 1 root root 80 Jul 21 2012 cross-feed.conf
-rw-r--r-- 1 root root 51 May 25 18:16 tdressler.conf

tdressler.conf:
src/gz tdressler http://ds1812/repo/ipkg/syno-i686

Extern ist das:
http://repo.tdressler.net/ipkg/<arch>

Die Pakete mit dem "Blitz" im Statusicon können nicht richtig funktionieren, sind also "broken", da mysql5 nicht vorhanden ist "Missing dependency". Liegt evtl. an der fehlenden Paketquelle, mach mal noch nichts Weiteres, bis ich das analysiert habe.
Die Packete habe ich selbst gebaut und mysql5 darin nur als "suggests" definiert, da mysql auf der syno ja schon im DSM enthalten ist.

Wie hast du denn aus der Paketquelle eine neue Datei installieren können, als in der Paketquelle vorhanden ist? Kann ja nur aus einer 2. Quelle sein, die die gleiche Datei in neuerer Version bereitstellt.
über die Gui habe ich noch kein Packet installiert. Die genannten neueren Pakete sind aus dem nicht angezeigtem eigenen Repository und wurden mit ipkg ganz normal auf der Kommandozeile installiert.

Thomas
 

QTip

Super-Moderator
Teammitglied
Mitglied seit
04. September 2008
Beiträge
2.323
Punkte für Reaktionen
1
Punkte
84
Website
www.smallco.de
DS1812>Die Packete habe ich selbst gebaut und mysql5 darin nur als "suggests" definiert, da mysql auf der syno ja schon im DSM enthalten ist.
"suggests" (Vorschlag) dürfte aber nicht helfen, bist du sicher das du nicht "depends" (abhängig von) meinst?
Für selbst compilierte Pakete gibt es das Flag "Externe Installation", eine Art virtuelles Paket. Die Pakete werden dadurch automatisch in die Status Datei aufgenommen, um die Abhängigkeitsprüfungen zu bestehen.
Rechtsklick auf "mysql5" und Auswahl von "Externe Installation" sollte dies fixen.

Wegen dem Repository schau ich mal, wieso das nicht funktionieren soll.
 
  AdBlocker gefunden!

Du bist nicht hier, um Support für Adblocker zu erhalten, denn dein Adblocker funktioniert bereits ;-)

Klar machen Adblocker einen guten Job, aber sie blockieren auch nützliche Funktionen.

Das Forum wird mit einem hohen technischen, zeitlichen und finanziellen Aufwand kostenfrei zur Verfügung gestellt. Wir zeigen keine offensive oder Themen fremde Werbung. Bitte unterstütze dieses Forum, in dem du deinen Adblocker für diese Seite deaktivierst.