[HOW TO] Sane-Backend auf DS einrichten

sowosamma

Benutzer
Mitglied seit
16. Juni 2009
Beiträge
565
Punkte für Reaktionen
0
Punkte
42
Hallo,

nachdem ich es geschafft habe, sane auf meiner Diskstation zum Laufen zu bringen, möchte ich gerne ein kleines HowTo ins Forum stellen, da dieses Thema schon öfters begonnen aber leider erfolglos abgeschlossen wurde.

Was will ich?
Da ich zwei PCs und einen Laptop habe, wollte ich meinen Multifunktionsdrucker Canon Pixma MP610 irgendwie über's Netzwerk nutzen. Leider unterstützt die Diskstation standardmäßig nur die Druckfunktion. Aber ich will auch scannen...

Und so geht's
Erstmal müssen folgende ipkg-Pakete installiert werden:
  • xinetd
  • libusb
  • libieee1284
  • sane-backends

Loggt euch also zuerst als root über SSH auf eurer Diskstation ein
Rich (BBCode):
DS109plus> ipkg install xinetd
DS109plus> ipkg install libusb
DS109plus> ipkg install libieee1284
DS109plus> ipkg install sane-backends

Irgendwie funktioniert der ipkg-libusb aber nicht richtig. Deswegen habe ich den syno-libusb kopiert.
Rich (BBCode):
DS109plus> cp /lib/libusb-0.1.so.4 /opt/lib/libusb-0.1.so.4
Quelle

Nun muss man in die /opt/etc/sane.d/saned.conf den IP-Bereich eintragen:
192.168.0.0/24 #Kompletter Zugriff aus 192.168.0.X

Und dann die /opt/etc/xinetd.d/saned wie folgt editieren
Rich (BBCode):
service saned
{
socket_type = stream
server = /opt/sbin/saned
protocol = tcp
user = root
group = root
wait = no
disable = no
}
Quelle

Jetzt sollte man die Diskstation rebooten. Dann geht es mit den ersten Scans los.

Rich (BBCode):
DS109plus> sane-find-scanner

  # sane-find-scanner will now attempt to detect your scanner. If the
  # result is different from what you expected, first make sure your
  # scanner is powered up and properly connected to your computer.

  # No SCSI scanners found. If you expected something different, make sure that
  # you have loaded a kernel SCSI driver for your SCSI adapter.

found USB scanner (vendor=0x04a9 [Canon], product=0x1725 [MP610 series]) at libusb:001:002
  # Your USB scanner was (probably) detected. It may or may not be supported by
  # SANE. Try scanimage -L and read the backend's manpage.

  # Not checking for parallel port scanners.

  # Most Scanners connected to the parallel port or other proprietary ports
  # can't be detected by this program.

DS109plus> scanimage -L
device `pixma:04A91725_46DF7D' is a CANON Canon PIXMA MP610 multi-function peripheral

DS109plus> scanimage --format tiff > /volume1/public/testscan.tiff

Und siehe da. Der Scanner brummt und im public liegt ein Scan :D

Da aber die Bedienung über die Konsole nict unbedingt komfortabel ist, habe ich mir Xsane installiert. Dort muss in der C:\sane\etc\sane.d\net.conf die IP Eurer Diskstation eingetragen werden. Anschließend kann xsane.exe gestartet werden.

So ich wünsche allen viel Spaß beim Scannen...
/Andi

PS: Ich würde dieses HowTo auch gerne ins wiki stellen. Aber ich habe keinen Plan wie ich eine neue Seite im wiki anlege und im Menü einen Link hierzu erstelle. Hilfe ;)
 

EPIX

Benutzer
Mitglied seit
21. September 2008
Beiträge
219
Punkte für Reaktionen
0
Punkte
16
Super!!

Hat Jemand schon erfahrung mit anderen Multidideldummdruckscannern?
zB den HP 5510?
 

sowosamma

Benutzer
Mitglied seit
16. Juni 2009
Beiträge
565
Punkte für Reaktionen
0
Punkte
42
was ich so während des Suchens im Internet über hp gelesen hab, war dass Du einen extra Treiber brauchst.

Schau Dir das mal an. Hab leider nur keine Ahnung ob das nur auf normalen Linux geht oder ob das auch auf dem DS-Linux funktioniert.

Nachtrag: Ich hoffe Du kannst Englisch. Scheint aber deutlich mehr Arbeit zu sein als mit meinem Canon.

/Andi
 

EPIX

Benutzer
Mitglied seit
21. September 2008
Beiträge
219
Punkte für Reaktionen
0
Punkte
16
Nach dieser Anleitung habe ich schon einmal 30 Stunden herumgemurkst es es dann zornig in die Ecke geschmissen....

Ich dachte nur, wenn es User gibt, die es bereits mit anderen Modellen als den Canon geschafft haben, dann wäre eine "Scanner-Liste" der betreffenden Modelle ganz praktisch...
 

DerZock

Benutzer
Mitglied seit
25. Dezember 2009
Beiträge
99
Punkte für Reaktionen
0
Punkte
12
Ich habe mich auch mal an dieser Anleitung versucht. Und zwar verwende ich einen Epson SX405 Multifunktionsdrucker.
Der Scanner wird auch gefunden. Nur wenn ich den Testscan mit scanimage --format tiff > /volume1/public/testscan.tiff durchführe, bekomme ich nach einer Weile eine Fehlermeldung:
Rich (BBCode):
scanimage: sane_read: Error during device I/O
Der Scanner brummt aber kurz und ein tiff wird auch unter public abgelegt, allerdings sind nur ein paar Streifen auf dem tiff zu sehen.
Der Scanner an sich hängt dabei irgendwie und ich muss ihn aus und wieder ein schalten.
Hat jemand vielleicht ne Idee wie ich den Scanner doch noch zum Laufen kriege? :confused:
 

-K!nickel-

Benutzer
Mitglied seit
03. April 2011
Beiträge
17
Punkte für Reaktionen
0
Punkte
0
Zuletzt bearbeitet:

shortyx

Benutzer
Mitglied seit
12. April 2011
Beiträge
4
Punkte für Reaktionen
0
Punkte
0
Hi,

ich bin auch ein Scanner-unter-Linux geplagter..

@ -K!nickel: Du hast dort in deinem Post auf einen Link verwiesen. Funktioniert soweit auch alles ganz gut. Zu meiner Frage: Der Canon N650U wird ja als plustek:libusb:001:003 erkannt. Welche Firmware hast du genommen?

Bei "scanimage --format tiff > /volume1/public/testscan.tiff" läuft der Scanner ca. 1/3 vom Bett ab, und fährt dann wieder zurück. Die Datei, die da raus kommen soll, ist nicht lesbar :(

Irgendeine Idee?

Danke :)
 

-K!nickel-

Benutzer
Mitglied seit
03. April 2011
Beiträge
17
Punkte für Reaktionen
0
Punkte
0
@shortyx:

Habe gar keine extra Firmware draufgespielt, alles so gelassen wie es war, als plustek wird er erkannt und ist ja auch gut soweit. Hab auch nichtmit scanimage weiter rumprobiert, sondern nur scanimage -T um zu sehen ob er erkannt wird. Danach mit sanetwain weiter probiert und lief ohne besondere Firmware aufspielen. Hab es nun auch mit dem Frontend von XSane probiert, was ja wesentlich angenehmer zu bedienen ist.
 

shortyx

Benutzer
Mitglied seit
12. April 2011
Beiträge
4
Punkte für Reaktionen
0
Punkte
0
Hi,

Danke für deinen Input K!Nickel :)

Habe mir inzwischen auch XSane für Windows besorgt:

XSane for Windows

und hier noch ne gute Anleitung gefunden, wie man das Sane-Backend unter Linux und XSane unter Windows konfiguriert.

Konfigurationsanleitung

- Works like a charm -

Muss noch ein bisschen mit den Kontrast/Helligkeitseinstellungen rumspielen, aber prinzipell kann ich nun scannen :)

Gotta Love DS211 - Screw Windows 7
 

herbst

Benutzer
Mitglied seit
29. Dezember 2011
Beiträge
9
Punkte für Reaktionen
0
Punkte
0
Hallo,

vielen Dank für das Tutorial, aber für mich als dummer n00b immer noch zu "hoch" ^^

Nun muss man in die /opt/etc/sane.d/saned.conf den IP-Bereich eintragen:

Wie komme ich in diese Ordner um die Dateien zu editieren? Mir wird nichts angezeigt wenn ich normal über das Netzwerk auf die Box gehe.


Vielen Dank im Voraus!
 

Stabmaster

Benutzer
Mitglied seit
04. September 2011
Beiträge
169
Punkte für Reaktionen
0
Punkte
0
Dafür muss du dich bspw. mittels SSH auf deiner Diskstation anmelden. Zuvor muss du aber die Option aktivieren.
Systemsteuerung -> Terminal -> SSH-Dienst aktivieren

Danach kannst du mittels Putty (such bei google den Download) via IP auf deine Diskstation anmelden. Login-Name ist "root" und Kennwort das des Admins.
 

herbst

Benutzer
Mitglied seit
29. Dezember 2011
Beiträge
9
Punkte für Reaktionen
0
Punkte
0
Danke für die schnelle Antwort,

soweit war ich bereits, das problem ist nur das wenn ich es jetzt so eingebe kommt folgendes:

Homeserver> /opt/etc/sane.d/saned.conf
-ash: /opt/etc/sane.d/saned.conf: Permission denied
 

-K!nickel-

Benutzer
Mitglied seit
03. April 2011
Beiträge
17
Punkte für Reaktionen
0
Punkte
0
du musst die Datei mit einem Editor öffnen, also zum Beispiel mit vi oder nano (ich empfehle nano, ist für Anfänger leichter, kann per ipkg nachinstalliert werden)

also der Befehl "nano /opt/etc/sane.d/saned.conf"
 

herbst

Benutzer
Mitglied seit
29. Dezember 2011
Beiträge
9
Punkte für Reaktionen
0
Punkte
0
Ich muss mich herzlich bedanken. Es hat alles einwandfrei funktioniert. Tolles Forum!

Edit:

Hoffe der Edit wird angezeigt, will nicht doppelposten. Das einzige problem was ich noch habe, ist dass Xsane angibt, dass keine Geräte gefunden werden. IP des DS hab ich angegeben in der net.conf
 
Zuletzt bearbeitet:

herbst

Benutzer
Mitglied seit
29. Dezember 2011
Beiträge
9
Punkte für Reaktionen
0
Punkte
0
Sorry für Doppelpost, aber der Betreig wurde nicht mehr als neu markiert.

Das einzige Problem was ich noch habe, ist dass Xsane angibt, dass keine Geräte gefunden werden. IP des DS hab ich angegeben in der net.conf
 

Shibou

Benutzer
Mitglied seit
07. Juli 2012
Beiträge
3
Punkte für Reaktionen
0
Punkte
0
Hallo Leute,

vielen Dank für die ausführliche Anleitung.
Leider stoße ich beim Versuche meinen Canon MP640 über Sane auch als Scanner nutzen zu können immer wieder auf Probleme.
Ich nutze eine DS411 mit DSM 4.0-2219.
Ich habe SSH Terminal aktiviert und kann mittels putty auch als root darauf zugreifen, aber dann hört es auch schon auf.
Beim Versuch die benötigten Pakete zu installieren funktioniert leider überhaupt nichts mehr:

DiskStation> ipkg install xinetd
-sh: ipkg: not found

Kann mir eventuell jemand sagen woran das liegen könnte?

Vielen Dank schonmal.
 

borg2k

Benutzer
Mitglied seit
08. Mai 2012
Beiträge
1.789
Punkte für Reaktionen
0
Punkte
0
du musst natürlich ipkg selber erstmal installieren.

Beitrag dazu gibts hier im Wiki.




Leider unterstützt Sane meinen Canon 3200F Scanner nicht, daher musste ich mir ein XP in eine VM installieren um diesen unter W7 x64 wieder nutzbar zu machen.
 

Shibou

Benutzer
Mitglied seit
07. Juli 2012
Beiträge
3
Punkte für Reaktionen
0
Punkte
0
Vielen Dank für die schnelle Antwort, ich habe es im Wiki gefunden.
 

Shibou

Benutzer
Mitglied seit
07. Juli 2012
Beiträge
3
Punkte für Reaktionen
0
Punkte
0
Hallo nochmal,

ich habe nach ein paar Stunden ipkg und saned vollständig nach der anleitung im wiki installieren können.
das scannen von bildern über terminal klappt ebenfalls, allerdings ahbe ich es weder mit xsane noch mit sanetwain geschafft bequem von windows aus zu scannen.
in beiden fällen kann kein gerät gefunden werden obwohl ich die IP der DiskStation eingegeben habe.

Hat noch jemand eine Idee woran es liegen könnte?
 

borg2k

Benutzer
Mitglied seit
08. Mai 2012
Beiträge
1.789
Punkte für Reaktionen
0
Punkte
0
evtl. den Port für Sane auf der DS Firewall nicht freigegeben?
 
  AdBlocker gefunden!

Du bist nicht hier, um Support für Adblocker zu erhalten, denn dein Adblocker funktioniert bereits ;-)

Klar machen Adblocker einen guten Job, aber sie blockieren auch nützliche Funktionen.

Das Forum wird mit einem hohen technischen, zeitlichen und finanziellen Aufwand kostenfrei zur Verfügung gestellt. Wir zeigen keine offensive oder Themen fremde Werbung. Bitte unterstütze dieses Forum, in dem du deinen Adblocker für diese Seite deaktivierst.