Erinnerungen mit caldav funktionieren auf dem iPhone nicht

Ghost108

Benutzer
Mitglied seit
27. Jun 2015
Beiträge
648
Punkte für Reaktionen
16
Punkte
38
Hi !

Ich habe Es ist Synology Calendar installiert.
Diesen calDAV binde ich am Macbook und am iPhone ein.

Am Macbook gibt es hier keine Probleme.
Ich sehe in der macOS "Erinnerungen-App" den neuen Bereich "Synology" mit der Kategorie "Inbox".
Hier habe ich eine Erinnerung "Test" angelegt:



1638967444859.png

Dieser Eintrag wird auch synchronisiert und ist über die Synology Calendar Webmaske zu sehen:

1638967444898.png



In die andere Richtung klappt es auch. Trage ich eine neue Erinnerung über die Synology Calendar Webmaske ein, wird diese am Macbook angezeigt. Bis hierhin alles super !


Nun zum iPhone.
Auch hier kann ich den calDAV Server einbinden, hier erkennt man aber schon ganz klar, das die Kategorie "Inbox" nicht angezeigt wird.
Lediglich der neue Bereich "Synology".


1638967444948.png



Dementsprechend sehe ich den o.g. "Test" Eintrag nicht und kann auch hierüber keine neuen Einträge im Bereich Synology machen, da mit "Inbox" fehlt.


Eckdaten:
Synology DS718+ (DSM 7.0.1-42218)
macbook Air 2020 (macOS Monterey 12.0.1)


Hatte dazu auch schon ein Ticket bei Synology aufgemacht.

Antwort:
An dieser Stelle kann ich Ihnen von unserer Seite nicht behilflich sein.
Dies ist ein Client Problem seitens Apple. Ob Apple das Verhalten schon beheben konnten, kann ich Ihnen
von unserer Seite aus leider nicht sagen.Ich bitte Sie, sich einmal mit dem Apple Support in Verbindung zu setze

Das Problem besteht aber schon bestimmt seit einem halben Jahr.
Hat jemand die selbe Situation und kann das bestätigen ?
 

Ghost108

Benutzer
Mitglied seit
27. Jun 2015
Beiträge
648
Punkte für Reaktionen
16
Punkte
38
und wie ich lese auch kein Lösung seitens Apple bislang.
Das Problem besteht ja bereits seit iOS 13 - heute schon iOS 15
 

Ghost108

Benutzer
Mitglied seit
27. Jun 2015
Beiträge
648
Punkte für Reaktionen
16
Punkte
38
Nun ... ich bin ein Schritt weitergekommen.
Meine Syno ist EIGENTLICH nur via VPN erreichbar.
Bedeutet: Ich habe meinen caldav Server am iPhone via IP der Syno eingebunden.

Kalender funktioniert auch, bis auf die o.g. "Erinnerungen".
Neuer Anlauf meinerseits:

- DDNS eingerichtet
- HTTPS Port für Synology Kalender unter Systemsteuerung > Anmeldeportal gesetzt
- Port in der Fritzbox geöffnet

caldav Server am iPhone via DDNS eingerichtet, statt mit Syno IP.
Siehe da: Erinnerungen am iPhone funktionieren.

So möchte ich es natürlich nicht lassen, denn dafür habe ich keine VPN Verbindung, damit ich die Ports öffnen muss (bzw. das jeder von extern drauf kommt)

Habe gelesen, dass das Problem darin liegt, dass das iPhone eine SSL Verbindung erwartet, mit einem Zertifikat, welches auch mit dem Namen im Zertifikat übereinstimmt. Das ist beim Einsatz des DDNS Namen der Fall, aber natürlich nicht beim Einsatz der IP.

Nun die Frage: Kann ich das Problem lösen, in dem ich ein Zertifikat erstelle, welches für die IP gilt?
Wenn ja, wie?

Oder hat jemand eine Idee, wie ich das Problem noch lösen könnte?
Danke !!
 
Zuletzt bearbeitet:

Ghost108

Benutzer
Mitglied seit
27. Jun 2015
Beiträge
648
Punkte für Reaktionen
16
Punkte
38
Dafür klappt es jetzt unter macOS nicht mehr. könnte ausrasten ! 😅
 

Ghost108

Benutzer
Mitglied seit
27. Jun 2015
Beiträge
648
Punkte für Reaktionen
16
Punkte
38
Guten Morgen und ein frohes neues Jahr ! :)
Möchte das Thema noch mal pushen.

Kurze Zusammenfassung:
Meine Syno ist via VPN erreichbar.
Als Adresse verwende ich hier eine Strato Domain als DDNS.
Diese Domain ist via Synology mit einem LE Zertifikat versehen und wird vom Browser auch ohne "Wenn und Aber" akzeptiert.
Keine Aktion notwendig, wo der User "Trotzdem öffnen" beim Aufruf der Synology anklicken muss, wenn es eine Umstimmigkeit im Zertifikat gibt.

Bildschirmfoto 2022-01-03 um 09.34.19.png

Das hat mein iPhone so glücklich gemacht, dass nun die Erinnerungen wieder funktionieren.
Aber macbook leider nicht mehr. Hier sieht es leider so aus:

Bildschirmfoto 2022-01-03 um 09.37.48.png

Obwohl die Option Kalender und Erinnerung aktiviert sind.
(Kalender funktioniert tadellos)

Bildschirmfoto 2022-01-03 um 09.38.39.png


Hat noch jemand eine Idee ??
 

Ghost108

Benutzer
Mitglied seit
27. Jun 2015
Beiträge
648
Punkte für Reaktionen
16
Punkte
38
Guten Morgen zusammen,

würde dieses Thema gerne wieder in Erinnerung rufen,
nachdem ich ein Ticket bei Synology aufgemacht habe (im Januar) und bis heute sich keiner lösungsorientier darum gekümmert hat (bin stinksauer), erwarte ich vom Support nichts mehr.

Aber ich hoffe nach wie vor sehr, das ich hier jemanden finde, der helfen kann.
Ich kann mir nicht vorstellen, das ich der einzige mit diesem Problem bin.

Für mich wäre interessant zu wissen, ob jemand dieses Problem nachstellen kann.
Im besten Fall eine Lösung dafür hat.

Noch mal kurzes Update:
  • DS718+ mit aktueller DMS 7 Version
  • Keine Ports geöffnet am Router
  • Syno Firewall testweise abgeschaltet
  • SSL Zertifikat von LE
  • DDNS
  • Zugriff auf NAS nur via VPN möglich (Quickconnect deaktiviert)

Am iPhone funktionieren die Erinnerungen, unter macOS wird mir nichts angezeigt (leer).
 

EDvonSchleck

Benutzer
Mitglied seit
06. Mrz 2018
Beiträge
978
Punkte für Reaktionen
197
Punkte
69
gleiches Thema hatten wir gestern schon einmal - ich erspare mir jetzt aber das doppelte aufschreiben. Es handelt sich zwar um eine andere App, jedoch mit dem gleichen Problem bzw. Problematik. Auch würde ich dir Als Kontakte/Kalender-Server dir Baikal ans Herz legen.
 

Ghost108

Benutzer
Mitglied seit
27. Jun 2015
Beiträge
648
Punkte für Reaktionen
16
Punkte
38
danke für den Hinweis.
Möchte aber sehr gerne bei den Boardmitteln bleiben.

Was heißt das jetzt für mich?
Pi Hole als DNS Server habe ich auch im Einsatz.

Gibt es eine Lösung für mein Problem??
 

EDvonSchleck

Benutzer
Mitglied seit
06. Mrz 2018
Beiträge
978
Punkte für Reaktionen
197
Punkte
69
steht doch alles in den Beitrag, Wiesel6 schrieb auch was dazu! Du musst einen Router haben der die Auflösung unterstützt oder Software dafür einsetzen. Alternativ damit leben und die Sachen über einen anderen Anbieter oder Apple laufen lassen, das sollte ja 100% funktionieren.
 

Ghost108

Benutzer
Mitglied seit
27. Jun 2015
Beiträge
648
Punkte für Reaktionen
16
Punkte
38
Verstehe aber den Inhalt nicht wirklich.
Was genau soll denn das Problem sein, warum das bei mir nicht klappt?
Nutze den VPN Server von Syno (nicht von der Fritzbox)
 

EDvonSchleck

Benutzer
Mitglied seit
06. Mrz 2018
Beiträge
978
Punkte für Reaktionen
197
Punkte
69
Du hast ein Zertifikat ausgestellt auf eine URL
Dieses Zertifikat greift NUR wenn du über diese URL kommst.
Wenn du also jetzt intern ohne diese URL dich verbindest, greift das Zertifikat nicht, macht ja Sinn.
Du muss also dein System so "umbiegen" das es denkt es kommt über diese URL.

Das können bestimmte Router (Fritzbox nicht) und eben Software wie schon aufgeführt. Die Fritzbox verhindert die DNS abfrage im internen Netz, sofern DNS-Rebind nicht hinterlegt ist.
 

Ghost108

Benutzer
Mitglied seit
27. Jun 2015
Beiträge
648
Punkte für Reaktionen
16
Punkte
38
das trifft aber nicht auf meien Situatuon zu (glaube ich).
Ich habe eine domain: test.domain.de
Für diese habe ich ein LE Zertifikat.

Pinge ich die Domain an, so wird die öffentliche IP meiner FB aufgelöst.
Und im Pi Hole habe ich die domain so umgebogen, das wenn ich intern / oder eben via VPN die domain anpinge, die IP meiner NAS aufgelöst wird.

Heißt: Ich baue IMMER via Domain test.domain.de eine Verbindung auf, nicht via IP
 

EDvonSchleck

Benutzer
Mitglied seit
06. Mrz 2018
Beiträge
978
Punkte für Reaktionen
197
Punkte
69
Du kommst aber nicht über diese ecterne IP auf den Server. Wenn deine Anfrage ohne VPN über einen externen Port kommt funktioniertz ja alles, wenn ich das richtig verstanden habe. Dort würde ich ansetzen. Erst einmal muss alles "normal" laufen.
Wie hast du denn den Reverse Proxy eingerichtet?
Die Domain im Pi Hole zeigt auf die IP des NAS?

Weiterhin verstehe ich nicht warum immer alle schreien nach Hilfe und denn ihre Einstellungen, Software und Co nicht richtig beschreiben (scheinbar aus Angst vor wichtigen Daten) - oder wo hab ich gelesen das due die IP mit Pi-Hole zur internen URL "umgebogen" hast. Sollen denn die die Helfen wollen "Hellseher" sein?
 
Zuletzt bearbeitet:

Ghost108

Benutzer
Mitglied seit
27. Jun 2015
Beiträge
648
Punkte für Reaktionen
16
Punkte
38
Die Konfig sieht wie folgt aus:

openVPN Server auf Syno aktiv.
Port von openVPN in der Fritzbox geöffnet.

Verbindung stelle ich her via VPN und der Domain vpn.domain.de
(Diese ist in der FB als DDNS hinterlegt).

Als DNS Server gebe ich via VPN Config File die IP vom Pi Hole mit.

meine cloud.domain.de habe ich als DDNS auf der Syno eingerichtet -> welche extern auf die öffentliche IP der FB zeigt.
Das war erforderlich, damit ich für diese Domain ein LE Zertifikat beantragen kann.

Die PiHole hat aber von mir (für intern) den DNS Eintrag gesetzt bekommen:
cloud.domain.de => IP der NAS (hier läuft ja auch caldav)

Bedeutet:
Wenn ich intern oder via vpn cloud.domain.de aufrufe, kommt die Webmaske der Syno ohne irgendwelche Zertifikatfehler o.ä.
 
NAS-Central - Ihr Partner für NAS Lösungen
NAS-Central - The Home of NAS

Kaffeautomat

Wenn du das Forum hilfreich findest oder uns unterstützen möchtest, dann gib uns doch einfach einen Kaffee aus.

Als Dankeschön schalten wir deinen Account werbefrei.

:coffee:

Hier gehts zum Kaffeeautomat 

Hosted by netcup