DSM 5.0 final und Perl 5.18.1-0007

QTip

Super-Moderator
Teammitglied
Mitglied seit
04. September 2008
Beiträge
2.330
Punkte für Reaktionen
1
Punkte
84
Vielen dank für die ausführliche Hilfe.
Ich komme aktuell bis zu dem Punkt



in diesem Verzeichnis existiert bei mir nur das dir usr und lib

kein ~.
Dann bist du falsch, mit cd /var/packages/notifier/target in das Verzeichnis der App wechseln, dort solltest du eine Datei ~ sehen.
Die Datei sense.pm befindet sich bei mir im Verzeichnis

/var/packages/Perl/target/lib/perl5/site_perl/common

irgendwo hab ich einen Denkfehler :)...wäre daher noch einmal um Hilfe dankbar.

Im Notification Messenger erscheint jetzt nicht mehr `Software error` sondern `die Seite konnte nicht gefunden werden`...schonmal eine Verbesserung :)
Ja stimmt, der Inhalt von /var/packages/Perl/target/lib/perl5/site_perl/ sieht ok aus. /lib/perl5/site_perl ist eine Verknüpfung/symbolischer Link von /var/packages/Perl/target/lib/perl5/site_perl, der Inhalt ist als der selbe.
Jetzt nur noch die ~ verschieben/umbennen.
 

IBRU

Benutzer
Mitglied seit
01. Januar 2012
Beiträge
97
Punkte für Reaktionen
0
Punkte
0
Servus QTip,

bei mir war jetzt urplötzlich der Ordner /var/packages/Perl/target/lib/perl5/site_perl/ leer. K.A. was da vorher für Dateien drinnen waren...
Egal. Die Zip Datei dort entpackt. Dann die Zarafa Admin App geöffnet und geschlossen.

Der Ordner /var/packages/notifier/target existiert bei mir gar nicht. Also ich habe noch nicht einmal den Ordner "notifier"

Gruß Roy
 

Syndrome1977

Benutzer
Mitglied seit
02. September 2013
Beiträge
70
Punkte für Reaktionen
0
Punkte
0
So...die Datei "~" existiert bei mir im Ordner /var/packages/notifier/target...
wenn ich diese nun wie beschrieben verschiebe kommt komischerweise keine Warnmeldung, die Dateien zu überschreiben...somit scheint die Datei nicht zu existieren???

Die Fehlermeldung beim Programmstart ist jedenfalls noch die gleiche `Seite kann nicht gefunden werden`.
 

Delgado

Benutzer
Mitglied seit
21. Dezember 2012
Beiträge
164
Punkte für Reaktionen
0
Punkte
22
Ich habe ein ähnliches Problem mit ipkgui. Ich habe alles gemacht, wie von QTip beschrieben,
dennoch bekomme ich von ipkgui die Fehlermeldung, das die Seite nicht gefunden werden konnte.

Irgend jemand eine Idee??

Perl und IpkGui ganz normal aus dem Packagemanager installiert und anschliessend den Perl-Fix wie in #1 beschrieben, durchgeführt.

Muss ich noch was konfigurieren?
 

QTip

Super-Moderator
Teammitglied
Mitglied seit
04. September 2008
Beiträge
2.330
Punkte für Reaktionen
1
Punkte
84
Servus QTip,

bei mir war jetzt urplötzlich der Ordner /var/packages/Perl/target/lib/perl5/site_perl/ leer. K.A. was da vorher für Dateien drinnen waren...
Egal. Die Zip Datei dort entpackt. Dann die Zarafa Admin App geöffnet und geschlossen.

Der Ordner /var/packages/notifier/target existiert bei mir gar nicht. Also ich habe noch nicht einmal den Ordner "notifier"

Gruß Roy
Den Ordner kannst du auch nicht haben, da du ja das Problem bei Zarafa hast. Das war speziell für Syndrome1977 sein Problem, beim 1. Post für den Fix habe ich nur /var/packages/<Name-der-Applikation>/target erwähnt, also müsst ihr ein wenig suchen. Du musst in den Ordner /var/packages/Zarafa/target/3rdparty wechseln

@Syndrome1977 und Delgado: Habt ihr auch in der Systemsteuerung - Sicherheit den Haken bei "Schutz gegen Cross-Site-Request-Forgery-Attacken verbessern" entfernt. Diese Apps laufen noch nicht mit eingeschalteter Option auf DSM 5.
 

Delgado

Benutzer
Mitglied seit
21. Dezember 2012
Beiträge
164
Punkte für Reaktionen
0
Punkte
22
@Syndrome1977 und Delgado: Habt ihr auch in der Systemsteuerung - Sicherheit den Haken bei "Schutz gegen Cross-Site-Request-Forgery-Attacken verbessern" entfernt. Diese Apps laufen noch nicht mit eingeschalteter Option auf DSM 5.

Hallo QTip,

nein, hatte ich noch nicht. Habe den Haken jetzt entfernt, aber leider kommt immer noch die Meldung, das die Seite nicht gefunden wurde. Muss ich die DS neu starten? Sicherheitshalber?

PS: Ich habe eine DS213+, nur zur Vollständigkeit halber. Das IPKG habe ich manuell über die Konsole installiert, wie im Synology Wiki beschrieben, funktioniert auch auf der Konsole prima.

PPS: Neustart der DS, keine Änderung, leider.
 
Zuletzt bearbeitet:

Syndrome1977

Benutzer
Mitglied seit
02. September 2013
Beiträge
70
Punkte für Reaktionen
0
Punkte
0
Hatte die Punkte "Schutz gegen Cross Site Attacken" und "DDos Attacken" mit Haken markiert gehabt. Diesen nun entfernt...Alle Schritte noch einmal von vorne durchgeführt...leider ebenfalls keine Veränderung.
 

Blaky

Benutzer
Mitglied seit
05. August 2013
Beiträge
2
Punkte für Reaktionen
0
Punkte
0
Hallo zusammen,

ich habe meine DS213 vorgestern auf DSM 5 gebracht und jetzt leider das selbe Problem.
Selbst mit den Tips hier bekomme ich z.B. Growler nicht zum laufen. Ich bekomme auch nur "Seite kann nicht angezeigt werden".
Der Dienst selber läuft allerdings.
 

Delgado

Benutzer
Mitglied seit
21. Dezember 2012
Beiträge
164
Punkte für Reaktionen
0
Punkte
22
Super, ich habs, vielen Dank QTip.
Man muß nicht nur den Haken entfernen, sondern, damit das wirksam wird, einmal ab- und wieder anmelden. Jetzt jeht dat :).
 

QTip

Super-Moderator
Teammitglied
Mitglied seit
04. September 2008
Beiträge
2.330
Punkte für Reaktionen
1
Punkte
84
Super, ich habs, vielen Dank QTip.
Man muß nicht nur den Haken entfernen, sondern, damit das wirksam wird, einmal ab- und wieder anmelden. Jetzt jeht dat :).
genau, abmelden und erneut anmelden ist wichtig.
 

QTip

Super-Moderator
Teammitglied
Mitglied seit
04. September 2008
Beiträge
2.330
Punkte für Reaktionen
1
Punkte
84
Hallo zusammen,

ich habe meine DS213 vorgestern auf DSM 5 gebracht und jetzt leider das selbe Problem.
Selbst mit den Tips hier bekomme ich z.B. Growler nicht zum laufen. Ich bekomme auch nur "Seite kann nicht angezeigt werden".
Der Dienst selber läuft allerdings.
Der Pfad zu der ~ ist /var/packages/growler/target/app, dort wirst du sie sehen, wenn du alle anderen Schritte (entpacken des Archivs, Start der Anwendung, Beenden der Anwendung) durchgeführt hast. Dann wie in der Anleitung weiter verfahren. Die Prozedur muss nur einmal durchgeführt und hilft sofort bei allen oben aufgeführten Apps und bei Zarafa.

Synology ist aber schon dran und wird asap ein Update vom Perl-Paket herausbringen.
 

laserdesign

Benutzer
Mitglied seit
11. Januar 2011
Beiträge
2.396
Punkte für Reaktionen
3
Punkte
84
Super, ich habs, vielen Dank QTip.
Man muß nicht nur den Haken entfernen, sondern, damit das wirksam wird, einmal ab- und wieder anmelden. Jetzt jeht dat :).

danke, das war der entscheidende Tipp.
 

Blaky

Benutzer
Mitglied seit
05. August 2013
Beiträge
2
Punkte für Reaktionen
0
Punkte
0
Der Pfad zu der ~ ist /var/packages/growler/target/app, dort wirst du sie sehen, wenn du alle anderen Schritte (entpacken des Archivs, Start der Anwendung, Beenden der Anwendung) durchgeführt hast. Dann wie in der Anleitung weiter verfahren. Die Prozedur muss nur einmal durchgeführt und hilft sofort bei allen oben aufgeführten Apps und bei Zarafa.

Synology ist aber schon dran und wird asap ein Update vom Perl-Paket herausbringen.

Das hatte ich schon, aber ich bin nicht auf den Gedanken gekommen mich ab und wieder anzumelden.

Jetzt läuft wieder alles.
Danke für den Tipp :D
 

Syndrome1977

Benutzer
Mitglied seit
02. September 2013
Beiträge
70
Punkte für Reaktionen
0
Punkte
0
Super funktioniert wieder ;)...Vielen dank für die Hilfe
 

Delgado

Benutzer
Mitglied seit
21. Dezember 2012
Beiträge
164
Punkte für Reaktionen
0
Punkte
22
@QTip
Hi QTip, ich habe mir ipkgui installiert und angeschaut und wollte nur sagen, tolles Progrämmchen.
Es ist deutlich komfortabler, mit einer durchdachten GUI, die Pakete zu installieren und deinstallieren, inklusive deren Abhängigkeiten, als von der Konsole. Also, von mir ein Dankeschön an dieser Stelle und weiter so ;).
 

coffex

Benutzer
Mitglied seit
19. März 2010
Beiträge
90
Punkte für Reaktionen
0
Punkte
0
jo joo jooo ... zu #1 @ QTip

Hat alles supper funktioniert.
Danke für deinen EINSATZ und deine Mühen.

Gruß Coffex



@ Synology-forum.de ... ( hier zwar an der falschen Stelle ;-) ... dennoch
ein Dankeschön-Button für die Beiträge wäre cool.
So könnte man sich konkret für einen Beitrag BEDANKEN,
ohne jedoch laufende Diskussionen durch ein "Dankeschön Betrag" zu stören.

Greetz Coffex
 

BaSto

Benutzer
Mitglied seit
15. März 2014
Beiträge
2
Punkte für Reaktionen
0
Punkte
0
Synology hat gerade Perl update 5.18.1-0010 im Package Center bereit gestellt.

Version: 5.18.1-0010
(2014/03/19)
Change log

Fixed an issue where some Perl-dependent packages might not be able to launch under rare circumstances.
Fixed an issue where some Perl scripts could not communicate with MySQL/MariaDB database.
Updated to add required modules for some 3rd party packages to load GUI correctly.

Dieses Update wollte dass ich ipkgui vorher deinstalliere, nach Neuinstallation funktioniert ipkgui wieder gut.
Gtrz, Bart
 

willliw

Benutzer
Mitglied seit
26. Januar 2013
Beiträge
3
Punkte für Reaktionen
0
Punkte
0
Habe auch das neue Perl Modul auf einer DS-411-Slim installiert.
Leider hat Synology vermutlich module für falsche CPU-Typen eingepackt.
Neue Perl Version:
Publisher: Synology
Version 5.18.1.0010


Vorher gabs den Fehler:
DBD::mysql missing

Jetzt kommt:
/volume1/wrk/SW/sh/syno/tstperl.pl
Test Started!!!
Illegal instruction (core dumped)


Das Perl script ist ganz einfach:

#!/usr/bin/perl
use strict;
use warnings;
use DBI;
use DBD::mysql;
use LWP::UserAgent;
use LWP::Simple;
use POSIX;
setlocale( &POSIX::LC_ALL, "German" );

use HTTP::Request::Common;
# use HTML::TreeBuilder;



# MYSQL CONFIG VARIABLES
my $srv = 'localhost';
my $db = 'dbname';
my $user = 'dbusr';
my $pw = 'dbpwd';
my $table = 'tbtab';

my $date = "undefined";


print "Test Started!!!n";


my $dbh = DBI->connect("DBI:mysql:$db:$srv", $user, $pw,
{'RaiseError' => 1, 'PrintError' => 1, 'AutoCommit' => 1 })
or die "Connection Failed: $db DB on $srvnt$DBI::errstrn";
 

Syndrome1977

Benutzer
Mitglied seit
02. September 2013
Beiträge
70
Punkte für Reaktionen
0
Punkte
0
Jupp...Leider funktioniert der Notification Messenger nach dem neuen Perl Update nicht mehr. Erhalte nur eine weisse leere Seite (ohne Fehlermeldung) beim öffnen des Notification Messengers. Vielleicht kann ja auch hier geholfen werden...Jemand das selbe Problem? Schonmal danke im voraus.
 
  AdBlocker gefunden!

Du bist nicht hier, um Support für Adblocker zu erhalten, denn dein Adblocker funktioniert bereits ;-)

Klar machen Adblocker einen guten Job, aber sie blockieren auch nützliche Funktionen.

Das Forum wird mit einem hohen technischen, zeitlichen und finanziellen Aufwand kostenfrei zur Verfügung gestellt. Wir zeigen keine offensive oder Themen fremde Werbung. Bitte unterstütze dieses Forum, in dem du deinen Adblocker für diese Seite deaktivierst.