VPN mit iOS geht nicht mehr

Chäli

Benutzer
Mitglied seit
26. Mai 2013
Beiträge
58
Punkte für Reaktionen
0
Punkte
12
Ort
Schweiz
Seit ich das ipad und das iphone auf 13.3 upgedatet habe, funktioniert das VPN nicht mehr. Es kommt immer die Fehlermeldung, der VPN Server sei nicht errreichbar. Vor dem Update ging es problemlos. Auch mit iOS 14.0.1 kriege ich keine Verbindung zum VPN Server. Für mich ist das ein Apple Problem, da es vor dem Update ging. Darum habe ich zuerst bei Apple angerufen. Der Firstlevel konnte nicht helfen und der Secondlevel hat gefragt, ob es sich um einen privaten VPN Server handle. Nachdem ich das bejaht habe, stellte sich die Frau auf den Strandpunkt, sie könne mir nicht helfen, das sei kein Apple Problem. Auf mein Nachfragen warum es denn früher ging, hat sie den Chat abgebrochen.

Weiss hier jemand die Lösung zu diesem Problem?
 

Chäli

Benutzer
Mitglied seit
26. Mai 2013
Beiträge
58
Punkte für Reaktionen
0
Punkte
12
Ort
Schweiz
@blurrrr Danke für die Antwort. Zu Google: Ich habe vorgängig selbstverständlich gesucht, leider nichts derartiges gefunden. Zum verlinkten Tread, ich kann relativ schlecht Englisch, wenn ich die drei Seiten aber richtig verstehe, ist da auch keine Lösung angegeben.
 

blurrrr

Benutzer
Mitglied seit
23. Jan 2012
Beiträge
4.248
Punkte für Reaktionen
468
Punkte
163
Die einen sagen so, die anderen so. Einer der wesentlichsten Punkte beim Thema VPN sind Verschlüsselungs- und Authentifizierungsalgorithmen (bezogen auf "IPSec", hast ja nichtmals geschrieben, was für eine Art von VPN, von daher gehe ich mal einfach davon aus). Da sich diese ständig ändern (es kommen neue hinzu, alte werden rausgeschmissen), muss man halt auch immer schauen, was beide Seiten unterstützen, aber teilst Du uns erstmal mit a) wohin Du Dich verbindest (Router/NAS/sonstwas) und b) wie (OpenVPN, IPSec, etc.)? :)
 

tproko

Benutzer
Mitglied seit
11. Jun 2017
Beiträge
1.124
Punkte für Reaktionen
47
Punkte
74
Welche Vpn Art verwendest du? @blurrrr hat es eh schon gefragt. Das wäre mal interessant.

Bei OpenVPN gab es bei mir am IOS Client und auch einmal am Server mit den Certs zu Problemen.
 
  • Like
Reaktionen: blurrrr

*Mac*

Benutzer
Mitglied seit
21. Aug 2016
Beiträge
1
Punkte für Reaktionen
2
Punkte
53
Ich hatte das Problem auch. Dank dem 2. Link von Blurrrr konnte ich aber das Problem wie folgt lösen:

In der Annahme das L2TP/IPSec genutzt wird: In der VPN-Serverconfig der DS darf das Feld "SHA2-256-kompatiblen-Modus-(96 bit) aktivieren" NICHT angehakt sein. Man muss etwas nach unten scrollen, da sich diese Option am Ende der Config befindet.
 

Wahlpirat

Benutzer
Mitglied seit
24. Dez 2012
Beiträge
4
Punkte für Reaktionen
0
Punkte
1
Hallo,
Wo kann ich denn für L2TP in dem VPN Server den haken für "SHA2-256-kompatiblen-Modus-(96 bit) aktivieren" in der DS setzten? Habe eine DS213+ mit DSM 6.2.3 und den VPN Server (Version: 1.3.11-2777). Finde aber keine Einstellmöglichkeit für SHA2-256.

Schon mal vorab vielen Dank für die Hilfe.
 

the other

Benutzer
Mitglied seit
17. Okt 2015
Beiträge
1.122
Punkte für Reaktionen
192
Punkte
89
Moinsen,
Könnte schwierig werden afaik .... Hier Dank Freund Google nach 5 Minuten Suche, allerdings in english, please.



Da sieht es so aus, als ob dein Gerät auch genannt wird.
 

the other

Benutzer
Mitglied seit
17. Okt 2015
Beiträge
1.122
Punkte für Reaktionen
192
Punkte
89
Moinsen,
Andererseits beschreibt der jeweilige link (nach sehr oberflächlich gelesenem) auch, dass die Möglichkeit den sha xyz zu aktivieren fehlt, ob der also bei dem Gerät überhaupt aktiv ist... Keine Ahnung. Nutze kein vpn auf dem NAS...
 
  • Like
Reaktionen: blurrrr

Wahlpirat

Benutzer
Mitglied seit
24. Dez 2012
Beiträge
4
Punkte für Reaktionen
0
Punkte
1
Hallo!

@blurrrr
Ich nutze die aktuelle Version des VPN Server. Hier kann ich die SHA2-256 nicht direkt aktivieren. Das ist wohl auch das Problem der meisten anderen Nutzern im zweiten link von the other.
VPNServer.JPG

@the other
Danke für die Links. Habe sie bei meiner google Suche nicht gefunden. Leider funktioniert der dort beschriebene workaround über die Änderung der L2PT ipsec.conf bei mir nicht.


Gruss wahlpirat
 

blurrrr

Benutzer
Mitglied seit
23. Jan 2012
Beiträge
4.248
Punkte für Reaktionen
468
Punkte
163
@Wahlpirat Dann war die Wahl wohl falsch, Pirat. 🤭 Tschulli, konnte ich mir nicht verkneifen :D
Leider funktioniert der dort beschriebene workaround über die Änderung der L2PT ipsec.conf bei mir nicht.
Den Dienst danach auch mal neugestartet (bzw. ggf. direkt die ganze Syno)? Schien ja funktioniert haben... Alternativ könnte man auch einfach das VPN wechseln, z.B. auf OpenVPN.... Problem ist halt durch Apple's Update entstanden, nur doof, wenn der Rest dann nicht mitzieht, bzw. "einige" nicht "instant" darauf reagieren (wie z.B. Synology), aber das ist im Grunde auch nix neues (s. z.B. iCloud-Geraffel für Outlook, gibt es auch öfters mal Probleme mit) :)
 

Wahlpirat

Benutzer
Mitglied seit
24. Dez 2012
Beiträge
4
Punkte für Reaktionen
0
Punkte
1
@blurrrr
Dann war die Wahl wohl falsch, Pirat. 🤭 Tschulli, konnte ich mir nicht verkneifen
Kein Ding. Habe mir schon ganz andere Sachen diesbezüglich anhören müssen :)

Den Dienst danach auch mal neugestartet (bzw. ggf. direkt die ganze Syno)? Schien ja funktioniert haben..
Ja, alles gemacht. Leider ohne Erfolg.

Alternativ könnte man auch einfach das VPN wechseln, z.B. auf OpenVPN
Ja klar, aber darum ging es bei meiner Frage nicht.

Problem ist halt durch Apple's Update entstanden, nur doof, wenn der Rest dann nicht mitzieht, bzw. "einige" nicht "instant" darauf reagieren
Ja leider ist das wohl so. Vielleicht schiebt Synology ja noch eine Patch hinterher. Ich frage mich nur, wo der Unterschied in den VPN Einstellungen herkommt. Ist das DS abhängig, oder gibt es unterschiedliche VPN Programme/Versionen? Es scheinen ja einige Anwender eine Checkbox für SHA2 zu haben.

Gruß wahlpirat
 

blurrrr

Benutzer
Mitglied seit
23. Jan 2012
Beiträge
4.248
Punkte für Reaktionen
468
Punkte
163
Letzteres scheint vermutlich wirklich an den Versionen zu liegen (anders kann ich mir das auch nicht erklären, denn die einzigen Unterschiede stammen von den Paketversionen, welche wiederum von der DSM-Version abhängig sind). Unterschiede bzgl. den Paketversionen in Bezug auf die Geräte selbst sind mir derweil nicht bekannt (abgesehen davon, ob ein Paket für ein Gerät "generell" zur Verfügung steht oder eben nicht). Selbst in der Syno-Anleitung zum VPN-Server ist dieser Punkt zu finden.

L2TP/IPSec VPN-Server aktivieren:
...
11. Setzen Sie ein Häkchen bei SHA2-256-kompatiblen Modus (96 Bit) aktivieren, um bestimmten Clients (nicht RFC-Standard) zu erlauben, die L2TP-/IPSec-Verbindung zu verwenden.
 

Zweimot

Benutzer
Mitglied seit
20. Jun 2019
Beiträge
30
Punkte für Reaktionen
5
Punkte
8
Habe das gleiche Probem und keine Lösung. Nach dem Update iPhone geht VPN (L2TP) von diesem iPhone nicht mehr. Von anderen Geräten allerdings schon. Ports und alles durchgetestet. Es liegt definitiv am iPhone.
 

blurrrr

Benutzer
Mitglied seit
23. Jan 2012
Beiträge
4.248
Punkte für Reaktionen
468
Punkte
163
Es dreht sich hier sowieso die ganze Zeit um die IOS-Updates, auch wenn das keiner sehen will...😋 lch vermute ja nach wie vor obiges... (SHA2-256-kompatiblen Modus (96 Bit) aktivieren). Was das OpenVPN angeht... da wird es dann vermutlich schlichtweg am Zertifikat liegen (https://support.apple.com/en-us/HT211025 - "Connections to TLS servers violating these new requirements will fail. This might cause network and app failures and prevent websites from loading.")
 

Zweimot

Benutzer
Mitglied seit
20. Jun 2019
Beiträge
30
Punkte für Reaktionen
5
Punkte
8
Das war's: "SHA2-256-kompatiblen Modus (96 Bit) aktivieren" am Server de-aktiviert, und schon verbindet sich das iPhone über L2TP fröhlich und blitzschnell, als ob nie etwas anderes gewesen wäre. Aktiviert ist noch "Im Kernelmodus ausführen", aber das scheint ohne Bedeutung in diesem Falle.
 
Zuletzt bearbeitet:
  AdBlocker gefunden!

Du bist nicht hier, um Support für Adblocker zu erhalten, denn dein Adblocker funktioniert bereits ;-)

Klar machen Adblocker einen guten Job, aber sie blockieren auch nützliche Funktionen.

Das Forum wird mit einem hohen technischen, zeitlichen und finanziellen Aufwand kostenfrei zur Verfügung gestellt. Wir zeigen keine offensive oder Themen fremde Werbung. Bitte unterstütze dieses Forum, in dem du deinen Adblocker für diese Seite deaktivierst.