Time Machine unter Catalina

GuidoG

Benutzer
Mitglied seit
15. Oktober 2014
Beiträge
26
Punkte für Reaktionen
0
Punkte
0
Hallo, Ich verwende eine Synology 918+. Nach dem Update auf Catalina gelang es mir - allerdings erst nach der Erstellung eines neuen Users auf der DS - ein komplettes TM- Backup zu erstellen. Auch liefen einige nachfolgende Backup problemlos durch. Seit heute Morgen ist TM der Meinung, dass ein Backup nicht möglich sei, da die Zugangsdaten falsch seien. Egal, ob ich den bislang funktionierenden Backup- User verwende oder den Admin. Eigenartig ist, dass ich offenbar Lesezugriff auf das TM- Backup habe. Eine andere Fehlerquelle, als Catalina kann ich nicht erkennen. Hat jemand das selbe Problem oder eine Idee, woran dieses Verhalten liegen kann?

Danke & Gruß
Guido
 

Synchrotron

Benutzer
Mitglied seit
13. Juli 2019
Beiträge
1.332
Punkte für Reaktionen
16
Punkte
64
Ohne dass dir das weiterhelfen wird: Habe auch inzwischen Catalina, TM läuft durch, keine Probleme, musste nichts anfassen.

Es kann sein, dass ich in der Flut der Abfragen nach Zugriffsrechten nach der Catalina-Installation irgendwo drauf klicken musste, um TM frei zu geben.

Vielleicht hat ja noch jemand eine Idee ?
 

GuidoG

Benutzer
Mitglied seit
15. Oktober 2014
Beiträge
26
Punkte für Reaktionen
0
Punkte
0
Nach mehreren Versuchen habe ich festgestellt, dass das Backup dann klappt, wenn ich mich mit dem Benutzernamen anmelde, mit welchem ich auch auf die anderen Ordner der DS zugreife.
 

Mymacly

Benutzer
Mitglied seit
26. Dezember 2014
Beiträge
15
Punkte für Reaktionen
0
Punkte
0
Hallo Zusammen

Ich hatte nach der Installation von Catalina im Finder keine Zugriffsrechte auf Time Machine nach dem ich über die Time Machine die alten Sicherungen angewählt habe und eine alte angewählt habe hat das Zugriffsrecht wieder funktioniert jedoch ein neues Backup ist nicht möglich. Es zeigt länger als sonst Backup vorbereiten an und dann kommt die Meldung Backup erstellt: 0 KB Speicherplatz freigeben... Habe aber noch 18 GB Speicher verfügbar. Nach anwählen dieses Backup überspringen kommt wieder die Meldung letztes Backup Vorgestern. Bei Backup jetzt erstellen geht das ganze wieder von vorne los. Danke für eure Infos.

Einige Stunden später hat nun das Backup begonnen scheint wieder zu funktionieren.
 
Zuletzt bearbeitet:

fischdoener

Benutzer
Mitglied seit
11. Januar 2014
Beiträge
15
Punkte für Reaktionen
0
Punkte
1
Moin,

ich habe die Situation, dass seit dem macOS 10.15 (Catalina) Update Time Machine zwar läuft, aber ewig braucht, um ein Backup vorzubereiten (kann ich verschmerzen). Das eigentliche Problem ist, dass ich seitdem nur noch auf das jeweils letzte Backup (seit dem macOS Update) Zugriff habe. Es gibt dieses Time Machine Backup aber schon seit 2016. Ich komme an keines der älteren Backups ran. Das ist fatal!

Ich dachte, es hätte etwas mit geänderten Permissions zu tun, aber an die komme ich (weil auf dem NAS) nicht ran. Da AFS nicht mehr unterstützt wird, habe ich das in den Mac Netzwerkeinstellungen deaktiviert und bin jetzt über SMB verbunden. Liegt es vielleicht daran? Apple selbst weist darauf hin, dass Time Machine Backups auf nicht-Apple NAS nicht unterstützt werden. Ich bin verwirrt...

Synology
 

Mymacly

Benutzer
Mitglied seit
26. Dezember 2014
Beiträge
15
Punkte für Reaktionen
0
Punkte
0
Hallo
Ich habe auf AFS die alten Backups auch nicht mehr angezeigt bekommen und habe deshalb im Synology auf SMB gewechselt die TimeMachine neu verbunden und die alten Backups werden wieder angezeigt.
 

fischdoener

Benutzer
Mitglied seit
11. Januar 2014
Beiträge
15
Punkte für Reaktionen
0
Punkte
1
Das wäre auch mein nächster Schritt gewesen, aber ich bin mir sicher: wird dann das existierende Backup fortgesetzt oder überschrieben? Ich habe z. Zt. keine geeignete Festplatte um ein "Backup vom Backup" zu machen...
 
Zuletzt bearbeitet von einem Moderator:

Mymacly

Benutzer
Mitglied seit
26. Dezember 2014
Beiträge
15
Punkte für Reaktionen
0
Punkte
0
Ich war auch etwas unsicher zuerst hat es die Synchronisation auch als erstes Backup angezeigt dann aber wieder alle bis 2016. Habe folgende Anleitung im Internet gefunden
https://philwiener.com/macos-smb-synology/ und die Synology so umgestellt und ich habe meine Backup wieder. Der Pfad von TimeMachine hat sich selber auf SMB umgestellt nach dem neuen Verbinden der Synology mit dem Mac.
 

Synchrotron

Benutzer
Mitglied seit
13. Juli 2019
Beiträge
1.332
Punkte für Reaktionen
16
Punkte
64
Das mit der fehlenden Möglichkeit „ein Backup vom Backup“ zu machen ist aus meiner Sicht eine Bemerkung, die auf ein Problem hindeutet. Ob es ein Problem ist, hängt von Randbedingungen ab, und von deiner persönlichen Einstellung.

Randbedingung: Es ist denkbar, dass du dein laufendes Backup in die iCloud machst, bzw. den iCloud-Sync aktiviert hast, und die TM als zweites BU läuft. Dann Haken dran, kein weiterer Handlungsbedarf - denn du hast 3 Sätze der Daten, davon 2 Backups, davon 1 Satz ausgelagert.

Wenn das TM-Backup auf die Syno dein einziges ist, würde ich es als kritisch bewerten. Denn in vielen Fällen werden beide am gleichen Ort sein, das heißt geht es dort gründlich schief, sind alle Daten verloren. Feuer, Wasser, Diebstahl ...

Die einfachste Lösung und zugleich die kostengünstigste wäre es, wenigstens die wichtigsten Daten ausgelagert zu sichern. Entweder ein kleines USB-Laufwerk (einige TB für ca. 100€), oder doch Cloud-Speicher. Wenn du eh alles im Original auf dem Mac hast, ist das schlank umzusetzen. Leg das Laufwerk zu Freunden, Verwandten oder in ein Bankschließfach, und tausche es z.B. monatlich gegen ein zweites aus. Liegen auch auf der Syno originäre Daten, ist es etwas aufwändiger - ich würde dann ein USB-Laufwerk von der Syno beschreiben lassen, über Hyper-BU, und dabei das TM-BU von der Syno einfach mit sichern.

Die komfortabelste, aber zuerst auch aufwändigste Lösung ist eine zweite (gerne kleine oder ältere) Syno an einem anderen Standort.
 

spiker

Benutzer
Mitglied seit
10. April 2014
Beiträge
21
Punkte für Reaktionen
0
Punkte
0
Bei mir funktioniert das Time Maschine Backup mit aktuellem Catalina problemlos.

Auf der Synology ist Bonjour für AFP aktiviert, damit geht es bei mir zumindest bis MacOSX Sierra.

Mit Catalina ist die Wiederherstellung eher problematisch
. Sowas teste ich zum Glück immer.

Nach dem Booten im Recovermode, erscheint wie gewohnt das Menü mit der Funktion MacOS aus TimeMaschine wieder herstellen.

Nach dem Anmelden an der Synology mit dem Time Maschine Account kann ich das Backup sehen und auch auswählen.
Das war es dann auch. :-(

Der weiter Button (Pfeil) ist nur helgrau hinterlegt und lässt sich nicht klicken.

Weiß da jemand eine Lösung zu ?

Was auf jedenfall geht ist Backup und Recover mit einer HD. Was darauf schließen läßt, dass es an der Synology liegen muss.

Nachtrag:
Funktioniert wieder. Weiß aber nicht woran es gelegen hat.
 
Zuletzt bearbeitet:

ScottyC

Benutzer
Mitglied seit
18. Februar 2016
Beiträge
271
Punkte für Reaktionen
0
Punkte
16
Hallo zusammen,

ich häng’ mich hier mal dran.
Bei mir funktioniert die time machine nicht, wenn ich den Zugriff über smb versuche; über afp klappt alles bestens.

Meine Hardware:
DS216 play (aktuellstes DSM)
MacBook pro 16 (Catalina ist auf dem aktuellsten Stand)

Ich habe gestern alle NAS-Zugriffe von AFP auf SMB umgestellt; das hat bestens funktioniert.
Im Finder kann ich auch - über SMB - mit meinem User, den ich für die time machine Sicherung angelegt habe, auf das Sicherungslaufwerk zugreifen.
Die eigentliche time machine Sicherung über SMB klappt aber nicht. Nach dem Auswählen des Laufwerkes und der Eingabe der Anmeldedaten werden ja vor der Sicherung 120 Sekunden (in den time machine Einstellungen) heruntergezählt.
Danach erhalte ich folgende Fehlermeldung:
Bildschirmfoto 2020-01-15 um 11.27.40.jpg

In den Dateidiensten ist der Bonjour TM Broadcast entsprechend aktiviert und die Ordner entsprechend ausgewählt.
Hat hier jemand ähnliche Erfahrungen gemacht und kann mir einen Tipp geben?

Vielen Dank im Voraus :)
 

Nebulos

Benutzer
Mitglied seit
29. Januar 2020
Beiträge
1
Punkte für Reaktionen
0
Punkte
0
Hallo,
Es scheint außerdem so zu sein, dass Catalina die alten Sicherungen nicht mehr erkennt, beziehungsweise die Dateistruktur komplett verändert wird. Man kann also nicht darauf zählen, nach der Installation von Catalina noch alte gesicherte Dateien wiederherstellen zu können. Blöd wenn man das nicht vorher weiß.
Grüsse
N
 

Mac-Trek

Benutzer
Mitglied seit
08. Februar 2020
Beiträge
30
Punkte für Reaktionen
0
Punkte
6
Ich reihe mich bei der Problematik mal ein. Allerdings nicht unter Catalina, sondern unter High Sierra und Mojave. Bis gestern lief das Backup am iMac unter High Sierra anstandslos, während es unter Mojave am MacBook Pro von Anfang an immer wieder gezickt hat. Nach meiner bisherigen Beobachtung, kommen die Macs mit den Benutzernamen durcheinander. Für die Shares habe ich den einen und für TimeMachine einen anderen Benutzer. Wenn Time Machine das Volume mal wieder nicht finden kann, ist mir aufgefallen, dass im Time Machine-User im Schlüsselbund plötzlich als Benutzername der vom Share, aber das Passwort vom Time Machine User eingetragen ist. Das kann natürlich nicht funktionieren. Eine manuelle Korrektur des Eintrags wird nicht gespeichert. Bisher habe ich Time Machin nur wieder ans laufen bekommen, wenn ich wie folgt vorgegangen bin:

- Verbindung zum Share bzw. zur DS im Finder trennen
- Backupvolume in Time Machine entfernen und mit dem Time Machine-User neu einrichten
- Verbindung zur DS und den Laufwerken im Finder wieder herstellen

Danach läufts bei mir erst mal wieder. Mal sehen wie lange.
 

jensrupprecht

Benutzer
Mitglied seit
28. Dezember 2015
Beiträge
23
Punkte für Reaktionen
0
Punkte
0
Hallo zusammen,

Gibt es bereits eine Lösung für die Time Machine Probleme unter Catalina zur Synology? Seit dem Update habe ich immer wieder das Problem das die Backups abbrechen oder gar nicht erst erstellt werden können.

Nun hatte ich meinen iMac im Service und habe ihn neu aufgesetzt. Seit dem kann ich gar kein Backup mehr auf die Synology erstellen. Ich habe bereits versucht einen neuen Benutzer auf der Synology für Time Machine anzulegen. Die normale Verbindung im Finder per smb funktioniert ohne Probleme.

Aktuell bekomme ich folgende Fehlermeldung:

Auf das Image des Backup-Volumes „/Volumes/.timemachine/192.168.178.xxx/FF9AE70F-89CB-493C-BB41-018C8340AB7F/Time Machine BackUp/iMac Jens.backupbundle“ konnte nicht zugegriffen werden (Fehler 45).

Manchmal kommt auch ein Fehler 92.
 

Mac-Trek

Benutzer
Mitglied seit
08. Februar 2020
Beiträge
30
Punkte für Reaktionen
0
Punkte
6
Der Lösungsansatz von mir, der unmittelbar vor Deinem Post steht, funktioniert nicht? Bei mir läuft es seither ohne Probleme (allerdings unter High Sierra und Mojave).
Ist Catalina bei Dir schon auf der 10.15.4, inklusive dem gestern Abend oder heute Morgen veröffentlichten Ergänzungsupdate?
 

ScottyC

Benutzer
Mitglied seit
18. Februar 2016
Beiträge
271
Punkte für Reaktionen
0
Punkte
16
Hallo Jens,

das kenne ich; mit SMB kann ich problemlos über den Finder auf alle Volumes zugreifen; das time machine Backup funktioniert bei mir unter Catalina nur mit AFP.
Probier mal folgendes:
- die entsprechenden AFP-Dienste in der Syno aktivieren
- Das Backup Volume aus den Systemeinstellungen der time machine (auf dem Mac) entfernen
- Die Syno neu starten; ggf. hat noch ein Dienst Zugriff auf das Backup
- Das Backup Volume in den Systemeinstellungen der time machine (auf dem Mac) hinzufügen.

Bei mir funktioniert dieses Vorgehen.
Poste mal, ob es auch bei dir klappt.
Viel Erfolg :)

VG Rainer
 

jensrupprecht

Benutzer
Mitglied seit
28. Dezember 2015
Beiträge
23
Punkte für Reaktionen
0
Punkte
0
Der Lösungsansatz von mir, der unmittelbar vor Deinem Post steht, funktioniert nicht? Bei mir läuft es seither ohne Probleme (allerdings unter High Sierra und Mojave).
Ist Catalina bei Dir schon auf der 10.15.4, inklusive dem gestern Abend oder heute Morgen veröffentlichten Ergänzungsupdate?
Leider nein. Sogar auf einem komplett frisch aufgesetzten MacOS funktioniert es nicht. Habe 10.15.4 drauf.
 

jensrupprecht

Benutzer
Mitglied seit
28. Dezember 2015
Beiträge
23
Punkte für Reaktionen
0
Punkte
0
Muss smb dann in der Synology komplett dekantiert werden? Oder reicht es wenn ich AFP zusätzlich aktiviere und nur das Time Machine Volume auf AFP umstelle?
 

jensrupprecht

Benutzer
Mitglied seit
28. Dezember 2015
Beiträge
23
Punkte für Reaktionen
0
Punkte
0
Nachdem der Apple Support mir nicht helfen konnte oder wollte habe ich nun mit dem Synology Support gechattet.

Es wurde der Hinweis gegeben das AFP komplett deaktiviert werden soll und bei den erweiterten SMB Einstellungen minSMB auf SMB2 und maxSMB auf SMB3 stehen soll.

Das Backup hat jetzt zumindest angefangen. Mal sehen ob es durchläuft und wie es mit zukünftigen Backups aussieht.
 

Synchrotron

Benutzer
Mitglied seit
13. Juli 2019
Beiträge
1.332
Punkte für Reaktionen
16
Punkte
64
Mein TM-Backup läuft schon seit langem mit AFP, aktuelles Catalina. Beim Wechsel von Mojave auf Catalina musste ich 1x manuell neu aufsetzen, seitdem lief es wieder.

Nach dem letzten Update Auf 10.15.4 (nicht das Zusatzupdate) bekam ich ein Meldung, dass das vorhandene Catalina-Update nicht mehr verwendbar sei, und dass ein neues angelegt wird. Das habe ich bestätigt, daraufhin wurde das vorhandene Backup automatisch gelöscht und ein neues angelegt. Das ist unauffällig durch gelaufen.

Mein Fazit: Irgendwas wackelt da, aber es scheint sich selbst zu korrigieren. Etwas unschön ist, dass zwangsweise auch die Versionshistorie weg ist.