Stromausfall bei FW Update

timMekk

Benutzer
Mitglied seit
14. Mrz 2014
Beiträge
10
Punkte für Reaktionen
0
Punkte
0
Moin moin,

ich bin am verzweifeln. Ich habe letzte Woche eine FW Update gemacht und dann ist hier komplett der Strom ausgefallen und seitdem macht meine DS209+II nichts mehr. Lediglich die blaue LED blinkt und die LEDs von den Disks leuchten kurz und fangen dann an zu blinken. Ich bekomme keine Verbindung mehr zur NAS.

Ich habe mir schon ein Kabel gekauft um mich auf die Serielle Schnittstelle zu hängen. Leider bekomme ich im Putty oder TeraTerm nichts angezeigt.
Baudrate 115200
Databits 8
Stopbits 1
Parity none
flowcontrol none

habe folgendes Kabel: $_57.JPG

angeschlossen mit 3,3v

wenn ich die NAS nicht anschalte, dann leuchten auf dem Adapter RX und TX. Schalte ich die NAS ein dann gehen die LEDs aus und nur die TX LED flackert ab und an.

Falls es das Kabel ist, werde ich noch mal versuchen, über den Raspberry PI über den GPIO Port gehen und versuchen eine Verbindung zu bekommen.


Hättet ihr noch Tips für mich?!

Danke!
 

goetz

Super-Moderator
Teammitglied
Mitglied seit
18. Mrz 2009
Beiträge
13.574
Punkte für Reaktionen
33
Punkte
338
Hallo,
hast Du mal TX und RX vertauscht?

Gruß Götz
 

timMekk

Benutzer
Mitglied seit
14. Mrz 2014
Beiträge
10
Punkte für Reaktionen
0
Punkte
0
Habe ich gerade mal gemacht. Mit einer Baud von 9600 kamen dann auch endlich mal Hyroglyphen auf screen. Mit einer Baud von 115200 leider gar nichts :/

muss ichdas 3,3v kabel anshließen, oder würde es auch ohne gehen, oder geht es auch mit 5v?
 

timMekk

Benutzer
Mitglied seit
14. Mrz 2014
Beiträge
10
Punkte für Reaktionen
0
Punkte
0
Habemich nun über des Raspberry pi undmit minicom draufgeschaltet. hier habe ich die ausgabe. Leider konnte ich nicht mehr sehen, weil mir dann die buchstaben das Bild verschoben haben.

könnt ihr damit was anfangen?

Rich (BBCode):
L2 cache 256KB: enabled
Using default environment

In:    serial
Out:   serial
Err:   serial

CPLD revision: 1.0
Synology Model: DS-209+II
DRAM Type: DIMM
Fan Status: GSK98#0
Press Ctrl+C to abort autoboot in 2 second
## Booting image at ffc00000 ...
   Image Name:   Linux-2.6.32.12
   Image Type:   PowerPC Linux Kernel Image (gzip compressed)
   Data Size:    1920529 Bytes =  1.8 MB
   Load Address: 00000000
   Entry Point:  00000000
   Verifying Checksum ... ncompressing Kernel Image ... oading RAMDisk Image at ffe00000 ...
   Image Name:   synology_ppc853x_209+II 3246
   Image Type:   PowerPC Linux RAMDisk Image (gzip compressed)
   Data Size:    704774 Bytes = 688.3 kB
   Load Address: 00000000
   Entry Point:  00000000
   Verifying Checksum ... Bad Data CRC
OK
   Booti

U-Boot 1.3.3 (Jan 12 2009 - 10:34:22)

CPU:   8533, Version: 1.1, (0x80340011)
Core:  E500, Version: 2.2, (0x80210022)
Clock Configuration:
       CPU:1067 MHz, CCB: 534 MHz,
       DDR: 267 MHz (534 MT/s data rate), LBC:  33 MHz
L1:    D-cache 32 kB enabled
       I-cache 32 kB enabled
I2C:   ready
DRAM:  Initializing
    DDR: 512 MB
4 MB
L2 cache 256KB: enabled
Using default environment

In:    serial
Out:   serial
Err:   serial

CPLD revision: 1.0
Synology Model: DS-209+II
DRAM Type: DIMM
Fan Status: GPress Ctrl+C to abort autoboot in 2 second
ng image at ffc00000 ...
   Image Name:   Linux-2.6.32.12
   Image Type:   PowerPC Linux Kernel Image (gzip compressed)
   Data Size:    1920Load Address: 00000000
   Entry Point:  00000000
   Verifying Checksum ... OK
   Uncompressing Kernel Image ... OK
## Loading RAMDisk Image at ffe00000 ...
   Image Name:   synology_ppc853x_209+II 3246
   Image Type:   PowerPC Linux RAMDisk Image (gzip compressed)
   Data Size:    704774 Bytes = 688.3 kB
   Load Address: 00000000
   Entry Point:  00000000
   Verifying Checksum ... Bad Data CRC
OK
   Bootiþ

U-Boot 1.3.3 (Jan 12 2009 - 10:34:22)

CPU:   8533, Version: 1.1, (0x80340011)
Core:  E500, Version: 2.2, (0x80210022)
Clock Configuration:
       CPU:1067 MHz, CCB: 534 MHz,
       DDR: 267 MHz (534 MT/s data rate), LBC:  33 MHz
L1:    D-cache 32 kB enabled
       I-cache 32 kB enabled
I2C:   ready
DRAM:  Initializing
 

goetz

Super-Moderator
Teammitglied
Mitglied seit
18. Mrz 2009
Beiträge
13.574
Punkte für Reaktionen
33
Punkte
338
Hallo,
es werden nur RX, TX und GND angeschlossen, keine Spannung.

Gruß Götz
 

timMekk

Benutzer
Mitglied seit
14. Mrz 2014
Beiträge
10
Punkte für Reaktionen
0
Punkte
0
Ich habe nun mit minicom eine log.txt erstellt. http://timmek.marin-schuetz.de/stuff/log.txt

könnt ihr mir sagen was defekt ist und wie ich es beheben kann?

@goetz:
ich habe gesehen, dass du so ein Problem schon mal behoben hast.

Könntest du mich da unterstüzuden? Ich habe alles auf dem PI vorbereitet,dass ich daten auf die NAS übertragen kann.
 
Zuletzt bearbeitet:

goetz

Super-Moderator
Teammitglied
Mitglied seit
18. Mrz 2009
Beiträge
13.574
Punkte für Reaktionen
33
Punkte
338
Hallo,
die RAM-Disk ist defekt,
Verifying Checksum ... Bad Data CRC
Weißt Du welche Version vorher drauf war?
Du extrahierst zImage und rd.bin aus dem .pat File mit der Version die vorher drauf war.
Dann wie hier im unteren Log verfahren.

Gruß Götz
 

timMekk

Benutzer
Mitglied seit
14. Mrz 2014
Beiträge
10
Punkte für Reaktionen
0
Punkte
0
ich hatte vorher 4.2 drauf, meine ich

ich komme leider nicht mal bis zu dem punkt wo ich was eingeben kann. daher kann ich auf der nas keine ip setzen. die fährt sich ganze zeit von alleine hoch und runter.

kann ich das unterbrechen?
 

goetz

Super-Moderator
Teammitglied
Mitglied seit
18. Mrz 2009
Beiträge
13.574
Punkte für Reaktionen
33
Punkte
338
Hallo,
aus Deinem Log
Rich (BBCode):
CPLD revision: 1.0 
Synology Model: DS-209+II 
DRAM Type: DIMM 
Fan Status: GSK98#0 
Press Ctrl+C to abort autoboot in 2 second 
## Booting image at ffc00000 ...
also rechtzeitig Ctrl+c tippen.

Gruß Götz
 

goetz

Super-Moderator
Teammitglied
Mitglied seit
18. Mrz 2009
Beiträge
13.574
Punkte für Reaktionen
33
Punkte
338
Hallo,
die Kommunikation sieht nicht so ganz gut aus, es werden einige Zeichen verschluckt, so sollte es aussehen
Rich (BBCode):
CPLD revision: 1.0
Synology Model: DS-209+II
DRAM Type: DIMM
Fan Status: Good

Net:   SK98#0
Press Ctrl+C to abort autoboot in 2 second
sobald die ersten Zeichen kommen immer hintereinander Ctrl+c tippen.

Gruß Götz
 

timMekk

Benutzer
Mitglied seit
14. Mrz 2014
Beiträge
10
Punkte für Reaktionen
0
Punkte
0
ich bin ja mit nem raspi über das tool minicom verbunden. da passiert nichts. kann ich die zimage datei noch anders hochladen ?
 

goetz

Super-Moderator
Teammitglied
Mitglied seit
18. Mrz 2009
Beiträge
13.574
Punkte für Reaktionen
33
Punkte
338
Hallo,
nein, geht nur so. Du brauchst zwingend eine stabile serielle Verbindung.

Gruß Götz
 

timMekk

Benutzer
Mitglied seit
14. Mrz 2014
Beiträge
10
Punkte für Reaktionen
0
Punkte
0
kannst du ein kabel empfehlen, dass ich dazu nutzen kann, dass ich auch mit windows auf den seriellen port zugreifen kann?
 

goetz

Super-Moderator
Teammitglied
Mitglied seit
18. Mrz 2009
Beiträge
13.574
Punkte für Reaktionen
33
Punkte
338
Hallo,
ich verwende USB Kabel für Siemens Handys bis S55 siehe hier.

Gruß Götz
 

timMekk

Benutzer
Mitglied seit
14. Mrz 2014
Beiträge
10
Punkte für Reaktionen
0
Punkte
0
kannst du mir so ein kabel zuschicken? was würdest du dafür nehmen?
 

goetz

Super-Moderator
Teammitglied
Mitglied seit
18. Mrz 2009
Beiträge
13.574
Punkte für Reaktionen
33
Punkte
338
Hallo,
das müßte ich erst basteln, sorry dazu fehlt mir momentan leider die Zeit.
Teste Dein Kabel noch mal ausgiebig unter Windows mit putty und möglichst alle anderen elektrischen Geräte weit weg stellen.

Gruß Götz
 

timMekk

Benutzer
Mitglied seit
14. Mrz 2014
Beiträge
10
Punkte für Reaktionen
0
Punkte
0
Guten Morgen,

ich habe mir nun auch so ein kabel gekauft und es funktioniert einwandfrei.

Ich habe die Version 4.2 3243 per TFTP hochgeladen und gebootet. Nun ist die NAS auch wieder ansprechbar. Vielen Dank für die Hilfe.
 

mactoolz

Benutzer
Mitglied seit
15. Jul 2009
Beiträge
71
Punkte für Reaktionen
0
Punkte
6
Hallo zusammen,

was für ein Zufall. Das gleiche ist mir auch passiert und seit dem blinkt bei mir auch die beiden Orangen leuchten auf. Die Power leuchte entsprechend auch.
Was ich festgestellt habe ist das sogar die Netzwerkkarte nicht mehr läuft. Das sehe ich an meinem Switch das die Kontroll LEDs nicht mehr leuchten.

Wäre das hier für mich auch eine Option über diesen Seriellen Adapter die Firmware auf zu spielen?

Wenn ja, könnt ihr bitte den Link für diesen Seriellen USB Adapter mal posten und das entsprechende Kabel dafür.

Dann eventuell beschreiben wie man die Firmware aufspielt.

Danke im Voraus


MacToolz
 

goetz

Super-Moderator
Teammitglied
Mitglied seit
18. Mrz 2009
Beiträge
13.574
Punkte für Reaktionen
33
Punkte
338
Hallo,
welche DS hast Du? Ansonsten sind die Links in Beitrag #15 und #7 (DS209+II) angegeben.

Gruß Götz
 
NAS-Central - Ihr Partner für NAS Lösungen
NAS-Central - The Home of NAS

Kaffeautomat

Wenn du das Forum hilfreich findest oder uns unterstützen möchtest, dann gib uns doch einfach einen Kaffee aus.

Als Dankeschön schalten wir deinen Account werbefrei.

:coffee:

Hier gehts zum Kaffeeautomat