Remote-Ordner mit Windows Server 2019

uwe-beach

Benutzer
Mitglied seit
23. September 2016
Beiträge
8
Punkte für Reaktionen
0
Punkte
0
Hallo,

ich versuche auf einer RS815+ mit DSM 6.2.2-24922 Update 6, einen Remote-Ordner von einem Windows Server 2019 per CIFS anzuhängen.
Die Fehlermeldung dabei ist :
"Fehler bei Verbindung mit Remote-Ordner. Bitte stellen Sie sicher, das der Remote Server über das CIFS-Protokoll erreichbar ist"

Im message-log der RS815+ steht :

2020-05-24T16:03:40+02:00 nas01 synoscgi_SYNO.FileStation.Mount_1_mount_remote[13980]: cifsrecord.cpp:87 Fail to mount.cifs \\192.168.15.211\Backup /volume1/NetBackup/ZSW ([115] Success)
2020-05-24T16:03:40+02:00 nas01 synoscgi_SYNO.FileStation.Mount_1_mount_remote[13980]: SYNO.FileStation.Mount.cpp:322 Failed to mount with MAC options. Will retry with sec=ntlm options.
2020-05-24T16:03:50+02:00 nas01 kernel: [3178591.277907] CIFS VFS: Error connecting to socket. Aborting operation.
2020-05-24T16:03:50+02:00 nas01 kernel: [3178591.285500] CIFS VFS: cifs_mount failed w/return code = -115
2020-05-24T16:03:50+02:00 nas01 synoscgi_SYNO.FileStation.Mount_1_mount_remote[13980]: cifsrecord.cpp:87 Fail to mount.cifs \\192.168.15.211\Backup /volume1/NetBackup/ZSW ([115] Success)
2020-05-24T16:03:50+02:00 nas01 synoscgi_SYNO.FileStation.Mount_1_mount_remote[13980]: SYNO.FileStation.Mount.cpp:330 Failed to mount with sec=ntlm options. Will retry with nodfs options.
2020-05-24T16:04:00+02:00 nas01 kernel: [3178601.305875] CIFS VFS: Error connecting to socket. Aborting operation.
2020-05-24T16:04:00+02:00 nas01 kernel: [3178601.313498] CIFS VFS: cifs_mount failed w/return code = -115
2020-05-24T16:04:00+02:00 nas01 synoscgi_SYNO.FileStation.Mount_1_mount_remote[13980]: cifsrecord.cpp:87 Fail to mount.cifs \\192.168.15.211\Backup /volume1/NetBackup/ZSW ([115] Success)
2020-05-24T16:04:00+02:00 nas01 synoscgi_SYNO.FileStation.Mount_1_mount_remote[13980]: SYNO.FileStation.Mount.cpp:360 mount error: 410

Ein
smbclient -U User -t 300 //192.168.15.211/Backup
/etc/samba/smb.reserved.conf not found
Enter User's password:
Connection to 192.168.15.211 failed (Error NT_STATUS_IO_TIMEOUT)
cli_cm_open returned NT_STATUS_IO_TIMEOUT

in der shell der RS815+ schlägt auch fehl.
Das Anhängen eines Remote-Ordners auf der RS815+ von einem Windows 10 Rechner funktioniert.

Das Anhängen des Windows Server-Ordner's an einen anderen Linux-Client per
smbclient -U User -t 300 //192.168.15.211/Backup
funktioniert.


Uwe
 

blurrrr

Benutzer
Mitglied seit
23. Januar 2012
Beiträge
2.478
Punkte für Reaktionen
4
Punkte
78
Gib mal nichts auf die Regeln, die Du beim WS19 vorfindest und erstell Dir mal eine "neue" Regel bzgl. des Zugriffs für das NAS und dann teste nochmal :)
 

uwe-beach

Benutzer
Mitglied seit
23. September 2016
Beiträge
8
Punkte für Reaktionen
0
Punkte
0
Welche Regel meinst du ?
An einem anderen Linux-Client kann ich die Serverfreigabe erfolgreich verbinden.
 

rednag

Benutzer
Mitglied seit
08. November 2013
Beiträge
3.883
Punkte für Reaktionen
0
Punkte
102
Ich vermute @blurrrr meint etwaige Regeln der Firewall.
 

blurrrr

Benutzer
Mitglied seit
23. Januar 2012
Beiträge
2.478
Punkte für Reaktionen
4
Punkte
78
So isses... vermutlich wurde alles andere brav in eine Domäne oder sonstwas gehängt, wie dem auch sei, spielt auch ÜBERHAUPT KEINE ROLLE... wie schon gesagt:

1) Leg eine neue Regel an, für:
- das passende Netzwerk (private/domain/public, musste selbst wissen)
- für den passenden Dienst (ggf. zum testen auch erstmal ANY)
- für den passenden Host (Syno-IP, oder komplette Netz).

2) Sieh zu, dass diese Regel - wenn möglich - noch vor allen anderen steht.

Danach schauen wir dann mal weiter...
 

rednag

Benutzer
Mitglied seit
08. November 2013
Beiträge
3.883
Punkte für Reaktionen
0
Punkte
102
Der TE erwähnt hier aber keine (aktiv beteiligte) Firewall.
Und der Ordner kann auch von einem anderen System erreicht werden.
 

uwe-beach

Benutzer
Mitglied seit
23. September 2016
Beiträge
8
Punkte für Reaktionen
0
Punkte
0
Ja, die Firewall sollte eigentlich keine Rolle spielen.
Auf Client A (aktuelles RHEL) funktioniert das Anhängen mit smbclient,
auf Client B (Synology RS815+) funktioniert das Anhängen weder mit smbclient noch über die Weboberfläche.
Server und beide Client's liegen im gleichen Netz (192.168.15.0/24)
Es gibt keine Domäne.
 

blurrrr

Benutzer
Mitglied seit
23. Januar 2012
Beiträge
2.478
Punkte für Reaktionen
4
Punkte
78
Halt erstmal die grundlegenden Dinge ausschliessen (Kabel scheinen ja gesteckt zu sein)... ;) Wo ich das aber grade nochmal so lese (man ist ja durchaus betriebsblind nach einer Weile)...

"Fail to mount.cifs \\192.168.15.211\Backup"

Müsste es nicht eher "//192.168.15.211/Backup" sein? :eek:

Jut, hab dann auch mal "weiter" gelesen... (ist noch früh...)

Ein
smbclient -U User -t 300 //192.168.15.211/Backup
/etc/samba/smb.reserved.conf not found
Enter User's password:
Connection to 192.168.15.211 failed (Error NT_STATUS_IO_TIMEOUT)
cli_cm_open returned NT_STATUS_IO_TIMEOUT

in der shell der RS815+ schlägt auch fehl.
Das Anhängen eines Remote-Ordners auf der RS815+ von einem Windows 10 Rechner funktioniert.

Das Anhängen des Windows Server-Ordner's an einen anderen Linux-Client per
smbclient -U User -t 300 //192.168.15.211/Backup
funktioniert.
"/etc/samba/smb.reserved.conf not found" finde ich übrigens auch etwas irritierend...
 

uwe-beach

Benutzer
Mitglied seit
23. September 2016
Beiträge
8
Punkte für Reaktionen
0
Punkte
0
Mit einer DS411j mit DSM 6.2.3-25426 funktioniert das Anhängen der WS 2019 Freigabe über smbclient (smbclient -U User -t 300 //192.168.15.211/Backup), allerdings nicht in der Weboberfläche.

Fehlermeldungen in /var/log/messages :

2020-05-26T16:01:01+02:00 srv02 kernel: [37461.200000] CIFS VFS: No response for cmd 114 mid 1
2020-05-26T16:01:01+02:00 srv02 kernel: [37461.200000] CIFS VFS: cifs_mount failed w/return code = -112
2020-05-26T16:01:01+02:00 srv02 synoscgi_SYNO.FileStation.Mount_1_mount_remote[21598]: cifsrecord.cpp:87 Fail to mount.cifs \\192.168.15.211\Backup /volume1/NetBackup/SRV11 ([112] Success)
2020-05-26T16:01:01+02:00 srv02 synoscgi_SYNO.FileStation.Mount_1_mount_remote[21598]: SYNO.FileStation.Mount.cpp:322 Failed to mount with MAC options. Will retry with sec=ntlm options.
2020-05-26T16:01:16+02:00 srv02 kernel: [37476.530000] CIFS VFS: No response for cmd 114 mid 1
2020-05-26T16:01:16+02:00 srv02 kernel: [37476.530000] CIFS VFS: cifs_mount failed w/return code = -112
2020-05-26T16:01:16+02:00 srv02 synoscgi_SYNO.FileStation.Mount_1_mount_remote[21598]: cifsrecord.cpp:87 Fail to mount.cifs \\192.168.15.211\Backup /volume1/NetBackup/SRV11 ([112] Success)
2020-05-26T16:01:16+02:00 srv02 synoscgi_SYNO.FileStation.Mount_1_mount_remote[21598]: SYNO.FileStation.Mount.cpp:330 Failed to mount with sec=ntlm options. Will retry with nodfs options.
2020-05-26T16:01:31+02:00 srv02 kernel: [37491.610000] CIFS VFS: No response for cmd 114 mid 1
2020-05-26T16:01:31+02:00 srv02 kernel: [37491.610000] CIFS VFS: cifs_mount failed w/return code = -112
2020-05-26T16:01:31+02:00 srv02 synoscgi_SYNO.FileStation.Mount_1_mount_remote[21598]: cifsrecord.cpp:87 Fail to mount.cifs \\192.168.15.211\Backup /volume1/NetBackup/SRV11 ([112] Success)
2020-05-26T16:01:31+02:00 srv02 synoscgi_SYNO.FileStation.Mount_1_mount_remote[21598]: SYNO.FileStation.Mount.cpp:360 mount error: 410