Plex Media Server - stoppt und lässt sich nicht mehr starten

wezoromax

Benutzer
Mitglied seit
27. Jun 2016
Beiträge
93
Punkte für Reaktionen
0
Punkte
0
Hallo,

zum bereits zweiten Mal, lässt sich (soeben) das Plex Paket auf meiner DS216j nicht mehr aufrufen oder im DSM starten.
Ich hatte jeweils die neuste Version direkt von Plex für Synology (ARM7) 1.0.3.2461-35f0caa installiert.

Beim ersten Absturz lief es ca. eine Woche, und ich habe relativ kurz vor "Absturz" eine weitere Mediathek (Hörbücher) hinzugefügt.
Diesmal habe ich vor dem Absturz eigentlich nur Dateien/Ordner umbenannt, so dass Plex diese besser selbst zuordnen kann (hatte beim ersten Mal ordentlich Zeit investiert) und auf dem Plex Server nur nach unzugeordneten Filmen geschaut. Nebenbei hat er aber wohl auch nur Musik und Audiobooks indexiert/Metadaten gesammelt.

Versuche ich über das Paket-Zentrum zu starten kommt: Status: starten.... .... ... angehalten. (Letzte Mal kam meiner Meinung nach auch mal Paketdienst konnte nicht gestartet werden, evtl. nach einem Neustart...)

Im Paket-Zentrum-Log Unbenannt.jpg
finde ich nichts Interessantes. Ich meine aber auch, dass dieser Log zu einer Zet aufhört, wie der Plex Server noch lief (spekulation).

Die Logs unter volume1/Plex/.../Logs helfen mir auch nicht viel:
Einige (Media Scanner Analysis, DLNA Server, Chapter Thumbnail, Deep Analysis, ) enden alle gegen 3-5Uhr, also gut 12h vor Absturz (ich meine das war letztes Mal auch so)
Plex Media Scanner.log: (Pfade/Dateien anonymisiert)
Rich (BBCode):
Aug 01, 2016 16:21:58.328 [0x74560000] DEBUG - Skipping hash check, no size match for 5606471 bytes.
Aug 01, 2016 16:21:58.328 [0x74560000] DEBUG - No match for hash.
Aug 01, 2016 16:21:58.346 [0x74560000] DEBUG - Found existing artist by name 41523
Aug 01, 2016 16:22:06.067 [0x74560000] DEBUG - Matched album 'by the way' with 'By the Way'
Aug 01, 2016 16:22:06.457 [0x74560000] DEBUG - Found existing album 'By the Way' by name.
Aug 01, 2016 16:22:06.490 [0x74560000] DEBUG - Downloading document http://127.0.0.1:32400/library/changestamp
Aug 01, 2016 16:22:06.490 [0x74560000] DEBUG - HTTP requesting GET http://127.0.0.1:32400/library/changestamp
Aug 01, 2016 16:22:06.491 [0x74560000] ERROR - Error issuing curl_easy_perform(handle): 7
Aug 01, 2016 16:22:06.491 [0x74560000] WARN - HTTP error requesting GET http://127.0.0.1:32400/library/changestamp (0, No error) (Failed connect to 127.0.0.1:32400; Connection refused)
Aug 01, 2016 16:22:06.491 [0x74560000] ERROR - HTTP -7 downloading url http://127.0.0.1:32400/library/changestamp
Aug 01, 2016 16:22:06.492 [0x74560000] ERROR - Exception inside transaction (inside=1) (../Library/MetadataItem.cpp:2609): Unable to allocate a changestamp from the server
Aug 01, 2016 16:22:06.492 [0x74560000] ERROR - Exception assimilating media item in *ArtistA/AlbumA*: Unable to allocate a changestamp from the server
Aug 01, 2016 16:22:06.493 [0x74560000] DEBUG -       * Scanning *ArtistA/AlbumA*
Aug 01, 2016 16:22:06.493 [0x74560000] DEBUG - Looking for path match for [/volume2/music/*ArtistA/AlbumA/Track3*.mp3]
Aug 01, 2016 16:22:06.890 [0x74560000] DEBUG - Skipping hash check, no size match for 6620231 bytes.
Aug 01, 2016 16:22:06.890 [0x74560000] DEBUG - No match for hash.
Aug 01, 2016 16:22:06.997 [0x74560000] DEBUG - Found existing artist by name 41523
Aug 01, 2016 16:22:15.633 [0x74560000] DEBUG - Matched album 'by the way' with 'By the Way'
Aug 01, 2016 16:22:15.636 [0x74560000] DEBUG - Found existing album 'By the Way' by name.
Erscheint mir auch irrelevant.

Plex Media Server.log:
Rich (BBCode):
/:/plugins/com.plexapp.agents.lastfm/messaging/function/***langesbuchstebenwirrwarr***__ (27 live) GZIP
Aug 01, 2016 14:08:14.756 [0x68e35400] DEBUG - MyPlex: Got response for 6cfcc4b4e84176c8b76b867d2b2c705c4a4b17f1 ~ registered 87.150.163.217:32400
Aug 01, 2016 14:08:14.779 [0x73b11400] DEBUG - Completed after connection close: [127.0.0.1:49476] 200 GET /library/metadata/36955/tree (28 live) GZIP 211201ms 65536 bytes
Aug 01, 2016 14:08:14.791 [0x73dff400] DEBUG - EventSource: Got event [data] '<Message address="87.150.163.217" port="32400" asyncIdentifier="a6284ed3-89b2-4646-88cf-870320e742da" connectivity="1" command="notifyConnectivity"/>'
Aug 01, 2016 14:08:14.944 [0x67323400] DEBUG - Request: [127.0.0.1:49596] GET /:/plugins/com.plexapp.system/messaging/function/***hash??*** (28 live) GZIP
Aug 01, 2016 14:08:16.107 [0x6d0a1400] WARN - Waited one whole second for a busy database.
Aug 01, 2016 14:08:33.531 [0x73b11400] DEBUG - Completed after connection close: [127.0.0.1:49488] 200 GET /library/metadata/36955/tree (27 live) GZIP 220346ms 65536 bytes
Aug 01, 2016 14:08:33.649 [0x73dff400] DEBUG - PubSub: Got notified of reachability: 1 for 87.150.163.217:32400
Aug 01, 2016 14:08:33.632 [0x657ff400] DEBUG - It took 0.0 sec to serialize a list with 26 elements.
Aug 01, 2016 14:08:33.862 [0x73b11400] DEBUG - Completed after connection close: [127.0.0.1:49484] 200 GET /library/metadata/36955/tree (26 live) GZIP 225323ms 65536 bytes
Aug 01, 2016 14:08:33.881 [0x6d0a1400] ERROR - Failed to begin transaction (../Statistics/StatisticsManager.h:183) (tries=2): Cannot begin transaction. database is locked
Aug 01, 2016 14:08:33.820 [0x69411400] DEBUG - HTTP 200 response from GET http://127.0.0.1:47066/:/plugins/com.plexapp.agents.vevo/messaging/function/X0FnZW50S2l0OkVyYXNlTWV0YWRhdGE_/Y2VyZWFsMQoxCmxpc3QKMApyMAo_/Y2VyZWFsMQoxCmRpY3QKMgpzNQpBbGJ1bXMxMAptZWRpYV90eXBlczEzCmxvY2FsOi8vNDc1ODBzNApndWlkcjAK

Be den Plugins habe ich noch ein com.plexapp.system.log gefunden:
Rich (BBCode):
 File "/volume2/@appstore/Plex Media Server/Resources/Plug-ins-35f0caa/Framework.bundle/Contents/Resources/Platforms/Shared/Libraries/urllib2_new.py", line 1192, in do_open
    raise URLError(err)
URLError: <urlopen error [Errno 111] Connection refused>

2016-08-01 16:14:41,557 (734b3460) :  DEBUG (runtime:1156) - Starting timed thread named 'auto_update_thread'
2016-08-01 16:14:42,688 (734b3460) :  INFO (storeservice:356) - Starting automatic update check
2016-08-01 16:14:44,575 (734b3460) :  DEBUG (runtime:1117) - Created a thread named 'remove_unavailable_agents'
2016-08-01 16:14:47,077 (734b3460) :  DEBUG (networking:166) - Requesting 'https://plugins.plex.tv/apps/all.json?frameworkVersion=2.6.3&machineIdentifier=6cfcc4b4e84176c8b76b867d2b2c705c4a4b17f1&os=Linux&osVersion=3.10.77%20%28%237393%20SMP%20Thu%20Jun%202%2019%3A49%3A11%20CST%202016%29&cpu=armv5tel&serverVersion=1.0.3.2461-35f0caa&systemRevision=35f0caa'
2016-08-01 16:14:54,622 (734b3460) :  INFO (storeservice:495) - No beta plugins.
2016-08-01 16:14:56,973 (71d43460) :  INFO (datakit:131) - Saved the dictionary file
2016-08-01 16:14:56,994 (734b3460) :  INFO (storeservice:531) - 'Services' plug-in [com.plexapp.system.services] is up to date (181fb80)
2016-08-01 16:14:57,010 (734b3460) :  INFO (storeservice:362) - All plug-ins are up to date
2016-08-01 16:14:57,187 (734b3460) :  DEBUG (runtime:1150) - Scheduled a timed thread named 'auto_update_thread'

Mit der .dmp Datei aus dem Crash Report kann ich leider nichts anfangen...

Bei einem ähnlichen Problem wurde nach der "plexmediaserver.pid" gefragt, diese ist vorhanden (nicht nur während eines Startversuchs)




Ich habe kein Problem damit, den Server nochmal neu zu installierne und einzurichten. Aber nicht alle zwei Tage. Deshalb würde ich schon gern das Problem ausmachen.
In einem anderen Thread wurde beschrieben, dass die Video Station Probleme macht. Ich möchte die beiden aber gerne parallel nutzen.
(Plex ist für mich schöner am Rechner (WebApp) wohingegen über Chromecast / Android die Plex Apps ja nur gegen Geld funktionieren. Die VideoStation Webapp spielt bei mir praktisch/gar nichts ab.)

Hat jemand eine Idee, wo/wie ich noch auf Fehlersuche gehen könnte?
 

Anhänge

  • Unbenannt.jpg
    Unbenannt.jpg
    27,5 KB · Aufrufe: 63

Fusion

Benutzer
Mitglied seit
06. Apr 2013
Beiträge
12.864
Punkte für Reaktionen
538
Punkte
384
Die einmalig paar Euro für die Plex App auf Android, für die free Variante.

Wichtig ist nur das Plex Media Server.log
Kannst du da noch ein wenig Zusammenhang herstellen, welche Zeiten z.B: den versuchten Paket-Neustart zeigen etc. oder ob da gar keine Einträge stattfinden etc?
 

wezoromax

Benutzer
Mitglied seit
27. Jun 2016
Beiträge
93
Punkte für Reaktionen
0
Punkte
0
Ja, 4€nochwas für mich einmalig, find ich für ne App schon teuer. Aber möchte ich dann noch andern Leuten (family) Zugriff geben, müssten die auch wieder bezahlen. Und so oft nutze ich den Medienserver jetzt auch nicht. Scheint mir bei der Videostation übrigens auch ein Vorteil, dass ich dort die Zugriffe verwalten kann ;) Wäre bei Plex wohl maximal mit PlexPass möglich

Versuchte Neustarte waren so gegen 16Uhr 16:30 ~ diese tauchen im Media Server.log überhaupt nicht auf.
Ich kann nicht genau sagen, ab wann Schluss war, gegen 15~ Uhr wohl, evtl früher.
Lediglich Einträge in der com.plexapp.system.log -> beim Neustart aber keine, also 16:14 evtl. letzte "Tätigkeit" hier

In der Media Scanner.log kann ich die restart versuche nachvollziehen:
Die ganze Datei voll davon, ca 45sekunden. In der Datei davor (.1.log) fand ich etwas abweichendes, "normales Media Scanning"
Kann gerne auch die vollen logfiles bringen (pastebin), aber ich denke bisher das nützt nichts.

..
Aug 01, 2016 18:08:05.989 [0x74560000] DEBUG - Adding file for scanner: /volume2/***musikpfad***/datei1
Aug 01, 2016 18:08:05.989 [0x74560000] DEBUG - Adding file for scanner: /volume2/***musikpfad***/datei2
Aug 01, 2016 18:08:05.989 [0x74560000] DEBUG - Adding file for scanner: /volume2/***musikpfad***/datei3
Aug 01, 2016 18:08:06.776 [0x74560000] DEBUG - * Scanning ***Artist/Album***
Aug 01, 2016 18:08:06.777 [0x74560000] DEBUG - Looking for path match for [/volume2/music/***musikpfad***/datei4]
Aug 01, 2016 18:08:06.779 [0x74560000] DEBUG - Skipping hash check, no size match for 1990738 bytes.
Aug 01, 2016 18:08:06.779 [0x74560000] DEBUG - No match for hash.
Aug 01, 2016 18:08:06.792 [0x74560000] DEBUG - Creating artist '***artist***'
...
Aug 01, 2016 18:10:27.911 [0x724ff400] ERROR - HTTP -7 downloading url http://127.0.0.1:32400/library/changestamp
Aug 01, 2016 18:10:27.911 [0x724ff400] ERROR - Exception in worker thread: Unable to allocate a changestamp from the server
Aug 01, 2016 18:10:27.915 [0x733ca400] DEBUG - Downloading document http://127.0.0.1:32400/library/changestamp
Aug 01, 2016 18:10:27.915 [0x733ca400] DEBUG - HTTP requesting GET http://127.0.0.1:32400/library/changestamp
Aug 01, 2016 18:10:27.916 [0x733ca400] ERROR - Error issuing curl_easy_perform(handle): 7
Aug 01, 2016 18:10:27.916 [0x733ca400] WARN - HTTP error requesting GET http://127.0.0.1:32400/library/changestamp (0, No error) (Failed connect to 127.0.0.1:32400; Connection refused)
Aug 01, 2016 18:10:27.917 [0x733ca400] ERROR - HTTP -7 downloading url http://127.0.0.1:32400/library/changestamp
Aug 01, 2016 18:10:27.917 [0x733ca400] ERROR - Exception in worker thread: Unable to allocate a changestamp from the server
 

wezoromax

Benutzer
Mitglied seit
27. Jun 2016
Beiträge
93
Punkte für Reaktionen
0
Punkte
0
Also, ich werd eben Trial & Error nachgehen.
ALso Plex löschen, und neuinstallieren. Dabei erst mal nur Video Mediatheken.

Falls wieder Probleme, werd ich die Video Station mal abschalten (vorm löschen + Neuinstall von Plex)

Okay, eben installiert. Einstellungen gemacht. Zwei Mediatheken (Filme + Serien) hinzugefügt. Nochmal Einstellung der Mediathek aufgerufen. und weg.

Morgen mal die Protokolle checken, ob sich was neues / ähnliches findet. Hatte ein paar Debug Optionen bzw. erweiterte Protokolle aktiviter....
 
Zuletzt bearbeitet:

wezoromax

Benutzer
Mitglied seit
27. Jun 2016
Beiträge
93
Punkte für Reaktionen
0
Punkte
0
Also die gute Nachricht:

Mit nur Video-Mediatheken und ausgeschalteter VideoStation läuft Plex jetzt schon länger durch.

Die schlechte Nachricht: niemand weiß warum und wie sich Videostation und Plex so böse in die Haare kriegen.

Auch bei den letzten Protokollen konnte ich nichts neues erkennen. Einfach "Ende".
 
NAS-Central - Ihr Partner für NAS Lösungen