PHP Datei lässt sich nicht anwählen

GeoPacMan

Benutzer
Mitglied seit
02. Dezember 2019
Beiträge
2
Punkte für Reaktionen
0
Punkte
0
Hallo,
ich bin neu hier und arbeite gerade an einem Projekt bei dem ich einen ESP32 Microcontroller im WLAN verwende, um Daten auf die NAS zu schreiben.
Nachdem ich mich ins WLAN einloggen kann, habe ich versucht mittels eines GET Befehls eine PHP Datei auf der NAS anzusprechen. Da bin ich dran verzweifelt. Da ich vermutet habe, dass es ggf. der Passwort Schutz war, versuche ich jetzt erst mal eine PHP Datei auf der NAS von meinem Browser aus aufzurufen.

Ich habe eine DS212j und habe Webstation, PHP 7.0 und 7.3 sowie Apache http Server 2.4 installiert.
Mein Versuchsaufbau:
Ich habe die PHP Datei „login.php“ in dem Verzeichnis „Daten-Exchange“ auf Volume1 gelegt
Der Ordner ist freigegeben für den user „guest“ mit Passwort „pwtest“

Inhalt der Datei:
<?php
echo "Test eingeloggt"
?>

Beim Aufrufen habe ich verschiedenes probiert:
1. http://192.168.178.48/Daten-Exchange/login.php?user=guest&pass=pwtest
2. http://192.168.178.48:5000/ Daten-Exchange/login.php?user=guest&pass=pwtest
3. http://192.168.178.48/ Daten-Exchange/login.php?
Fehlermeldung 1+3: Fehler 500
Fehlermeldung 2: Synology: Es tut uns Leid, die von Ihnen gesuchte Seite konnte nicht gefunden werden.

Ich mache bestimmt einiges falsch. Wer kann mir helfen?
GeoPacMan
 

DustFireSky

Benutzer
Mitglied seit
22. September 2014
Beiträge
204
Punkte für Reaktionen
7
Punkte
24
Website
www.german-syslinux-blog.de
Also bei deiner Echozeile fehlt schon mal das Semikolon am Ende => ;

Das wird aber zu 100% nicht der Fehler für den HTTP Statuscode 500 sein. Denn bei so einem Fehler (vergessenes Semikolon) kommt nur der bekannte schöne weiße Bildschirm mit schwarzem Fehlertext. Wahrscheinlicher ist eine fehlerhafte .htaccess Datei im besagten Verzeichnis, wo auch die login.php liegt. Vorausgesetzt, dass dein Daten-Exchange Verzeichnis der Webroot ist. Es kann auch sein, dass diese eine Ebene höher liegt, aber ich kenne dein gesamtes Konstrukt nicht. Der 500er Code ist aber nicht immer so einfach einzugrenzen. Es kann auch an was völlig anderem liegen. Nur das mit der .htaccess Datei ist der am meisten verbreitete Auslöser für einen Statuscode 500.
 

GeoPacMan

Benutzer
Mitglied seit
02. Dezember 2019
Beiträge
2
Punkte für Reaktionen
0
Punkte
0
Ich habe keine .htaccess Datei gefunden. Daher habe ich eine aus dem Internet gezogen. Ich hoffe das geht. Den Inhalt füge ich unten an. Ich habe die Datei ins gleiche Verzeichnis wie die login.php gelegt.
Leider komme ich mit meinen 3 Varianten die gleichen Ergebnisse.

Datei .htaccess

Options All -Indexes

DirectoryIndex index.php index.htm index.html

RewriteEngine on
RewriteBase /

# Force HTTPS on the subdomains/subdirectories login or admin
#RewriteCond %{HTTPS} off
#RewriteCond %{HTTP_HOST} ^(login|admin)\. [NC]
#RewriteCond %{REQUEST_URI} ^(login|admin)\. [NC,OR]
#RewriteRule (.*) https://%{HTTP_HOST}%{REQUEST_URI} [R=301,L]

# Force WWW if no subdomain is given
RewriteCond %{HTTP_HOST} ^[^.]+\.[^.]+$
RewriteCond %{HTTP_HOST} !^$
RewriteCond %{HTTPS}s ^on(s)|
RewriteRule ^ http%1://www.%{HTTP_HOST}%{REQUEST_URI} [R=301,L]