OpenVPN + Pihole

tamen

Benutzer
Mitglied seit
29. Okt 2020
Beiträge
17
Punkte für Reaktionen
0
Punkte
1
Hallo,
ich habe einen DS218+ auf dem ich mit OpenVPN von außerhalb meines Netzwerks zugreifen kann. Außerdem befindet sich innerhalb meines Netzwerkes ein Raspberry Pi mit Pihole. Wenn ich von außerhalb meines Netzwerkes per VPN verbinde klappt soweit auch alles, ich kann jede interne-IP ansteuern und habe keine Probleme, außer dass die Werbung nicht vom Pihole geblockt wird. Natürlich funktioniert der Pihole innerhalb das Netzwerkes ohne VPN Verbindung

Was ich bisher versucht habe:
  • Ich habe in der VPNConfig.ovpn unter "dhcp-option" die Raute entfernt und die IP des Piholes hinzugefügt (192.168.x.x).
  • Außerdem habe ich in den Netzwerkeinstellungen des NAS den DNS-Server manuell konfiguriert. Ich habe bei primär und sekundär die die Pihole-IP eingetragen.
Mehr leider nicht, weil ich auch nicht weiß, was ich tun soll. Wenn ich nach diesem Problem google finde ich viele Beiträge, wo dieses Problem nicht gelöst wurde bzw. wurde oft nicht ein Synology NAS für die VPN Verbindung verwendet. Ich habe schonmal versucht Konfigurationsdateien von OpenVPN zu finden, damit ich dort einen DNS-Server eintragen kann. Ich würde mich sehr freuen, wenn ich hier Hilfe finde.

Viele Grüße
 

the other

Benutzer
Mitglied seit
17. Okt 2015
Beiträge
1.097
Punkte für Reaktionen
183
Punkte
89
Moinsen,
auch hier nutze ich NICHT den openVPN Server des NAS.
Normalerweise kannst du aber angeben, welcher DNS Server genutzt werden soll (bzw Resolver wie etwa Pihole, dann dessen IP eintragen). Hier ein link (der untere Teil könnte interessant sein):

Du könntest davon ab aber auch mal grundsätzlich überlegen, ob du nicht vielleicht den VPN Server vom NAS entfernst und zB deine Himbeere nutzt. Hätte den Vorteil, dass dort dann meist umfangreicher konfiguriert werden kann und vor allem, dass der VPN Server vom NAS auf ein anderes, eher in der Netzperipherie angesiedeltes Gerät kommt, was deine Sicherheit im Heimnetz erhöht.
 
  • Like
Reaktionen: tamen

Puppetmaster

Benutzer
Mitglied seit
03. Feb 2012
Beiträge
17.823
Punkte für Reaktionen
164
Punkte
439
In der Konfig von openVPN auf dem Client muss auch

Code:
dhcp-option DNS <IP.VON.PIHOLE>

angegeben sein. Dann klappt's auch mit der Werbung. ;-)
 
  • Like
Reaktionen: blurrrr und tamen

tamen

Benutzer
Mitglied seit
29. Okt 2020
Beiträge
17
Punkte für Reaktionen
0
Punkte
1
Vielen dank für eure schnelle Antworten.

@the other: ich hatte auch schon darüber nachgedacht PiVPN auf den Raspberry zu installieren oder das Pihole und den OpenVPN auf dem NAS laufen zu lassen. Aber dein Beitrag find ich gut und werde darüber nachdenken, vielen Dank.

@Puppetmaster: so klappt es tatsächlich. In meiner Config file hatte ich hinter "dhcp-option" direkt die IP des Piholes. Vielen Dank!
 
  AdBlocker gefunden!

Du bist nicht hier, um Support für Adblocker zu erhalten, denn dein Adblocker funktioniert bereits ;-)

Klar machen Adblocker einen guten Job, aber sie blockieren auch nützliche Funktionen.

Das Forum wird mit einem hohen technischen, zeitlichen und finanziellen Aufwand kostenfrei zur Verfügung gestellt. Wir zeigen keine offensive oder Themen fremde Werbung. Bitte unterstütze dieses Forum, in dem du deinen Adblocker für diese Seite deaktivierst.