Nach Update von Docker (17.05.0-401 => 18.09.0-0513) kann ich kein Image mehr downloaden

christofk

Benutzer
Mitglied seit
11. Juli 2009
Beiträge
21
Punkte für Reaktionen
0
Punkte
1
Hallo,
ich habe vor kurzem den Docker Dienst auf meiner DS218+ upgedated.
Alle Container fahren sauber hoch, soweit OK.
Jetzt wollte ich einen Container updaten und sehe, dass ich gar kein Image mehr ziehen kann.
Die Docker Registry kann ich aber erfolgreich durchsuchen. Ich habe z.B. python ausgewählt und sehe auch alle verfügbaren Tags. Dann startet vermeintlich der Download, jedoch ohne Erfolg.
In /var/log/messages sehe ich nur die Fehlermeldung
DS218plus synoscgi_SYNO.Docker.Image_1_pull_start[6513]: image.cpp:889 Image pull failed, statusCode: [500], errMsg [{"message":"Get https://registry-1.docker.io/v2/: net/http: request canceled while waiting for connection (Client.Timeout exceeded while awaiting headers)"}]
Auch ein
Bash:
docker pull python:3.7.8-buster
ergibt nur die Fehlermeldung
Error response from daemon: Get https://registry-1.docker.io/v2/: net/http: request canceled while waiting for connection (Client.Timeout exceeded while awaiting headers)

Ich nutze zwar PiHole in einem eigenen Container, es hat aber vorher ohne Probleme funktioniert und auch wenn ich PiHole abschalte, erhalte ich das gleiche Problem.

Auch ein Reboot hat nicht geholfen.

Hat jemand einen Tip?
Danke
Christof
 

Der Paul

Benutzer
Mitglied seit
04. Februar 2014
Beiträge
73
Punkte für Reaktionen
2
Punkte
8
Trag mal die IP Deines Routers als primärem DNS der DiskStation ein und versuche es dann noch einmal - nur, um PI Hole als Fehlerquelle wirklich auszuschließen...
 

christofk

Benutzer
Mitglied seit
11. Juli 2009
Beiträge
21
Punkte für Reaktionen
0
Punkte
1
Hi,
schräg, mit Googles DNS 8.8.8.8 ging es....komisch ist, dass es vorher immer funktioniert hat - auch mit aktivem PiHole.
Auch habe ich bei PiHole im Query-Log keine geblockte Adresse entdeckt.

Irgend eine Idee, was falsch laufen kann?
Danke
Christof
 

Der Paul

Benutzer
Mitglied seit
04. Februar 2014
Beiträge
73
Punkte für Reaktionen
2
Punkte
8
Wie läuft denn Dein PiHole Container? Eigenes macvlan plus bridge?
 

christofk

Benutzer
Mitglied seit
11. Juli 2009
Beiträge
21
Punkte für Reaktionen
0
Punkte
1
Hi,
wie Du vermutet hast, läuft PiHole mit eigenem MacVlan + Bridge.
Bis vor dem Update von Docker hat das Pull eines Images auch wunderbar funktioniert.
Auch sehe ich in PiHole, dass bei einem Pull die Adresse registry-1.docker.io angefragt und aufgelöst wurde.
Die Docker-Hub Registry durchsucht die Synology Docker-App auch erfolgreich. Es ist also kein prinzipielles Problem, nur das Pull geht nicht.
Schräg......
Screenshot.png
Bin für jeden Tip dankbar!
Bis dann
Christof
 

Der Paul

Benutzer
Mitglied seit
04. Februar 2014
Beiträge
73
Punkte für Reaktionen
2
Punkte
8
Was liefert denn curl -I https://registry-1.docker.io/v2/python/manifests/3.7.8-buster zurück? Ebenfalls einen Timeout, oder ein (in dem Fall normales) 401?
 

christofk

Benutzer
Mitglied seit
11. Juli 2009
Beiträge
21
Punkte für Reaktionen
0
Punkte
1
Hi,
Curl funktioniert:
Code:
root@DS218plus:~# docker pull python:3.7.8-slim-buster
Error response from daemon: Get https://registry-1.docker.io/v2/: net/http: request canceled while waiting for connection (Client.Timeout exceeded while awaiting headers)

root@DS218plus:~# curl -I https://registry-1.docker.io/v2/python/manifests/3.7.8-buster
HTTP/1.1 401 Unauthorized
Content-Type: application/json
Docker-Distribution-Api-Version: registry/2.0
Www-Authenticate: Bearer realm="https://auth.docker.io/token",service="registry.docker.io",scope="repository:python:pull"
Date: Mon, 13 Jul 2020 21:05:36 GMT
Content-Length: 149
Strict-Transport-Security: max-age=31536000

Hilft das weiter?
Danke schon einmal soweit!
Christof
 

Der Paul

Benutzer
Mitglied seit
04. Februar 2014
Beiträge
73
Punkte für Reaktionen
2
Punkte
8
Nutzt Du in Deinem Netz IPv6? Falls ja: bitte mal deaktivieren. Und: hast Du ggf. eine DockerID? Falls ja: mal docker login versuchen, evtl. könnte es auch daran liegen. Was ist denn der DNS Forwarder im PI Hole? Dein Router? Dann wäre zu prüfen, welchen DNS der verwendet. Im Zweifelsfall dort dann auch mal die 8.8.8.8 eintragen. Wenn es dann tut, liegt es imho nicht am Pi Hole...
 

christofk

Benutzer
Mitglied seit
11. Juli 2009
Beiträge
21
Punkte für Reaktionen
0
Punkte
1
Danke...dann probiere ich mal die Optionen durch melde mich, wenn ich etwas rausbekommen habe.
 

christofk

Benutzer
Mitglied seit
11. Juli 2009
Beiträge
21
Punkte für Reaktionen
0
Punkte
1
So, ich hoffe, Du liest noch mit.
Der Tip mit IPv6 war es.
Wenn ich in der Synology den DNS auf manuell stelle, bei IPv4 die PiHole Adresse drin lasse und den Eintrag bei IPv6 lösche, geht es.
Leider stehe ich nun auf dem Schlauch, was die Ursache ist und wie ich das beheben kann

Ich hoffe, es gibt noch einen Tip.
Danke
Christof
 

Der Paul

Benutzer
Mitglied seit
04. Februar 2014
Beiträge
73
Punkte für Reaktionen
2
Punkte
8
Ist Dein macvlan denn auch als Dual Stack konfiguriert? Ansonsten laufen die IPv6 Anfragen ja von der DS aus ins Leere...
 

_107

Benutzer
Mitglied seit
12. Januar 2014
Beiträge
47
Punkte für Reaktionen
0
Punkte
6
Hallo, ich hab dasselbe Problem, ich kann seit kurzem keine Images mehr downloaden. Ich bekomme immer die Meldung
"Download von Docker-Image docker.io/... fehlgeschlagen. Weitere Informationen finden Sie im Docker-Protokoll."
Log zeigt jedoch keine Fehler oder Warnungen an. Ich hab auch schon versucht, mit unterschiedlichen DNS-Einträgen im DSM und/oder Fritzbox, aber das zeigt keine Wirkung...
Vor ein paar Wochen ging's noch absolut ohne Probleme. PiHole hab ich nicht.

Hat jemand ne Idee oder ne Lösung zu dem Problem?
DS216+2, DSM 6.2.3-25426 Update 2, Docker 19.09.0 -0513
 

TeXniXo

Benutzer
Mitglied seit
07. Mai 2012
Beiträge
4.948
Punkte für Reaktionen
98
Punkte
134
Probier doch mal aus Testgründen mit anderen Quellen deiner Images? (also neben docker.io), ob die Meldung weiterhin auftaucht. Sonst kann man davon ausgehen, dass die Quelle "kaputt" ist.
 

haydibe

Benutzer
Mitglied seit
12. April 2016
Beiträge
743
Punkte für Reaktionen
13
Punkte
38
Aus irgendeinem Grund existiert in cat /root/.docker/config.json ein Token für Kommunikation mit " "https://index.docker.io/v1/".
Für die public Images auf Dockerhub ist das nicht notwendig. Versuch die Pull aktion nochmal nach einem docker logout.
 

_107

Benutzer
Mitglied seit
12. Januar 2014
Beiträge
47
Punkte für Reaktionen
0
Punkte
6
Danke euch! Ich hab das leider noch nicht testen können, ich bin mit SSH noch nicht so vertraut, ich hab bisher die Container immer übers GUI eingerichtet und gestartet.
Vielleicht könnt ihr mir hierbei etwas unter die Arme greifen?
Probier doch mal aus Testgründen mit anderen Quellen deiner Images
Kannst du mir andere Quellen sagen? Ich hab danach gegoogelt, hab aber keine funktionierende Quelle eintragen können.

Versuch die Pull aktion nochmal nach einem docker logout.
Wie mach ich das? docker logout funktionierte übers SSH-Terminal nicht. Als root eingeloggt ist klar, soweit war ich schon...
 

haydibe

Benutzer
Mitglied seit
12. April 2016
Beiträge
743
Punkte für Reaktionen
13
Punkte
38
Wie mach ich das? docker logout funktionierte übers SSH-Terminal nicht. Als root eingeloggt ist klar, soweit war ich schon...
:unsure:Bei mir funktioniert das auf einer Root-Shell (sudo -i) genau mit dem angegeben Befehl.
 
Zuletzt bearbeitet:

_107

Benutzer
Mitglied seit
12. Januar 2014
Beiträge
47
Punkte für Reaktionen
0
Punkte
6
A5236493-247F-408F-9B9F-0DF7B3BB6B3B.jpeg

Bin scheinbar garnicht eingeloggt...
 

haydibe

Benutzer
Mitglied seit
12. April 2016
Beiträge
743
Punkte für Reaktionen
13
Punkte
38
Das es in diesem Fall nicht das Problem war und etwas anderes die Ursache ist.
 
  AdBlocker gefunden!

Du bist nicht hier, um Support für Adblocker zu erhalten, denn dein Adblocker funktioniert bereits ;-)

Klar machen Adblocker einen guten Job, aber sie blockieren auch nützliche Funktionen.

Das Forum wird mit einem hohen technischen, zeitlichen und finanziellen Aufwand kostenfrei zur Verfügung gestellt. Wir zeigen keine offensive oder Themen fremde Werbung. Bitte unterstütze dieses Forum, in dem du deinen Adblocker für diese Seite deaktivierst.