Medienserver zeigt keine Dateien mehr an

Rufus19

Benutzer
Mitglied seit
21. Oktober 2020
Beiträge
3
Punkte für Reaktionen
0
Punkte
1
Ort
Berlin
Hallo,
betreibe eine DS218j in Kombination mit einem Linux-Rechner (Mint 19.3) und wollte den Medienserver einrichten. Leider habe ich dabei scheinbar nun einiges durcheinander gebracht, so dass der Medienserver keine Dateien mehr aus den Standardpfaden /music, /photo und /video findet bzw. anzeigt (per Samsung TV). Leider weiß nicht, wie ich es wieder hinkriege.

Meine Idee war, die genannten drei Pfade der Synology auf dem Rechner per fstab zu mounten, damit ich dann die gewünschten Dateien per Backup-Programm da hinein kopieren kann.

Ablauf so ungefähr anhand eines Beispiels:
$ sudo mkdir /media/NAS-Musik
fstab-Eintrag:
192.168.178.48:/volume1/music /media/NAS-Musik nfs noauto,users,rw,nosuid,dev,exec,async

Das hat eigentlich auch korrekt geklappt, konnte aber vom Linux Rechner noch nicht auf den Pfad zugreifen und habe daher die Rechte für den Pfad/Dateien umgestellt per:
$ sudo chown -R -v $USER:$USER /media/NAS-Musik
$ chmod 777 /media/NAS-Musik

Leider trat danach das Problem auf (Medienserver zeigt keine Dateien mehr an).

Habe nun versucht den Medienserver neu zu installieren, hat aber nicht die erhoffte Wirkung gebracht, ändern von $USER auf $root war ebenfalls erfolglos, ebenso wie diverese Versuche mit unterschiedlichen Rechten per chmod.
Auch wenn ich Dateien direkt über den Diksmanager in die Pfade hineinkopiere werden sie nicht angezeigt.

Irgendwelche guten Ideen?
 

Benares

Benutzer
Mitglied seit
27. September 2008
Beiträge
3.715
Punkte für Reaktionen
78
Punkte
108
An den Berechtigungen der Gemeinsamen Ordner sollte man besser nicht mit Shell-Befehlen rumfummeln, erst recht nicht bei den vordefinierten Systemordnern (photo, video, music, ...) und schon gar nicht remote über NFS. Ich fürchte, mit dieser Aktion hast du dir die Berechtigungsstruktur von /volume1/music zerschossen.

Ich sehe da nur 2 Lösungswege:
Entweder den Ordner music umbenennen, den Medienserver nochmal neu installieren, hoffen, dass dabei music neu entsteht, und dann die Inhalte umkopieren, oder

Mit dem Tool synoacltool versuchen, die Rechte wiederherzustellen. Mir scheinen z.B. die Rechte von video und music auf den ersten Blick identisch zu sein, zumindest ist das bei mir so:
Code:
root@DS415:/volume1# ls -als
    40 drwxrwxrwx+   4 root                users                   36864 Sep 23  2018 music
    72 drwxrwxrwx+   5 root                users                   65536 Jul 25 13:20 video

root@DS415:/volume1# synoacltool -get music
ACL version: 1
Archive: has_ACL,is_support_ACL
Owner: [root(user)]
---------------------
         [0] user:hpclj2:deny:rwxpdDaARWcCo:fd--  (level:0)
         [1] user:admin:allow:rwxp-DaARWc--:---n  (level:0)
         [2] group:boxusers:allow:r-x---a-R-c--:fd--  (level:0)
         [3] everyone::allow:rwxp-DaARWc--:---n  (level:0)
         [4] group:boxadmins:allow:rwxpdDaARWc--:fd--  (level:0)

root@DS415:/volume1# synoacltool -get video
ACL version: 1
Archive: has_ACL,is_support_ACL
Owner: [root(user)]
---------------------
         [0] user:hpclj2:deny:rwxpdDaARWcCo:fd--  (level:0)
         [1] user:admin:allow:rwxp-DaARWc--:---n  (level:0)
         [2] group:boxusers:allow:r-x---a-R-c--:fd--  (level:0)
         [3] everyone::allow:rwxp-DaARWc--:---n  (level:0)
         [4] group:boxadmins:allow:rwxpdDaARWc--:fd--  (level:0)
Man könnte daher versuchen die Rechte zu kopieren, z.B. mit
Code:
synoacltool -copy video music

Schau dir mal die Hilfe von synoacltool an (synoacltool -h)
 

Rufus19

Benutzer
Mitglied seit
21. Oktober 2020
Beiträge
3
Punkte für Reaktionen
0
Punkte
1
Ort
Berlin
Leider habe ich urspünglichen Rechte von /video und /photo auch schon überschrieben :-(, so dass das Kopieren der Konfig leider nicht mehr geht.
"ls -als" gibt bei mir folgendes aus:

insgesamt 4384
4 dr-xr-xr-x 3 ralph ralph 4096 Okt 21 09:27 .
4 drwxr-xr-x 8 root root 4096 Okt 21 09:23 ..
4376 -rwxrwxrwx 1 ralph ralph 4478976 Dez 28 2013 '01 Patricia

Mit welchen Parametern müßte ich per chmod die Rechte ändern, so dass es wie bei Dir auf "... root users ..." umgestellt wird?

Ich habe an anderer Stelle noch folgenden Hinweis gefunden:
"I found that if you modify the permissions on a file or folder with chmod then this seems to wipe out the ACL information."
Das würde sich m.M. nach mit Deiner Analyse decken, nur wüßte ich noch nicht, wie ich es wieder korrigiere.
 

Benares

Benutzer
Mitglied seit
27. September 2008
Beiträge
3.715
Punkte für Reaktionen
78
Punkte
108
Mmh, für die Linux-Grundrechte sollte "chown root:users /volume1/music" und "chmod 777 /volume1/music" reichen, aber die ACLs fehlen dann noch.

Dann hilft wohl nur Variante 1 - wenigsten erstmal mit einem der beiden Ordner video oder music probieren und danach wie ACLs kopieren.
Ich habe bei mir kein Verzeichnis gefunden, das man sonst als Kopiervorlage verwenden könnte.

PS: photo scheint nicht mit ACLs zu arbeiten
Code:
root@DS415:/volume1# synoacltool -get photo
(synoacltool.c, 359)It's Linux mode
 

BerndByNas

Benutzer
Mitglied seit
20. September 2020
Beiträge
7
Punkte für Reaktionen
0
Punkte
1
Ich hab da mal ne vielleicht dumme Idee. Falls Du mit einem web-Browser auf die NAS kommst mal versuchen mittels der Filestation
die Rechte eines Ordners zu ändern. Wenn Du an die files mittels Filestation rankommest, dann kann man auch alle Dateien in einen beliebigen neuen Ordner verschieben und den alten löschen und einen neuen "music" anlegen. Das hat bei mir vor langer Zeit funktioniert. Man kann das auch in der Systemsteuerung - Gemeinsamer Ordner durchführen.
Viel Erfolg.
 

Rufus19

Benutzer
Mitglied seit
21. Oktober 2020
Beiträge
3
Punkte für Reaktionen
0
Punkte
1
Ort
Berlin
Hallo,
habe per Telnet auf den NAS zugegriffen und die alten Ordner /music, /photo und /video erst umbenannt und dann gelöscht (über die Filestation ging das nicht).
Danach habe ich die genannten Ordner neu angelegt.
Der Medienserver kommt nun an Inhalte ran und ich kann mir Musik/Bilder etc. per Fernseher anhören/-sehen.
So richtig perfekt ist das aber noch nicht, da z.B. für Fotos in Übersichten keine Vorschaubilder angezeigt werden.

Habe dann versucht, per "Berechtigungen" über die NAS Nutzeroberfläche die Zugriffe zu erleichtern und auch Lese-/Schreibrechte zu geben, das hat aber nicht funktioniert. Außer, dass nun alle Unterordner von /photo defekt sind :-(((
 

BerndByNas

Benutzer
Mitglied seit
20. September 2020
Beiträge
7
Punkte für Reaktionen
0
Punkte
1
Das mit den Vorschaubildern ist so eine Sache. Der Indizierungsdienst der NAS arbeitet wahrscheinlich noch, denn das dauert bei einigen tausend Bildern schon mal ein paar Tage. Erstellt werden dabei die sogenannten "@eaDir" - Verzeichnisse, in denen ähnlich wie bei Windows thumb.db erstellt werden. Also muss man einfach mal ein paar Tage warten und dann sind die Vorschaubilder auch wieder da. Auch vergewissern, dass unter Systemsteuerung - Indizierungsdienst der Status auf abgeschlossen steht. 1605205997954.png
 
  AdBlocker gefunden!

Du bist nicht hier, um Support für Adblocker zu erhalten, denn dein Adblocker funktioniert bereits ;-)

Klar machen Adblocker einen guten Job, aber sie blockieren auch nützliche Funktionen.

Das Forum wird mit einem hohen technischen, zeitlichen und finanziellen Aufwand kostenfrei zur Verfügung gestellt. Wir zeigen keine offensive oder Themen fremde Werbung. Bitte unterstütze dieses Forum, in dem du deinen Adblocker für diese Seite deaktivierst.