iSCSI Manger funktioiert mit DSM 6.2-23739 nicht mehr

thoschi1211

Benutzer
Mitglied seit
19. Okt 2013
Beiträge
11
Punkte für Reaktionen
0
Punkte
1
Hallo,

ich hatte auf meiner DS412+, DSM 6.1xxx, seither eine 30 GB iSCS-Platte, auf die von einem Windows10-PC als Laufwerk R: zugegriffen wurde. 2 mal in der Woche wurden hiervon Snapshots gemacht. Die Verwaltung der LUN und Targets hat einwandfrei geklappt.
Heute habe ich auf 6.2-23739 upgedatet. Die iSCSI- Verwaltung ist jetzt nicht mehr im Speicher Manager drin, sondern im neu erschaffenen "iSCSI Manager". Wenn ich den iSCSI Manager starte, erscheint das unten stehende Bild, und auch nach Stunden tut sich rein gar nichts. Andere Anwendung lassen sich problemlos starten.

iSCSI-Manager 01.jpg

Das Fenster kann ich nur zumachen, irgend ein anderes Menü auf der linken Seite kann ich nicht auswählen. Auch nach Update auf 6.2-23739 Update 1 hat sich daran nichts geändert. Diverse Dienste und Prozesse , die im Namen alle den Begriff "iSCSI" beinhalten, stehen ausnahmslos auf CPU 0%. Da tut sich offensichtlich nichts. Ich habe zusätzlich alle Snapshots gelöscht; hat auch nichts gebracht. Das iSCSI-Laufwerk ist für meinen Windows10-PC immer noch da und funktioniert einwandfrei, ich kann nur das iSCSI-Laufwerk im NAS nur nicht mehr verwalten.:(

Weiß jemand Rat oder hat eine Idee?

Grüße Thomas
 

blurrrr

Benutzer
Mitglied seit
23. Jan 2012
Beiträge
6.204
Punkte für Reaktionen
1.084
Punkte
248
Nur eine allgemeine Idee bzw. eher ein Rat: Die beste Idee wäre vermutlich bei solchen Geschichten nicht immer direkt den Update-Knopf zu drücken, damit die Hersteller auch Zeit haben entsprechende Probleme auszubügeln bzw. das Update zurückzuziehen. Du hast noch Glück, dass es "nur" für einen "Rechner" ist... Firmen die sowas nun für Virtualisierungsspeicher nutzen, dürften vermutlich ziemlich angesch***en sein. Solange es aber funktioniert, sei froh, warte ab und die Zeit (bzw. Synology) wird es schon richtigen. Ich z.B. habe einen Cluster laufen und werde den Teufel tun und aktuell Updates installieren (da es auch einen neuen Clustermanager gibt), damit mir eben genau sowas wie Dir nun nicht passiert. Lehrreicher wäre natürlich ein nicht-funktionierendes ISCSI-Laufwerk gewesen, aber ich will Dir ja nix böses, von daher wünsch ich mal, dass das schnell behoben wird :eek:

Um die Sache evtl. etwas zu beschleunigen, sollest Du aber auf jeden Fall ein Ticket bei Synology aufmachen. Wenn 10 Leute einen Bug melden ist das eine Sache, wenn es 10.000 Leute melden eine ganz andere (mit entsprechendem Druck auf Herstellerseite) ;)
 

thoschi1211

Benutzer
Mitglied seit
19. Okt 2013
Beiträge
11
Punkte für Reaktionen
0
Punkte
1
Hallo blurrr,

den Ratschlag des Wartens habe ich seither immer berücksichtigt. Das Update 6.2-23739 war von Ende Mai, jetzt haben wir Ende Juni. Ein Monat warten sollte eigentlich genug sein. Update 6.2-23739-1 habe ich nur sofort aufgespielt, weil ich mir davon eine Besserung erhofft hatte.

Ein Ticket bei Synology mache ich sowieso auf, ich dachte nur, dass es vielleicht schon eine Lösung oder einen workaround hierfür gibt. Ich kann mir nicht vorstellen, dass ich der Einzige mit dem Problem bin.
 

HeronIsland

Benutzer
Mitglied seit
25. Jun 2018
Beiträge
4
Punkte für Reaktionen
0
Punkte
0
Hallo thoschi,

nach dem Update tritt bei mir exakt das gleiche Problem auf. Auf mein Ticket vom 25.06.2018 habe ich noch keine Antwort erhalten.

Bin übrigens eher konservativ was Updates betrifft, aber gerade der iscsi Manager hat mich interessiert, da ich verschiedene Systeme darüber angebunden habe.

Grüße
 

TheTwist76

Benutzer
Mitglied seit
21. Apr 2013
Beiträge
227
Punkte für Reaktionen
3
Punkte
18
Hallo,

bei mir tritt das Problem nicht auf. Der iSCSI Manager öffnet sehr schnell und alle Funktion funktionieren ohne Probleme.

iSCSI Manager.jpg

DSM Version 6.2-23739 Update 1

Viele Grüße
Thorsten
 

thoschi1211

Benutzer
Mitglied seit
19. Okt 2013
Beiträge
11
Punkte für Reaktionen
0
Punkte
1
habe heute auch ein Ticket aufgemacht. Bin mal gespannt wann, bzw. ob, ich zeitnah eine Antwort bekomme.

Grüße
 

HeronIsland

Benutzer
Mitglied seit
25. Jun 2018
Beiträge
4
Punkte für Reaktionen
0
Punkte
0
Hallo Thorsten,

hattest Du eine aktive iscsi Verbindung während des Updates? Bei mir war wahrscheinlich ein externes System verbunden.

Grüße
 

TheTwist76

Benutzer
Mitglied seit
21. Apr 2013
Beiträge
227
Punkte für Reaktionen
3
Punkte
18
Hallo HeronIsland,

nein ich habe es nach dem Update auf DSM 6.2-23739 U1 ein Target und LUN angelegt.
Es kann sein das der Fehler nur bei einem bestehendem Target und LUN auftritt.

Viele Grüße
Thorsten
 

HeronIsland

Benutzer
Mitglied seit
25. Jun 2018
Beiträge
4
Punkte für Reaktionen
0
Punkte
0
Hallo,

das Update bei aktiver Verbindung könnte also tatsächlich die Ursache sein. Mal sehen, wann Synology antwortet.

Grüße
 

blurrrr

Benutzer
Mitglied seit
23. Jan 2012
Beiträge
6.204
Punkte für Reaktionen
1.084
Punkte
248
Wenn dem so wäre, wäre das aber schon ein ziemlich schlechter Scherz... man bedenke die Firmen, welche die Geräte (z.B. auch die FS) als Storage für die Virtualisierung einsetzen (via ISCSI).
 

HeronIsland

Benutzer
Mitglied seit
25. Jun 2018
Beiträge
4
Punkte für Reaktionen
0
Punkte
0
Fehler wurde durch Synology behoben.

Laut Synology ist das ein bekanntes Problem. Nachdem das Konfigurationsfile durch einen Synology Mitarbeiter gelöscht und neu angelegt wurde, geht der Manager bei mir einwandfrei.
 

Cyberbob19

Benutzer
Mitglied seit
05. Mai 2011
Beiträge
231
Punkte für Reaktionen
0
Punkte
22
Hallo,

ich habe den folgenden Effekt (siehe Bilder)

iscsi.jpg
iscsi2.jpg
iscsi3.jpg

Kann also keine Snapshots anlegen obwohl ein LUN existiert ;-)

Gruß
Bob
 

thoschi1211

Benutzer
Mitglied seit
19. Okt 2013
Beiträge
11
Punkte für Reaktionen
0
Punkte
1
Hallo,

Synology hat mir inzwischen auch geantwortet und möchte Fernzugriff auf mein NAS. Das ist mir aber nicht recht, denn dort sind sensible Daten des Büros meiner Frau gespeichert und ich weiss auch nicht von welchem Land aus zugegriffen wird. Das ist zwar sicher ein gut gemeintes Angebot von Synology, aber nicht so recht mit der neuen DSGVO in Einklang zu bringen.
Ich denke, ich setze das NAS in nächster Zeit neu auf, zumal ich derzeit nicht unbedingt auf ein iSCSI-Laufwerk angewiesen bin. Ich weiss außerdem nicht was beim nächsten Update passiert, wenn Verbinungen aktiv sind...

Grüße Thomas
 

blurrrr

Benutzer
Mitglied seit
23. Jan 2012
Beiträge
6.204
Punkte für Reaktionen
1.084
Punkte
248
Sowas hilft den Entwicklern natürlich ungemein... Bugs melden, aber die Leute dann nicht gucken lassen :p Hast Du nicht evtl. die Möglichkeit die Daten kurzerhand woanders zu deponieren?
 

Benutzer2018

Benutzer
Mitglied seit
11. Jul 2018
Beiträge
1
Punkte für Reaktionen
0
Punkte
0
Hallo,

gibt es zu dem Thema was neues?

Kann man es inzwischen wagen ein 1513+ die eine iSCSI LUN hat upzudaten von 6.0 auf 6.2 ?

Grüße