iperf starten - command not found

d00d

Benutzer
Mitglied seit
24. Februar 2011
Beiträge
2
Punkte für Reaktionen
0
Punkte
0
Hallo Gemeinde,

ich möchte meinen Datendurchsatz testen und habe hierzu auf meiner DS218 iperf für Realtek ARM Architektur runtergeladen und mittels Paketmanager installiert (http://www.jadahl.com/iperf-arp-scan/DSM_6.2/iperf_rtd1296-6.2_3.7-1.spk). Dort wird es auch als gestartet angezeigt :

iperf.png

Von da an weiß ich aber nicht mehr weiter. Logge ich mich als Admin/Root mittels SSH auf die Maschine ein und will den iperf command mal ausführen, wird dieser nicht gefunden:

ash-4.3# iperf
ash: iperf: command not found
Bin jetzt leider kein Linux-Crack und weiß nicht, wo ich da am besten anfange. Hat jemand schon mal die Pakete von jadahl verwendet und kann mir ein paar Tipps geben?
 

3x3cut0r

Benutzer
Mitglied seit
21. Mai 2011
Beiträge
438
Punkte für Reaktionen
0
Punkte
0
Also,
kurz gesagt das liegt daran, das wohl irgendwas mit deiner Pfad-Variable ($PATH) nicht stimmt.
Das kann nun mehrere Ursachen haben. Ich habe mir das Paket gezogen und bei mir funktioniert es.

1) Probiere erstmal auf die aktuellste Version 3.7-1 zu updaten. Eventuell wurde das ja bereits hier gefixt!

2) Falls das nicht geholfen hat:
Was unabhängig von einer 'richtigen' Pfadvariable aber immer funktionieren muss, wenn du den kompletten Pfad zum binary angibst.
Probiere also mal folgendes aus:
Rich (BBCode):
/volume1/\@appstore/iperf/bin/iperf3
3) Tools vom SynoCommunity Repository nutzen.
Ich kann nur ausdrücklich empfehlen immer erstmal nach Tools in dem SynoCommunity Repository zu suchen:
http://packages.synocommunity.com
Dort das Tool "SynoCli Monitor Tools" installieren, welches unter anderem auch iperf3 mitbringt.
Damit funktionieren auch die Befehle als root/admin ohne den kompletten Pfad mit anzugeben!

Schreib wenn du noch Hilfe brauchst

Gruß