G Suite Drive Mount auf ARM Syno ohne lokalen Sync

B0ngripper

Benutzer
Mitglied seit
11. Februar 2018
Beiträge
39
Punkte für Reaktionen
0
Punkte
6
Ich habe bisher meine Plex Mediathek auf meinem NAS liegen gehabt.

Da ich mittlerweile einen G Suite Account besitze, möchte ich in Zukunft meine Mediathek zum Großteil in der Cloud speichern, um lokal Speicherplatz zu sparen. Die 4 Einschübe sind voll, die Kapazität zu 70% belegt und ein Upgrade kommt mittelfristig nicht infrage.

Am Windows Rechner ist das mit Drive Filestream kein Problem, aber dann müsste der Rechner ständig laufen, damit das Drive verfügbar ist. Aber wie löst man das auf einem NAS? Cloud Sync & Co bieten nur 2-way Sync an, ich möchte die Daten aber nur in der Cloud ändern und diese mit dem NAS verknüpfen, damit der Plex Server die Daten lesen kann?
Zusätzlich muss man beachten, dass ich eine DS418 mit ARM CPU habe, die in der Appkompatibilität eingeschränkt ist. (Docker geht z.B. nicht)

Wie bekomme ich das hin? Gibt es dafür eine Anleitung? Mit der Konsole bin ich nur so mittel fit.

P.S. Hier geht es nur um die Mediathek und deren Cloud Streaming, ich habe natürlich für bestimmte Sachen ein echtes Backup parallel.
 

ruedi66

Benutzer
Mitglied seit
25. April 2018
Beiträge
112
Punkte für Reaktionen
14
Punkte
18
Nö, kein komplexes Thema. Da gibts zb rclone. Mit dem kannst du gdrive lokal mounten und in plex dann auf den mountpoint zugreifen.
 
  • Like
Reaktionen: B0ngripper

B0ngripper

Benutzer
Mitglied seit
11. Februar 2018
Beiträge
39
Punkte für Reaktionen
0
Punkte
6
Ich scheitere im Moment an der Authentifizierung von Rclone über die Localhost IP. Obwohl der Zugriff grundsätzlich geht, nur bricht er die Authentifizierung immer mit "Connection refused" ab.
 

ruedi66

Benutzer
Mitglied seit
25. April 2018
Beiträge
112
Punkte für Reaktionen
14
Punkte
18
Das sind für mich zu wenig Angaben, um dir helfen zu können.
 

B0ngripper

Benutzer
Mitglied seit
11. Februar 2018
Beiträge
39
Punkte für Reaktionen
0
Punkte
6
Die Installationsroutine von rclone versucht irgendwann, eine Authentifizierung für 127.0.0.1 durchzuführen und wechselt dafür in den Browser, um die Adresse aufzurufen. Dort erhalte ich dann die Fehlermeldung, dass kein Zugriff auf 127.0.0.1 möglich ist, obwohl das mit anderen Adressen testweise funktioniert. Ich schalte mich per Putty auf die Synology und die Authentifizierung findet dann im Browser von Windows 10 statt. Die Authentifizierungs URL lässt auch mit verschiedenen Browsern nicht aufrufen.
 

ruedi66

Benutzer
Mitglied seit
25. April 2018
Beiträge
112
Punkte für Reaktionen
14
Punkte
18
Installationsrouting? rclone muss nur entpackt werden und dann ausführbar machen.
Danach rclone config eingeben und die Einstellungen durchgehen.

127.0.0.1 ist localhost.
Das geht nicht, wenn du es von einem anderen PC aus aufrufen willst, wenn rclone auf dem NAS läuft. Ich weiss aber ehrlich gesagt nicht, an was du scheiterst, weil ich nicht weiss an welchem Schritt du bist, welche commands du gerade verwendest, etc. Diese Authentifizierung müsstest du eigentlich bei gdrive machen. Du musst gdrive sagen, dass rclone "als APP" auf gdrive zugreifen darf.
Mach doch mal einen Screenshot, dann kann man dir auch helfen anstatt die Glaskugel zu putzen..
 

Synology_Stan

Benutzer
Mitglied seit
27. Oktober 2020
Beiträge
13
Punkte für Reaktionen
1
Punkte
9
Ort
Hamburg
Ich stimme ruedi66 zu. Lad hier am besten mal einen Screenshot davon hoch, damit dir hier auch geholfen werden kann.
 
  AdBlocker gefunden!

Du bist nicht hier, um Support für Adblocker zu erhalten, denn dein Adblocker funktioniert bereits ;-)

Klar machen Adblocker einen guten Job, aber sie blockieren auch nützliche Funktionen.

Das Forum wird mit einem hohen technischen, zeitlichen und finanziellen Aufwand kostenfrei zur Verfügung gestellt. Wir zeigen keine offensive oder Themen fremde Werbung. Bitte unterstütze dieses Forum, in dem du deinen Adblocker für diese Seite deaktivierst.