Mail Server EMail intern auf Syno und dann weiterleiten

cosmo87

Benutzer
Mitglied seit
19. August 2020
Beiträge
11
Punkte für Reaktionen
0
Punkte
1
Hallo zusammen,

ich bin beim Thema "EmailServer" leider noch etwas unerfahren.

Mein Problem:
Wir haben im Haus Sensoren die bei zu hoher Luftfeuchtigkeit eine EMail Warnung ausgeben. Diese unterstützen jedoch kein TLS.

Jetzt war meine Idee auf der Syno den EMailServer zu installieren und diesen zu nutzen um von Port 25 auf Port 587 weiterzuleiten.
Nur hier habe ich gerade ein Denkblockade...
Muss ich die Syno als SMTP Server einrichten, einen Account erstellen und dann auf das gewünschte EMail Postfach weiterleiten?

Ich hoffe ihr könnt mir helfen diesen Gedankenknoten zu entwirren :)

Gruß
cosmo87
 

blurrrr

Benutzer
Mitglied seit
23. Januar 2012
Beiträge
3.709
Punkte für Reaktionen
302
Punkte
143
Diese unterstützen jedoch kein TLS.
Das ist in der heutigen Zeit natürlich schon etwas blöd... Was Du machen könntest, wäre eine Grundkonfiguration der Mailstation (System sendet dann über die Mailstation ohne TLS) und diese leitet die Mail dann weiter über Deinen externen Hoster. Das ganze nennt sich dann "Relay", da erst der Hoster die Mail dann "offiziell" verschickt :)

Hier gibt es ein paar Infos dazu: https://www.mailjet.de/blog/news/vorteile-des-smtp-relays/

Das Bild unter SMTP-Relay-Funktionsweise.png zeigt es schon sehr gut. Statt dem Mailjet-SMTP-Server denkst Du Dir dann einfach Deine Syno dahin ☺️
 

cosmo87

Benutzer
Mitglied seit
19. August 2020
Beiträge
11
Punkte für Reaktionen
0
Punkte
1
Bild unter SMTP-Relay-Funktionsweise.png zeigt es schon sehr gut. Statt dem Mailjet-SMTP-Server denkst Du Dir dann einfach Deine Syno dahin ☺️
Ja genau so hätte ich es mir bildlich vorgestellt.
Habe nun rausgefunden dass ich das "Mailplus Server" Paket brauche.

Jetzt muss ich nur noch raus finden wie ich den SMTP richtig einrichte.
Meine Logik:
Der Sensor sendet mittels SMTP server, mit der Adresse: sensor1@domain.local, an die syno und die sendet mittels office365 an die jeweilige Email Adresse (monitoring@domain.de).

Geht das überhaupt mit einer lokalen Domäne?
 

blurrrr

Benutzer
Mitglied seit
23. Januar 2012
Beiträge
3.709
Punkte für Reaktionen
302
Punkte
143
Nur wenn die Adressen entsprechend umgeschrieben werden. Dein Hoster wird wohl kaum Mails von "@domain.local" akzeptieren ;) Als alternative kannst Du aber den Relay-Weg einrichten und um Dich gänzlichst von Clientanmeldeprozeduren zu befreifen (was das senden angeht), gibt es noch die Möglichkeit, dass "bestimmte IP-Adressen" einfach direkt über das NAS senden dürfen. Sieht dann z.B. so aus:

Absender-Adresse: existierende-mailadresse@domain.tld
Server: <interne Syno>
Empfänger: existierende-mailadresse@domain.tld

Damit wird die Mail <von/an> einfach nur an die Syno übergeben. Da diese via Relay weiterleiten soll (und sich beim Hoster auch erst authentifizieren muss), übernimmt die Syno somit die Authentifizierung am Hoster und übergibt die Mail dann entsprechend.
 

cosmo87

Benutzer
Mitglied seit
19. August 2020
Beiträge
11
Punkte für Reaktionen
0
Punkte
1
Von der Logik her glaube ich es zu verstehen, aber an der Konfiguration scheint es zu scheitern...
beim Senso habe ich folgendes:
SMTP Server: <interne Syno DNS Name> (oder kann man hier direkt die IP angeben?)
SMTP Port: 25
SMTP Authentication: Enable
SMTP Server Login Name: sendmail
SMTP Server Password: Passwort von dem lokalen "sendmail" nutzer auf der syno

Auf der Syno:
MailPlusServer installiert
bei Domain: domain.local (Primär)
bei Mailübermittlung:
Allgemeines: - SMTP-Authentifizierung aktivieren
- Hostname (FQDN): mail.domain.local
- den Rest auf standarteinstellungen gelassen
Delivery: EMails direkt von diesem Server senden
Relay-Steuerung: - vertrauenswürdige IPs (172.16.0.0/20) angegeben
- In Domainliste die smtp.office365.com konfiguriert

irgendwo ist noch der Hacken. Entweder findet dieser "innovative" Sensor den DNS namen nicht und wenn ich die IP als SMTP Server angebe bekomme ich "Bad AUTH: 503 5.5.1"

EDIT.: reicht es wenn am DNS Server die IP mit dem DNS Namen angegeben ist? Der Befehl nslooup verweist immerhin den DNS Namen auf die IP, jedoch nicht die IP auf den DNS namen?!
 
Zuletzt bearbeitet:

blurrrr

Benutzer
Mitglied seit
23. Januar 2012
Beiträge
3.709
Punkte für Reaktionen
302
Punkte
143
Das wäre dann die Reverse-Zone (generell: IP -> Name), das spielt aber keine Rolle auf der Syno. "Bad AUTH: 503 5.5.1" besagt ja schon, dass die Authentifizierung fehlgeschlagen ist. Frage ist in dem Moment nur, "welcher" Server das von sich gibt (Syno oder Hoster).

Grundsätzlich sollte es halt wie folgt ablaufen:

Client/Sensor -> Syno -> Hoster

Kannst auch erstmal nur Syno-"intern" werkeln und mal ein Testpostfach anlegen (auf der Syno) und erstmal schauen, dass Du es hinbekommst, dass der Sensor über die Syno eine Mail ins lokale Postfach bekommt.
 

cosmo87

Benutzer
Mitglied seit
19. August 2020
Beiträge
11
Punkte für Reaktionen
0
Punkte
1
Hätte ich auch schon angefangen zu versuchen, aber ich weiß nicht ob und wie ich es mit einer .local oder mit einer .de Domain konfiguriere..
 

blurrrr

Benutzer
Mitglied seit
23. Januar 2012
Beiträge
3.709
Punkte für Reaktionen
302
Punkte
143
Mach erstmal "irgendwie" (ganz egal wie) und ggf. auch erstmal ohne Relay, so dass Du es erstmal überhaupt schaffst "intern" zu mailen (sowohl Ein- als auch Ausgang (mit lokaler Zustellung)).
 

cosmo87

Benutzer
Mitglied seit
19. August 2020
Beiträge
11
Punkte für Reaktionen
0
Punkte
1
Endlich funktioniert es halbwegs. es lag an der internen SMTP Authentifizierung. Diese habe ich nun auf der Syno deaktiviert und der Sensor meldet zumindest schon einmal eine "Keep Alive" EMail. Nur bei der Test- und Warn-Email bringt der Syno-EmailServer einen Fehler:
I'm sorry to have to inform you that your message could not
be delivered to one or more recipients. It's attached below.

For further assistance, please send mail to postmaster.

If you do so, please include this problem report. You can
delete your own text from the attached returned message.
...
said: 554 5.2.0

Laut Google handelt es sich hier um ein "Clutter Problem" nur weis ich nicht wo ich das ändern könnte...
 

Ulfhednir

Benutzer
Mitglied seit
26. August 2013
Beiträge
590
Punkte für Reaktionen
58
Punkte
54
Mein Problem:
Wir haben im Haus Sensoren die bei zu hoher Luftfeuchtigkeit eine EMail Warnung ausgeben. Diese unterstützen jedoch kein TLS.

Mal unabhängig zu deiner Anforderung an einem separaten Mailserver: Das ist eigentlich ein üblicher Fall für ein gescheites Smarthome-System (z.B. ioBroker). Mails hatte ich vor Jahren auch zur Benachrichtigung eines Aktors verwendet - allerdings war das auch nicht so wirklich das Wahre.
Geeigneter sind Push-Notifications. Für einige Anwendungsfälle wäre ein Smartspeaker (z.B. Alexa) geeignet, weil man Handy oder Mailclient nicht permanent zur Hand hat. Trigger z.B., wenn Luftfeuchtigkeit > 60 lass Alexa quatschen.
 
  AdBlocker gefunden!

Du bist nicht hier, um Support für Adblocker zu erhalten, denn dein Adblocker funktioniert bereits ;-)

Klar machen Adblocker einen guten Job, aber sie blockieren auch nützliche Funktionen.

Das Forum wird mit einem hohen technischen, zeitlichen und finanziellen Aufwand kostenfrei zur Verfügung gestellt. Wir zeigen keine offensive oder Themen fremde Werbung. Bitte unterstütze dieses Forum, in dem du deinen Adblocker für diese Seite deaktivierst.