Anmeldung WebIF schlägt fehl wegen zu wenig Speicher (/dev/md0 2.3G 2.3G 0 100% /)

pctelco

Benutzer
Mitglied seit
26. Mai 2015
Beiträge
59
Punkte für Reaktionen
1
Punkte
8
Ich habe nun auf meiner frisch eingerichteten DS420+ erneut das Problem, welches ich auch schon auf meiner DS216+ vor ein paar Wochen hatte und weswegen ich diese durch die DS420+ abgelöst habe.
Leider habe ich jedoch jetzt erst das Problem, jedoch keine Lösung erkennen können. Scheinbar läuft mir das root-Verzeichnis voll (/dev/md0 2.3G 2.3G 0 100% /), jedoch finde ich nicht heraus wodurch.
Aktuell bin ich auf dem WebIF des DS420+ angemeldet (Mit putty per SSH anmelden geht gerade auch noch), jedoch werde ich vermutlich beim ersten Versuch mich erneut anmelden zu wollen, dort die Meldung erhalten, dass eine Anmeldung mangels Speicher derzeit nicht möglich sei und ich die DS neu starten und es dann noch mal versuchen soll (Anmeldeversuch per SSH endet dann mit Meldung Access denied).
Dies brachte allerdings leider nie etwas und es half erst mal nur DSM neu zu installieren. Aber nach kurzer Zeit, kommt es dann wohl wieder zum Überlauf von md0.

Aktuell sind auch die gemeinsamen Ordner nicht mehr erreichbar.

Vielleicht habt ihr ja für mich, als unerfahrenen User hier, Tipps oder Hinweise wie ich mein Problem in den Griff bekomme?

Installiert ist auf der DS (aktuelles DSM, s. screenshot, auch hier zu erkennen, das md0 voll ist) übrigens nichts weiter, lediglich ein Skript (wget) zur Datensicherung von Videos von meiner Enigma2-Sat-Box habe ich als Aufgabe eingerichtet und laufen lassen (s. Code). Eventuell ist dies ja der Grund, obwohl ich es mir nicht vorstellen kann.

Screenshot DSM:

Screenshot_2020-07-27 RP-Home-PV - Synology NAS.png

Skript als Aufgabe:

Code:
wget -m ftp://user:password@192.168.0.23/hdd/movie/* /volume1/video
wget -m ftp://user:password@192.168.0.23/hdd/!!trashcan/* /volume1/video
Ausgaben zur Speicherermittlung:
Code:
ash-4.3# df -h
Filesystem         Size  Used Avail Use% Mounted on
/dev/md0           2.3G  2.3G     0 100% /
none               2.8G     0  2.8G   0% /dev
/tmp               2.9G  1.8M  2.9G   1% /tmp
/run               2.9G  4.3M  2.9G   1% /run
/dev/shm           2.9G  4.0K  2.9G   1% /dev/shm
none               4.0K     0  4.0K   0% /sys/fs/cgroup
cgmfs              100K     0  100K   0% /run/cgmanager/fs
/dev/vg1/volume_1   14T  2.9T   12T  21% /volume1
Code:
ash-4.3# du -xhd 1 /
1.4G    /root
4.0K    /mnt
9.5M    /etc
4.0K    /initrd
4.0K    /tmpRoot
4.0K    /lost+found
8.6M    /etc.defaults
4.0K    /.old_patch_info
22M     /.syno
20K     /.system_info
871M    /usr
8.0K    /boot
27M     /var
7.2M    /var.defaults
212K    /.log.junior
2.3G    /
Code:
ash-4.3# du -xhd 1 /var/log
8.0K    /var/log/disk-latency
4.0K    /var/log/selfcheck
4.0K    /var/log/sssd
16K     /var/log/diskprediction
8.0K    /var/log/nginx
108K    /var/log/packages
36K     /var/log/samba
4.0K    /var/log/openvswitch
108K    /var/log/synolog
4.0K    /var/log/bios
764K    /var/log/upstart
4.0K    /var/log/healthtest
8.0K    /var/log/fsck
4.0K    /var/log/pstore
2.1M    /var/log
 
Zuletzt bearbeitet:

pctelco

Benutzer
Mitglied seit
26. Mai 2015
Beiträge
59
Punkte für Reaktionen
1
Punkte
8
Etwas habe ich nun heraus gefunden und es hängt scheinbar doch mit dem wget-Skript als aufgabe zusammen, denn ein Verzeichnis ist extrem voll, siehe unten.
Code:
ash-4.3# du -xhd 1 /root
8.0K    /root/.gnupg
24K     /root/.pulse
1.4G    /root/192.168.0.23
1.4G    /root
Dem Anschein nach, hat mir das Skript von oben, meine Videos in md0 geschrieben, aber wie kann ich die per SSH löschen und wie muss das Skript angepasst werden, dass mir das nicht noch mal passiert?

Code:
ash-4.3# du -xhd 1 /root/192.168.0.23/hdd
1.4G    /root/192.168.0.23/hdd/movie
1.4G    /root/192.168.0.23/hdd
 

pctelco

Benutzer
Mitglied seit
26. Mai 2015
Beiträge
59
Punkte für Reaktionen
1
Punkte
8
Ich habe es nun geschafft, md0 wieder frei zu schaufeln mit "rm -r /root/192.168.0.23" und werde das Skript erst einmal deaktivieren, aber für einen Tipp, wie das Skript aussehen muss, damit nicht mehr md0 voll geschrieben und die Dateien am richtigen Ziel auf volume1/video landen, wäre ich sehr dankbar.
 

AndiHeitzer

Benutzer
Mitglied seit
30. Juni 2015
Beiträge
2.066
Punkte für Reaktionen
83
Punkte
94
Wenn 'wget' so ähnlich arbeitet, wie 'scp', dann fehlt in Deinem Script eigentlich nur ein ':'

Code:
wget -m ftp://user:password@192.168.0.23:/hdd/movie/* /volume1/video
wget -m ftp://user:password@192.168.0.23:/hdd/!!trashcan/* /volume1/video
Nachgeschaut habe ich hier:
 
  • Like
Reaktionen: pctelco

pctelco

Benutzer
Mitglied seit
26. Mai 2015
Beiträge
59
Punkte für Reaktionen
1
Punkte
8
@AndiHeitzer Erst mal Danke!

Ich hatte den Doppelpunkt nun hinter der IP der Quelle eingefügt, weil ich unter Nachforschung nach der richtigen Syntax für wget herausgefunden hatte, dass der hier auch notwendig scheint, jedoch habe ich mich damit leider komplett aus der DS ausgesperrt, da kein Login auf DSM, aber auch nicht mehr als admin per SSH möglich war (Access denied).

Also werde ich DSM neu aufsetzen und auf einen Lösungsvorschlag für meine Kopieraufgabe hoffen, die mir nicht md0 voll schreibt, sondern in das gewünschte Verzeichnis.
 

Fusion

Benutzer
Mitglied seit
06. April 2013
Beiträge
11.121
Punkte für Reaktionen
116
Punkte
319
Mit -m (mirror) kannst dir das * sparen. Der spiegelt mit unendlicher Rekursionstiefe.
Hätte also versucht '/hdd/movie/ /volume1/video/'
Für die Ausrufezeichen bin ich mir grad nicht sicher, ob man die besser mit \! escaped.

Und probiers halt mit einem Testverzeichnis wo nur 1-2 Dateien drin liegen, dann schreibt er auch nix voll.
 
  • Like
Reaktionen: pctelco

pctelco

Benutzer
Mitglied seit
26. Mai 2015
Beiträge
59
Punkte für Reaktionen
1
Punkte
8
Egal ob mit, oder ohne *, werden die Dateien immer im root unter dem Verzeichnis "192.168.0.23........." abgelegt und müllen mir damit den Speicher zu. Leider wird nicht unter /volume1/video....... auf dem Volume der DS gespeichert. Ich verstehe es einfach nicht wieso.
 

Benares

Benutzer
Mitglied seit
27. September 2008
Beiträge
3.541
Punkte für Reaktionen
44
Punkte
108
So wie ich das sehe, ist die Syntax falsch. Da gibt es kein Ziel. Also landen die Sachen dort, wo man grad steht (s. wget --help)
Code:
Usage: wget [OPTION]... [URL]...
...
 
  • Like
Reaktionen: pctelco

pctelco

Benutzer
Mitglied seit
26. Mai 2015
Beiträge
59
Punkte für Reaktionen
1
Punkte
8
@Benares

Es fehlte vor dem Zielpfad tatsächlich noch ein "-P". Damit kopiert er es nicht mehr nach md0, jedoch legt er mir auf dem eigentlichen Ziel nun die Verzeichnisstruktur "192.168.0.23/hdd/movie" mit allen weiteren Verzeichnissen darin an. Kann ich so nicht gebrauchen, denn er soll die auf Quelle und Ziel vorhandene Verzeichnisstruktur nebst Inhalten synchronisieren und nicht noch den kompletten FTP-Pfad neu anlegen
 

Benares

Benutzer
Mitglied seit
27. September 2008
Beiträge
3.541
Punkte für Reaktionen
44
Punkte
108
Dann lies dir doch mal die Hilfe von wget durch. Evtl. ist ja --no-host-directories der richtige Schalter ;)
 
  • Like
Reaktionen: pctelco

pctelco

Benutzer
Mitglied seit
26. Mai 2015
Beiträge
59
Punkte für Reaktionen
1
Punkte
8
Die Lösung zu meiner Problemstellung sieht nun folgendermaßen aus:

Code:
wget -m --no-host-directories --cut-dirs=2 ftp://username:passwort@192.168.0.23/hdd/movie/ -P /volume1/video
wget -m --no-host-directories --cut-dirs=2 ftp://username:passwort@192.168.0.23/hdd/!!trashcan/ -P /volume1/video
Wobei sich in meinem Passwort ein "#" befindet, welches ich durch "%23" ersetzen musste.
 

pctelco

Benutzer
Mitglied seit
26. Mai 2015
Beiträge
59
Punkte für Reaktionen
1
Punkte
8
Letztendlich musste ich eine Winzigkeit anpassen, weil sonst die Unterverzeichnisse im Ziel nicht richtig beachtet wurden. So läuft es jetzt jedenfalls zuverlässig.

Code:
wget -m --no-host-directories --cut-dirs=2 ftp://username:passwort@192.168.0.23/hdd/movie/* -P /volume1/video/movie/
wget -m --no-host-directories --cut-dirs=2 ftp://username:passwort@192.168.0.23/hdd/!!trashcan/* -P /volume1/video/!!trashcan/
 
Zuletzt bearbeitet:

pctelco

Benutzer
Mitglied seit
26. Mai 2015
Beiträge
59
Punkte für Reaktionen
1
Punkte
8
Mit meinen Problemen der Einrichtung (Datensicherung), bin ich leider noch nicht durch und hoffe auf Eure Erfahrung und Tipps zu folgendem Probem.

Warum führt folgender wget-Aufruf zum Anlegen eines nicht gewünschtem Verzeichnis. (siehe Befehlszeile und Screenausgabe des Terminal)


Befehlszeile:

Code:
wget -m --no-host-directories --cut-dirs=2 ftp://username:passwort@192.168.0.23/hdd/AdvancedEventLibrary/* -P /volume1/Sicherungsordner/!!VuUl4kBackup/hdd/AdvancedEventLibrary/

Ausgabe:

Code:
--2020-07-28 16:01:19--  ftp://username:passwort@192.168.0.23/hdd/AdvancedEventLibrary/cover/MiBkdXJjaCBkZXV0c2NobGFuZCAtIHNhY2hzZW4tYW5oYWx0.jpg
           => '/volume1/Sicherungsordner/exitVuUl4kBackup/hdd/backup/VuUl4kBackup/hdd/EPGImages/VuUl4kBackup/hdd/AdvancedEventLibrary/VuUl4kBackup/hdd/AdvancedEventLibrary/cover/MiBkdXJjaCBkZXV0c2NobGFuZCAtIHNhY2hzZW4tYW5oYWx0.jpg'
==> CWD not required.
==> PASV ... done.    ==> RETR MiBkdXJjaCBkZXV0c2NobGFuZCAtIHNhY2hzZW4tYW5oYWx0.jpg ... done.
Length: 93632 (91K)

cover/MiBkdXJjaCBkZXV0c2NobGFuZCAtIH 100%[===================================================================>]  91.44K  --.-KB/s    in 0.006s

Ist nur die Ausgabe von einer Datei, jedoch werden mit dem Job, mehrere tausend Dateien so in den vom Job angelegten Ordner "/volume1/Sicherungsordner/exitVuUl4kBackup..............." versenkt und nicht mit "/volume1/Sicherungsordner/!!VuUl4kBackup/hdd/AdvancedEventLibrary/" synchronisiert.

Es wurde bei ähnlichem Synrchronisierjob auch schon mal ein Verzeichnis "sudo" in dem Sicherungsordner auf meiner DS420+ angelegt und dort alles herein gepumpt.

Meine Zielverzeichnisse sind übrigens alle existent (wie in der Befehlszeile als Ziel angegeben) und schon mit älteren Daten befüllt.
 
  AdBlocker gefunden!

Du bist nicht hier, um Support für Adblocker zu erhalten, denn dein Adblocker funktioniert bereits ;-)

Klar machen Adblocker einen guten Job, aber sie blockieren auch nützliche Funktionen.

Das Forum wird mit einem hohen technischen, zeitlichen und finanziellen Aufwand kostenfrei zur Verfügung gestellt. Wir zeigen keine offensive oder Themen fremde Werbung. Bitte unterstütze dieses Forum, in dem du deinen Adblocker für diese Seite deaktivierst.