Alias Hostname

TobStar

Benutzer
Mitglied seit
30. Juni 2020
Beiträge
3
Punkte für Reaktionen
0
Punkte
1
Hallo,

wir haben 2 Diskstations an 2 Standorten die jeweils mit dem Standortspezifischem Hostnamen eingerichtet sind. Zur Vereinfachung der PXE Umgebung haben wir einen 2. auf beiden Standorten identischen Hostnamen vergeben der per nslookup auch vernünftig auflöst. Problem ist nur, das die DiskStation den Zugriff auf den Share mittels "Alias" Hostname nicht zulässt.

Der Zugriff über den in der Diskstation hinterlegten Hostnamen (Standortbezogen) funktioniert, ich nehme an das es sich hierbei um eine Sicherheitseinstellung handelt. Weiß jemand welche das sein könnte?
 

blurrrr

Benutzer
Mitglied seit
23. Januar 2012
Beiträge
3.256
Punkte für Reaktionen
198
Punkte
123
Bitte ein "bisschen" weniger Informationen bitte... 🤪 Vielleicht sagste erstmal, was ihr da generell feiert (PXE standortübergreifend ist ja auch schon wieder so eine Sache für sich ....) und was der Blödsinn mit den Alias-Hostnamen soll... (und nu komm mir nicht wieder mit "Vereinfachung") :p
 

TobStar

Benutzer
Mitglied seit
30. Juni 2020
Beiträge
3
Punkte für Reaktionen
0
Punkte
1
Also auf jeder NAS läuft ein eigener PXE Server. Jeder PXE Server benötigt seine routen (IP-Adresse zu Paketquellen etc.) nennen wir diese mal aktuell STANDORT_EINS und STANDORT_2. Damit man nicht jedes mal bei einer Änderung beide PXE Server anfassen muss, haben wir die NAS über einen weiteren DNS Namen in unserem Netzwerk verfügbar gemacht (NASHOST).

nslookup NASHOST ergibt an Standort eins nun die IP 192.168.178.1 und an Standort zwei nun 172.17.3.1
Somit wäre das an beiden Standorten identisch und die Scripte müssen nicht angepasst werden da im Script überall NASHOST auftaucht, der dann zu den jeweiligen IP-Adressen auflöst.

Die Namensauflösung ist aber das eine (die funktioniert, er löst jeweils zur entsprechenden IP auf), aber das SMB Protokoll scheint hier zu prüfen über welchen Hostnamen auf die NAS zugegriffen wird. Ich nehme an, es ist nur der Hostname erlaubt der auf der NAS selbst konfiguriert ist (z.B. STANDORT_EINS). Grundsätzlich gibt es genau für solche Zwecke Whitelists, solche kann ich aber auf der NAS via SSH nicht entdecken und evtl. gibt es dafür noch weitere mechanismen die ich aber nicht kenne.
 

blurrrr

Benutzer
Mitglied seit
23. Januar 2012
Beiträge
3.256
Punkte für Reaktionen
198
Punkte
123
Ihr könnt die Dingern doch einfach den entsprechenden Hostnamen geben und jut ist, das beisst sich doch standortübergreifend nicht und wenn das Problem der standortbezogenen-DNS-Auflösung schon erledigt ist, ist doch soweit alles in Ordnung, oder habt ihr die Dinger auch noch im AD, weswegen es dann anderweitig nicht funktioniert?

Alternativ könnte man nochmal schauen, ob ein zusätzlicher FQDN (@DSM/externer Zugriff) Abhilfe schaffen kann (denke aber eher nicht, dass der Samba-relevant ist, sondern vermutlich nur für den Webserver).

Mal ganz doof gefragt... "netbios alias = ....." in der smb.conf unter der [Global]-Sektion hast Du schon versucht?
(Da kann man mehrere Einträge vornehmen, danach halt Dienst/NAS neustarten)

EDIT: Da wird es doch auch sicherlich Logauszüge zu geben, wenn man mit einem Alias beim Samba ankommt... hast Du da ggf. was parat?
 
Zuletzt bearbeitet:
  AdBlocker gefunden!

Du bist nicht hier, um Support für Adblocker zu erhalten, denn dein Adblocker funktioniert bereits ;-)

Klar machen Adblocker einen guten Job, aber sie blockieren auch nützliche Funktionen.

Das Forum wird mit einem hohen technischen, zeitlichen und finanziellen Aufwand kostenfrei zur Verfügung gestellt. Wir zeigen keine offensive oder Themen fremde Werbung. Bitte unterstütze dieses Forum, in dem du deinen Adblocker für diese Seite deaktivierst.