chmod 777 scheint nicht zu funktionen

Elrob

Benutzer
Mitglied seit
03. Jul 2018
Beiträge
56
Punkte für Reaktionen
1
Punkte
14
Ich habe auf einer DS224 den Apache von Synology am Laufen. Nun Müsste ich den Timeout von 300 auf 600 ändern.

habe erreicht dass mit chmod 777 ich das entsprechende File editieren kann und zurückspielen....

Bekomme dann die Meldung keine Rechte um die Zeit und Datumswerte zu schreiben (Siehe Bild im Anhang)
Schau ich nach ist das file aber ok... und meine 600 sekunden sind vorhanden... Dies bleibt auch über Tage in Ordnung wenn ich den NAS nicht neu boote oder den WebServer stoppe und neustarte...
denn dann sind die Werte auf 300 zurückgeschrieben.
 

Anhänge

  • Capture d’écran 2024-04-20 155523.jpg
    Capture d’écran 2024-04-20 155523.jpg
    108,2 KB · Aufrufe: 19

Benares

Benutzer
Sehr erfahren
Mitglied seit
27. Sep 2008
Beiträge
12.611
Punkte für Reaktionen
3.041
Punkte
448
Lass das mit dem "chmod", wenn der der "Freigegebene Ordner" im Windows-ACL-Modus arbeitet. Da werden die Rechte auf Ebene der Freigegebenen Ordner festgelegt und 1:1 nach unten vererbt. Jeder "chmod" kappt diese Vererbung an dieser Stelle und setzt die Berechtigungsstruktur wieder auf Linux-Standard zurück.
 

Elrob

Benutzer
Mitglied seit
03. Jul 2018
Beiträge
56
Punkte für Reaktionen
1
Punkte
14
Hmm, und wie kann ich das Problem lösen... Ich brauche wegen der Maria 10db die längere Timeout (504) funktion
da beim suchen dies etwas länger dauert... Die Datenbank ist leider sehr gross.
Ich habe deswegen schon zweimal beim Synology Support interveniert.
Der Kommentar war nur die Maria 10DB braucht zu viel Ressourcen...
Wobei ich sagen muss bei der vorherigen Version hatte ich da weniger Probleme... und bei der vorherigen Version von MyPHPAdmin konnte ich da timeout direkt in der App einstellen...
 

Benares

Benutzer
Sehr erfahren
Mitglied seit
27. Sep 2008
Beiträge
12.611
Punkte für Reaktionen
3.041
Punkte
448
Sorry, das weiß ich nicht. Aber Timeouts und Rechte sind unterschiedlich Dinge.
 

alexhell

Benutzer
Sehr erfahren
Mitglied seit
13. Mai 2021
Beiträge
2.701
Punkte für Reaktionen
798
Punkte
154
Nutz doch einfach sudo vi pfad-zu-der-datei und editier es damit. Dafür musst du keine rechte ändern.
 

Benares

Benutzer
Sehr erfahren
Mitglied seit
27. Sep 2008
Beiträge
12.611
Punkte für Reaktionen
3.041
Punkte
448
Ach wenn's nur ums Editieren einer Datei geht, dann mach dich doch einfach zuvor zum root (sudo -i), der darf alles. Oder halt jedesmal mit "sudo ..." wie von @alexhell beschrieben, aber mich nervt das.
 
  • Like
Reaktionen: Valkyrianer

alexhell

Benutzer
Sehr erfahren
Mitglied seit
13. Mai 2021
Beiträge
2.701
Punkte für Reaktionen
798
Punkte
154
Musst doch nur beim ersten mal das Passwort eingeben und dann erst wieder in 15 Minuten.
 

Elrob

Benutzer
Mitglied seit
03. Jul 2018
Beiträge
56
Punkte für Reaktionen
1
Punkte
14
mache alles mit sudo-i
auch das file mit sudo vi xxxx geändert.... und kontrolliert
sobald der Apache-Server neu startet, wird mein geändertes file wieder mit den alten werten zurückgeschrieben und es ist alles wie zuvor...

Dies ein paar mal Probiert... jedesmal wenn der Apache neu startet ist wieder die original Datei vorhanden...
 

Benares

Benutzer
Sehr erfahren
Mitglied seit
27. Sep 2008
Beiträge
12.611
Punkte für Reaktionen
3.041
Punkte
448
Dazu kann ich dir wenig sagen, aber lies mal hier.
 

Elrob

Benutzer
Mitglied seit
03. Jul 2018
Beiträge
56
Punkte für Reaktionen
1
Punkte
14
Hallo
Danke der Tipp war zu 50% ok...
1. Ich habe wie im Artikel diese NGINX geändert und den Wert von 300 auf 600 gesetzt...
Nach Neustart ist in der Ecke alles ok und die Werte sind vorhanden.
2. Habe dann die usr/locale/ ... bei sites-enabled auch dort den Wert von 300 auf 600 gesetzt...
Neustart des Apache-Servers und das alte Leiden ... das System hat mir den Wert wieder auf 300 gesetzt...

Es sieht also so aus, dass bei einem Neustart des Apache er sich die Werte aus irgendeiner Ecke holt und dann meine geänderte Datei wieder in den Urzustand zurückschreibt.
 

Benares

Benutzer
Sehr erfahren
Mitglied seit
27. Sep 2008
Beiträge
12.611
Punkte für Reaktionen
3.041
Punkte
448
Hast du auch das mit der user.conf probiert?
 

Elrob

Benutzer
Mitglied seit
03. Jul 2018
Beiträge
56
Punkte für Reaktionen
1
Punkte
14
Yep... Konnte die user.conf nicht anlegen....

Bin gerade dabei am suchen warum ich dieses nicht anlegen kann
 

alexhell

Benutzer
Sehr erfahren
Mitglied seit
13. Mai 2021
Beiträge
2.701
Punkte für Reaktionen
798
Punkte
154
Was ist denn die Meldung? Hast du es mal mit sudo probiert?
 

Elrob

Benutzer
Mitglied seit
03. Jul 2018
Beiträge
56
Punkte für Reaktionen
1
Punkte
14
OK
1. Die user.conf ist angelegt ... war irgendwie mein fehler

2. alles nach diesem Hinweis (siehe oben ) überprüft

3. auch den sites-enabled erneut von 300 auf 600 gesetzt...

Diesmal den kompletten NAS neu gebootet...

Bei schauen der Dateien ist der sites-enabled wieder auf 300...

Anwendung Maria10db gestartet und getestet...

Nach 5 Minuten kommt der Timeout mit dem Http 504 Fehler

PS: änderungen mach ich Prinzipiell mit sudo
 

Benares

Benutzer
Sehr erfahren
Mitglied seit
27. Sep 2008
Beiträge
12.611
Punkte für Reaktionen
3.041
Punkte
448
Und in der user.conf steht "TimeOut 600"?
Schau mal, ob du in der Konfiguration der Webstation im DSM irgendwas mit dem Wert 300 findest.
 

Elrob

Benutzer
Mitglied seit
03. Jul 2018
Beiträge
56
Punkte für Reaktionen
1
Punkte
14
Yep in der user.conf steht TimeOut 600

Nach dem 300er zu suchen ist ne gute Idee...

Gut meine LINUX Kenntnisse sind echt mager ...aber ich versuche zu suchen...

Heute nicht mehr... Morgen ist auch noch ein Tag

Danke vorab für deine Mühe und Geduld
 


 

Kaffeautomat

Wenn du das Forum hilfreich findest oder uns unterstützen möchtest, dann gib uns doch einfach einen Kaffee aus.

Als Dankeschön schalten wir deinen Account werbefrei.

:coffee:

Hier gehts zum Kaffeeautomat 

 
 
  AdBlocker gefunden!

Du bist nicht hier, um Support für Adblocker zu erhalten. Dein Adblocker funktioniert bereits ;-)

Klar machen Adblocker einen guten Job, aber sie blockieren auch nützliche Funktionen.

Das Forum wird mit hohem technischen, zeitlichen und finanziellen Aufwand kostenfrei zur Verfügung gestellt. Wir zeigen keine offensive Werbung und bemühen uns um eine dezente Integration.

Bitte unterstütze dieses Forum, in dem du deinen Adblocker für diese Seite deaktivierst.

Du kannst uns auch über unseren Kaffeautomat einen Kaffe ausgeben oder ein PUR Abo abschließen und das Forum so werbefrei nutzen.

Vielen Dank für Deine Unterstützung!