PDA

Archiv verlassen und diese Seite im Standarddesign anzeigen : Konfiguration Mediatomb



mayday
05.02.2009, 21:53
Hallo zusammen,

nachdem mir der integrierte Mediaserver meiner DS508 überhaupt nicht gefällt, die Sortierung nur nach Interpret und dann nicht weiter nach Album ist für mich viel zu unübersichtlich. Daher habe ich über ipkg mediatomb installiert, das hat soweit auch super geklappt, das Teil läuft auch wenn ich es über die shell starte. Von meiner PS3 kann ich auch darauf zugreifen, soweit so gut. Nur leider gibt es jetzt ein Verzeichnis "PC Directory" was über UPnP zur Verfügung gestellt wird und das ist der komplette Verzeichnisbaum meiner DS ab der Wurzel und den kann man jetzt beliebig durchbrowsen. Wie lässt sich das unterbinden, ich möchte nur ganz "normal" das Audio,Photo usw. haben, nicht aber PC Directory. Ich habe in der Config nichts gefunden, wo man das abschalten könnte. Kann mir jemand sagen, wie ich das anstelle?

Gruss Mayday

mayday
05.02.2009, 22:05
Ok, ich habe noch was gefunden: Wenn man die Zeile

<pc-directory upnp-hide="yes"/>

in die config.xml einträgt, dann ist zumindest das browsing nicht mehr ab der Wurzel möglich. Dem Namen nach hätte ich zwar erwartet, dass das Verzeichnis dann gar nicht mehr auftaucht, dem ist aber nicht so. Aber jetzt hat es wenigstens nur noch den Inhalt music und @optware. Also falls jemand doch noch einen Tipp hat, wie ich das ganz ausblende, wäre ich dankbar.

Gruss Mayday

mayday
05.02.2009, 22:17
Gut, nächstes mal probiere ich vor dem posten noch ein paar Sachen aus :-)

Also jedenfalls, es geht jetzt, nach einem nochmaligen Neustart wird der Eintrag aus der config.xml jetzt korrekt ausgewertet, das PC Directory ist weg. Auch das UI habe ich abgeschaltet, sieht also soweit erstmal sehr gut aus. So wie es aussieht ist das wirklich eine sehr gute Alternative zum integrierten Mediaserver, leider gibt es ja keinen Twonky für das DS508. Jedenfalls probiere ich noch weiter ein paar Sachen aus, aber der erste Eindruck ist schonmal nicht schlecht.

Gruss Mayday

Trolli
05.02.2009, 22:45
Hört sich doch schon mal prima an. Wäre super, wenn Du uns weiter auf dem Laufenden hältst, wenn Du noch weitere Sachen rausfindest.

Nicht dass Du nachher noch denkst, das hier würde keiner lesen. Ich finde das Thema sehr interessant.

Trolli

mayday
06.02.2009, 09:27
Ja gerne doch :)

Ja fürs erste bin ich schonmal relativ zufrieden, 2 Dinge habe ich noch. Zum Einen muss ich noch die DS so einrichten, dass Mediatomb beim Systemstart mit gestartet wird (da habe ich schon ein paar Sachen hier im Forum/Wiki gefunden, muss ich mal schauen) und dann habe ich noch das Problem, dass bei ein paar Files beim Scan vom Server angezeigt wird, dass die Samplerate falsch sein, was auch immer das bedeutet, jedenfalls laufen alle meine Files ohne Probleme im "normalen" Mediaserver der DS und auch bsp. in itunes, keine Ahnung was da falsch sein soll, es wird dummerweise auch nicht angezeigt bei welcher Datei das beanstandet wird.

Aber da muss ich eben noch ein bischen weiter suchen.

Sonst ist das Teil prima, die Sortierung ist endlich so, wie ich es erwarten würde. Ich habe ~4000 Musikstücke (Itunes-Plus Stücke und eigene gerippte CDs), mehrere Alben pro Interpret und wenn da immer bei der Auswahl Interpret einfach nur alle Stücke, so wie beim Standard-DS-Mediaserver angezeigt werden, ist das sehr unübersichtlich und unpraktisch, jedenfalls für mich. Das ist jetzt viel besser, man bekommt danach eine Auswahl der Alben, so wie ich das auch erwartet hätte.

Gruss Mayday

saeschu
24.04.2009, 07:30
Wenn ich das richtig mitbekommen habe kodiert mediatomb mkv-Files onthefly?

Kannst du also mkv-files auf der diskstation direkt auf der PS3 abspielen?

_TokTok_
24.04.2009, 17:05
Hallo mayday,

Du scheinst ne Menge Erfahrung mit der Installation und Konfiguration von Mediatomb gesammelt zu haben. Das Thema ist sicherlich auch für andere Benutzer sehr interessant. Gerade vor dem Hintergrund, dass nicht alle so zufrieden mit dem eingebauten upnp-server der DS sind, wär es super wenn Du basierend auf Deinen Erkenntnissen ne kurze Anleitung für die DS hier ins Forum oder noch besser ins Wiki stellen könntest.

Gruß

_TokTok_

drknickel
25.04.2009, 09:16
Ich wäre auch sehr an einem kleinen Tutorial interessiert :)

LG

PS: Das hab ich noch auf der englischen Siete gefunden:
http://www.jpkessler.de/mybookupnp/index.html
http://www.nslu2-linux.org/wiki/Info/MediaTomb
http://forum.synology.com/enu/viewtopic.php?f=3&t=6813&start=0&hilit=mediatomb

Garfield
21.07.2009, 10:24
Hi,

ich hab den Mediatomb zum laufen bekommen. Nun möchte ich gerne mkv Dateien transcodieren. Laut dieser Seite bin ich vorgegangen: http://www.webmasterpro.de/server/article/services-mediatomb-plattformunabhaengiger-medienserver.html#goto-matroska-mkv-dateien-on-the-fly-umkodieren .

Allerdings komme ich hier nicht weiter. Für die 16 Zeilen aus dem Beispiel wrapperscript mediatomb-ffmpeg habe ich im Verzeichniss /root/.mediatomb/ eine Datei mit dem Namen mediatomb-ffmpeg angelegt und den den Inhalt aus dem Script eingefügt. RICHTIG?!? FALSCH!?!

Die 22 Zeilen aus dem Abschnitt MKV Dateien Transcodieren habe ich in die config.xml eingefügt.

Wenn ich jetzt den mediatomb starten will, bekomme ich folgende Fehlermeldung:
NAS> mediatomb

MediaTomb UPnP Server version 0.11.0 - http://mediatomb.cc/

================================================== =============================
Copyright 2005-2008 Gena Batsyan, Sergey Bostandzhyan, Leonhard Wimmer.
MediaTomb is free software, covered by the GNU General Public License version 2

2009-07-21 11:17:30 INFO: Loading configuration from: /root/.mediatomb/config.xml
2009-07-21 11:17:30 INFO: Checking configuration...
2009-07-21 11:17:30 INFO: Setting filesystem import charset to ANSI_X3.4-1968
2009-07-21 11:17:30 INFO: Setting metadata import charset to ANSI_X3.4-1968
2009-07-21 11:17:30 INFO: Setting playlist charset to ANSI_X3.4-1968
2009-07-21 11:17:30 ERROR: error in configuration, transcoding profile "transcode-mkv" could not find transcoding command mediatomb-ffmpeg in $PATH

In der config.xml finde ich allerdings keinen Hinweis auf $PATH. Könnt ihr mir hier weiterhelfen?

LG

coolhot
21.07.2009, 14:13
Vielleicht ist die systemweite Umgebungsvariable PATH gemeint. Gib mal auf der Koommandozeile set ein und checke die Ausgabe PATH='.

Darin sollte der Pfad zum mediatom Executable enthalten sein. Falls es fehlt kannst du es erweitern unter /etc/profile.

mayday
21.07.2009, 15:08
@_TokTok_:

sorry, für die leicht :-) verspätete Antwort, ich war lange nicht hier...

jedenfalls habe ich das mit Mediatomb erstmal wieder verworfen, bzw. nichts mehr weiter dran gemacht. Ich war mit den Möglichkeiten immer noch nicht so recht zufrieden, auch wenn die schon viel besser waren als der integrierte... Jedenfalls habe ich mir ein paar Squeezeboxen gekauft, Squeezecenter installiert und bin zufrieden :-) War zwar auch noch ein kleiner Kampf bis das Teil AAC ausgeben konnte, aber das tut jetzt (anderes Thema).

Ich habe aber alles mitprotokoliert was ich mit Mediatomb so gemacht habe, das kann ich gerne zur Verfügung stellen, allerdings nicht vor Ende der Woche, bin gesch. unterwegs.

Gruss Mayday

Garfield
21.07.2009, 15:26
Hi :o) ,

da ich gerade voll im Mediatomb stecke, bin ich sehr an deinen Protokollen interessiert :D. Würd mich freuen, wenn Du sie online stellst. Many THX im vorraus

coolhot
21.07.2009, 18:51
Vielleicht ist die systemweite Umgebungsvariable PATH gemeint. Gib mal auf der Koommandozeile set ein und checke die Ausgabe PATH='.

Darin sollte der Pfad zum mediatom Executable enthalten sein. Falls es fehlt kannst du es erweitern unter /etc/profile.

@Garfield: Hast du diese Antwort von mir gesehen und falls ja - hat´s was gebracht?

Garfield
21.07.2009, 19:37
@Garfield: Hast du diese Antwort von mir gesehen und falls ja - hat´s was gebracht?

Hi Coolhot,

nanu.... ich hatte Deine Antwort gelesen und habe auch sofort drauf geantwortet. Komisch wo isn die geblieben :confused:. Nunja, dann jetzt hier nochmal:

Hatte kurz vor Deinem Beitrag einfach mal den kompletten Pfad ins Script geschrieben, dann gings aber auch noch nicht. Erst nachdem ich dem Script per CHMOD ein paar mehr Rechte verpasst hatte, gings. In der /etc/profile steht der Pfad nicht drin, habe ihn gerade eingetragen und nun gehts auch so.

Jetzt funktioniert MediaTomb prinzipiell. Verbindung zum TV steht, MP3s werden auch schon abgespielt. Nun hänge ich gerade am Abspielen von AVIs (TV-Meldung: Datei wird nicht unterstützt) - keine Fehlermeldung an der Mediatomb Console und bei MKV Dateien (TV-Meldung: Datei nicht verfügbar) und folgender Consolenmeldung:


2009-07-21 17:53:10 INFO: Arguments: %in %out
2009-07-21 17:53:10 ERROR: process terminated early
2009-07-21 17:53:13 ERROR: open: failed to open: /tmp//mt_transcode_46I8WU
2009-07-21 17:53:13 INFO: Arguments: %in %out
2009-07-21 17:53:13 ERROR: process terminated early
2009-07-21 17:53:16 ERROR: open: failed to open: /tmp//mt_transcode_GOKRXU
2009-07-21 17:53:17 INFO: Arguments: %in %out
2009-07-21 17:53:17 ERROR: process terminated early
2009-07-21 17:53:20 ERROR: open: failed to open: /tmp//mt_transcode_T8LHXU
2009-07-21 17:53:20 INFO: Arguments: %in %out
2009-07-21 17:53:20 ERROR: process terminated early
2009-07-21 17:53:23 ERROR: open: failed to open: /tmp//mt_transcode_2ROSXU
2009-07-21 17:53:24 INFO: Arguments: %in %out
2009-07-21 17:53:24 ERROR: process terminated early
2009-07-21 17:53:27 ERROR: open: failed to open: /tmp//mt_transcode_TSLHXU

Hat jemand ne Idee?

jahlives
22.07.2009, 15:49
2009-07-21 17:53:27 ERROR: open: failed to open: /tmp//mt_transcode_TSLHXU
Korrekte Pfade sehen für mich aber anders aus...

Garfield
22.07.2009, 16:01
mit dem korrekten Pfad stimm ich Dir voll und ganz zu :D. Habe es mir bis jetzt so erklärt, das es ein Zusfallsordner ist, welcher beim transcodieren angelegt wird... warum allerdings /tmp// (2x /) ist mir noch nicht klar. Das Script, welches hierfür zuständig ist, schaut wie folgt aus:
#!/bin/bash
# cat /usr/bin/mediatomb-transcode-video-ffmpeg
INPUT="$1"
OUTPUT="$2"
VIDEO_CODEC="mpeg2video"
VIDEO_BITRATE="4096k"
AUDIO_CODEC="mp2"
AUDIO_BITRATE="192k"
AUDIO_SAMPLERATE="48000"
AUDIO_CHANNELS="2"
FORMAT="dvd"

exec /usr/bin/ffmpeg -threads 2 -i "${INPUT}" -vcodec ${VIDEO_CODEC} -b ${VIDEO_BITRATE} \
-acodec ${AUDIO_CODEC} -ab ${AUDIO_BITRATE} -ar ${AUDIO_SAMPLERATE} -ac ${AUDIO_CHANNELS} \
-f ${FORMAT} - > "${OUTPUT}" #2>/dev/null

wasabi_sheep
27.10.2009, 02:39
das mediatomb-ffmpeg sollte in eine ausführbare umgebung.
bei mir habe ich es nach /usr/local/bin verschoben
(cp mediatomb-ffmpeg /usr/local/bin/mediatomb-ffmpeg)
und nun gehts, ausserdem würde ich noch chmod +x und chmod 777 setzen falls es nicht klappt.