Wo finde ich das LMS Paket?

JackieFan

Benutzer
Mitglied seit
31. Jan 2018
Beiträge
22
Punkte für Reaktionen
0
Punkte
1
Hallo, ich benötige mal ein Tipp von euch.

Bis jetzt läuft soweit alles, LMS läuft über Docker, Port 9002 (9000 ging nicht), Die PUID/GUID habe ich geändert und erst dann fand LMS die Musik von mir... aber:

Aus irgendwelchen Grund konnte LMS nicht die komplette Musik Sammlung Indizieren/Scan.
Meine Musik liegt auf "/volume1/Musik"
Darin sind drei Ordner zu finden, Alben, Singles, Soundtracks. LMS hat Musikdateien nur unter Alben finden können, Singles und Soundtracks sind keine gescannt worden.
Ein erneutes Scannen hat leider nichts gebracht, es werden keine weiteren hinzugefügt. Weiß jemand woran das liegen kann ?

Des Weiteren findet meine Sqeeuzbox Radio unter Eigene Musik > Musikordner keine Ordner die man durchstöbern kann, sprich Alben, Singles, Soundtracks. Woran kann das liegen ?

Dank im Voraus.
 

CptGambit

Benutzer
Mitglied seit
25. Nov 2013
Beiträge
336
Punkte für Reaktionen
0
Punkte
22
Ich komm mir wie ein ziemlicher Idiot vor. Ich bin über den Thread hier wie alle anderen gestolpert. Fälschlicherweise Perl Update gemacht und dann ging der LMS nicht mehr.
Ich bin gerade dabei die alte Perl Version zu installieren und das hat auch gut funktoniert. Jetzt will ich die 7.9.2 vom LMS runterladen und installieren (Docker läuft auf meiner DS214+ nicht).
Aber wenn ich den sourceforge links die hier oder in anderen Thread verlinkt sind folge, also konkret: https://sourceforge.net/projects/lmsupdate/files/DSM6.x/ dann lande ich immer auf https://sourceforge.net/directory/ und da ist dann kein Link. Hab schon verschiedene Browser ausprobiert. Funzt mit keinem. Ich hab auf sourceforge schon nach lmsupdate gesucht aber nichts konkretes gefunden.
Wie komme ich an das LMS Update ran, zu Hülf!
 

CptGambit

Benutzer
Mitglied seit
25. Nov 2013
Beiträge
336
Punkte für Reaktionen
0
Punkte
22
Ich muss nochmal fragen. Gibt es irgendwo eine Quelle für LMS für eine 8.0.1 oder höher für die DS214+ also armadaxp?

Hab zwischenzeitlich eine Quelle gefunden wo ich die 8.0.0 runterladen konnte, aber jetzt ist mein LMS "zu hoch" für mein SB Radio. Und fürs Radio gibts keine neuere Version mehr von Logitech. Also müsste ich auf eine community software zurückgreifen. Für deren Installation brauche ich aber ein plugin was nur unter 8.0.1 oder höher läuft.
Es ist ein bekackter Teufelskreis und das alles weil ich Pearl aktualisiert hab. Das ist echt lächerlich.
 

CptGambit

Benutzer
Mitglied seit
25. Nov 2013
Beiträge
336
Punkte für Reaktionen
0
Punkte
22
@steje43
@metalian
@soundsmith
@Airmaxchen

Hab mir jetzt auch nen neue DS gegönnt und seit 2h versucht LMS in Docker ans Laufen zu kriegen.

Der LMS lief auch recht schnell und es war unkompliziert ihn zu starten. Was bei mir nie funktioniert hat, das Einlesen der Musik aus dem /music Ordner.
Er hatte immer nach 0 sek gesagt er wäre fertig.

Bei mir lag es tatsächlich auch an den PUID und PGID.

Die PUID war nicht das Problem, aber die PGID. Bei cat /etc/passwd hab ich
MEINUSER:x:1026:100::/var/services/homes/meinuser:/bin/sh
herausbekommen und wenn ich id MEINUSER gemacht habe kam:
uid=1026(MEINUSER) gid=100(users) groups=100(users),101(administrators)

Mein Fehler war jetzt, dass ich in der PGID die 100 eingetragen hab. Das ist die users Gruppe. Die darf auf meiner DS aber nicht sehr viel. Ich hab dann auf 101 geändert (administrators) und dann liesen sich die mp3 auch einlesen.

@KAyAN
Vielleicht kannst du das in deinem Tutorial noch etwas abändern, damit man die richtigen IDs findet.
 

holzwurm83

Benutzer
Mitglied seit
21. Nov 2021
Beiträge
1
Punkte für Reaktionen
0
Punkte
1
Mich hat die Einstellung des LMS als PACKTE und das K.O. durch das Perl-Update auch kalt erwischt.
Um anderen etwas Zeit zu sparen, nachfolgen hier mal meine Konfiguration mit der ich das Docker-Image auf einer Synology-NAS zu laufen gebracht habe.

Hier meine Vorgehensweise zur Installation von LMS und anderen Docker-Containern.
Die Anleitung bezieht sich auf den Container von https://registry.hub.docker.com/r/lmscommunity/logitechmediaserver/.
(Die Vorgehensweise hat keinen Anspruch auf Allgemeingültig- und Richtigkeit, Verbesserungsvorschläge werden dankend angenommen)

Grundlagen/Vorgehen:
1. Im Pack-Zentrum den Logitech Media Server UNBEDINGT deinstallieren, da sich die Ports bei der Installation des Docker-Abbilds ins Gehege kommen und die Konfiguration dann verloren geht, weil nicht gespeichert werden kann.
2. „Docker“ über das „Pack-Zentrum“ installieren.
3. Mit der „File Station“ auf einem Volumen einen Ordner „docker“ anlegen.
In diesem Ordner eine Unterordner „LogitechMediaServer“ und in diesem Ordner „Playlist“ anlagen.
4. Das Synology-Packet „Docker“ öffnen und unter „Registrierung“ in der SUCHE LMS eingeben.
5. Das Abbild „lmscommunity/logitechmediaserver“ mit dem Tag „lastest“ downloaden.
6. Unter „Abbild“ das Abbild „lmscommunity/logitechmediaserver“ auswählen und auf „Starten“ klicken.
7. Unter „Allgemeine Einstellungen“ auf „Erweiterte Einstellungen“ klicken.
8. Im Reiter „Allgemeine Einstellungen“ „Automatischer Neustart aktivieren“.
8.1. Im Reiter „Volume“ nachfolgende „Ordner hinzufügen“:
8.1.1. Ordner: docker/LogitechMediaServer/PlayList --- Mount-Pfad: /playlist
8.1.2. Ordner: Ihr Ordner wie Sie ihre Musik gespeichert haben --- Mount-Pfad: /music und diesen als „nur Lesen“ markieren.
8.1.3. Ordner: docker/LogitechMediaServer --- Mount-Pfad: /config
8.2. Im Reiter „Netzwerk“ unverändert auf „bridge“ belassen.
8.3. Im Reiter „Ports“ die Vorschläge der Ports wie folgt anpassen:
8.3.1. Lokaler Port: 3483 --- Container-Port: 3483 - TCP
8.3.2. Lokaler Port: 3483 --- Container-Port: 3483 - UDP
8.3.3. Lokaler Port: 9002 --- Container-Port: 9002 - TCP
8.3.4. Lokaler Port: 9090 --- Container-Port: 9090 – TCP
8.4. Im Reiter „Links“ keine Änderungen vornehmen.
8.5. Im Reiter „Umgebung“ die Folgende Variablen anpassen bzw. hinzufügen:
8.5.1. Klick auf das graue „+“ und Variable: TZ --- Wert: Europe/Vienna oder Europe/Berlin eintragen (Hinweis siehe weiter unten)
8.5.2. Variable: PUID --- Wert: 1000 ändern.
8.5.3. Variable: PGID --- Wert: 1000 ändern.
8.5.4. Variable: HTTP_PORT --- Wert: 9002 ändern.
Wenn alles erledigt ist, dann sollte der LMS unter http://IP-derNAS:9002 erreichbar sein!

Was mir so gar nicht gefällt ist die Tatsache, dass auf zwei unterschiedlichen Synology-NAS die Zeiteinstellung bei dem Wert der Variable „TZ“ ganz unterschleich ist. Bei einer muss ich „Europe/Vienna“ setzen bei der anderen geht „Europe/Berlin“. Sehr sehr komisch. Vielleicht hat jemand eine gute Idee?

Die weitergehenden Konfigurationen kann wie gewohnt dann unter „Einstellungen“ vorgenommen werden.
Ich hoffe ich konnte etwas helfen und möchte mich auf diesem Wege recht herzlich bei der „lmscommunity“ für ihre tolle Arbeit bedanken um das Ökosystem LMS nicht sterben zu lassen!
Hallo zusammen,

ich habe mein LMS nach der Anleitung zum laufen gebracht. Mein Problem ist nur das ich nicht auf meine iTunes Bibliothek zugreifen kann, die außerhalb vom Docker Ordner liegt. Wenn ich diese innerhalb des Ordners ablege kann ich darauf zugreifen.

Ich kann demnach nur Ordner einbinden, die im Dockerordner liegen und die außerhalb liegen nicht.
Das hängt doch mit den Rechten zusammen? wie kann ich das lösen?
 
NAS-Central - Ihr Partner für NAS Lösungen