SynoExt - Firefox Plugin

Harry_Hirsch

Benutzer
Mitglied seit
29. Sep 2008
Beiträge
53
Punkte für Reaktionen
0
Punkte
6
geht wohl nur bei der beta

Hi,

ich habe gerade mal nachgeschaut. Meine Version ist auch die "4.0" und dabei handelt es sich meines Wissens nach um den RC3 (meine mich daran erinnern zu können, dass das so beim Update stand). Aber wie auch immer....ein Blick in about:config offenbart, dass das Ausschalten der Versionsabfrage wohl nur bei der beta-Version funktioniert hat, denn der Eintrag "extensions.checkCompatibility" oder "extensions.checkCompatibility.40b" zeigt keine Wirkung (mehr). Kommt Zeit, kommt Rat...vielleicht kann ja der Entwickler mal sagen, ob/wann es das addon für die aktuelle 4er-Version geben wird!?!?

CU

H_H
 

moshquito

Benutzer
Mitglied seit
05. Mrz 2011
Beiträge
53
Punkte für Reaktionen
0
Punkte
0
ich hatte ja gestern vor der Installation von FF4.0 mit Mozbackup eine Sicherung angelegt und werde wohl ein Downgrade machen.... bei mir funktionieren einige Plugins nicht mehr....
 

moshquito

Benutzer
Mitglied seit
05. Mrz 2011
Beiträge
53
Punkte für Reaktionen
0
Punkte
0
Unter Einstellungen - Erweitert - Update - Update-Chronik kannst du dir die exakte Version anschauen....
 

alexserikow

Benutzer
Mitglied seit
23. Feb 2011
Beiträge
877
Punkte für Reaktionen
0
Punkte
36
hallo zusammen,

ich bekomme immer die angehangene Fehlermeldung...

Gruß
 

Anhänge

  • Fehlermeldung.JPG
    Fehlermeldung.JPG
    33,1 KB · Aufrufe: 181

lucullus_52

Benutzer
Mitglied seit
24. Jan 2010
Beiträge
78
Punkte für Reaktionen
0
Punkte
6
Hallo,

nach dem Update auf Firefox 4.0 (BuildID 20110318052756) wird Synoload als "nicht kompatibel" angezeigt.
Bleibt zu hoffen, daß diese Erweiterung bald aktualisiert wird.

Jürgen
 

Kauabunga

Benutzer
Mitglied seit
18. Jul 2009
Beiträge
105
Punkte für Reaktionen
0
Punkte
0
Hi zusammen!

Ich habe das Synoext bei meinem FF4.0 so zum laufen gebracht:
In das FF Userprofil zur Synoext-Extension wecheln. Diese liegt normal hier
Rich (BBCode):
C:\Dokumente und Einstellungen\USERNAME\Anwendungsdaten\Mozilla\Firefox\Profiles\crn02zjo<-Profilname.default\extensions\synoext@masterfix.mine.nu

Dort die Datei install.rdf im Texteditor aufmachen und MaxVersion so abändern:
Rich (BBCode):
<?xml version="1.0"?>
<RDF:RDF xmlns:em="http://www.mozilla.org/2004/em-rdf#"
		 xmlns:NC="http://home.netscape.com/NC-rdf#"
		 xmlns:RDF="http://www.w3.org/1999/02/22-rdf-syntax-ns#">
	<RDF:Description RDF:about="urn:mozilla:install-manifest"
					 em:id="synoext@masterfix.mine.nu"
					 em:name="SynoExt"
					 em:version="0.7"
					 em:creator="Patrik Obrist"
					 em:description="A Download Redirector for Synology NAS devices."
					 em:iconURL="chrome://synoext/skin/synoext.png"
					 em:optionsURL="chrome://synoext/content/preferences.xul">
		<em:targetApplication RDF:resource="rdf:#$d6a5X3"/>
	</RDF:Description>
	<RDF:Description RDF:about="rdf:#$d6a5X3"
					 em:id="{ec8030f7-c20a-464f-9b0e-13a3a9e97384}"
					 em:minVersion="3.0"
					 em:maxVersion="4.*" />
</RDF:RDF>

Dann lief das Ganze bei mir problemlos.

Im FF4.0 dann noch ein Rechtsklick in die freie Menüleiste und "Add-on-Leiste anzeigen"

Fertig!
 

petehild

Benutzer
Mitglied seit
17. Mrz 2011
Beiträge
443
Punkte für Reaktionen
0
Punkte
22
Kauabungas Tipp funktioniert übrigens auch vor der Installation des Addons, wenn man die Datei install.rdf direkt in der xpi Datei anpasst :)
Dazu muss man die xpi-Datei runterladen, editieren und dann im Firefox öffnen...
 
Zuletzt bearbeitet:

coolhot

Benutzer
Mitglied seit
01. Mrz 2009
Beiträge
926
Punkte für Reaktionen
0
Punkte
0
@Kauabunga: Danke für den Tipp. Ich konnte damit gerade ebenfalls das "TinyURLGenerator"-Add-On in FF4 reaktivieren.
 

lucullus_52

Benutzer
Mitglied seit
24. Jan 2010
Beiträge
78
Punkte für Reaktionen
0
Punkte
6
@Kauabunga: Danke für die Erinnerung. Mit diesem Schritt konnte ich auch Synoload 1.5 wieder lauffähig in Firefox 4.0 einbinden. In diesem Fall half es aber nichts, in der im extension-Verzeichnis befindlichen Datei "load@syno.nas.xpi" die Änderungen vorzunehmen, sondern in der "install.rdf" der Datei "synoload-1.5-fx sm.xpi"
Die "install.rdf" sieht nach dem Editieren so aus:
<?xml version="1.0" encoding="UTF-8"?>
<RDF xmlns="http://www.w3.org/1999/02/22-rdf-syntax-ns#"
xmlns:em="http://www.mozilla.org/2004/em-rdf#">
<Description about="urn:mozilla:install-manifest">
<em:id>load@syno.nas</em:id>
<em:name>SynoLoad</em:name>
<em:version>1.5</em:version>
<em:creator>Christian Bender</em:creator>
<em:description>A small Plugin that allows you to send Downloads to your Synology NAS</em:description>
<em:eek:ptionsURL>chrome://synoload/content/options.xul</em:eek:ptionsURL>
<em:iconURL>chrome://synoload/skin/images/icon.png</em:iconURL>
<em:homepageURL>http://cbender.dyndns.org/synoload/</em:homepageURL>
<em:targetApplication>
<Description>
<em:id>{ec8030f7-c20a-464f-9b0e-13a3a9e97384}</em:id> <!-- firefox -->
<em:minVersion>1.5</em:minVersion>
<em:maxVersion>4.*</em:maxVersion>
</Description>
</em:targetApplication>
<!-- SeaMonkey -->
<em:targetApplication>
<Description>
<em:id>{92650c4d-4b8e-4d2a-b7eb-24ecf4f6b63a}</em:id>
<em:minVersion>1.1</em:minVersion>
<em:maxVersion>4.*</em:maxVersion>
</Description>
</em:targetApplication>
</Description>
</RDF>

Ich weiß zwar nicht, ob es nötig war, beide markierte Stellen in "4.0" zu ändern (1. von 3.6, 2. von 2.0), auf jeden Fall läuft es so....

Synoext ließ sich so zwar auch anpassen, ich finde Synoload aber im Gebrauch praktischer, da bei diesem Add-On einfach ein Zusatzpunkt in die Download-Maske kommt. .... Das Bild der Maske kann ich leider nicht einfügen, da mir die URL zu meinem screenshot fehlt ... peinlich.....
 

Kauabunga

Benutzer
Mitglied seit
18. Jul 2009
Beiträge
105
Punkte für Reaktionen
0
Punkte
0
..freut mich dass ich der Syno-Gemeinde auch mal wieder etwas zurückgeben konnte...:cool:
 

frakki

Benutzer
Mitglied seit
29. Dez 2009
Beiträge
133
Punkte für Reaktionen
0
Punkte
16
Ihr könnt auch in die about:config gehen einen neuen Boolean Wert mit dem Namen: extensions.checkCompatibility.4.0 anlegen und den auf false setzen. So wird die Update-Kompatibilität ausgeschaltet und ihr könnte jedes Addon installieren!
 

Breitkrug

Benutzer
Mitglied seit
09. Mrz 2011
Beiträge
149
Punkte für Reaktionen
0
Punkte
0
Hallo!

Ich habe gerade SynoExt zu Firefox 3.6.14 hinzugefügt und bekomme bei jedem Donloadversuch die gleiche Fehlermedlung: "1 Download task accepted! / 1 Download task not accepted!" Mehr passiert nicht. Server-URL und User/pwd scheinen zu stimmern, den das SynoExt Icon ist grün. Bei fehlenden oder verkehrten Angaben ist es rot.

Was kann ich tun?

Danke & Gruß,
Fu Shen

Ich klinke mich mal mit ein...

Betriebssystem: Mac OS X 10.6.7
Browser: Firefox 4

Download des Addons über Rechtsklick (Ziel speichern unter)
Nun wie hier im Post beschrieben, die Install.rdf abgeändert.
Die XPI-Datei habe ich allerdings unter Windows entpackt und wieder zurückgepackt (Extender in Zip geändert, nach Abschluss in Xpi zurück geändert), da Mac irgendwelche verstecke Dateien hinzufügt und die Xpi-Datei dadurch in Firefox nicht mehr anerkannt wird.
Für SynoExt einen Benutzer erstellt mit Zugriff auf den Downloadordner sowie Anwendungsberechtigung für die Downloadstation.
SynoExt Einstellungen gesetzt, Symbol wird grün, jedoch kein Download möglich (erhalte selbe Fehlermeldung wie im Zitat angegeben).
Lösung: Einloggen auf die DS mit dem SynoExt Benutzer und starten der DownloadStation --> Downloadordner angeben --> ausloggen --> Addon funktioniert nun.

Greets
 

lucullus_52

Benutzer
Mitglied seit
24. Jan 2010
Beiträge
78
Punkte für Reaktionen
0
Punkte
6
Ihr könnt auch in die about:config gehen einen neuen Boolean Wert mit dem Namen: extensions.checkCompatibility.4.0 anlegen und den auf false setzen. So wird die Update-Kompatibilität ausgeschaltet und ihr könnte jedes Addon installieren!

Vielleicht habe ich meinen Firefox mit irgendwelchen Einstellungen oder Add-ons so gesichert, daß ich selber nichts mehr über about:config ändern kann. Wenn ich den o.g. Boolschen Wert anlege, ist er nach einem Firefox-Neustart wieder verschwunden....
Mach ich was falsch?
 

Henryk42

Benutzer
Mitglied seit
11. Mai 2007
Beiträge
135
Punkte für Reaktionen
0
Punkte
16
ich bekomme immernoch die fehlermeldung. bei mir läufts leider nicht :(

Mit Mozilla 3.6.17 hatte ich auch diese Meldung.
Habe mich dann den DSM unter Mozilla aufgerufen,
es kam eine Sicherheitswarnung und nach meiner Zustimmung,
das mir die Quelle bekannt ist,
wurde das Zertifikat der Synology in den Zertifikatmanager des Mozilla eingefügt.

Somit ist bei mir diese Meldung weg und Synoext ist endlich verbunden.

Habe gerade ein upgrade auf 4.01 gemacht: Synoext wird deaktiviert da es nicht zum Firefox 4 kompatibel ist.
Daraufhin habe ich wieder ein upgrade auf Firefox 3.6.17 durchgeführt und das Synoext Plugin läuft wieder.
 
Zuletzt bearbeitet:

Henryk42

Benutzer
Mitglied seit
11. Mai 2007
Beiträge
135
Punkte für Reaktionen
0
Punkte
16
...
Habe gerade ein upgrade auf 4.01 gemacht: Synoext wird deaktiviert da es nicht zum Firefox 4 kompatibel ist.
Daraufhin habe ich wieder ein upgrade auf Firefox 3.6.17 durchgeführt und das Synoext Plugin läuft wieder.

Heute habe ich auf die Synoext pluginseite geschaut und dort hat ein User in der Bewertung aufgeführt wie das Plugin ab Firefox 4.0 läuft.
Siehe:
h**ps://addons.mozilla.org/de/firefox/addon/synoext/

Habe gleich ein upgrade des Firefox von 3.6.17 auf 4.01 durchgeführt und das plugin im Firefox 4.01 installiert.

Es läuft.

PS.: Habe den Tip von Breitkrug übersehen der hier im 173ten Beitrag gepostet wurde und das gleiche bewirkt
 
Zuletzt bearbeitet:

linuxdep

Benutzer
Mitglied seit
02. Jan 2009
Beiträge
537
Punkte für Reaktionen
7
Punkte
38
schade das es kein update auf die 4.x Version gibt....
 

petehild

Benutzer
Mitglied seit
17. Mrz 2011
Beiträge
443
Punkte für Reaktionen
0
Punkte
22
Mit Firefox 5.0 geht das Spiel wieder von vorne los... Der "Trick" mit dem Hochsetzen der maxversion funktioniert aber auch mit Firefox 5.0 :)
 
NAS-Central - Ihr Partner für NAS Lösungen