phpMyAdmin für php8

Darian

Benutzer
Mitglied seit
02. Aug 2022
Beiträge
3
Punkte für Reaktionen
0
Punkte
1
Moin zusammen,

ich bin neu im Thema eigener Webserver. Hatte früher Webspace bei den Domainanbietern.
Nun versuche ich die Anleitung von Synology durchzugehen.

Ich habe jetzt
  • PHP 8.0
  • Apache HTTP Server 2.4
  • Web Station
installiert. Nun wollte ich phpMyAdmin installieren. So wie ich das verstehe funktioniert das (wie auch Joomla oder WordPress) nur mit PHP 7.4 - ist das richtig? Kann ich die Programme nicht auch mit PHP 8 nutzen?

Ich nutze eine DS420+ mit DSM 7.1

Beste Grüße

Darian
 

Fusion

Benutzer
Sehr erfahren
Mitglied seit
06. Apr 2013
Beiträge
13.653
Punkte für Reaktionen
722
Punkte
404
Du musst es von der Quelle installieren und nicht über das Paketzentrum. Dann kannst du phpMyAdmin mit jeder ph-Version verwenden die dieser unterstützt.

Über das Paketzentrum musst du eben mit fest pro Paket definierten Abhängigkeiten leben wie sie Synology definiert hat bzw. wenn sie die Pakete aktualisieren.

Gleiches gilt für andere Software.
 

TheGardner

Benutzer
Mitglied seit
30. Nov 2012
Beiträge
1.701
Punkte für Reaktionen
14
Punkte
64
Was Fusion meint:

- hier hingehen https://www.phpmyadmin.net/
- die aktuelle 5.2.0 laden und unter /web/phpmyAdmin/ entpacken
- dann https://Deine_DS/phpmyAdmin/ aufrufen und das Ganze "installieren" (Datenbank und User [root] angeben...etc.)

Danach immer dort die aktuelle Version downloaden und im phpmyAdmin Ordner entpacken, ABER NIEMALS die config.inc.php überschreiben oder löschen...
 
NAS-Central - Ihr Partner für NAS Lösungen
NAS-Central - The Home of NAS

Kaffeautomat

Wenn du das Forum hilfreich findest oder uns unterstützen möchtest, dann gib uns doch einfach einen Kaffee aus.

Als Dankeschön schalten wir deinen Account werbefrei.

:coffee:

Hier gehts zum Kaffeeautomat 

Hosted by netcup