Nextcloudhub 21.0.1 und cron

TheGardner

Benutzer
Mitglied seit
30. Nov 2012
Beiträge
1.646
Punkte für Reaktionen
6
Punkte
64
Hatte das Ganze jetzt noch bei Andreas geschrieben, vielleicht findet der etwas, woran das liegt. Bei mir gehts nach wie vor nicht. Bin aber zu faul jetzt das Backup mal probeweise einzuspielen.
 

OdinsAuge

Benutzer
Mitglied seit
12. Nov 2015
Beiträge
334
Punkte für Reaktionen
15
Punkte
24
Was ich rausgefunden habe, hab ich ja schon geschrieben. Mir fällt gerade auf, der Link in meiner Signatur ist ja gar nicht mehr da.
Ich freu mich natürlich immer wenn ich weiterhelfen kann, aber wenn ich mal ansteh lande ich auch hier.

Ich bin jetzt kurz davor Nextcloud doch noch mal über Docker zu versuchen, da scheints ja wirklich weniger Probleme zu geben.
Hab auch noch mal in NC Forum gepostet aber da ist man sich ja meist keiner Schuld bewusst.
 

TheGardner

Benutzer
Mitglied seit
30. Nov 2012
Beiträge
1.646
Punkte für Reaktionen
6
Punkte
64

LORDNIKON1

Benutzer
Mitglied seit
16. Nov 2015
Beiträge
244
Punkte für Reaktionen
15
Punkte
24
Ja geiler Scheiß. Bei den letzten Updates lief alles wunderbar. Musste zwar immer die Rechte wieder anpassen aber habe den cronjob jeweils wieder zum laufen gebracht. Mit dem Update auf 21.0.3 allerdings klappt das nicht mehr. Was für ein riesen Schei***
 

LORDNIKON1

Benutzer
Mitglied seit
16. Nov 2015
Beiträge
244
Punkte für Reaktionen
15
Punkte
24
Bei mir hat es übrigens keine Auswirkungen auf die crontab, wenn ich den memcache Eintrag in der config rausnehme. Bekomme dann halt eine Fehlermeldung mehr in der Nextcloud Verwaltung, der cronjob läuft trotzdem nicht.
 

Tuxnet

Benutzer
Mitglied seit
02. Jan 2019
Beiträge
199
Punkte für Reaktionen
4
Punkte
18
@LORDNIKON1

Wie und welche rechte hast du Manuel gesetzt ?
 

TheGardner

Benutzer
Mitglied seit
30. Nov 2012
Beiträge
1.646
Punkte für Reaktionen
6
Punkte
64
er meint (wenn er die Nextcloud Install manuell durchführt, dann macht er unter WEB ja quasi nen neuen Nextcloud Ordner mit seinem Benutzer und muss) diesen nextcloud Ordner unter /web dann manuell auf http in chown und chgrp setzen.
Das ist das manuelle Setzen, was jeder immer machen muss, wenn sie/er nextcloud manuell installiert (ohne die Nextcloud Auto-Install zu verwenden).
 

jck42

Benutzer
Mitglied seit
18. Mrz 2012
Beiträge
15
Punkte für Reaktionen
7
Punkte
3
Naaabend. Ich hatte nach Aktualisierung des Synology PHP 7.4 und Nextcloud auf 21.0.3 das gleiche Problem:

Entweder:
  • APCu geht - dann geht cron nicht (APCu scheinbar nicht nutzbar per CLI)
Oder:
  • APCu-Memcache in config.php auskommentiert, dann geht cron, aber die Übersicht meckert, dass kein PHP-Cache aktiviert ist.
Fehlermeldungen im log gab es natürlich keine!

Ich habe eine Lösung gefunden, die es erlaubt, beides zu nutzen:
  1. Code:
    In der config.php kann 'memcache.local' => '\\OC\\Memcache\APCu', als Zeile bleiben (muss nicht mehr auskommentiert werden)
  2. Code:
    /usr/local/etc/php74/cli/php.ini editieren: in der Sektion [apc] den Parameter apc.enable_cli = 1 setzen (steht per default auf 0)
  3. Code:
    /usr/local/etc/php74/cli/conf.d/extension.ini editieren: als erste Zeile extension = apcu.so hinzufügen
Diese Lösung sollte bis zum nächsten PHP 7.4 Update halten...kommen ja nicht allzu oft. Hat bei mir funktioniert - your mileage may vary.

Grüße
jck42
 

junkfood

Benutzer
Mitglied seit
17. Jan 2013
Beiträge
13
Punkte für Reaktionen
0
Punkte
1
Ich habe @jck42s Anleitung verwendet, aber leider dennoch kein Glück.

Die Anzeige, dass seit Tagen kein Cron Job ausgeführt wurde, bleibt bestehen.

Als Workaroud empfehle ich daher einen Webcron Dienst, bis das Problem möglicherweise final gelöst wird.

Danke sehr
 

luddi

Benutzer
Mitglied seit
05. Sep 2012
Beiträge
1.928
Punkte für Reaktionen
114
Punkte
89
Bei mir hat folgendes geholfen:
Siehe folgenden Beitrag: https://www.synology-forum.de/threa...ehr-langsamer-seitenaufbau.110517/post-906564

Lege die benutzerspezifische Datei /usr/local/etc/php74/cli/conf.d/user_settings.ini an und füge wie beschrieben den Inhalt dort ein.
Vorausgesetzt dass php 7.4 im Einsatz ist, ansonsten müsste das gleiche auch für php73 gelten.

Die relevanten Einträge müssten sein:
Code:
extension = apcu.so

[apc]
apc.shm_size = 512M
apc.enable_cli = 1

Somit kann als local memcache apcu weiterhin in der config beibehalten werden und der cron läuft wieder sauber.
 

jck42

Benutzer
Mitglied seit
18. Mrz 2012
Beiträge
15
Punkte für Reaktionen
7
Punkte
3
@luddi: Danke, das ist vielleicht die elegantere Lösung als meine - funktioniert ebenfalls bei mir.

Da ich aber prinzipiell vorher lieber Redis als APCu für memcache.local verwendet habe, habe ich dazu noch
Code:
extension = redis.so
eingefügt und in der config.php den memcache.local auf Redis geändert.

Resultat: cron-job läuft, aber die Webversion gibt einen "Internal Server Error". Irgendwie hat das letzte PHP7.4 Update Redis rausgeschmissen. Auf der CLI funktionierte es mit dem fix wieder, nicht aber beim FPM. Einen Konfigurationsparameter für dieses Modul gibt es ja bei der Webstation nicht.

Also: Hard-Edit der /volume1/@appstore/PHP7.4/misc/php-fpm.ini, am Ende einfügt:

Code:
[Redis]


extension = redis.so

Webstation neu gestartet und...ta da! Läuft wieder mit Redis als memcache.local.
 
  • Like
Reaktionen: Tuxnet und luddi

OdinsAuge

Benutzer
Mitglied seit
12. Nov 2015
Beiträge
334
Punkte für Reaktionen
15
Punkte
24
EDIT: Ich kann die Lösung von @luddi bestätigen

Scheinbar hat Nextcloud mal wieder für NC 22 irgendwelche Änderungen geplant die Sie schon heimlich und unangekündigt in 21.0.3 hineingeschmissen haben.

@jck42 macht es einen Unterschied wenn man Redis für den lokalen Cache einsetzt, bzw. hast du einen Unterschied gemerkt?
 
Zuletzt bearbeitet:

Tuxnet

Benutzer
Mitglied seit
02. Jan 2019
Beiträge
199
Punkte für Reaktionen
4
Punkte
18
Ich bekomme Redis nicht zum laufen,
weder auf der DS noch im docker
 

OdinsAuge

Benutzer
Mitglied seit
12. Nov 2015
Beiträge
334
Punkte für Reaktionen
15
Punkte
24
Was für eine DS hat du? auf einigen der neuen Modelle ist ein Prozessor verbaut den Redis nicht unterstützt.
 

jck42

Benutzer
Mitglied seit
18. Mrz 2012
Beiträge
15
Punkte für Reaktionen
7
Punkte
3
@OdinsAuge Ich habe keine Ahnung, was jetzt wirklich besser ist, APCu oder Redis. Habe bis zur der beschriebenen Buggeritis Redis verwendet und das lief immer fein, daher habe ich jetzt wieder den vorherigen Zustand hergestellt. Bin zu faul, um da jetzt irgendeinen Benchmark zu ermitteln. Auf meiner Kiste (918+) laufen ziemlich viele Anwendungen (Syno-Pakete, nativ installierte Applikationen, Docker-Container und sogar eine VM - das beeinflusst sich sicherlich gegenseitig in der Performance.

@Tuxnet Ich habe für Redis das SynoCommunity Paket von DigitalBox98 (aktuell V 5.0.7-6) installiert. Das ist mit folgenden Zeilen in der config.php eingebunden:
Code:
  'memcache.local' => '\\OC\\Memcache\\Redis',
  'filelocking.enabled' => true,
  'memcache.locking' => '\\OC\\Memcache\\Redis',
  'redis' =>
  array (
    'host' => 'localhost',
    'port' => '6379',
    'timeout' => '0',
    'dbindex' => '0',
  ),

Ja, ich habe da tatsächlich 'localhost' eingetragen und meine, mich erinnern zu können, dass dies nur so funktioniert hatte, bei mir nicht mit der lokalen numerischen IP. Nextcloud läuft bei mir als native Installation.

Ich habe noch ein weiteres Redis als Container (redis:6.0) laufen, allerdings als Container in einem geschlossenen Subnetz zur Unterstützung von paperless-ng - der Port ist also von aussen nicht erreichbar.

Vielleicht hilft das.
 
  • Like
Reaktionen: Tuxnet und OdinsAuge

TheGardner

Benutzer
Mitglied seit
30. Nov 2012
Beiträge
1.646
Punkte für Reaktionen
6
Punkte
64

Tuxnet

Benutzer
Mitglied seit
02. Jan 2019
Beiträge
199
Punkte für Reaktionen
4
Punkte
18
@OdinsAuge

Hast recht, sollte mal meine Signatur erstellen ;-)

DS 218+ 10GB RAM
DS7
Radis im Docker laufen

edit :
So ich habe jetzt REDIS im Docker mit der NC zum laufen bekommen ;-)
Vielen Dank an @jck42

Ich habe aber zwei Fehlermeldungen :

- WARNING overcommit_memory is set to 0! Background save may fail under low memory condition. To fix this issue add 'vm.overcommit_memory = 1'

- The TCP backlog setting of 511 cannot be enforced because /proc/sys/net/core/somaxconn is set to the lower value of 128.
 
Zuletzt bearbeitet: