Marvell Armada 370 armv7l DSM 5.0 Netzwerkfehler bei SATA-Energeisparmodus

jgbossert

Benutzer
Mitglied seit
29. Oktober 2014
Beiträge
2
Punkte für Reaktionen
0
Punkte
0
Hallo zusammen,

ich bin mir nicht ganz sicher, ob dieser Beitrag in diesem Unterforum ganz richtig aufgehoben ist. Ich bitte die Administratoren ihn zur Not zu verschieben.

Ich habe auf einem Kundennas beobachtet, dass Synology Netzwerk Time Backups (rsync) auf dieses regelmäßig abbrechen. Im Protokoll des Ziel-NAS (DS114) finde ich dann Seitenweise Fehler wie diese:

Rich (BBCode):
Information	System	2014/11/03 09:47:49	SYSTEM	IP address [192.168.220.127] and subnet mask [255.255.255.0] were assigned to the DHCP client on [LAN 1].
Information	System	2014/11/03 09:47:29	SYSTEM	Windows file service was started.
Information	System	2014/11/03 09:47:27	SYSTEM	Apple file service was started.
Information	System	2014/11/03 09:47:27	SYSTEM	Windows file service was stopped.
Information	System	2014/11/03 09:47:26	SYSTEM	Apple file service was stopped.
Information	System	2014/11/03 09:47:21	SYSTEM	IP address [192.168.220.127] and subnet mask [255.255.255.0] were assigned to the DHCP client on [LAN 1].
Information	System	2014/11/03 09:41:51	SYSTEM	Windows file service was started.
Information	System	2014/11/03 09:41:49	SYSTEM	Apple file service was started.
Information	System	2014/11/03 09:41:49	SYSTEM	Windows file service was stopped.
Information	System	2014/11/03 09:41:48	SYSTEM	Apple file service was stopped.
Information	System	2014/11/03 09:41:38	SYSTEM	IP address [192.168.220.127] and subnet mask [255.255.255.0] were assigned to the DHCP client on [LAN 1].
Information	System	2014/11/03 09:39:39	SYSTEM	Windows file service was started.
Information	System	2014/11/03 09:39:37	SYSTEM	Apple file service was started.
Information	System	2014/11/03 09:39:37	SYSTEM	Windows file service was stopped.
Information	System	2014/11/03 09:39:36	SYSTEM	Apple file service was stopped.

Die Kabel haben wir bereits getauscht. Die Switches haben wir getauscht. Der Fehler tritt dabei nur auf dem Zeil-NAS (DS114) auf.

Im Kernel-Log (dmesg) findet sich dann ähnliches (hier aus einem anderen Zeitraum):

Rich (BBCode):
[Tue Nov  4 05:22:52 2014] ata1.00: configured for UDMA/133
[Tue Nov  4 05:22:52 2014] ata1.00: Disable disk write cache in EH
[Tue Nov  4 05:22:52 2014] ata1: wake up successful, the reset fail can be ignored
[Tue Nov  4 05:22:52 2014] eth0: link down
[Tue Nov  4 05:22:52 2014] eth0: link up, full duplex, speed 1 Gbps
[Tue Nov  4 05:43:15 2014] eth0: link down
[Tue Nov  4 05:43:15 2014] eth0: link up, full duplex, speed 1 Gbps
[Tue Nov  4 07:59:43 2014] ata2: wake up from deepsleep, reset link now
[Tue Nov  4 07:59:43 2014] ata2: device plugged sstatus 0x123
[Tue Nov  4 07:59:46 2014] eth0: link down
[Tue Nov  4 07:59:46 2014] eth0: link up, full duplex, speed 1 Gbps
[Tue Nov  4 07:59:50 2014] ata1: wake up from deepsleep, reset link now
[Tue Nov  4 07:59:50 2014] ata1: device plugged sstatus 0x123
[Tue Nov  4 07:59:55 2014] ata2: SATA link up 3.0 Gbps (SStatus 123 SControl F300)
[Tue Nov  4 07:59:55 2014] ata2.00: configured for UDMA/133
[Tue Nov  4 07:59:55 2014] ata2.00: Disable disk write cache in EH
[Tue Nov  4 07:59:55 2014] ata2: wake up successful, the reset fail can be ignored
[Tue Nov  4 07:59:59 2014] ata1: link is slow to respond, please be patient (ready=0)
[Tue Nov  4 08:00:02 2014] ata1: SATA link up 3.0 Gbps (SStatus 123 SControl F300)
[Tue Nov  4 08:00:02 2014] ata1.00: configured for UDMA/133
[Tue Nov  4 08:00:02 2014] ata1.00: Disable disk write cache in EH
[Tue Nov  4 08:00:02 2014] ata1: wake up successful, the reset fail can be ignored
[Tue Nov  4 08:20:49 2014] eth0: link down
[Tue Nov  4 08:20:49 2014] eth0: link up, full duplex, speed 1 Gbps
[Tue Nov  4 08:31:53 2014] ata1: wake up from deepsleep, reset link now
[Tue Nov  4 08:31:53 2014] ata1: device plugged sstatus 0x123
[Tue Nov  4 08:32:00 2014] ata2: wake up from deepsleep, reset link now
[Tue Nov  4 08:32:00 2014] ata2: device plugged sstatus 0x123
[Tue Nov  4 08:32:05 2014] ata1: SATA link up 3.0 Gbps (SStatus 123 SControl F300)
[Tue Nov  4 08:32:05 2014] ata1.00: configured for UDMA/133
[Tue Nov  4 08:32:05 2014] ata1.00: Disable disk write cache in EH
[Tue Nov  4 08:32:05 2014] ata1: wake up successful, the reset fail can be ignored
[Tue Nov  4 08:32:09 2014] ata2: link is slow to respond, please be patient (ready=0)
[Tue Nov  4 08:32:12 2014] ata2: SATA link up 3.0 Gbps (SStatus 123 SControl F300)
[Tue Nov  4 08:32:12 2014] ata2.00: configured for UDMA/133
[Tue Nov  4 08:32:12 2014] ata2.00: Disable disk write cache in EH
[Tue Nov  4 08:32:12 2014] ata2: wake up successful, the reset fail can be ignored
[Tue Nov  4 08:32:12 2014] eth0: link down
[Tue Nov  4 08:32:12 2014] eth0: link up, full duplex, speed 1 Gbps
[Tue Nov  4 09:24:55 2014] eth0: link down
[Tue Nov  4 09:24:55 2014] eth0: link up, full duplex, speed 1 Gbps
[Tue Nov  4 09:36:03 2014] ata1: wake up from deepsleep, reset link now
[Tue Nov  4 09:36:03 2014] ata1: device plugged sstatus 0x123
[Tue Nov  4 09:36:10 2014] ata2: wake up from deepsleep, reset link now
[Tue Nov  4 09:36:10 2014] ata2: device plugged sstatus 0x123
[Tue Nov  4 09:36:15 2014] ata1: SATA link up 3.0 Gbps (SStatus 123 SControl F300)
[Tue Nov  4 09:36:15 2014] ata1.00: configured for UDMA/133
[Tue Nov  4 09:36:15 2014] ata1.00: Disable disk write cache in EH
[Tue Nov  4 09:36:15 2014] ata1: wake up successful, the reset fail can be ignored
[Tue Nov  4 09:36:19 2014] ata2: link is slow to respond, please be patient (ready=0)
[Tue Nov  4 09:36:22 2014] ata2: SATA link up 3.0 Gbps (SStatus 123 SControl F300)
[Tue Nov  4 09:36:22 2014] ata2.00: configured for UDMA/133
[Tue Nov  4 09:36:22 2014] ata2.00: Disable disk write cache in EH
[Tue Nov  4 09:36:22 2014] ata2: wake up successful, the reset fail can be ignored
[Tue Nov  4 09:36:23 2014] eth0: link down
[Tue Nov  4 09:36:23 2014] eth0: link up, full duplex, speed 1 Gbps
[Tue Nov  4 10:29:05 2014] eth0: link down
[Tue Nov  4 10:29:05 2014] eth0: link up, full duplex, speed 1 Gbps
[Tue Nov  4 10:40:14 2014] ata1: wake up from deepsleep, reset link now
[Tue Nov  4 10:40:14 2014] ata1: device plugged sstatus 0x123
[Tue Nov  4 10:40:21 2014] ata2: wake up from deepsleep, reset link now
[Tue Nov  4 10:40:21 2014] ata2: device plugged sstatus 0x123
[Tue Nov  4 10:40:25 2014] ata1: SATA link up 3.0 Gbps (SStatus 123 SControl F300)
[Tue Nov  4 10:40:26 2014] ata1.00: configured for UDMA/133
[Tue Nov  4 10:40:26 2014] ata1.00: Disable disk write cache in EH
[Tue Nov  4 10:40:26 2014] ata1: wake up successful, the reset fail can be ignored
[Tue Nov  4 10:40:30 2014] ata2: link is slow to respond, please be patient (ready=0)
[Tue Nov  4 10:40:33 2014] ata2: SATA link up 3.0 Gbps (SStatus 123 SControl F300)
[Tue Nov  4 10:40:33 2014] ata2.00: configured for UDMA/133
[Tue Nov  4 10:40:33 2014] ata2.00: Disable disk write cache in EH
[Tue Nov  4 10:40:33 2014] ata2: wake up successful, the reset fail can be ignored
[Tue Nov  4 10:40:33 2014] eth0: link down
[Tue Nov  4 10:40:33 2014] eth0: link up, full duplex, speed 1 Gbps

Wir gingen erst von einem Hardwaredefekt aus. Trotzdem prüfte ich kurzerhand ein paar andere Kunden-NAS Systeme mit verschiedenen CPUs. Alle laufen bereits mit DSM 5.0 Ich war erstaunt:
Alle DS114 und DS213j Systeme sind betroffen. Keine Fehler hingegen fand ich auf RS814, DS214+, DS712+, ... Systemen. Kurz: Der Fehler tritt mit DSM 5.0 auf Marvell Armada 370 basierten Systemen auf.
Ob der Fehler auch schon bei DSM 4.x auftrat kann ich nicht mehr prüfen.

Die Vermutung lag nache, dass es am SATA-Energiesparmodus liegt. Der SATA-Controller des SoC reißt vermutlich den Ethernet-Controller gleich mit in den Tod.

Energiesparmodus der internen und externen Festplatten aller Marvell Armada 370 DiskStations deaktiviert und nach 24 Std wieder kontrolliert:
Die vorher planbar auftretenden Fehler sind vollständig verschwunden.

Ob es ein Softwarefehler in DSM 5.0 oder ein Hardwarefehler in den Marvell Armada 370 SoCs ist müsste noch geprüft werden.
Bis dahin empfehle ich: Festplatten-Energeisparmodus bei diesen Modellen deaktivieren:
  • DS114
  • DS115j
  • DS213j
  • DS214se
  • DS414slim
  • EDS14
  • RS214


Viele Grüße!
 

dil88

Benutzer
Mitglied seit
03. September 2012
Beiträge
28.575
Punkte für Reaktionen
2
Punkte
644
Sehr interessante und umfassende Information. Danke für den Hinweis!
 
  AdBlocker gefunden!

Du bist nicht hier, um Support für Adblocker zu erhalten, denn dein Adblocker funktioniert bereits ;-)

Klar machen Adblocker einen guten Job, aber sie blockieren auch nützliche Funktionen.

Das Forum wird mit einem hohen technischen, zeitlichen und finanziellen Aufwand kostenfrei zur Verfügung gestellt. Wir zeigen keine offensive oder Themen fremde Werbung. Bitte unterstütze dieses Forum, in dem du deinen Adblocker für diese Seite deaktivierst.