Keine Benachrichtigungsmail bei IP-Block

JudgeDredd

Benutzer
Mitglied seit
12. Nov 2009
Beiträge
1.056
Punkte für Reaktionen
1
Punkte
64
Ort
Frankfurt
Hallo Zusammen,

bei mir tritt seit geraumer Zeit das Problem auf, das ich über blockierte IP-Adressen bei fehlerhaften SSH-Loginversuchen keine Benachrichtigungsmail erhalte.
Natürlich ist unter "DSM->Systemsteuerung->Benachrichtigung->System/IP-Adresse blockiert" der Aktivierungshaken gesetzt.

Das LOG zeigt zur besagten Zeit folgenden Eintrag:
H:SV001 F:mail P:postfix/smtpd [2013/07/13 23/43/18] connect from localhost[127.0.0.1]
H:SV001 F:mail P:postfix/smtpd [2013/07/13 23/43/18] SSL_accept error from localhost[127.0.0.1]: -1
H:SV001 F:mail P:postfix/smtpd [2013/07/13 23/43/18] warning: TLS library problem: 21960:error:1408F119:lib(20):func(143):reason(281):NA:0:
H:SV001 F:mail P:postfix/smtpd [2013/07/13 23/43/18] lost connection after STARTTLS from localhost[127.0.0.1]
H:SV001 F:mail P:postfix/smtpd [2013/07/13 23/43/18] disconnect from localhost[127.0.0.1]

Für mich scheint besonders der Eintrag SSL_accept error eine Rolle zu spielen. Leider erschliesst es sich mir aber nicht, was genau dahinter steckt.

Desweiteren wäre noch zu erwähnen, das mir das Mail-Server Paket sehr wohl Benachrichtigungen über blockierte Adressen sendet, welche versuchen meinen SMTP zu missbrauchen.

Augenscheinlich liegt das Problem also in der Kommunikation zwischen dem DSM und dem Mail-Server Paket (welches allerdings sonst tadellos funktioniert).
 
Zuletzt bearbeitet von einem Moderator:

JudgeDredd

Benutzer
Mitglied seit
12. Nov 2009
Beiträge
1.056
Punkte für Reaktionen
1
Punkte
64
Ort
Frankfurt
Da leider noch keine Vorschläge zu meinem Problem gepostet wurden, anbei nochmal ein Screenshot meiner Einstellungen der Benachrichtigungen. Evtl. hilft es ja zum Denkanstoss.

Benachrichtigungseinstellungen.jpg
 

jahlives

Moderator
Mitglied seit
19. Aug 2008
Beiträge
18.275
Punkte für Reaktionen
2
Punkte
0
mal TLS/SSL weggelassen? Ist ja eh nur der localhost von da her wäre unverschlüsselt nicht wirklich ein Risiko.
 

JudgeDredd

Benutzer
Mitglied seit
12. Nov 2009
Beiträge
1.056
Punkte für Reaktionen
1
Punkte
64
Ort
Frankfurt
Danke, habe ich gerade sowieso mal getestet und schon hat es funktioniert.
Du hast natürlich vollkommen Recht, der DSM sollte schon seinem eigenen Mailserver "vertrauen" :D
Ich werde es jetzt auch so belassen. Was ich aber dennoch komisch finde:
a) Im Mailserver hatte ich "Auth für LAN Verbindung ignorieren" angeschaltet. OK, intern ist kein LAN aber ich dachte das deckt es mit ab.
b) "Testmail senden" funktioniert auch mit TLS/SSL .... komisch
c) Benachrichtigungen über IP-Block des Postfix gehen auch mit TLS/SSL raus. Naja, da ist es wahrscheinlich so, das die Mail direkt im Postfix generiert wird und nicht vom DSM erst überstellt wird.

Dennoch vielen Dank für Deine Hilfe.
 

jahlives

Moderator
Mitglied seit
19. Aug 2008
Beiträge
18.275
Punkte für Reaktionen
2
Punkte
0
es ging mir weniger um das "Vertrauen" als um den Sinn und Zweck von SSL. SSL ist dafür gedacht eine Verbindung Punk-zu-Punkt zu sichern, sodass ein Lauscher auf dem Weg zwischen den beiden Endpunkten nichts damit anfangen kann. Nur im Fall von localhost müsste sich ein solcher Lauscher bereits auf dem System befinden, ziemlich sicher mit root Rechten. Dann hat man normalerweise gaaaanz andere Probleme als Mailpassworte oder so was ;-)