kein externer Zugriff mehr auf Datenbank mehr möglich

TylonHH

Benutzer
Mitglied seit
14. Apr 2016
Beiträge
29
Punkte für Reaktionen
2
Punkte
3
Moin,
ich habe Backaups auf meine neue 220+ gespielt. Momentan hänge ich gerade daran, dass ich "von außen" nicht auf die MariaDB10 zugreifen kann. Von außen meine ich innerhalb des Netzwerks, nicht vom Internet.
  • Über phpMyAdmin kann ich mich einloggen
  • Über HeidiSQL oder einem Raspberry nicht (Can't connect to server on '192.168.178.58' (10061))
ich habe schon:
  1. den root user schon neu angelegt zum Testen. root2 ist der User der letztendlich funktionieren soll
    1. MariaDB [(none)]> SELECT User, Host FROM mysql.user WHERE Host <> 'localhost'; +------------+---------------+ | User | Host | +------------+---------------+ | RWeanres0w | % | | octoprint | % | | root2 | % | | root | 192.168.178.% | +------------+---------------+ 4 rows in set (0.001 sec)
  2. Passwort neu vergeben (myAdmin verlangt da sehr sichere PW mit Sonderzeichen)
  3. my.cnf angepasst (eingespielt aus der Sicherung), insbesondere bind-address = 0.0.0.0
  4. root2 User auf der DS ist bereits angelegt, aus der Sicherung
  5. Firewall auf der DS testweise abgeschaltet
  6. Ports und Einstellung überprüft
    1653026509796.png
  7. Port Freigabe auf der FritzBox übertragen (ist das überhaupt relevant?)
Was habe ich noch übersehen? Wie kann ich es weiter debuggen?

Gruß René
 

Fusion

Benutzer
Sehr erfahren
Mitglied seit
06. Apr 2013
Beiträge
13.653
Punkte für Reaktionen
722
Punkte
404
Hat sich der Port eventuell auf 3306 geändert?
3307 wurde nur gewählt wenn Mariadb noch parallel installiert war.
 

TylonHH

Benutzer
Mitglied seit
14. Apr 2016
Beiträge
29
Punkte für Reaktionen
2
Punkte
3
Soweit ich weiß ist 3306 für mariadb5 und 3307 für mariadb10
Über beide Ports bekomme ich keine Verbindung.
 
Zuletzt bearbeitet von einem Moderator:

Fusion

Benutzer
Sehr erfahren
Mitglied seit
06. Apr 2013
Beiträge
13.653
Punkte für Reaktionen
722
Punkte
404
Das gilt wie gesagt nur für Parallelinstallation. Wenn frei schnappt sich auch die Mariadb 10 den 3306.

DSM Neustart nach Wiederherstellung gemacht?

Konnte man in Mariadb GUI den Port setzen?
 

TylonHH

Benutzer
Mitglied seit
14. Apr 2016
Beiträge
29
Punkte für Reaktionen
2
Punkte
3
Auf der DS ist nur MariaDB10 installiert
Ich habe eben nochmal ins Paket auf der DS geschaut

Finde den Fehler :censored:
1653036414864.png

Nach Aktivierung läuft es nun.
Ich habe schon befürchtet das es was ganz banales ist.
Trotzdem Danke für deine Zeit.
 
  • Like
Reaktionen: Fusion
NAS-Central - Ihr Partner für NAS Lösungen
NAS-Central - The Home of NAS

Kaffeautomat

Wenn du das Forum hilfreich findest oder uns unterstützen möchtest, dann gib uns doch einfach einen Kaffee aus.

Als Dankeschön schalten wir deinen Account werbefrei.

:coffee:

Hier gehts zum Kaffeeautomat 

Hosted by netcup