JitsiMeet für Synology

Tosoboso

Benutzer
Mitglied seit
27. Aug 2012
Beiträge
1.243
Punkte für Reaktionen
49
Punkte
74
Hallo zusammen. Nach Update auf DSM7 wird der ReverseProxy nicht mehr akzeptiert, obwohl dieser nicht verändert wurde. Meldung: "Synology reverse proxy not setup incl. Web-Socket to point to jitsi http web container port; see FAQ or at sample.
Bis zum Upgrade auf DSM7 hat alles funktioniert. Danke schon mal.
Hi, der Reverse Proxy in DSM-7 liegt woanders, im Sytembereich, jedenfalls wenn man den neu anlegt. Wie es sich bei einer Migration verhält, weiss ich nicht. Ich empfehle den Reverse Proxy zu löschen und neu anzulegen. Parallel prüfe ich, ob der Health Check DSM-6 vs. DSM-7 bzgl. ReverseProxy nach wie vor korrekt ist, Welche Porst man nimmt ist wirklich zweitrangig. Da hat sich der Default Port von 8080 auf 8000 geändert.
-TosoBoso
 
  • Like
Reaktionen: OliverJ

OliverJ

Benutzer
Mitglied seit
23. Nov 2020
Beiträge
56
Punkte für Reaktionen
6
Punkte
8
Hey, Danke. Habs schon mit Löschen und Neuanlegen des Reverse Proxies versucht. Ohne Erfolg. Bei der Installation wird Port 8000 für http und Prefix+443, (also 8443?) für https angezeigt. Gebe ich nun in den Reverse Proxy 8000 als Port an, lässt sich die Seite aufrufen, allerdings bricht dann die Verbindung beim Einloggen ab. Und egal, was ich in den Reverse Proxy eingebe, die GUI sagt immer, der Reverse Proxy sei nicht konfiguriert. Zertifikat habe ich auch vorsichtshalber erneuert.
EDIT: So langsam vermute ich, dass der Fehler am Jitsi-Docker-Release selbst liegen könnte (wäre ja nicht das erste Mal?)
 
Zuletzt bearbeitet:

OliverJ

Benutzer
Mitglied seit
23. Nov 2020
Beiträge
56
Punkte für Reaktionen
6
Punkte
8
Heute Morgen kam der Hinweis, dass ein neuer Release verfügbar sei. Nach Herunterladen dasselbe Problem: Trotz eingerichtetem Reverse Proxy behauptet die GUI nach wie vor, es sei keiner eingerichtet. Seite lässt sich aufrufen, Verbindung bricht aber ab. Da dies unmittelbar nach Upgrade auf DSM7 begann, dürfte das doch kein Einzelfall sein?

Edit: Ich bin einen Schritt weiter. Die Public_URL war nicht im Script eingetragen, obwohl im Setup angegeben. Nun habe ich zwar keinen Verbindungsabbruch, kann mich aber nicht als User anmelden (Passwort ungültig).

Edit: Mit add-usr habe ich nun auch das hinbekommen. Es sieht also ganz so aus, als ob die Angaben im Setup nicht übernommen werden. Das Jitsi-GUI behauptet immer noch, es sei kein konfigurierter Reverse Proxy vorhanden, Jitsi scheint nun aber trotz allem zu funktionieren.
 

Anhänge

  • Jitsi3.jpg
    Jitsi3.jpg
    32,4 KB · Aufrufe: 6
  • Jitsi2.jpg
    Jitsi2.jpg
    61,2 KB · Aufrufe: 6
  • Jitsi1.jpg
    Jitsi1.jpg
    45,3 KB · Aufrufe: 7
Zuletzt bearbeitet:

OliverJ

Benutzer
Mitglied seit
23. Nov 2020
Beiträge
56
Punkte für Reaktionen
6
Punkte
8
Hallo. Ich mache hier einmal eine kurze Checkliste bezüglich der Version 1.3 für DSM 7:

- mitunter kommt es zu Verbindungsabbrüchen, wenn Teilnehmer sich ein- oder ausloggen

- Jitsi-Admin erkennt wohl den Reverse Proxy nicht (Meldung: "Synology reverse proxy not setup incl. Web-Socket to point to jitsi http web container port; see FAQ or at sample <www.synology-forum.de/attachments/jitsi-rproxy-png.60537>", es läuft aber trotzdem

- außerdem werden folgende Meldungen ausgegeben:
/usr/syno/etc/packages/Jitsi-Meet/.mod: line 52: unexpected EOF while looking for matching `"'
/usr/syno/etc/packages/Jitsi-Meet/.mod: line 55: syntax error: unexpected end of file

- cphub scheint wohl nicht mehr erreichbar zu sein, die Seite lässt sich seit ein paar Tagen nicht mehr aufrufen, folglich auch TosoBosos Paket von dort derzeit nicht herunterladen
 

Lineflyer

Benutzer
Mitglied seit
27. Mrz 2021
Beiträge
16
Punkte für Reaktionen
1
Punkte
3
Bislang konnte ich die beschriebenen Probleme (bis auf die inkorrekte Meldung, dass der Proxy nicht konfiguriert ist obwohl alles funktioniert) nicht nachvollziehen.
Heute habe ich jedoch die Container neu gebaut (nach >1 Monat) und nun habe ich ähnliche Probleme. Keine Abbrüche, aber Probleme für Teilnehmer die Loginseite zu erreichen.
 

OliverJ

Benutzer
Mitglied seit
23. Nov 2020
Beiträge
56
Punkte für Reaktionen
6
Punkte
8
Etwas Ähnliches kann ich ebenfalls berichten. Wie schon beschreiben, werden teilweise Änderungen in den Scripten nicht gesetzt. Nachdem ich durch ein neues Release ebenfalls neue Container hatte, waren die Änderungen plötzlich da. Es muss wohl derzeit wirklich größtenteils an DSM7 liegen, vor dem Upgrade lief alles rund.
Ich bekomme auch immer mal wieder beim Einloggen den Hinweis, dass Moderator-Passwort sei falsch und ich muss es erst neu anlegen um mich einloggen zu können.

Habe erst später gesehen, dass TosoBoso für das DSM7-Paket noch folgenden Tipp gibt:

"Wichtig ist, dass man nach der ersten Installation zunächst Docker stoppen und neu starten muss, damit die Zugriffsrechte passen.
Ein Neustart des Jitsi-Meet Pakets erledigt dann das Übrige. Das dauert einige Minuten, während denen das Jitsi-Meet Icon grau ist und man kann sich den Fortschritt ansehen mit > tail -f /var/packages/Jitsi-Meet/target/log/package.log. Wenn das einmal erfolgt ist, kann man sich wie gewohnt den Fortschritt während der Installation mit % Anzeige ansehen."

Hat bei mir leider nichts geändert, werde es aber nochmals mit einer kompletten Neuinstallation versuchen.

Ich frage mich ja wirklich, weshalb die Verantwortlichen von Upgrades immer wieder komplette vorab funktionierende Dinge über den Haufen schmeißen, und so die User erst einmal zwingen, alles mögliche neu konfigurieren zu müssen. War ja nach neuen Jitsi-Releases auch schon häufiger der Fall. Speziell im Fall von Leuten wie TosoBoso stelle ich es mir doch mitunter frustrierend vor, wenn man immer mal wieder "hinterherprogrammieren" muss, was ja gerade in letzter Zeit wieder häufiger der Fall war. Dafür jedenfalls meinen tiefsten Respekt.
 
Zuletzt bearbeitet:

DIY

Benutzer
Mitglied seit
05. Dez 2020
Beiträge
65
Punkte für Reaktionen
20
Punkte
58
Ort
BY
Mal was ganz anderes ... positives Feedback :)

Update auf SPK V1.5 unter DSM 6 auf die Jitsi-Version 6433 ohne Probleme in Verbindung mit den Dockerimages ...
- Nginxproxymanager von 'JLesage' (host)
- Coturn von 'Coturn' (host)

...läuft.
 

OliverJ

Benutzer
Mitglied seit
23. Nov 2020
Beiträge
56
Punkte für Reaktionen
6
Punkte
8
Nachdem ich sämtliche Portfreigaben gelöscht und neu angelegt habe, läuft Jitsi bei mir jetzt auch stabil. Die Meldung, es sei kein Reverse Proxy konfiguriert ist immer noch vorhanden, stört aber nicht weiter, da sie offensichtlich ignoriert werden kann. Im Großen und Ganzen läuft alles mit DSM7 jetzt wie es aussieht. Gab mal kurz eine Fehlermeldung im Paketmanager bezüglich Apache und musste repariert werden, war aber auch problemlos behebbar. Soweit bin ich mit DSM7 eigentlich zufrieden, ich habe sogar den Eindruck, die Oberfläche läuft etwas flotter als noch unter DSM6.
 

OliverJ

Benutzer
Mitglied seit
23. Nov 2020
Beiträge
56
Punkte für Reaktionen
6
Punkte
8
Klingt, als ob da mit den Docker-Jitsi-Image was nicht stimmt? Ich habe auch wieder die Meldung bekommen, dass neue Images verfügbar sind, das Update aber noch ausgespart. Läuft es mittlerweile?
 
Synology Mail Server Installation