iSCSI geht nicht ...

glowaq

Benutzer
Mitglied seit
22. November 2009
Beiträge
234
Punkte für Reaktionen
0
Punkte
0
Wir besitzen nun eine DS1010+ aber ich Ich bekomme kein iSCSI target zum laufen. VMWARE zeit das volumen zwar an, aber er kann die volumengröße nicht ermitteln.

Im log steht dieses:

Jul 1 14:42:07 kernel: iSCSI Enterprise Target Software - version 0.4.17
Jul 1 14:42:07 ietd: unable to create server socket (Address family not supported by protocol) 10 1 6!

Hat jemand eine idee?
 

glowaq

Benutzer
Mitglied seit
22. November 2009
Beiträge
234
Punkte für Reaktionen
0
Punkte
0
Habe ich probiert:

Rich (BBCode):
netstat -ln | grep 3260
tcp        0      0 0.0.0.0:3260            0.0.0.0:*               LISTEN

Er bindet sich immer an alle interfaces. Ausserdem wird nach jedem start die "ADDRESS"-zeile wieder aus der config gelöscht (er macht das selber, scheinbar).

Ich bin etwa ratlos ... Wir haben hier noch DELL iSCSI-Storages, die im gleichen netz problemlos laufen.
 

jahlives

Moderator
Mitglied seit
19. August 2008
Beiträge
18.275
Punkte für Reaktionen
0
Punkte
0
Website
911-research.info
Hast du auchmal probiert im DSM die IP für die DS manuell vorzugeben und nicht via dhcp zu beziehen?
Wie es scheint überschreibt das Startscript des iscsi die Konfigdatei. Schau mal in dessen Startscript rein ob ggf irgendwo die IP im Code gesetzt wird
 

glowaq

Benutzer
Mitglied seit
22. November 2009
Beiträge
234
Punkte für Reaktionen
0
Punkte
0
Ich habe die DS in zwei netze. Das LAN2 (eth1) ist im storagenetz. Die ESX-Server sehen die DS1010. Vmware zeigt mir den target an und auch dass 2TB frei sind. Wenn ich das volume erstellen möchte, sagt VMWARE "Fehler bei Konfiguration des Hosts. Failed to get disk information".

Ich habe alles probiert. Jumbo ON/OFF, Chap ON/Off. Es geht nicht :-(
 

Matthieu

Super-Moderator
Teammitglied
Mitglied seit
03. November 2008
Beiträge
13.068
Punkte für Reaktionen
12
Punkte
334
Meld dich bitte bei Synology. Es scheint ja doch was tieferes zu sein.

MfG Matthieu
 

glowaq

Benutzer
Mitglied seit
22. November 2009
Beiträge
234
Punkte für Reaktionen
0
Punkte
0
So, ich habe den fehler gefunden. Es war die iSCSI volumengröße. Diese darf bei VMWARE vSphere maximal 2048GB gross sein. Wenn die auch nur ein MB größer ist, bekomme ich bei VMWARE einen fehler, dass die partitionstabelle nicht lesbar ist. Ich war davon ausgegangen, dass VMWARE das iSCSI auf größere partitionen umgestellt hatte ....

Das lustige ist, dass ich beim ersten erstellen eine 4TB iSCSI-vol erstellt hatte und da vmware die (falsche) partition gelesen hatte. Es liess sich ein volume unter vShere erstellen ...

Der fehler im Log ist immer noch, scheint aber nicht zu stören.
 
Zuletzt bearbeitet:

Rotschman

Benutzer
Mitglied seit
21. Dezember 2007
Beiträge
31
Punkte für Reaktionen
0
Punkte
0
Ich habe leider auch Probleme mit iSCSI.

Auf meiner DS 210J ist alles eingestellt.
Dummerweisse ist der benötigte Dienst unter WIN7 64 deaktiviert.
Wenn ich denn Dienst starten möchte kommt folgende Fehlermeldung:

Der Dienst "Microsoft iSCSI-Initiator-Dienst auf "Lokaler Computer" konnte nicht gestartet werden. Fehler 1717: Die Schnitstelle ist unbekannt.

Hat da jemand ein Plan. Hab gegoogelt aber leider nichts gefunden.

Danke und Gruss Rotschman
 

qbic

Benutzer
Mitglied seit
16. August 2008
Beiträge
476
Punkte für Reaktionen
0
Punkte
16

Rotschman

Benutzer
Mitglied seit
21. Dezember 2007
Beiträge
31
Punkte für Reaktionen
0
Punkte
0
danke für deine hilfe.
habe das schon mehrmals versucht. das iSCSI wiki hab ich auch schon gesehen und getestet. einrichten wär eigentlich ein kinderspiel.

doch für das muss erstmals der dienst gestartet werden.

mist, iSCSI wär glaub ne geile sache.
 
  AdBlocker gefunden!

Du bist nicht hier, um Support für Adblocker zu erhalten, denn dein Adblocker funktioniert bereits ;-)

Klar machen Adblocker einen guten Job, aber sie blockieren auch nützliche Funktionen.

Das Forum wird mit einem hohen technischen, zeitlichen und finanziellen Aufwand kostenfrei zur Verfügung gestellt. Wir zeigen keine offensive oder Themen fremde Werbung. Bitte unterstütze dieses Forum, in dem du deinen Adblocker für diese Seite deaktivierst.