Mail Server Hilfe beim Konfigurieren der Mailstation / Mailserver benötigt...

MatCH

Benutzer
Mitglied seit
09. Sep 2009
Beiträge
60
Punkte für Reaktionen
0
Punkte
0
Hoi zusammen

Ich stehe beim konfigurieren des Mailservers etwas an...

Folgendes wurde bereits eingerichtet:
- Statische IP mit Reverse DNS Eintrag
- Domain mit den nötigen MX und SPF Einträgen.
- NAT Ports wurden an den Mailserver weitergeleitet (25 / 587)

Folgendes funktioniert:
- Mail versenden an externen Empfänger (bsp. meine Domain an Gmail...)

Was nicht funktioniert:
- Mails kommen beim Mailserver an (werden in der Warteschleife angezeigt) jedoch nicht an die Mailstation an den Empfänger weitergeleitet

Fehlermeldung in der Mailstation:
2.png

Fehlermeldung in der Warteschleife des Mailservers:
1.png

Ich hoffe es ist einigermaßen verständlich, was ich schildern möchte... :)
Vielleicht hat ja jemand einen Tip...

Vielen Dank und schöne Weihnachten
 

MatCH

Benutzer
Mitglied seit
09. Sep 2009
Beiträge
60
Punkte für Reaktionen
0
Punkte
0
Ich nochmals... Da bisher keine Antwort kam, hier noch einige Ergänzungen:

Ich habe versucht gemäss der Fehlermeldung im Terminal die "doveconf" neu zu schreiben (doveconf -n > dovecot-new.conf doveconf). Dies im Verzeichnis "volume1/@appstore/MailServer/bin/".
Leider kam dann die Meldung: -sh: can't create dovecot-new.conf: Permission denied
Ich bin aber mit SSH als Admin angemeldet.

Wäre froh um etwas Unterstützung :)

Gruss

Mathias
 

laserdesign

Benutzer
Mitglied seit
11. Jan 2011
Beiträge
2.482
Punkte für Reaktionen
28
Punkte
94
Leider kam dann die Meldung: -sh: can't create dovecot-new.conf: Permission denied
Ich bin aber mit SSH als Admin angemeldet.

Hallo, ich kann dir nur zu der Fehlermeldung etwas sagen, du musst dich als Benutzer root mit Passwort vom Admin anmelden.
 

MatCH

Benutzer
Mitglied seit
09. Sep 2009
Beiträge
60
Punkte für Reaktionen
0
Punkte
0
Alles klar, werde es dann Morgen mal mit Root probieren.
Danke
 

MatCH

Benutzer
Mitglied seit
09. Sep 2009
Beiträge
60
Punkte für Reaktionen
0
Punkte
0
Ja, mit Root hat es geklappt. Ich konnte die Doveconf neu erstellen. Jedoch hat sich im Mailserver nichts geändert. Die Fehlermeldung bleibt die gleiche.
Sieht dann folgendermaßen aus in der Console:
GALAXY> ./doveconf -n > dovecot-new.conf
doveconf: Warning: NOTE: You can get a new clean config file with: doveconf -n > dovecot-new.conf
doveconf: Warning: Obsolete setting in /var/packages/MailServer/target/etc/dovecot/conf.d/20-imap.conf:2: listen=..:port has been replaced by service { inet_listener { port } }
doveconf: Warning: Obsolete setting in /var/packages/MailServer/target/etc/dovecot/conf.d/20-imap.conf:2: protocol { listen } has been replaced by service { inet_listener { address } }
doveconf: Warning: NOTE: You can get a new clean config file with: doveconf -n > dovecot-new.conf
doveconf: Warning: Obsolete setting in /var/packages/MailServer/target/etc/dovecot/conf.d/20-imap.conf:2: listen=..:port has been replaced by service { inet_listener { port } }
doveconf: Warning: Obsolete setting in /var/packages/MailServer/target/etc/dovecot/conf.d/20-imap.conf:2: protocol { listen } has been replaced by service { inet_listener { address } }



Hoffe es gibt doch noch jemanden der mit helfen kann... Denn auch eine Deinstallation von Mailserver und Mailstation und anschließende Neuinstallation hat auch nichts gebracht :-(
 

MatCH

Benutzer
Mitglied seit
09. Sep 2009
Beiträge
60
Punkte für Reaktionen
0
Punkte
0
Also ich konnte die "doveconf" neu schreiben. Nun erscheint im Mailserver UI nicht mehr die oben eingefügte Fehlermeldung sondern nur noch "deferred" und "Temporary failture".

Also eigentlich noch immer nicht weiter... :)
 

waldek

Benutzer
Mitglied seit
22. Sep 2013
Beiträge
144
Punkte für Reaktionen
1
Punkte
18
Hi,

installiere doch Zarafa um Mails zu empfangen und an Outlook & Co zu verteilen oder dann per WebApp darauf zu zugreifen
 

MatCH

Benutzer
Mitglied seit
09. Sep 2009
Beiträge
60
Punkte für Reaktionen
0
Punkte
0
Hi,

Ist dann ja nur ein anderes Programm. Möchte es eigentlich schon mit der Mailstation und dem Syno Mailserver machen.
Ich hatte das ganze vor zwei Jahren schon mal auf meiner alten DS509+ am laufen. Da hat es von Anfang an geklappt.
Jetzt auf der DS1813+ gehts irgendwie nicht... ich sehe aber einfach nicht woran es liegt.

Sollte ja mit dem Syno eigenen Produkt genauso gehen wie mit einem anderen (Zarafa...)...
 

MatCH

Benutzer
Mitglied seit
09. Sep 2009
Beiträge
60
Punkte für Reaktionen
0
Punkte
0
Mal ne andere Frage. Möchte ganz von vorne anfangen.
Wenn ich aber Mailserver und Mailstation deinstalliere sind nach einer neuen Installation wieder alle vorherigen Einstellungen da...

Kann mir jemand sagen, welche Dateien oder Verzeichnisse ich via SSH in der Console löschen muss, damit ich wirklich von vorne anfangen kann?

Danke

Gruäss
Mathias
 

MatCH

Benutzer
Mitglied seit
09. Sep 2009
Beiträge
60
Punkte für Reaktionen
0
Punkte
0
Scheinbar kann mir niemand weiter helfen :(
Dann hoffe ich mal, dass der Synologysupport helfen kann...
 

MatCH

Benutzer
Mitglied seit
09. Sep 2009
Beiträge
60
Punkte für Reaktionen
0
Punkte
0
Nachdem ich dem Support mein Protokoll gesendet hatte, kam nachstehende Antwort... Das kann ja wohl kein ernst gemeinter Support sein...??

Sie haben auf Ihrem Gerät Zusatzpakete und Programme Dritter installiert. Dies ist von uns nicht supportet, da diese Programme und Einstellungen von DSM ändern oder löschen könnten. Auch eine Deinstallation dieser Zusatzpakete korrigiert in der Regel nicht die Änderungen auf dem Betriebssystem. Ihre aktuellen Probleme können von diesen Zusatzpaketen resultieren.
Bitte wie folgt vorgehen:

1. Deaktivieren Sie die Drittanbieter Pakete und prüfen Sie ob das Problem weiterhin besteht
falls kein Erfolg,
2. Deinstallieren Sie die Drittanbieter Pakete und prüfen Sie ob das Problem weiterhin besteht
falls kein Erfolg,
3. Resetten Sie das DSM und prüfen Sie ob das Problem weiterhin besteht

Informationen über das Zurücksetzen der DiskStation finden Sie hier: http://www.synology.com/de-de/support/tutorials/493


Nebenbei bemerkt... Es sind keine Pakete installiert, welche nicht aus dem ofizellen Paketzentrum stammen... bin enttäuscht von solch einer Antwort, welche eher nach einem Abschieben klingt und nicht den Eindruck hinterlässt, dass man sich wirklich den Problemen annimmt...


Vielleicht hat ja im Forum doch noch jemand einen Tipp..
 

MatCH

Benutzer
Mitglied seit
09. Sep 2009
Beiträge
60
Punkte für Reaktionen
0
Punkte
0
Hallo zusammen

Der Synology-Support konnte mir helfen. Es scheint ein Problem beim migrieren der Daten von meiner alten DS509+ zur 1813+ gegeben zu haben. Deshalb die scheinen Benutzerberechtigungen etwas durcheinander gekommen zu sein. Danach erschien immer eine Fehlermeldung beim einloggen bei Roundcube und Mails konnten nicht gelöscht oder verschoben werden.

Folgendes hatte der Support gemacht und mir als empfehlung gegeben:



Diese Vorgehensweise löst das Problem, direkt nach der Anmeldung erscheinende Fehlermeldung:
1. Sie erstellen Beispw. Benutzer "Müller"
2. Dieser Benutzer bekommt automatisch auch ein Verzeichnis "/homes/Müller"/
3. File Station öffnen auf den Ordner /homes/"Müller/"
4. Klicken Sie mit der rechten Maustaste auf den Ordner "/.Maildir" dann "Eigenschaften"
5. Allgemein
6. Hier müssen Sie unter dem Punkt "Besitzer" "admin" oder den jeweiligen Besitzer d.h. "Müller" auswählen
7. Bitte haken setzen auf "Auf diesen Ordner, Unterordner und Dateien anwenden"
8. OK klicken
Nun hat der Benutzer "Müller" richtigen Besitzer.


Diese Vorgehensweise löst das Problem von Löschen der Emails
1. File Station öffnen
2. Verzeichnis /homes/"User"/.Maildir/
3. löschen Sie alle Inhalte in den Verzeichnis (Es wird automatisch neue Verzeichnisstruktur nach der Anmeldung erzeugt)

Nicht .Maildir löschen, nur den Inhalt.



Vieleicht hilft das ja sonst noch jemandem...

Gruss

Mathias
 
Synology Mail Server Installation
NAS-Central - The Home of NAS

Kaffeautomat

Wenn du das Forum hilfreich findest oder uns unterstützen möchtest, dann gib uns doch einfach einen Kaffee aus.

Als Dankeschön schalten wir deinen Account werbefrei.

:coffee:

Hier gehts zum Kaffeeautomat