HA Proxy lässt sich nicht ausführen

JudgeDredd

Benutzer
Mitglied seit
12. Nov 2009
Beiträge
1.056
Punkte für Reaktionen
1
Punkte
64
Ort
Frankfurt
Hallo zusammen,

es ist schon eine Weile her, das ich das Paket "HA Proxy" geupdated habe, aber seit diesem Update, kann ich das Paket "HA Proxy" nicht mehr Ausführen.

Meldung:
"Der Paketdienst konnte nicht ausgeführt werden."

DSM-Version: 4.2-3202
HA Proxy Version: 1.5~dev19-9 (aktuelle Version)
Python Version: 2.7.5-6 (aktuelle Version)
Paketquelle: http://packages.synocommunity.com

Bereits versucht:
De-/Neuinstallation "HA Proxy"
Neustart DSM

Gibt es eine Möglichkeit zu erfahren, wo genau das Problem liegt ?

Gruß,
Andreas
 

jahlives

Moderator
Mitglied seit
19. Aug 2008
Beiträge
18.275
Punkte für Reaktionen
2
Punkte
0
die Logs sagen nichts zu dem Problem?
 

JudgeDredd

Benutzer
Mitglied seit
12. Nov 2009
Beiträge
1.056
Punkte für Reaktionen
1
Punkte
64
Ort
Frankfurt
Das einzige was ich anbieten kann wäre das LOG "user.PkgMan.cgi.txt"
[2013/10/17 07/56/47] pkgstartstop.cpp:100 Failed to start package haproxy
[2013/10/17 07/56/55] pkgtool.cpp:1709 Failed to query package status, haproxy
[2013/10/17 08/15/00] pkgstartstop.cpp:100 Failed to start package haproxy
[2013/10/17 08/15/22] pkgstartstop.cpp:100 Failed to start package haproxy

Ansonsten taucht das Paket in keinem weitern Logfile auf. Es sei denn, Du hättest noch eine Stelle wo ich Infos hierzu suchen sollte.
 

jahlives

Moderator
Mitglied seit
19. Aug 2008
Beiträge
18.275
Punkte für Reaktionen
2
Punkte
0
Die üblichen Verdächtigen wären in /var/log und dann messages, daemon, syslog (falls vorhanden)
 

JudgeDredd

Benutzer
Mitglied seit
12. Nov 2009
Beiträge
1.056
Punkte für Reaktionen
1
Punkte
64
Ort
Frankfurt
Leider liefern die Log's nicht mehr Infos wie oben gepostet.

Mittlerweile habe ich den Proxy sowie Python mal deinstalliert und anschließend wieder installiert.
An der Situation hat dies nichts geändert. Nach dem Versionsupdate des Proxy lässt er sich nicht mehr starten.

HAProxy.jpg
 

JudgeDredd

Benutzer
Mitglied seit
12. Nov 2009
Beiträge
1.056
Punkte für Reaktionen
1
Punkte
64
Ort
Frankfurt
Gibt es eventuell eine Möglichkeit die Version VOR 1.5~dev19-9 irgendwo runterzuladen und manuell zu installieren ?

EDIT:
Gerade habe ich gesehen, das auf der Entwicklerseite von HA Proxy die letzte stable Version die 1.4.24 ist und die 1.5-dev??-? nur die Entwickler Version ist.
Ich dachte bisher die Community Paketquelle ist immer die letzte stable-Version.

Jetzt würde ich natürlich gerne die 1.4.24 auf meine DS bringen. Hat dazu vielleicht jemand eine Idee ?

Gruß,
Andreas
 
Zuletzt bearbeitet:

JudgeDredd

Benutzer
Mitglied seit
12. Nov 2009
Beiträge
1.056
Punkte für Reaktionen
1
Punkte
64
Ort
Frankfurt
Wenn ich auf der Konsole den Proxy starten will (/volume1/@appstore/haproxy/sbin/haproxy), sofern das überhaupt möglich ist, dann erhalte ich folgende Fehlermeldung:

[ALERT] 291/110122 (3778) : Critical internal error: ACL keyword '▒▒▒▒▒▒▒,' relies on sample fetch '▒▒▒H' which was not registered!

Welcher Befehl wird denn auf der DS ausgeführt, wenn ich im DSM auf "Paket ausführen" klicke ?
Vielleicht hilft das ja jemanden weiter, um dann mir weiter zu helfen :)
Wie kann ich herausfinden, wer die HA Proxy Software für die DS compiliert hat ? Evtl. bekomme ich dort ja eine Vorversion (die bei mir ja funktionierte).

Gruß,
Andreas
 

fpo4711

Benutzer
Mitglied seit
26. Mai 2010
Beiträge
2.772
Punkte für Reaktionen
1
Punkte
0
Hallo,

im Paketzentrum hast Du unter Einstellungen die Möglichkeit "Release" oder "Beta" zu wählen. Ansonsten kannst Du auch über den ftp von Synology diverse ältere Sachen laden.

http://ukdl.synology.com/ftp/

Bin mir nicht sicher ob das bei HA identisch ist, aber im Regelfall wird dies über das start-stop-status Script gelöst. Siehe auch hier Bei vielen Paketen müssen aber vorher noch Umgebungsvariablen gesetzt werden. Vorher mal einen Blick ins Script werfen.

Gruß Frank
 

JudgeDredd

Benutzer
Mitglied seit
12. Nov 2009
Beiträge
1.056
Punkte für Reaktionen
1
Punkte
64
Ort
Frankfurt
Hallo Frank,

vielen Dank für den Versuch, mir weiterzuhelfen. Leider bin ich, trotz intensiver Suche, nicht fündig geworden.

Mein Paketzentrum steht schon immer auf "Release". Sehr verwunderlich, das dann die DEV-Version angeboten wird.

Ich finde auch weiterhin keine Möglichkeit, auf dem Server der "packages.synocommunity.com" eine ältere Version zu suchen/finden.
Ebenso ist es wohl nicht möglich zu sehen, wer das Paket bereitgestellt hat, um Ihn/Sie mal zu kontaktieren.

Schade, so ist der Community Paketserver natürlich völlig unbrauchbar. (Wie eine Schachtel Pralinen - Man weiß nie was man bekommt :D)

Ab jetzt beruht meine Hoffnung nur noch auf ein nächstes Update des HAProxy Pakets oder vielleicht doch noch jemand, der mir sagen kann wo und wie ich an eine ältere Version komme.

Gruß,
Andreas
 

fpo4711

Benutzer
Mitglied seit
26. Mai 2010
Beiträge
2.772
Punkte für Reaktionen
1
Punkte
0
Oh. sorry erst jetzt festgestellt. Tja, wer lesen kann ist klar im Vorteil. :eek: Hatte das mit der Lösung von Synology verwechselt. Nämlich dem High Availability Cluster. So kannst Du natürlich auf dem Synology-FTP nichts finden.

Gruß Frank
 

JudgeDredd

Benutzer
Mitglied seit
12. Nov 2009
Beiträge
1.056
Punkte für Reaktionen
1
Punkte
64
Ort
Frankfurt
Hallo Frank,

Ich bin also nicht alleine. Na da geht es mir doch gleich viel besser. :)
Dann besteht also die Hoffnung (die stirbt ja eh immer zuletzt), das da evtl. noch was passiert.

Danke auf jeden Fall für den Hinweis, ich werde den verlinkten Thread im Auge behalten.

Gruß
Andreas
 

linuxdep

Benutzer
Mitglied seit
02. Jan 2009
Beiträge
534
Punkte für Reaktionen
7
Punkte
38
Hi,

mal ne Frage, nutzt den Proxy wer für Windows Updaters? Habe ne langsame Leitung, da würde ich gerne einen Proxy für die Windows updates auf der syno haben.
Oder eine ne bessere Lösung?