DSM startet nicht mehr. HTTPS nicht mehr verfügbar.

  • Lange schon haben wir uns gewünscht, diese Mitteilung veröffentlichen zu können. Seit langer Zeit planen wir den Umzug auf neue Server und nun ist es geschafft. Um euch einen Einblick hinter die Kulissen zu geben haben wir einen extra Beitrag geschrieben:

    Das Forum hat eine neue Heimat bei netcup gefunden

    Wir möchten uns ganz herzlich bei netcup bedanken! necup stellt uns die neuen Server. Schaut mal in unsere Beiträge, was sich durch den Umzug alles verbessert hat.

oschmidt

Benutzer
Mitglied seit
17. Sep 2020
Beiträge
53
Punkte für Reaktionen
11
Punkte
58
Hallo zusammen,

auf meiner DS415+ wollte ich testweise schauen ob ich eine externe USB Festplatte als SSD Cache einbinden kann und bin nach dieser Anleitung vorgegangen:
https://www.casler.org/wordpress/synology-ssd-cache-on-external-devices/
Soweit hat auch alles geklappt jedoch konnte ich die DSM nicht mehr über HTTPS aufrufen und ich erhielt die folgende Meldung:
1603354414130.png
Über Systemsteuer-Netzwerk-DSM Einstellungen konnte ich die Optionen HTTP Verbindungen auf HTTPS umleiten nicht deaktivieren bzw. erhielt immer die Meldung "Operation fehlgeschlagen".

Anfangs dachte ich das die Änderungen an der synoinfo.conf verantwortlich wären weswegen ich diese wieder rückgängig gemacht habe jedoch bleibt der Fehler.

Eine ähnliche Problematik habe ich bereits hier gefunden:
https://www.synology-forum.de/threa...t-dsm-das-er-nicht-normal-starten-kann.45596/
Der letzte Link ist jedoch nicht verfügbar und unter /usr/syno/etc/ssl/ gibt es die angesprochene Datei nicht.
1603355262259.png


Im Protokoll Zentrum wird aufgeführt das die Änderung gespeichert wurde:
1603355491836.png
 

Fusion

Benutzer
Mitglied seit
06. Apr 2013
Beiträge
12.934
Punkte für Reaktionen
557
Punkte
384
Einmal 'nginx - t' und / oder 'synoservicectl --restart nginx' und sehen was für Fehler ausgespuckt werden.
 
  • Like
Reaktionen: blurrrr und oschmidt

oschmidt

Benutzer
Mitglied seit
17. Sep 2020
Beiträge
53
Punkte für Reaktionen
11
Punkte
58
Oh man.....
Danke für den Tipp bzw. schubs in die richtige Richtung....
Code:
root@DSM:~# synoservicectl --restart nginx
nginx restarted.
root@DSM:~# nginx -t
nginx: [emerg] open() "/usr/local/etc/nginx/conf.d/www.PhotoStation.conf" failed (2: No such file or directory) in /etc/nginx/nginx.conf:87
nginx: configuration file /etc/nginx/nginx.conf test failed

Nach der Meldung ist mir eingefallen das ich vor einiger Zeit diese umleitung für Photstation ausprobiert hatte:
https://www.synology-forum.de/threads/nginx-redirect-fuer-photo-station.97096/post-807449
Photostation selbst habe ich wieder gelöscht aber vergessen die Änderungen wieder rückgängig zu machen.
Code:
root@DSM:~# synoservicectl --restart nginx
nginx restarted.
root@DSM:~# nginx -t
nginx: the configuration file /etc/nginx/nginx.conf syntax is ok
nginx: configuration file /etc/nginx/nginx.conf test is successful

Alle Probleme sind behoben und ich kann mich wieder um den SSD Cache kümmern.

Vielen dank.
 
Zuletzt bearbeitet:
  • Like
Reaktionen: Fusion
NAS-Central - Ihr Partner für NAS Lösungen