DS241SE - uboot - zImage / rd.bin - Kernel Panic

boa996

Benutzer
Mitglied seit
02. Juni 2010
Beiträge
8
Punkte für Reaktionen
0
Punkte
0
Hallo zusammen,

ich habe eine DS214SE bei welcher es bei uboot wohl das kernel-image / ram-disk zerschossen hat. Eine serielle Verbindung habe ich hinbekommen. Ich kann auch die per tftpboot die die zImage und das rd.bin beziehen.
Doch beim Start bekomm ich dann Kernel-Panic. Man muss dazusagen, ich habe nur eine "jungfräuliche" Festplatte mit ext3 formatiert drauf. Beim Start wird jedoch das md0/md1-Device gesucht, mit welchem ich nicht dienen kann.
Auch die bootartgs mit "raid=noautodetect" bzw. mit "root=/dev/sda1" bringen leider nichts. Auch verschiedene DSM-Stände hab ich probiert. Theoretisch sollte es ja mein Ziel sein, die DS ans Netz zu bringen, damit die .pat hochladen kann.

Hier mal meine Configs und Ausgaben:

Rich (BBCode):
Marvell>> printenv
CASset=min
MALLOC_len=5
autoload=no
baudrate=115200
bootargs=console=ttyS0,115200 ip=off initrd=0x8000040,8M root=/dev/md0 rw syno_hw_version=DS214se ihd_num=2 netif_num=1 flash_size=8
bootargs_end=:10.4.50.254:255.255.255.0:KW40:eth0:none
bootargs_root=root=/dev/nfs rw
bootcmd=sf probe 0 50000000;bootm 0xf40c0000 0xf4390000
bootdelay=3
cacheShare=no
console=console=ttyS0,115200
disL2Cache=yes
disaMvPnp=no
eeeEnable=no
enaAutoRecovery=yes
enaClockGating=no
enaFPU=no
enaWrAllo=no
eth1addr=00:50:43:1b:dd:05
eth1mtu=1500
ethact=egiga0
ethaddr=00:50:43:1b:1b:dd
ethmtu=1500
ethprime=egiga0
image_name=uImage
initrd_name=uInitrd
ipaddr=10.4.50.136
loadaddr=0x02000000
loads_echo=0
mvNetConfig=mv_net_config=1,(00:50:43:11:11:11,0:1:2:3:4),mtu=1500
mv_pon_addr=00:50:43:05:dd:1b
netbsd_en=no
netmask=255.255.255.0
netretry=no
pcieTune=no
pexMode=rc
pxe_files_load=:default.arm-armada370-db:default.arm-armadaxp:default.arm
pxefile_addr_r=3100000
rcvrip=169.254.100.100
rootpath=/srv/oneiric
sata_delay_reset=0
sata_dma_mode=yes
serverip=10.4.50.68
setL2CacheWT=no
standalone=fsload 0x2000000 $image_name;setenv bootargs $console $mtdparts root=/dev/mtdblock0 rw ip=$ipaddr:$serverip$bootargs_end; bootm 0x2000000;
stderr=serial
stdin=serial
stdout=serial
usb0Mode=host
usb1Mode=host
usb2Mode=device
usbActive=1
vxworks_en=no
yuk_ethaddr=00:00:00:EE:51:81

Environment size: 1464/65532 bytes
Marvell>>

Folgende Dateien lade ich per tftpboot hoch

Rich (BBCode):
Marvell>> tftpboot 0x1000000 zImage
Using egiga0 device
TFTP from server 192.168.1.235; our IP address is 192.168.1.1
Filename 'zImage'.
Load address: 0x1000000
Loading: #################################################################
         #################################################################
         #################
done
Bytes transferred = 2156960 (20e9a0 hex)
Marvell>> tftpboot 0x2000000 rd.bin
Using egiga0 device
TFTP from server 192.168.1.235; our IP address is 192.168.1.1
Filename 'rd.bin'.
Load address: 0x2000000
Loading: #################################################################
         #################################################################
         #################################################################
         ################################################
done
Bytes transferred = 3556023 (3642b7 hex)

da mein Post zu lang ist, verteil ichs auf zwei... bis gleich....
 

boa996

Benutzer
Mitglied seit
02. Juni 2010
Beiträge
8
Punkte für Reaktionen
0
Punkte
0
..... so.. hier gehts weiter.... habe ein paar Zeilen rausgeschnitten.....

Danach starte ich mit bootm und bekomme am Ende den Kernel-panic

Rich (BBCode):
Marvell>> bootm 1000000 2000000
## Booting kernel from Legacy Image at 01000000 ...
   Image Name:   Linux-3.2.40
   Created:      2016-06-02  11:48:48 UTC
   Image Type:   ARM Linux Kernel Image (uncompressed)
   Data Size:    2156896 Bytes = 2.1 MiB
   Load Address: 00008000
   Entry Point:  00008000
   Verifying Checksum ... OK
## Loading init Ramdisk from Legacy Image at 02000000 ...
   Image Name:   synology_armada370_214se 7393
   Created:      2016-06-02  13:02:39 UTC
   Image Type:   ARM Linux RAMDisk Image (gzip compressed)
   Data Size:    3555959 Bytes = 3.4 MiB
   Load Address: 08000000
   Entry Point:  08000000
   Verifying Checksum ... OK
   Loading Kernel Image ... OK
OK

Starting kernel ...


[    3.451263]   Marvell Armada370 Board-- SYNO-DS214se-BP  Soc: MV6710 A1 LE
[    3.451281]   LSP version: linux-3.2.y-2013_Q1.2p2
[    3.451289]
[    3.451293]
[    3.451303]  Detected Tclk 200000000, SysClk 533000000, FabricClk 533000000
[    3.453730] Synology Armada370 DS214se GPIO Init
[    3.455353] Marvell USB EHCI Host controller #0: c4047000
[    3.455767] Marvell USB EHCI Host controller #1: c405de00
[    3.456290] PCI: bus0: Fast back to back transfers enabled
[    3.456313] mvPexLocalBusNumSet: ERR. Invalid PEX interface 1
[    3.456323] mvPexLocalDevNumSet: ERR. Invalid PEX interface 1
[    3.467156] bio: create slab <bio-0> at 0
[    3.637063] raid6: int32x1    108 MB/s
[    3.806915] raid6: int32x2    158 MB/s
[    3.976900] raid6: int32x4    179 MB/s
[    4.146903] raid6: int32x8    179 MB/s
[    4.146912] raid6: using algorithm int32x4 (179 MB/s)
[    4.147706] SCSI subsystem initialized
[    4.149507] Switching to clocksource armada370_clocksource
[    4.149712] AppArmor: AppArmor Filesystem Enabled
[    4.152144] NET: Registered protocol family 2
[    4.152267] IP route cache hash table entries: 2048 (order: 1, 8192 bytes)
[    4.152513] TCP established hash table entries: 8192 (order: 4, 65536 bytes)
[    4.152638] TCP bind hash table entries: 8192 (order: 3, 32768 bytes)
[    4.152735] TCP: Hash tables configured (established 8192 bind 8192)
[    4.152746] TCP reno registered
[    4.152759] UDP hash table entries: 256 (order: 0, 4096 bytes)
[    4.152779] UDP-Lite hash table entries: 256 (order: 0, 4096 bytes)
[    4.152955] NET: Registered protocol family 1
[    4.153194] RPC: Registered named UNIX socket transport module.
[    4.153208] RPC: Registered udp transport module.
[    4.153217] RPC: Registered tcp transport module.
[    4.153227] RPC: Registered tcp NFSv4.1 backchannel transport module.
[    4.153459] Trying to unpack rootfs image as initramfs...
[    4.167212] Freeing initrd memory: 8192K

[    4.810611] brd: module loaded
[    4.813693] Loading iSCSI transport class v2.0-870.
[    4.819994] sata_mv sata_mv.0: slots 32 ports 2
[    4.826535] scsi0 : sata_mv
[    4.829935] scsi1 : sata_mv
[    4.833153] ata1: SATA max UDMA/133 irq 55
[    4.837280] ata2: SATA max UDMA/133 irq 55
[   13.369546] ata1: link is slow to respond, please be patient (ready=0)
[   14.389561] ata1: SATA link up 1.5 Gbps (SStatus 113 SControl F300)
[   14.429589] ata1.00: ATA-7: WDC WD1500ADFD-00NLR1, 20.07P20, max UDMA/133
[   14.436424] ata1.00: 293046768 sectors, multi 0: LBA48 NCQ (depth 31/32)
[   14.499588] ata1.00: configured for UDMA/133
[   14.519660] scsi 0:0:0:0: Direct-Access     WDC      WD1500ADFD-00NLR1        20.0 PQ: 0 ANSI: 5
[   14.529448] sd 0:0:0:0: [sda] 293046768 512-byte logical blocks: (150 GB/139 GiB)
[   14.537576] sd 0:0:0:0: [sda] Write Protect is off
[   17.529441] Delay 5 seconds to wait for disk 2 ready.
[   22.512691] sd 0:0:0:0: [sda] Write cache: enabled, read cache: enabled, doesn't support DPO or FUA
[   22.533984]  sda: sda1
[   22.537400] sd 0:0:0:0: [sda] Attached SCSI disk
[   22.859554] ata2: SATA link down (SStatus 0 SControl F300)
[   22.866301] physmap platform flash device: 00800000 at f0000000
[   22.873581] physmap-flash physmap-flash.0: map_probe failed
[   22.882591] SPI Serial flash detected @ 0xf0000000, 8192KB (128sec x 64KB)
[   22.889547] Searching for RedBoot partition table in SYNOMTD-0 at offset 0x7f0000
[   22.936853] 6 RedBoot partitions found on MTD device SYNOMTD-0
[   22.942731] SYNOMTD flash bank 0: Using RedBoot partition definition
[   22.949123] Creating 6 MTD partitions on "SYNOMTD-0":
[   22.954222] 0x000000000000-0x0000000c0000 : "RedBoot"
[   22.960520] 0x0000000c0000-0x000000390000 : "zImage"
[   22.966572] 0x000000390000-0x0000007d0000 : "rd.gz"
[   22.972583] 0x0000007d0000-0x0000007e0000 : "vendor"
[   22.977676] vender Mac1 checksum error ucSum:0x00 Buf:0x00 Sum:0.
[   22.983829] vender Mac2 checksum error ucSum:0x00 Buf:0x00 Sum:0.
[   22.989969] vender Mac3 checksum error ucSum:0x00 Buf:0x00 Sum:0.
[   22.996099] vender Mac4 checksum error ucSum:0xa1 Buf:0x3d Sum:161.
[   23.002411] vender Mac5 checksum error ucSum:0x5a Buf:0x4e Sum:346.
[   23.008716] vender Mac6 checksum error ucSum:0x28 Buf:0x2c Sum:296.
[   23.015031] vender Mac7 checksum error ucSum:0x7c Buf:0x30 Sum:380.
[   23.021350] serial number='13A0M8N005021'
[   23.026321] 0x0000007e0000-0x0000007f0000 : "RedBoot Config"
[   23.033344] 0x0000007f0000-0x000000800000 : "FIS directory"

[   23.160332] md: linear personality registered for level -1
[   23.165854] md: raid0 personality registered for level 0
[   23.171218] md: raid1 personality registered for level 1
[   23.176562] md: raid10 personality registered for level 10
[   23.182090] md: raid6 personality registered for level 6
[   23.187434] md: raid5 personality registered for level 5
[   23.192784] md: raid4 personality registered for level 4
[   23.198534] device-mapper: ioctl: 4.22.0-ioctl (2011-10-19) initialised: dm-devel@redhat.com
[   23.207182] cpuidle: using governor ladder
[   23.211559] cpuidle: using governor menu
[   23.215661] cancel mvsdio probe
[   23.219133] TCP cubic registered
[   23.222407] NET: Registered protocol family 17
[   23.226922] Registering the dns_resolver key type
[   23.231818] VFP support v0.3: implementor 56 architecture 2 part 20 variant 9 rev 6
[   23.240245] registered taskstats version 1
[   23.245624] md: Waiting for all devices to be available before autodetect
[   23.252497] md: If you don't use raid, use raid=noautodetect
[   23.258938] md: Autodetecting RAID arrays.
[   23.263087] md: Scanned 0 and added 0 devices.
[   23.267557] md: autorun ...
[   23.270376] md: ... autorun DONE.
[   23.274008] EXT3-fs (md0): error: unable to read superblock
[   23.279755] EXT2-fs (md0): error: unable to read superblock
[   23.285452] EXT4-fs (md0): unable to read superblock
[   23.290483] List of all partitions:
[   23.294009] 0800       146523384 sda  driver: sd
[   23.298674]   0801       146522112 sda1 00000000-0000-0000-0000-000000000000
[   23.305791] 1f00             768 mtdblock0  (driver?)
[   23.310897] 1f01            2880 mtdblock1  (driver?)
[   23.315994] 1f02            4352 mtdblock2  (driver?)
[   23.321098] 1f03              64 mtdblock3  (driver?)
[   23.326195] 1f04              64 mtdblock4  (driver?)
[   23.331299] 1f05              64 mtdblock5  (driver?)
[   23.336392] No filesystem could mount root, tried:  ext3 ext2 ext4
[   23.342665] Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(9,0)
[   23.350983] Backtrace:
[   23.353482] [<c0011c68>] (dump_backtrace+0x0/0x10c) from [<c03fc598>] (dump_stack+0x18/0x1c)
[   23.361979]  r7:c41195e0 r6:c415a00f r5:c05525e0 r4:c0587330
[   23.367727] [<c03fc580>] (dump_stack+0x0/0x1c) from [<c03fc810>] (panic+0x70/0x18c)
[   23.375448] [<c03fc7a0>] (panic+0x0/0x18c) from [<c0531e70>] (change_floppy+0x0/0xec)
[   23.383331]  r3:c4027f38 r2:00000020 r1:c4027f38 r0:c04b179c
[   23.389072]  r7:c41195e0
[   23.391647] [<c0531b20>] (mount_block_root+0x0/0x350) from [<c0531fc4>] (mount_root+0x68/0x6c)
[   23.400324] [<c0531f5c>] (mount_root+0x0/0x6c) from [<c0532164>] (prepare_namespace+0x19c/0x1e0)
[   23.409162]  r5:c05525e0 r4:c0586360
[   23.412796] [<c0531fc8>] (prepare_namespace+0x0/0x1e0) from [<c05319bc>] (kernel_init+0x1b4/0x1bc)
[   23.421816]  r6:c0586300 r5:c05525bc r4:00000008
[   23.426510] [<c0531808>] (kernel_init+0x0/0x1bc) from [<c004c730>] (do_exit+0x0/0x648)
[   23.434481]  r7:00000013

Da ich mit meiner begrenzten Trail-and-Error-Tour leider durch bin, möchte ich Euch gerne um Hilfe bitten.

Freue mich schon Eure Unterstützung
Martin
 

goetz

Super-Moderator
Teammitglied
Mitglied seit
18. März 2009
Beiträge
13.512
Punkte für Reaktionen
5
Punkte
328
Hallo,
welche Ausgabe kommt denn wenn Du ohne Eingriff bootest? Kommt das gleiche Ergebnis wenn Du ohne Platte mit Eingriff bootest? Du kannst auch mal die Adressen von hier versuchen.

Gruß Götz
 

boa996

Benutzer
Mitglied seit
02. Juni 2010
Beiträge
8
Punkte für Reaktionen
0
Punkte
0
Hallo Götz,

ersmal vielen lieben Dank für Deine schnelle Reaktion!

Auch wenn ichs mit den Adressen aus dem Link probiere und/oder auch keine Festplatte drin hab, kommt immer die gleiche Kernel-Panic.... kurios!

Grüßle zurück, Martin
 
  AdBlocker gefunden!

Du bist nicht hier, um Support für Adblocker zu erhalten, denn dein Adblocker funktioniert bereits ;-)

Klar machen Adblocker einen guten Job, aber sie blockieren auch nützliche Funktionen.

Das Forum wird mit einem hohen technischen, zeitlichen und finanziellen Aufwand kostenfrei zur Verfügung gestellt. Wir zeigen keine offensive oder Themen fremde Werbung. Bitte unterstütze dieses Forum, in dem du deinen Adblocker für diese Seite deaktivierst.