DS212+ - bis u-boot und nicht weiter

vik-t

Benutzer
Mitglied seit
21. August 2016
Beiträge
7
Punkte für Reaktionen
0
Punkte
0
Hallo Goetz,

Meine DS212+ befindet sich im Streik, so dass ich mich während der letzten 2 Tage erstmals mit embedded Linux beschäftigt habe.

Nach vielen Stunden Lektüre und Ausprobieren bin ich nun so weit, dass ich seriell angeschlossen bin. Dank deines Beitrags anno 2011 weiss ich nun, wie ich das Kernel-Image (zImage) wie auch die Ramdisk (rd.bin) per tftp herunterladen und einbinden kann. Mir geht es dabei gleich wie Dark Dragon damals, dass die Speicheradresse 0x900000 für die rd.bin nicht ausreichte und ich deinem Vorschlag gemäss auf die zwei Speicheradressen 0x2000000 und 0x3000000 auswich. Leider strande aber auch ich am selben Ort wie Dark Dragon dazumal, nämlich dass das ganze in einer Kernel Panic endet.

Rich (BBCode):
[   19.030000] No filesystem could mount root, tried:  ext3 ext2 ext4
[   19.030000] Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(9,0)

Du hattest damals einen Lösungsvorschlag. In Beitrag 9 hast du anhand des Flashlayouts ausgerechnet, wo die rd.bin genau hinkopiert werden muss.

Auch ich habe diese Rechnung für mich gemacht anhand folgender Angaben:

Rich (BBCode):
[   18.680000] physmap platform flash device: 00400000 at f8000000
[   18.690000] SPI Serial flash detected @ 0xf8000000, 4096KB (64sec x 64KB)
[   18.700000] Searching for RedBoot partition table in SYNOMTD-0 at offset 0x3f0000
[   18.710000] 6 RedBoot partitions found on MTD device SYNOMTD-0
[   18.710000] SYNOMTD flash bank 0: Using RedBoot partition definition
[   18.720000] Creating 6 MTD partitions on "SYNOMTD-0":
[   18.730000] 0x000000000000-0x000000080000 : "RedBoot"
[   18.730000] 0x000000080000-0x000000280000 : "zImage"
[   18.740000] 0x000000280000-0x0000003c0000 : "rd.gz"
[   18.740000] 0x0000003c0000-0x0000003d0000 : "vendor"

Demnach beginnt die Flash-Partition also bei der Adresse 0xF8000000. Um die erwartete Position von rd.bin bzw. rd.gz herauszufinden, muss deren relative Position, nämlich 0x280000 zur Anfangsadresse dazugerechnet werden, was 0xF8280000 ergibt.

Die nächsten Schritte sind dann, gemäss deinen damaligen Anweisungen:

Code:
protect off all
erase f8280000 <Endwert>
cp.b 3000000 f8280000 <Hex-Grösse der rd.bin, in meinem Fall FFB0C>
protect on all
reset

Um die Adresse des Endwerts für den erase-Befehl zu berechnen, hast du die Speichergrösse von rd.bin im Flash Layout zur Anfangsadresse dazugerechnet (minus 1). Leider kenne ich das Flash-Layout in meinem Fall aber nicht und verstehe nicht, woher ich die Information erhalte. Ohne dieses kann ich die Grösse von rd.bin im Flash nicht feststellen und damit fehlt mir der Endwert für den erase-Befehl.

Kannst du mir hier weiterhelfen?

Grüsse,
Vik
 

vik-t

Benutzer
Mitglied seit
21. August 2016
Beiträge
7
Punkte für Reaktionen
0
Punkte
0
Hallo zusammen,

Darf ich mir erlauben, diesen Beitrag zu bumpen? Würde mich über eine Antwort freuen, dann kann ich die DS212+ vielleicht vorm Elektroschrott bewahren und noch etwas dazulernen.

Grüsse,
Vik
 

goetz

Super-Moderator
Teammitglied
Mitglied seit
18. März 2009
Beiträge
13.512
Punkte für Reaktionen
5
Punkte
328
Hallo,
stammt die Zeile
Rich (BBCode):
[   18.740000] 0x000000280000-0x0000003c0000 : "rd.gz"
von Deiner DS?
Wenn ja dann ist die Endadresse 0xF8000000+3c0000-1=F83BFFFF

Gruß Götz
 

vik-t

Benutzer
Mitglied seit
21. August 2016
Beiträge
7
Punkte für Reaktionen
0
Punkte
0
Hi Götz,

Vielen Dank für deine Antwort.

Ja, die Ausgabe ist von meiner DS. Ich ging davon aus, bei diesem Wert handelt es sich um eine generierte Speicheradresse in Abhängigkeit der Grösse von der neuen rd.bin und dass die bestehende rd.bin im Speicher vielleicht einen ganz anderen Platz vereinnahmt.

Jetzt, da du das geklärt hast, probier ich das nun gleich mal aus und melde mich mit dem Resultat.

Gruss Vik
 

vik-t

Benutzer
Mitglied seit
21. August 2016
Beiträge
7
Punkte für Reaktionen
0
Punkte
0
Hm, leider bin ich auch nach diesen Schritten noch immer gleich weit.. Nachdem ich den Reset durchführte, wurde das Boot-Image noch immer nicht gefunden

Ich werde mal meine Schritte hier nacheinander auflisten, vielleicht hast du, oder sonst jemand, ein wachsameres Auge als ich.

Hier erst mal die Uboot-Anzeige bis zum Prompt. Ich muss den Boot nicht abbrechen, der bricht von alleine ab (Bad Magic Number)

Rich (BBCode):
U-Boot 1.1.4 (Dec  2 2011 - 15:56:02) Marvell version: 3.5.9

U-Boot code: 00600000 -> 0067FFF0  BSS: -> 0068B3D4

Soc: 88F6282 A1CPU running @ 2000Mhz L2 running @ 500Mhz
SysClock = 500Mhz , TClock = 200Mhz

DRAM (DDR3) CAS Latency = 7 tRP = 7 tRAS = 20 tRCD=7
DRAM CS[0] base 0x00000000   size 256MB
DRAM CS[1] base 0x10000000   size 256MB
DRAM Total size 512MB  16bit width
Addresses 8M - 0M are saved for the U-Boot usage.
Mem malloc Initialization (8M - 7M): Done
Using default environment

[4096kB@f8000000] Flash:  4 MB

CPU : Marvell Feroceon (Rev 1)

Streaming disabled
Write allocate disabled


USB 0: host mode
PEX 0: PCI Express Root Complex Interface
PEX interface detected Link X1
PEX 1: PCI Express Root Complex Interface
PEX interface detected Link X1

Synology Model: DS212+r1
Fan Status: Good

Net:   egiga0 [PRIME], egiga1
Hit any key to stop autoboot:  0
## Booting image at f8080000 ...
Bad Magic Number
Marvell>>

Hier mein Environment vor jeglichen Änderungen:

Rich (BBCode):
Marvell>> printenv
bootcmd=bootm F8080000 F8280000
baudrate=115200
loads_echo=0
ipaddr=192.168.1.154
serverip=192.168.1.155
rootpath=/mnt/ARM_FS/
netmask=255.255.254.0
run_diag=yes
stdin=serial
stdout=serial
stderr=serial
console=console=ttyS0,115200 mtdparts=spi_flash:0x80000@0(uboot)ro,0x300000@0x100000(root)
mainlineLinux=no
enaMonExt=no
enaCpuStream=no
enaWrAllo=no
pexMode=RC
disL2Cache=no
setL2CacheWT=yes
disL2Prefetch=yes
enaICPref=yes
enaDCPref=yes
sata_dma_mode=yes
MALLOC_len=1
ethprime=egiga0
netbsd_en=no
vxworks_en=no
bootargs_root=root=/dev/nfs rw
bootargs_end=:::DB88FXX81:eth0:none
image_name=uImage
standalone=fsload 0x2000000 $(image_name);setenv bootargs $(console) root=/dev/mtdblock0 rw ip=$(ipaddr):$(serverip)$(bootargs_end) $(mvPhoneConfig); bootm 0x2000000;
lcd0_enable=0
lcd0_params=640x480-16@60
bootdelay=3
disaMvPnp=no
ethaddr=00:50:43:3c:3b:5d
ethmtu=1500
mvPhoneConfig=mv_phone_config=dev[0]:fxs,dev[1]:fxo
mvNetConfig=mv_net_config=(00:11:88:0f:62:81,0:1:2:3),mtu=1500
usb0Mode=host
pcieTune=no
pcieTune1=no
bootargs=console=ttyS0,115200 ip=off initrd=0x00800040,4M root=/dev/md0 rw syno_hw_version=DS212pv20 ihd_num=2 netif_num=1 esata_7042=1
ethact=egiga0

Environment size: 1174/4092 bytes

Anschliessend verändere ich gewisse Einträge, damit ich vom Netz booten kann:

Rich (BBCode):
Marvell>> setenv ipaddr 192.168.0.103
Marvell>> setenv netmask 255.255.255.0
Marvell>> setenv serverip 192.168.0.189
Marvell>> ping 192.168.0.189
Using egiga0 device
host 192.168.0.189 is alive

Im nächsten Schritt lade ich zImage und rd.bin herunter. Es handelt sich dabei um Dateien aus einer 5_0 Version der Firmware. Auf der DS212+ war eine unbestimmte 5_2 drauf, also etwas neueres.

Rich (BBCode):
Marvell>> tftpboot 0x2000000 zImage
Using egiga0 device
TFTP from server 192.168.0.189; our IP address is 192.168.0.103
Filename 'zImage'.
Load address: 0x2000000
Loading: #################################################################
         #################################################################
         #################################################################
         #################################################################
         ##########################################
done
Bytes transferred = 1544028 (178f5c hex)
Marvell>> tftpboot 0x3000000 rd.bin
Using egiga0 device
TFTP from server 192.168.0.189; our IP address is 192.168.0.103
Filename 'rd.bin'.
Load address: 0x3000000
Loading: #################################################################
         #################################################################
         #################################################################
         #########
done
Bytes transferred = 1044101 (fee85 hex)
 

vik-t

Benutzer
Mitglied seit
21. August 2016
Beiträge
7
Punkte für Reaktionen
0
Punkte
0
[FORTGESETZT]

Wenn ich jetzt mit bootm 0x2000000 0x3000000 boote, passiert folgendes.

Rich (BBCode):
Marvell>> bootm 0x2000000 0x3000000
## Booting image at 02000000 ...
   Image Name:   Linux-2.6.32.12
   Image Type:   ARM Linux Kernel Image (uncompressed)
   Data Size:    1543964 Bytes =  1.5 MB
   Load Address: 00008000
   Entry Point:  00008000
   Verifying Checksum ... OK
OK
## Loading Ramdisk Image at 03000000 ...
   Image Name:   synology_88f6282_212+ 5055
   Image Type:   ARM Linux RAMDisk Image (gzip compressed)
   Data Size:    1044037 Bytes = 1019.6 kB
   Load Address: 00800000
   Entry Point:  00800000
   Verifying Checksum ... OK

Starting kernel ...

Uncompressing Linux... done, booting the kernel.
[    0.000000] Linux version 2.6.32.12 (root@build4) (gcc version 4.6.4 (Linaro GCC branch-4.6.4. Marvell GCC Dev 201309-2126.3d181f66 64K MAXPAGESIZE ALIGN) ) #5055 Tue May 12 15:22:35 CST 2015
[    0.000000] CPU: Feroceon 88FR131 [56251311] revision 1 (ARMv5TE), cr=00053977
[    0.000000] CPU: VIVT data cache, VIVT instruction cache
[    0.000000] Machine: Synology 6282 board
[    0.000000] Using UBoot passing parameters structure
[    0.000000] Sys Clk = 200000000, Tclk = 166666667
[    0.000000] Synology Board ID: 27
[    0.000000] Memory policy: ECC disabled, Data cache writeback
[    0.000000] Built 1 zonelists in Zone order, mobility grouping off.  Total pages: 130048
[    0.000000] Kernel command line: console=ttyS0,115200 ip=off initrd=0x00800040,4M root=/dev/md0 rw syno_hw_version=DS212pv20 ihd_num=2 netif_num=1 esata_7042=1
[    0.000000] Synology Hardware Version: DS212pv20-j
[    0.000000] Internal HD num: 2
[    0.000000] Internal netif num: 1
[    0.000000] Esata chip use 7042: 1
[    0.000000] PID hash table entries: 2048 (order: 1, 8192 bytes)
[    0.000000] Dentry cache hash table entries: 65536 (order: 6, 262144 bytes)
[    0.000000] Inode-cache hash table entries: 32768 (order: 5, 131072 bytes)
[    0.000000] Memory: 256MB 256MB = 512MB total
[    0.000000] Memory: 506880KB available (3632K code, 519K data, 124K init, 0K highmem)
[    0.000000] Hierarchical RCU implementation.
[    0.000000] NR_IRQS:128
[    0.000000] Console: colour dummy device 80x30
[    0.000000] Calibrating delay loop... 1985.74 BogoMIPS (lpj=9928704)
[    0.250000] Mount-cache hash table entries: 512
[    0.250000] CPU: Testing write buffer coherency: ok
[    0.250000] devtmpfs: initialized
[    0.250000] xor: measuring software checksum speed
[    0.300000]    arm4regs  :  1810.800 MB/sec
[    0.350000]    8regs     :  1086.400 MB/sec
[    0.400000]    32regs    :  1402.400 MB/sec
[    0.400000] xor: using function: arm4regs (1810.800 MB/sec)
[    0.400000] NET: Registered protocol family 16
[    0.400000] Feroceon L2: Enabling L2
[    0.400000] Feroceon L2: Cache support initialised, in WT override mode.
[    0.420000]
[    0.420000] CPU Interface
[    0.420000] -------------
[...]
[    0.420000] PEX0_MEM ....base e0000000, size 128MB
[    0.420000] PEX0_IO ....base f2000000, size   1MB
[    0.420000] PEX1_MEM ....base e8000000, size 128MB
[    0.420000] PEX1_IO ....base f2100000, size   1MB
[    0.420000] INTER_REGS ....base f1000000, size   1MB
[    0.420000] NFLASH_CS ....base fa000000, size   2MB
[    0.420000] SPI_CS ....base f4000000, size  16MB
[    0.420000] BOOT_ROM_CS ....no such
[    0.420000] DEV_BOOTCS ....no such
[    0.420000] CRYPT_ENG ....base f0000000, size   2MB
[    0.420000]  Detected Tclk 200000000 and SysClk 500000000
[    0.420000] Apply DS 212 GPIO
[    0.420000] Synology 6282 1, 2 bay GPIO Init
[    0.420000] PCIe link is enable, apply PCIe workaround
[    0.920000] PEX0 interface detected Link X4
[    1.420000] PEX1 interface detected Link X1
[    1.420000] PCI: bus0: Fast back to back transfers disabled
[    1.420000] pci 0000:01:01.0: PME# supported from D0 D3hot
[    1.420000] pci 0000:01:01.0: PME# disabled
[    1.420000] PCI: bus1: Fast back to back transfers disabled
[    1.430000] bio: create slab <bio-0> at 0
[    1.430000] vgaarb: loaded
[    1.430000] SCSI subsystem initialized
[    1.600000] raid6: int32x1    146 MB/s
[    1.770000] raid6: int32x2    211 MB/s
[    1.940000] raid6: int32x4    216 MB/s
[    2.110000] raid6: int32x8    239 MB/s
[    2.110000] raid6: using algorithm int32x8 (239 MB/s)
[    2.110000] Switching to clocksource kw_clocksource
[    2.110000] NET: Registered protocol family 2
[    2.110000] IP route cache hash table entries: 4096 (order: 2, 16384 bytes)
[    2.110000] TCP established hash table entries: 16384 (order: 5, 131072 bytes)
[    2.110000] TCP bind hash table entries: 16384 (order: 4, 65536 bytes)
[    2.110000] TCP: Hash tables configured (established 16384 bind 16384)
[    2.110000] TCP reno registered
[    2.110000] NET: Registered protocol family 1
[    2.110000] RPC: Registered udp transport module.
[    2.110000] RPC: Registered tcp transport module.
[    2.110000] RPC: Registered tcp NFSv4.1 backchannel transport module.
[    2.110000] Trying to unpack rootfs image as initramfs...
[    2.110000] Freeing initrd memory: 4096K
[    2.110000] XOR registered 4 channels
[    2.110000] XOR 2nd invalidate WA enabled
[    2.110000] VFS: Disk quotas dquot_6.5.2
[    2.110000] Dquot-cache hash table entries: 1024 (order 0, 4096 bytes)
[    2.110000] msgmni has been set to 998
[    2.110000] alg: No test for md5 (md5-generic)
[    2.110000] alg: No test for des (des-generic)
[    2.110000] alg: No test for des3_ede (des3_ede-generic)
[    2.110000] alg: No test for stdrng (krng)
[    2.110000] Block layer SCSI generic (bsg) driver version 0.4 loaded (major 254)
[    2.110000] io scheduler noop registered
[    2.110000] io scheduler anticipatory registered (default)
[    2.120000] Serial: 8250/16550 driver, 4 ports, IRQ sharing disabled
[    2.120000] serial8250.0: ttyS0 at MMIO 0xf1012000 (irq = 33) is a 16550A
[    2.130000] console [ttyS0] enabled
[    2.140000] serial8250.1: ttyS1 at MMIO 0xf1012100 (irq = 34) is a 16550A
[    2.150000] brd: module loaded
[    2.150000] sata_mv sata_mv.0: version 1.28
[    2.160000] sata_mv sata_mv.0: slots 32 ports 2
[    2.160000] scsi0 : sata_mv
[    2.160000] scsi1 : sata_mv
[    2.170000] ata1: SATA max UDMA/133 irq 21
[    2.170000] ata2: SATA max UDMA/133 irq 21
[    6.340000] ata1: SATA link up 1.5 Gbps (SStatus 113 SControl F300)
[    6.400000] ata1.00: ATA-8: WDC WD3200BEVS-08VAT2, 14.01A14, max UDMA/133
[    6.400000] ata1.00: 625142448 sectors, multi 0: LBA48 NCQ (depth 31/32)
[    6.470000] ata1.00: configured for UDMA/133
[    6.490000] scsi 0:0:0:0: Direct-Access     WDC      WD3200BEVS-08VAT2        14.0 PQ: 0 ANSI: 5
[    6.490000] sd 0:0:0:0: [sda] 625142448 512-byte logical blocks: (320 GB/298 GiB)
[    6.500000] sd 0:0:0:0: [sda] Write Protect is off
[    6.510000] sd 0:0:0:0: [sda] Write cache: enabled, read cache: enabled, doesn't support DPO or FUA
[    6.520000]  sda: sda1 sda2
[    6.530000] sd 0:0:0:0: [sda] Attached SCSI disk
[    9.530000] Delay 5 seconds to wait for disk 2 ready.
[   17.800000] ata2: SATA link up 3.0 Gbps (SStatus 123 SControl F300)
[   17.820000] ata2.00: ATA-8: SAMSUNG HM320HJ, 2AK10001, max UDMA/133
[   17.820000] ata2.00: 625142448 sectors, multi 0: LBA48 NCQ (depth 31/32)
[   17.850000] ata2.00: configured for UDMA/133
[   17.870000] scsi 1:0:0:0: Direct-Access     SAMSUNG  HM320HJ                  2AK1 PQ: 0 ANSI: 5
[   17.870000] sd 1:0:0:0: [sdb] 625142448 512-byte logical blocks: (320 GB/298 GiB)
[   17.880000] sd 1:0:0:0: [sdb] Write Protect is off
[   17.890000] sd 1:0:0:0: [sdb] Write cache: enabled, read cache: enabled, doesn't support DPO or FUA
[   17.900000]  sdb: sdb1 sdb2 sdb3 sdb4
 

vik-t

Benutzer
Mitglied seit
21. August 2016
Beiträge
7
Punkte für Reaktionen
0
Punkte
0
[FORTGESETZT]

Rich (BBCode):
[   17.960000] ata3: SATA max UDMA/133 mmio m1048576@0xe0000000 port 0xe0022000 irq 9
[   17.970000] ata4: SATA max UDMA/133 mmio m1048576@0xe0000000 port 0xe0024000 irq 9
[   17.980000] ata5: SATA max UDMA/133 mmio m1048576@0xe0000000 port 0xe0026000 irq 9
[   17.990000] ata6: SATA max UDMA/133 mmio m1048576@0xe0000000 port 0xe0028000 irq 9
[   18.350000] ata3: SATA link down (SStatus 0 SControl 300)
[   18.700000] ata4: SATA link down (SStatus 0 SControl 300)
[   19.050000] ata5: SATA link down (SStatus 0 SControl 300)
[   19.400000] ata6: SATA link down (SStatus 0 SControl 300)
[   19.400000] physmap platform flash device: 00400000 at f8000000
[   19.410000] SPI Serial flash detected @ 0xf8000000, 4096KB (64sec x 64KB)
[   19.420000] Searching for RedBoot partition table in SYNOMTD-0 at offset 0x3f0000
[   19.430000] 6 RedBoot partitions found on MTD device SYNOMTD-0
[   19.430000] SYNOMTD flash bank 0: Using RedBoot partition definition
[   19.440000] Creating 6 MTD partitions on "SYNOMTD-0":
[   19.450000] 0x000000000000-0x000000080000 : "RedBoot"
[   19.450000] 0x000000080000-0x000000280000 : "zImage"
[   19.460000] 0x000000280000-0x0000003c0000 : "rd.gz"
[   19.460000] 0x0000003c0000-0x0000003d0000 : "vendor"
[   19.470000] vender Mac1 checksum error ucSum:0x00 Buf:0x00 Sum:0.
[   19.470000] vender Mac2 checksum error ucSum:0x00 Buf:0x00 Sum:0.
[   19.480000] vender Mac3 checksum error ucSum:0x00 Buf:0x00 Sum:0.
[   19.490000] serial number='C6KNN00413'
[   19.490000] 0x0000003d0000-0x0000003f0000 : "RedBoot Config"
[   19.500000] 0x0000003f0000-0x000000400000 : "FIS directory"
[   19.500000] SPI Serial flash detected @ 0xf4000000, 4096KB (64sec x 64KB)
[   19.510000] cmdlinepart partition parsing not available
[   19.520000] Loading Marvell Ethernet Driver:
[...]
[   19.590000]
[   19.590000] md: linear personality registered for level -1
[   19.600000] md: raid0 personality registered for level 0
[   19.600000] md: raid1 personality registered for level 1
[   19.610000] md: raid10 personality registered for level 10
[   19.620000] md: raid6 personality registered for level 6
[   19.620000] md: raid5 personality registered for level 5
[   19.630000] md: raid4 personality registered for level 4
[   19.630000] device-mapper: ioctl: 4.15.0-ioctl (2009-04-01) initialised: dm-devel@redhat.com
[   19.640000] cpuidle: using governor ladder
[   19.640000] TCP cubic registered
[   19.650000] NET: Registered protocol family 17
[   19.650000] NET: Registered protocol family 15
[   19.660000] registered taskstats version 1
[   19.660000] md: Waiting for all devices to be available before autodetect
[   19.670000] md: If you don't use raid, use raid=noautodetect
[   19.670000] md: Autodetecting RAID arrays.
[   19.680000] md: Scanned 0 and added 0 devices.
[   19.680000] md: autorun ...
[   19.690000] md: ... autorun DONE.
[   19.690000] EXT3-fs: unable to read superblock
[   19.690000] EXT2-fs: unable to read superblock
[   19.700000] EXT4-fs (md0): unable to read superblock
[   19.700000] List of all partitions:
[   19.710000] 0800       312571224 sda driver: sd
[   19.710000]   0801       305893633 sda1
[   19.720000]   0802         6675007 sda2
[   19.720000] 0810       312571224 sdb driver: sd
[   19.720000]   0811          203776 sdb1
[   19.730000]   0812       287842304 sdb2
[   19.730000]   0813        24417280 sdb3
[   19.740000]   0814          105816 sdb4
[   19.740000] 1f00             512 mtdblock0 (driver?)
[   19.740000] 1f01            2048 mtdblock1 (driver?)
[   19.750000] 1f02            1280 mtdblock2 (driver?)
[   19.750000] 1f03              64 mtdblock3 (driver?)
[   19.760000] 1f04             128 mtdblock4 (driver?)
[   19.760000] 1f05              64 mtdblock5 (driver?)
[   19.770000] 1f06            4096 mtdblock6 (driver?)
[   19.770000] No filesystem could mount root, tried:  ext3 ext2 ext4
[   19.780000] Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(9,0)

Anstatt dem direkten Zugriff über bootm 0x200000 0x3000000 habe ich auch den im ersten Post beschriebenen Weg versucht, nämlich die rd.bin in den Flashspeicher zu schreiben mit exakt den folgenden Befehlen:

Rich (BBCode):
protect off all
erase f8280000 f83bffff 
cp.b 3000000 f8280000 fee85
protect on all
reset

Der Bad-Magic Number-Fehler bleibt bestehen, und auch sonst bleibt alles beim alten.

Ich habe dies mit 2 verschiedenen Plattenpaaren, wie auch mit nur einer Platte versucht, das Endergebnis ist immer dasselbe. Mit meinem derzeitigen Wissenstand bin ich am Ende meines Lateins und bin daher dankbar für Hinweise.

Gruss ,
Vik
 

goetz

Super-Moderator
Teammitglied
Mitglied seit
18. März 2009
Beiträge
13.512
Punkte für Reaktionen
5
Punkte
328
Hallo,
Rich (BBCode):
## Booting image at f8080000 ...
Bad Magic Number
ist der Kernel zImage
Rich (BBCode):
0x000000080000-0x000000280000 : "zImage"
also das Prozedere für den Kernel durchführen.
Startadresse f8000000+80000=f8080000
Endadresse f8000000+280000-1=f827ffff
bitte auch noch mal nachrechnen.

Gruß Götz
 

vik-t

Benutzer
Mitglied seit
21. August 2016
Beiträge
7
Punkte für Reaktionen
0
Punkte
0
Hi Götz,

Dein Titel "Syno-Gott" ist offensichtlich nicht aus der Luft gegriffen - es hat alles geklappt und die DS arbeitet wie neu :) vielen, vielen Dank für deine Unterstützung!

Mein Problem ist nun gelöst, aber wenn du mal die Zeit für eine Erklärung findest, würde ich sehr gerne verstehen, wieso der Schritt mit bootm nach tftboot nicht wie erwartet funktionierte und die beiden Images zuvor zwingend in den Flash Speicher geschrieben werden mussten. Die meisten online erhältlichen Anweisungen beschreiben nur diesen einfachen Weg, der aber offensichtlich oft nicht funktioniert.

Gruss,
Vik
 

goetz

Super-Moderator
Teammitglied
Mitglied seit
18. März 2009
Beiträge
13.512
Punkte für Reaktionen
5
Punkte
328
Hallo,
erklären kann ich es Dir nicht, vermutlich liegt es an den tftp-load Adressen.
Viel Spaß mit Deiner DS.

Gruß Götz
 

Silentor

Benutzer
Mitglied seit
13. Januar 2012
Beiträge
15
Punkte für Reaktionen
0
Punkte
0
Hallo zuammen!

Ich bin etwas am verzweifeln.

Der Post passt haargenau auf mein bestehendes Problem:

Meine DS212+ blinkt nach gescheitertem Update nur noch blau.
Serielle Verbindung konnte ich herstellen.

Ich habe nun schon mehrfach die oben genannten Schritte durchgeführt, jedoch meldet er mir nach dem Reset-Befehl:

## Booting image at f8080000 ...
Image Name: synology_88f6282_212+ 7321
Image Type: ARM Linux RAMDisk Image (gzip compressed)
Data Size: 1030063 Bytes = 1005.9 kB
Load Address: 00800000
Entry Point: 00800000
Verifying Checksum ... OK
Wrong Image Type for bootm command

Ich sehe eigentlich nur noch eine Fehlerquelle, die den Post von Götz betrifft:
Startadresse f8000000+80000=f8080000
Endadresse f8000000+280000-1=f827ffff

Wo trage ich die korrigierte Endadresse ein?
Doch in den erase-Befehl!?!?

Also müsste der verbesserte Erase-Befehl lauten: erase f808000 f827ffff

Oder bin ich falsch?

Danke im Voraus!

VG
Silentor
 
  AdBlocker gefunden!

Du bist nicht hier, um Support für Adblocker zu erhalten, denn dein Adblocker funktioniert bereits ;-)

Klar machen Adblocker einen guten Job, aber sie blockieren auch nützliche Funktionen.

Das Forum wird mit einem hohen technischen, zeitlichen und finanziellen Aufwand kostenfrei zur Verfügung gestellt. Wir zeigen keine offensive oder Themen fremde Werbung. Bitte unterstütze dieses Forum, in dem du deinen Adblocker für diese Seite deaktivierst.