DS File (iPad & iPhone) funktioniert nach Update nicht mehr (Zertifikat)

kingofbattle

Benutzer
Mitglied seit
11. Nov 2013
Beiträge
114
Punkte für Reaktionen
0
Punkte
0
Hallo liebe Gemeinde,

ich habe folgendes Problem: Gestern Abend kam für die iOS App "DS File" ein Update. Seitdem ich das Update installiert habe, kann ich keine Dateien mehr im DS File öffnen. Es kommt immer die Fehlermeldung "Das Zertifikat für diesen Server ist ungültig. Eventuell werden Sie mit einem Server verbunden, der vorgibt, 192.168.XXX.XX zu sein, und Ihre vertraulichen Daten gefährdet"

Bis gestern Abend lief alles ohne Probleme. Erst seit dem ich das Update der DS File App auf meinen iPhone und iPad installiert habe kommt diese Fehlermeldung. Kann mir da jemand vielleicht weiterhelfen?

VG Markus
 

Beagle06

Benutzer
Mitglied seit
28. Jan 2014
Beiträge
13
Punkte für Reaktionen
0
Punkte
0
Dsfile funktioniert nach Update nicht mehr (Zertifikat)

:(...habe das gleiche Problem, wie bereits von Kingofbattle beschrieben. Seit letztem Update ist ein Zugriff über Internet nicht mehr möglich...
 

rindle

Benutzer
Mitglied seit
21. Apr 2013
Beiträge
17
Punkte für Reaktionen
0
Punkte
0
Ich habe das selbe Problem! Da muss es doch eine Lösung geben? Habt ihr das Thema schon bei Synology adressiert?
 

siggylux

Benutzer
Mitglied seit
08. Jun 2012
Beiträge
27
Punkte für Reaktionen
0
Punkte
0
Hallo,

Habe seit dem letzten update der Ds File App das selbe Problem.
Es gibt aber eine Lösung , einfach bei der Ds File Https login ausschalten und es funktioniert wieder.

Sig
 

kingofbattle

Benutzer
Mitglied seit
11. Nov 2013
Beiträge
114
Punkte für Reaktionen
0
Punkte
0
Ja es liegt einfach an der App ... im AppStore gibt es massenweise 1 Sterne Bewertungen deswegen ;)
 

Beagle06

Benutzer
Mitglied seit
28. Jan 2014
Beiträge
13
Punkte für Reaktionen
0
Punkte
0
dsfile funktioniert nach Update nicht mehr (Zertifikat)

Die Lösung HTTP statt HTTPS zu verwenden, ist nicht wirklich brauchbar... HTTP verwendet eine umverschlüsselte Übertragung, das sollte man heutzutage wirklich nicht mehr machen... Kennst sich jemand mit dem Zertifikat aus? Synology stellt ja eines zur Verfügung, aber wie bringe ich die Info hinunter auf DSFILE?
Danke, Beagle06
 

kingofbattle

Benutzer
Mitglied seit
11. Nov 2013
Beiträge
114
Punkte für Reaktionen
0
Punkte
0
Ja es ist heutzutage wirklich nicht sonderlich clever so etwas ohne eine HTTPS Verbindung zu verwenden. Aber momentan scheint es ja leider einfach nicht anders zu gehen. Da muss sich Synology definitiv etwas einfallen lassen. Vor dem Update lief ja auch alles reibungslos.
 

gaty

Benutzer
Mitglied seit
12. Aug 2012
Beiträge
11
Punkte für Reaktionen
0
Punkte
0
Hi!
Bekomme mit der neuen Version dieselbe Fehlermeldung.
Möchte das eigentlich NICHT ohne SSL verwenden, egal ob selbsterstelltes Zertifikat oder öffentlich-gültiges.

Insofern...?!
 

Tomn8

Benutzer
Mitglied seit
15. Jan 2013
Beiträge
12
Punkte für Reaktionen
0
Punkte
0
... das kann doch echt nicht wahr sein. Ich habe das gleiche Problem. Gibt es noch keine Lösung? Wann wird von Synology ein Update zur Problemlösung bereitgestellt?
 

gaty

Benutzer
Mitglied seit
12. Aug 2012
Beiträge
11
Punkte für Reaktionen
0
Punkte
0
halb-Lösung gefunden

2 Dinge habe ich gemacht damits funktioniert:

1) glaube nicht, dass das die Lösung war
2) Vermute eher das

1) Wenn man nicht die Quick-ConnectID verwendet sondern DDNS Dienst oder Zugriff per IP/Hostname, dann muss vermutlich der Hostname mit dem Hostnamen in der Synology übereinstimmen.
Hostnamen in der Synology (DSM 4.3) tragt man in der Systemsteuerung unter DSM-Einstellungen -> Router-Port und dort gibt man den Hostnamne/DDNS-Hostnamen ein.

2) Systemsteuerung -> DSM Einstellungen -> Sicherheit -> Schutz gegen Cross-Site-Request-Forgery-Attacken verbessern ABSCHALTEN

Danan funktioniert https wieder im DS File. Bei mir half danach ein Synology-Neustart und DS File hat wieder funktioniert.
 

Beagle06

Benutzer
Mitglied seit
28. Jan 2014
Beiträge
13
Punkte für Reaktionen
0
Punkte
0
Hallo Syno-Lehrling,

Ich habe Beides probiert... bei mir funktioniert gar nichts (ausser http, was ich nicht möchte). Ich habe inzwischen sogar mit dem Synology Team Verbindung aufgenommen, die mir empfohlen haben, ein eigenes Zertifikat anzulegen. Habe ich inzwischen auch schon gemacht (nach Anleitung im Wiki). Erfolg: Null. Das Problem bleibt das Gleiche. Es ist eindeutig ein Fehler in der DSFile App (scheint bei Synology auch bekannt zu sein). Inzwischen habe ich aber einen anderen "workaround" gefunden: Die Gratis App: "Documents by Readdle" funktioniert über die WebDAV Verbindung wunderbar. Ich verwende dieses Tool jetzt, bis der DSFile Fehler behoben ist...
 

ottosykora

Benutzer
Mitglied seit
17. Apr 2013
Beiträge
4.869
Punkte für Reaktionen
141
Punkte
143
Habt ihr versucht mal in die Einstellungen zu gehen?
Dort gibt es eine Tickbox 'Zertifikate überprüfen'

Leider ist diese nach den Updates offenbar defaultmässig aktiv.
Wie soll das Ding aber einen Selfsigned Zertifikat überprüfen? Das wäre nur möglich wenn es von einer CA ausgestellt und signiert wäre und so was gibt es für DDNS Adressen nun mal nicht.

Also diese Tickbox deaktivieren und schon geht alles wieder.
 

Beagle06

Benutzer
Mitglied seit
28. Jan 2014
Beiträge
13
Punkte für Reaktionen
0
Punkte
0
Diese Tickbox 'Zertifikat überprüfen' habe ich natürlich deaktiviert - das war das Erste, was ich versucht habe. Funktioniert aber nicht (zumindest bei mir nicht)... Es liegt schon an der App selbst...
Diesen Hinweis hat mir übrigens auch der Tech.Support von Synology gegeben.

Hier die Email von Synology:
************************************
Hi,

Currently if you could not open PDF or files under HTTPS, then this could be know issue.

As for current workaround:
1.Install the self-signed certificate
-Create self-signed certificate that signed to connect address, ex domain name or ip (Certificate.png)
(The DS default certificate is signed to "synology.com". User need to create a new one for the address he want to connect manually.)
-Export generated certificates from Control Panel
-Email with exported ca.crt file attached to iDevice
-Open ca.crt file in the Mail app, and accept to trust it

2.Latest DS file login page, there is setting icon located at left bottom of the page, please select it and disable SSL verification since your SSL if different than domain that you use to access DS, this option will only be available on latest DS file.


See if it helps.

Best Regards,
Jim Cheng
Technical Support
******************************************

Siehe erste Zeile: "a known issue...."

Das ist genau mein Problem....
 

ottosykora

Benutzer
Mitglied seit
17. Apr 2013
Beiträge
4.869
Punkte für Reaktionen
141
Punkte
143
ja, aber in diesem Fall hast du ja gar kein Cert mit deiner Adresse, sondern es wird immer noch die von der Synology verwendet, dann macht es auch Sinn.

Ich habe natürlich einen Selfsigned schon am Anfang erstellt und drin steht natürlich die DDNS Adresse drin.

Es wäre doch nicht richtig wenn absolut jedes beliebiges Zertifikat verwendet werden könnte so wie oft unter Windows funktioniert. So was gehört schon lange verboten, aber bei Microsoft scheint es niemanden zu interessieren.

Also 'this is not a bug it is a feature' uns es bleibt zu hoffen es nicht wieder abgeschafft.
 

Heinz-G

Benutzer
Mitglied seit
12. Jul 2012
Beiträge
251
Punkte für Reaktionen
0
Punkte
0
Gelöscht
 
Zuletzt bearbeitet:

Beagle06

Benutzer
Mitglied seit
28. Jan 2014
Beiträge
13
Punkte für Reaktionen
0
Punkte
0
Lieber Ottosykora,

Ich hab mich offensichtlich missverständlich ausgedrückt: Ich habe genau die Anweisungen des Synology technical support befolgt und es funktioniert absolut nicht. Auch nicht, wenn ich die Überprüfung des Zertifikates deaktiviere! In diesem Fall sollte ja eine Zertifikat Überprüfung gar nicht stattfinden! Wenn ich diese aktiviere, funktioniert (bei ungültigem Zertifikat) ja schon das Sign In nicht (so soll es auch sein). Das Problem tritt aber erst beim Öffnen von Dateien auf und zwar bei deaktivierter Zertifikatsprüfung....

DSfile hat ganz einfach einen (mittlerweile bekannten) Bug, der offensichtlich auch mein Problem ist. Allerdings noch keine Lösung....
 

ottosykora

Benutzer
Mitglied seit
17. Apr 2013
Beiträge
4.869
Punkte für Reaktionen
141
Punkte
143
hmm, dann,

bei mir kein Problem, alles geht prima, File ob jpg oder pdf oder word wird gleich geladen, und wird in der entsprechenden App geöffnet. Habe word, xls, jpg, pdf, zip probiert, noch nie Probleme gehabt es sein denn ich schalte die Prüfung des Cert ein, dann geht natürlich gar nichts.
Weiss nicht was Version ist, glaube habe in den letzten Tagen wieder ein Update bekommen davon.

Version so was wie 4.0.1-123 in dem About
 

Beagle06

Benutzer
Mitglied seit
28. Jan 2014
Beiträge
13
Punkte für Reaktionen
0
Punkte
0
Das Problem kam mit Version 5.0 vom 27.01.2014 hinein. Davor hat alles wunderbar funktioniert....
 

Future2013

Benutzer
Mitglied seit
29. Dez 2013
Beiträge
399
Punkte für Reaktionen
0
Punkte
0
Hab das gleiche Problem.

Geht nur mit http
 

Heinz-G

Benutzer
Mitglied seit
12. Jul 2012
Beiträge
251
Punkte für Reaktionen
0
Punkte
0
Hallo,
ich habe in der DS unter "DSM-Einstellungen -> Zertifikat" zwei Zertifikate von Synology (server.key, ca.key), gültig bis 2033 (wie die entstanden sind, keine Ahnung).
Diese Zertifikate habe ich exportiert und auf meinem iPad installiert.
Nun kann ich meine Dateien auf der iPad App "DS-File" wieder öffnen, auch ohne das die Tickbox 'Zertifikate überprüfen' aktiviert ist.
 
  AdBlocker gefunden!

Du bist nicht hier, um Support für Adblocker zu erhalten, denn dein Adblocker funktioniert bereits ;-)

Klar machen Adblocker einen guten Job, aber sie blockieren auch nützliche Funktionen.

Das Forum wird mit einem hohen technischen, zeitlichen und finanziellen Aufwand kostenfrei zur Verfügung gestellt. Wir zeigen keine offensive oder Themen fremde Werbung. Bitte unterstütze dieses Forum, in dem du deinen Adblocker für diese Seite deaktivierst.